]> git.pld-linux.org Git - packages/sssd.git/blob - sssd-systemd.patch
- up to 1.12.3
[packages/sssd.git] / sssd-systemd.patch
1 --- sssd-1.11.6/src/conf_macros.m4.orig 2014-06-03 16:31:33.000000000 +0200
2 +++ sssd-1.11.6/src/conf_macros.m4      2014-06-19 08:53:15.746551619 +0200
3 @@ -141,14 +141,15 @@
4    fi
5  
6    if test x"$with_initscript" = xsysv || \
7 -     test x"$with_initscript" = xsystemd; then
8 +     test x"$with_initscript" = xsystemd || \
9 +     test x"$with_initscript" = xsysv,systemd; then
10          initscript=$with_initscript
11    else
12        AC_MSG_ERROR([Illegal value -$with_initscript- for option --with-initscript])
13    fi
14  
15 -  AM_CONDITIONAL([HAVE_SYSV], [test x"$initscript" = xsysv])
16 -  AM_CONDITIONAL([HAVE_SYSTEMD_UNIT], [test x"$initscript" = xsystemd])
17 +  AM_CONDITIONAL([HAVE_SYSV], [test x"${initscript#sysv}" != "x${initscript}"])
18 +  AM_CONDITIONAL([HAVE_SYSTEMD_UNIT], [test x"${initscript%systemd}" != x"${initscript}"])
19    AC_MSG_NOTICE([Will use init script type: $initscript])
20    ])
21  
22 --- sssd-1.12.0/Makefile.am.orig        2014-07-15 20:47:04.758973132 +0200
23 +++ sssd-1.12.0/Makefile.am     2014-07-15 20:55:56.852284135 +0200
24 @@ -2532,7 +2532,8 @@
25      systemdconf_DATA += \
26          src/sysv/systemd/journal.conf
27  endif
28 -else
29 +endif
30 +if HAVE_SYSV
31  if HAVE_SUSE
32      init_SCRIPTS += \
33          src/sysv/SUSE/sssd
34 --- sssd-1.11.6/configure.ac.orig       2014-06-19 17:11:23.749261993 +0200
35 +++ sssd-1.11.6/configure.ac    2014-06-19 17:33:50.355900593 +0200
36 @@ -172,7 +172,7 @@
37  fi
38  
39  WITH_INITSCRIPT
40 -if test x$initscript = xsystemd; then
41 +if test x"${initscript%systemd}" != x"${initscript}"; then
42      WITH_SYSTEMD_UNIT_DIR
43  fi
44  
This page took 0.052459 seconds and 3 git commands to generate.