]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- update wal patch
[packages/sqlite3.git] / sqlite3.spec
index 8b948615ac5918b059e3354ac224f789ccf38ff2..8db95694b1f11f08fa7ccf77f5ef50ec493b006b 100644 (file)
@@ -11,8 +11,9 @@
 %bcond_without unlock_notify   # disable unlock notify API
 %bcond_without load_extension  # enable load extension API
 %bcond_with    icu             # ICU tokenizer support
+%bcond_without wal_replication         # WAL replication support
 
-%ifarch alpha sparc %{x8664}
+%ifarch %{x8664}
 %undefine      with_tests
 %endif
 
 
 # sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
 # but trailing 00 means no 4rd part (3 11 01 00 is 3.11.1)
-%define                vnum    3250000
+%define                vnum    3300100
 %define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.",""):gsub("\.0$","");print(v)}
 
+# wal replication version
+%define                walver  3.30.1
+
 %define                tclver          8.6
 Summary:       SQLite3 library
 Summary(pl.UTF-8):     Biblioteka SQLite3
@@ -36,10 +40,13 @@ Release:    1
 License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/2018/sqlite-src-%{vnum}.zip
-# Source0-md5: 4aa37b7b3cf5bd708dae325a0a0d440e
+Source0:       https://www.sqlite.org/2019/sqlite-src-%{vnum}.zip
+# Source0-md5: a090a543b1d17178627f280f0fe07324
 Patch0:                %{name}-sign-function.patch
-URL:           http://www.sqlite.org/
+# https://github.com/CanonicalLtd/dqlite/issues/91
+Patch1:                https://github.com/CanonicalLtd/sqlite/releases/download/version-%{walver}+replication3/sqlite-%{walver}.diff
+# Patch1-md5:  117f94e914198df90aac081262bdd146
+URL:           https://www.sqlite.org/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 %{!?with_readline:BuildRequires:       libedit-devel}
@@ -53,6 +60,7 @@ Requires:     %{name}-libs = %{version}-%{release}
 %{?with_icu:Provides:  %{name}(icu) = %{version}}
 %{?with_load_extension:Provides:       %{name}(load_extension) = %{version}}
 %{?with_unlock_notify:Provides:        %{name}(unlock_notify) = %{version}}
+%{?with_wal_replication:Provides:      %{name}(wal_replication) = %{version}}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _ulibdir        /usr/lib
@@ -89,6 +97,7 @@ Group:                Libraries
 %{?with_icu:Provides:  %{name}-libs(icu) = %{version}}
 %{?with_load_extension:Provides:       %{name}-libs(load_extension) = %{version}}
 %{?with_unlock_notify:Provides:        %{name}-libs(unlock_notify) = %{version}}
+%{?with_wal_replication:Provides:      %{name}-libs(wal_replication) = %{version}}
 Conflicts:     sqlite3 < 3.23.1-2
 
 %description libs
@@ -111,6 +120,7 @@ Provides:   %{name}-devel(load_extension) = %{version}
 %if %{with icu}
 Provides:      %{name}-devel(icu) = %{version}
 %endif
+%{?with_wal_replication:Provides:      %{name}-devel(wal_replication) = %{version}}
 
 %description devel
 SQLite is a C library that implements an SQL database engine. A large
@@ -154,6 +164,7 @@ Provides:   %{name}-static(unlock_notify)
 %if %{with load_extension}
 Provides:      %{name}-static(load_extension)
 %endif
+%{?with_wal_replication:Provides:      %{name}-static(wal_replication)}
 
 %description static
 SQLite is a C library that implements an SQL database engine. A large
@@ -198,6 +209,7 @@ Rozszerzenie sqlite3 dla Tcl.
 %prep
 %setup -q -n sqlite-src-%{vnum}
 %patch0 -p1
+%{?with_wal_replication:%patch1 -p1}
 
 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
 
@@ -274,6 +286,11 @@ append-libs "-licui18n -licuuc"
 append-libs "-ldl"
 %endif
 
+%if %{with wal_replication}
+# A patched version of SQLite with support for WAL-based replication
+append-cppflags -DSQLITE_ENABLE_WAL_REPLICATION
+%endif
+
 %configure \
        %{?with_readline:--disable-editline} \
        %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
This page took 0.047691 seconds and 4 git commands to generate.