]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
up to 3.24.0
[packages/sqlite3.git] / sqlite3.spec
index 7a98f260e12fad83db70adfa9b03c2eb165de985..76932649a3118c0bc69728df4d10df1f5254bc09 100644 (file)
@@ -1,9 +1,11 @@
 # TODO:
 # - some tests fail with tcl8.5, it's tcl fault,
 #      if someone REALLY cares (s)he can look into it
+# - sqlite binary is linked statically with sqlite library
 #
 # Conditional build:
 %bcond_with    tests           # run tests
+%bcond_with    readline        # readline (GPL) instead of libedit
 %bcond_without tcl             # Tcl extension
 %bcond_without doc             # disable documentation building
 %bcond_without unlock_notify   # disable unlock notify API
 
 # sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
 # but trailing 00 means no 4rd part (3 11 01 00 is 3.11.1)
-%define                vnum    3110100
+%define                vnum    3240000
 %define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.",""):gsub("\.0$","");print(v)}
 
 %define                tclver          8.6
-Summary:       SQLite library
-Summary(pl.UTF-8):     Biblioteka SQLite
+Summary:       SQLite3 library
+Summary(pl.UTF-8):     Biblioteka SQLite3
 Name:          sqlite3
 Version:       %{ver}
-Release:       1
+Release:       3
 License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/2016/sqlite-src-%{vnum}.zip
-# Source0-md5: 52f96513281a97f0632d2280964798fa
+Source0:       http://www.sqlite.org/2018/sqlite-src-%{vnum}.zip
+# Source0-md5: 36408fba1079b68421f3341f4505a960
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
-%{?with_load_extension:Provides:       %{name}(load_extension)}
-%{?with_unlock_notify:Provides:        %{name}(unlock_notify)}
-%{?with_icu:Provides:  %{name}(icu)}
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
+%{!?with_readline:BuildRequires:       libedit-devel}
 BuildRequires: libtool
-BuildRequires: readline-devel
+%{?with_readline:BuildRequires:        readline-devel}
 %{?with_load_extension:BuildRequires:  sed >= 4.0}
 BuildRequires: tcl
 %{?with_tcl:BuildRequires:     tcl-devel >= %{tclver}}
 BuildRequires: unzip
+Requires:      %{name}-libs = %{version}-%{release}
+%{?with_icu:Provides:  %{name}(icu) = %{version}}
+%{?with_load_extension:Provides:       %{name}(load_extension) = %{version}}
+%{?with_unlock_notify:Provides:        %{name}(unlock_notify) = %{version}}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _ulibdir        /usr/lib
@@ -78,19 +82,34 @@ bazodanowych przy większości operacji na bazie danych. Dodatkowo
 oprócz biblioteki języka C, dostarczany jest program do zarządzania
 bazami danych.
 
+%package libs
+Summary:       Shared library for the sqlite3 embeddable SQL database engine
+Summary(pl.UTF-8):     Biblioteka współdzielona osadzalnego silnika baz danych SQL sqlite3
+Group:         Libraries
+%{?with_icu:Provides:  %{name}-libs(icu) = %{version}}
+%{?with_load_extension:Provides:       %{name}-libs(load_extension) = %{version}}
+%{?with_unlock_notify:Provides:        %{name}-libs(unlock_notify) = %{version}}
+Conflicts:     sqlite3 < 3.23.1-2
+
+%description libs
+This package contains the SQLite 3 shared library.
+
+%description libs -l pl.UTF-8
+Ten pakiet zawiera bibliotekę współdzieloną SQLite 3.
+
 %package devel
 Summary:       Header files for SQLite development
 Summary(pl.UTF-8):     Pliki nagłówkowe SQLite
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 %if %{with unlock_notify}
-Provides:      %{name}-devel(unlock_notify)
+Provides:      %{name}-devel(unlock_notify) = %{version}
 %endif
 %if %{with load_extension}
-Provides:      %{name}-devel(load_extension)
+Provides:      %{name}-devel(load_extension) = %{version}
 %endif
 %if %{with icu}
-Provides:      %{name}-devel(icu)
+Provides:      %{name}-devel(icu) = %{version}
 %endif
 
 %description devel
@@ -191,7 +210,7 @@ fi
 %{__libtoolize}
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
-%{__autoconf}
+%{__autoconf} --force
 append-cppflags() {
        CPPFLAGS="$CPPFLAGS $*"
 }
@@ -215,6 +234,7 @@ append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
 # http://sqlite.org/fts3.html
 #append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
 append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
+append-cppflags -DSQLITE_ENABLE_FTS3_TOKENIZER
 
 # Support R*Trees.
 # http://sqlite.org/rtree.html
@@ -244,9 +264,11 @@ append-libs "-ldl"
 %endif
 
 %configure \
+       %{?with_readline:--disable-editline} \
        %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
        %{__enable_disable load_extension load-extension} \
-       --enable-threadsafe
+       --enable-threadsafe \
+       --enable-fts5
 
 %{__make}
 
@@ -259,10 +281,11 @@ append-libs "-ldl"
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
        $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
@@ -272,15 +295,18 @@ cp -p sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun libs -p /sbin/ldconfig
+
+%files libs
+%defattr(644,root,root,755)
+%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
+%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
 
 %files
 %defattr(644,root,root,755)
 %doc README.md
 %attr(755,root,root) %{_bindir}/sqlite3
-%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
-%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
 %{_mandir}/man1/sqlite3.1*
 
 %files devel
This page took 0.106108 seconds and 4 git commands to generate.