]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- up to 3.25.1
[packages/sqlite3.git] / sqlite3.spec
index 5a1b5ac9afaff51f8cc81959ec45eb6816c38268..6e3e2822b14f169c64da5209839dbbd432950d7c 100644 (file)
@@ -1,14 +1,16 @@
 # TODO:
 # - some tests fail with tcl8.5, it's tcl fault,
 #      if someone REALLY cares (s)he can look into it
-# - enable --enable-load-extension?
+# - sqlite binary is linked statically with sqlite library
 #
 # Conditional build:
 %bcond_with    tests           # run tests
+%bcond_with    readline        # readline (GPL) instead of libedit
 %bcond_without tcl             # Tcl extension
 %bcond_without doc             # disable documentation building
 %bcond_without unlock_notify   # disable unlock notify API
-%bcond_with    load_extension  # enable load extension API
+%bcond_without load_extension  # enable load extension API
+%bcond_with    icu             # ICU tokenizer support
 
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 %undefine      with_tests
 %endif
 
-%define                realver         3070603
-%define                srcver          src
-%define                rpmver          %(echo %{realver}|sed -e "s/00//g" -e "s/0/./g")
-%define                _ulibdir        /usr/lib
-%define                tclver          8.5
+# sqlite3 version with zero padded without any dots (3 08 10 01 is 3.8.10.1)
+# but trailing 00 means no 4rd part (3 11 01 00 is 3.11.1)
+%define                vnum    3250100
+%define                ver             %{lua:vn=rpm.expand("%vnum");v="";for i in string.gmatch(string.format("%08d", vn), "..") do v=v.."."..i:gsub("^0", "");end;v=v:gsub("^.",""):gsub("\.0$","");print(v)}
 
-Summary:       SQLite library
-Summary(pl.UTF-8):     Biblioteka SQLite
+%define                tclver          8.6
+Summary:       SQLite3 library
+Summary(pl.UTF-8):     Biblioteka SQLite3
 Name:          sqlite3
-Version:       3.7.6.3
+Version:       %{ver}
 Release:       1
 License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/sqlite-%{srcver}-%{realver}.zip
-# Source0-md5: f8e22ec0931c91f029d539fe3f5ef0f9
+Source0:       http://www.sqlite.org/2018/sqlite-src-%{vnum}.zip
+# Source0-md5: 17c9c3de62ed42f3e850cd5c72aa3b43
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
-%{?with_load_extension:Provides:       %{name}(load_extension)}
-%{?with_unlock_notify:Provides:        %{name}(unlock_notify)}
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
+%{!?with_readline:BuildRequires:       libedit-devel}
 BuildRequires: libtool
-BuildRequires: readline-devel
+%{?with_readline:BuildRequires:        readline-devel}
 %{?with_load_extension:BuildRequires:  sed >= 4.0}
 BuildRequires: tcl
-%{?with_tcl:BuildRequires:     tcl-devel}
+%{?with_tcl:BuildRequires:     tcl-devel >= %{tclver}}
 BuildRequires: unzip
+Requires:      %{name}-libs = %{version}-%{release}
+%{?with_icu:Provides:  %{name}(icu) = %{version}}
+%{?with_load_extension:Provides:       %{name}(load_extension) = %{version}}
+%{?with_unlock_notify:Provides:        %{name}(unlock_notify) = %{version}}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _ulibdir        /usr/lib
+
 %description
 SQLite is a C library that implements an SQL database engine. A large
 subset of SQL92 is supported. A complete database is stored in a
@@ -75,18 +82,34 @@ bazodanowych przy większości operacji na bazie danych. Dodatkowo
 oprócz biblioteki języka C, dostarczany jest program do zarządzania
 bazami danych.
 
+%package libs
+Summary:       Shared library for the sqlite3 embeddable SQL database engine
+Summary(pl.UTF-8):     Biblioteka współdzielona osadzalnego silnika baz danych SQL sqlite3
+Group:         Libraries
+%{?with_icu:Provides:  %{name}-libs(icu) = %{version}}
+%{?with_load_extension:Provides:       %{name}-libs(load_extension) = %{version}}
+%{?with_unlock_notify:Provides:        %{name}-libs(unlock_notify) = %{version}}
+Conflicts:     sqlite3 < 3.23.1-2
+
+%description libs
+This package contains the SQLite 3 shared library.
+
+%description libs -l pl.UTF-8
+Ten pakiet zawiera bibliotekę współdzieloną SQLite 3.
+
 %package devel
 Summary:       Header files for SQLite development
 Summary(pl.UTF-8):     Pliki nagłówkowe SQLite
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 %if %{with unlock_notify}
-Requires:      %{name}(unlock_notify)
-Provides:      %{name}-devel(unlock_notify)
+Provides:      %{name}-devel(unlock_notify) = %{version}
 %endif
 %if %{with load_extension}
-Requires:      %{name}(load_extension)
-Provides:      %{name}-devel(load_extension)
+Provides:      %{name}-devel(load_extension) = %{version}
+%endif
+%if %{with icu}
+Provides:      %{name}-devel(icu) = %{version}
 %endif
 
 %description devel
@@ -126,11 +149,9 @@ Summary(pl.UTF-8): Statyczne biblioteki SQLite
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 %if %{with unclock_notify}
-Requires:      %{name}-devel(unlock_notify)
 Provides:      %{name}-static(unlock_notify)
 %endif
 %if %{with load_extension}
-Requires:      %{name}-devel(load_extension)
 Provides:      %{name}-static(load_extension)
 %endif
 
@@ -175,27 +196,91 @@ sqlite3 tcl extension.
 Rozszerzenie sqlite3 dla Tcl.
 
 %prep
-%setup -q -n sqlite-%{srcver}-%{realver}
+%setup -q -n sqlite-src-%{vnum}
 %patch0 -p1
 
-%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
+%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
+
+if [ "$(cat VERSION)" != "%{version}" ]; then
+       echo "Tarball content doesn't match version %{version}." >&2
+       exit 1
+fi
 
 %build
 %{__libtoolize}
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
-%{__autoconf}
-CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE %{?with_unlock_notify:-DSQLITE_ENABLE_UNLOCK_NOTIFY}"
-export CFLAGS
-%if %{with load_extension}
-LIBS=-ldl
+%{__autoconf} --force
+append-cppflags() {
+       CPPFLAGS="$CPPFLAGS $*"
+}
+append-libs() {
+       LIBS="$LIBS $*"
+}
+export CPPFLAGS="%{rpmcflags}"
 export LIBS
+%if %{with tcl}
+export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
+%endif
+
+append-cppflags -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_SECURE_DELETE
+
+# Support for optional ORDER BY and LIMIT clause on UPDATE and DELETE statements
+append-cppflags -DSQLITE_ENABLE_UPDATE_DELETE_LIMIT
+
+# Support column metadata functions.
+# http://sqlite.org/c3ref/column_database_name.html
+# http://sqlite.org/c3ref/table_column_metadata.html
+append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
+
+# Support Full-Text Search versions 3 and 4.
+# http://sqlite.org/fts3.html
+#append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
+append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS
+append-cppflags -DSQLITE_ENABLE_FTS3_TOKENIZER
+
+# Support R*Trees.
+# http://sqlite.org/rtree.html
+append-cppflags -DSQLITE_ENABLE_RTREE
+
+# Support Geopoly module (new as of 3.25.0)
+# https://www.sqlite.org/geopoly.html
+append-cppflags -DSQLITE_ENABLE_GEOPOLY
+
+# Support soundex() function.
+# http://sqlite.org/lang_corefunc.html#soundex
+#append-cppflags -DSQLITE_SOUNDEX
+
+# Support dbstat virtual table.
+# https://www.sqlite.org/dbstat.html
+append-cppflags -DSQLITE_ENABLE_DBSTAT_VTAB
+
+# Support for session extension (record changes to a changeset).
+# https://www.sqlite.org/sessionintro.html
+append-cppflags -DSQLITE_ENABLE_SESSION -DSQLITE_ENABLE_PREUPDATE_HOOK
+
+%if %{with unlock_notify}
+# Support unlock notification.
+# http://sqlite.org/unlock_notify.html
+append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
+%endif
+
+%if %{with icu}
+append-cppflags -DSQLITE_ENABLE_ICU
+append-libs "-licui18n -licuuc"
+%endif
+
+%if %{with load_extension}
+append-libs "-ldl"
 %endif
+
 %configure \
-       %{?with_tcl:--with-tcl=%{_ulibdir}} \
-       %{!?with_tcl:--disable-tcl} \
-       --enable-threadsafe
-%{?with_load_extension:sed -i~ s/-DSQLITE_OMIT_LOAD_EXTENSION=1// Makefile}
+       %{?with_readline:--disable-editline} \
+       %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
+       %{__enable_disable load_extension load-extension} \
+       --enable-threadsafe \
+       --enable-fts5
+
 %{__make}
 
 %if %{with doc}
@@ -211,25 +296,28 @@ install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mand
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
        $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
 
-cp -a sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
+cp -p sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  libs -p /sbin/ldconfig
+%postun libs -p /sbin/ldconfig
 
-%files
+%files libs
 %defattr(644,root,root,755)
-%doc README
-%attr(755,root,root) %{_bindir}/sqlite3
 %attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
 %attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
+
+%files
+%defattr(644,root,root,755)
+%doc README.md
+%attr(755,root,root) %{_bindir}/sqlite3
 %{_mandir}/man1/sqlite3.1*
 
 %files devel
This page took 0.104749 seconds and 4 git commands to generate.