]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
extra requires on features not required due strict dependencies
[packages/sqlite3.git] / sqlite3.spec
index 2cacf50f0cce1800dfd4cceab807a9eed4de1ca2..5f2e33627f24ccf0ff9ce7f7071e4588cc2d3196 100644 (file)
@@ -1,14 +1,13 @@
 # TODO:
 # - some tests fail with tcl8.5, it's tcl fault,
 #      if someone REALLY cares (s)he can look into it
-# - enable --enable-load-extension?
 #
 # Conditional build:
 %bcond_with    tests           # run tests
 %bcond_without tcl             # Tcl extension
 %bcond_without doc             # disable documentation building
 %bcond_without unlock_notify   # disable unlock notify API
-%bcond_with    load_extension  # enable load extension API
+%bcond_without load_extension  # enable load extension API
 
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 %undefine      with_tests
 %endif
 
-%define                realver         3070900
-%define                srcver          src
-%define                rpmver          %(echo %{realver}|sed -e "s/00//g" -e "s/0/./g")
+#define                version_num %(echo %{version} |  awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
+%define                version_num 3071602
 %define                _ulibdir        /usr/lib
 %define                tclver          8.5
 
 Summary:       SQLite library
 Summary(pl.UTF-8):     Biblioteka SQLite
 Name:          sqlite3
-Version:       3.7.9
+Version:       3.7.16.2
 Release:       1
 License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/sqlite-%{srcver}-%{realver}.zip
-# Source0-md5: b2646c5a0c0b5bc6b8f0b67fc318bab3
+Source0:       http://www.sqlite.org/2013/sqlite-src-%{version_num}.zip
+# Source0-md5: 0d821779acdb56eee1fd71343b41a1cc
 Patch0:                %{name}-sign-function.patch
 URL:           http://www.sqlite.org/
 %{?with_load_extension:Provides:       %{name}(load_extension)}
@@ -81,11 +79,9 @@ Summary(pl.UTF-8):   Pliki nagłówkowe SQLite
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 %if %{with unlock_notify}
-Requires:      %{name}(unlock_notify)
 Provides:      %{name}-devel(unlock_notify)
 %endif
 %if %{with load_extension}
-Requires:      %{name}(load_extension)
 Provides:      %{name}-devel(load_extension)
 %endif
 
@@ -126,11 +122,9 @@ Summary(pl.UTF-8): Statyczne biblioteki SQLite
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 %if %{with unclock_notify}
-Requires:      %{name}-devel(unlock_notify)
 Provides:      %{name}-static(unlock_notify)
 %endif
 %if %{with load_extension}
-Requires:      %{name}-devel(load_extension)
 Provides:      %{name}-static(load_extension)
 %endif
 
@@ -175,7 +169,7 @@ sqlite3 tcl extension.
 Rozszerzenie sqlite3 dla Tcl.
 
 %prep
-%setup -q -n sqlite-%{srcver}-%{realver}
+%setup -q -n sqlite-src-%{version_num}
 %patch0 -p1
 
 %{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile*
@@ -197,8 +191,9 @@ export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
 %configure \
        %{?with_tcl:--with-tcl=%{_ulibdir}} \
        %{!?with_tcl:--disable-tcl} \
+       %{__enable_disable load_extension load-extension} \
        --enable-threadsafe
-%{?with_load_extension:sed -i~ s/-DSQLITE_OMIT_LOAD_EXTENSION=1// Makefile}
+
 %{__make}
 
 %if %{with doc}
This page took 0.03186 seconds and 4 git commands to generate.