]> git.pld-linux.org Git - packages/sqlite3.git/blobdiff - sqlite3.spec
- rel 2; really update to 3.8.7.2
[packages/sqlite3.git] / sqlite3.spec
index 95c9d0dd65e30df01335a9a6cfc8b1ac3c470ec8..5c74c3a65b3275c08f99b1afd0fd67105f4f265c 100644 (file)
@@ -1,47 +1,53 @@
 # TODO:
 # - some tests fail with tcl8.5, it's tcl fault,
 #      if someone REALLY cares (s)he can look into it
-# - alpha build fail:
-#   tclsh ./tool/mksqlite3c.tcl
-#   tclsh: allocatestack.c:404: allocate_stack: Assertion `size != 0' failed.
-#   make: *** [sqlite3.c] Aborted
 #
 # Conditional build:
-%bcond_with    tests   # run tests
-%bcond_without tcl     # disable tcl extension
-%bcond_without doc     # disable documentation building
-#
+%bcond_with    tests           # run tests
+%bcond_without tcl             # Tcl extension
+%bcond_without doc             # disable documentation building
+%bcond_without unlock_notify   # disable unlock notify API
+%bcond_without load_extension  # enable load extension API
+%bcond_with            icu             # ICU tokenizer support
+
 %ifarch alpha sparc %{x8664}
 %undefine      with_tests
 %endif
 
 # disabling tcl currently breaks making test target,
 # some hack in Makefile needs to be done
-%if !%{with tcl}
+%if %{without tcl}
 %undefine      with_tests
 %endif
 
+#define                version_num %(echo %{version} |  awk -F. '{printf("%d%02d%02d%02d", $1, $2, $3, $4)}')
+%define                version_num 3080702
 %define                _ulibdir        /usr/lib
-%define                tclver          8.5
+%define                tclver          8.6
 
 Summary:       SQLite library
 Summary(pl.UTF-8):     Biblioteka SQLite
 Name:          sqlite3
-Version:       3.6.3
-Release:       1
-License:       LGPL
+Version:       3.8.7.2
+Release:       2
+License:       Public Domain
 Group:         Libraries
 # Source0Download: http://www.sqlite.org/download.html
-Source0:       http://www.sqlite.org/sqlite-%{version}.tar.gz
-# Source0-md5: 671d2715f33158abc47a7a2ddd6066c5
+Source0:       http://www.sqlite.org/2014/sqlite-src-%{version_num}.zip
+# Source0-md5: d5f7285c59527caeb2e7401454fdc63e
 Patch0:                %{name}-sign-function.patch
-Patch1:                %{name}-pkgconfig.patch
 URL:           http://www.sqlite.org/
-BuildRequires: autoconf
+%{?with_load_extension:Provides:       %{name}(load_extension)}
+%{?with_unlock_notify:Provides:        %{name}(unlock_notify)}
+%{?with_icu:Provides:  %{name}(icu)}
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: libtool
 BuildRequires: readline-devel
-%{?with_tcl:BuildRequires:     tcl-devel}
+%{?with_load_extension:BuildRequires:  sed >= 4.0}
+BuildRequires: tcl
+%{?with_tcl:BuildRequires:     tcl-devel >= %{tclver}}
+BuildRequires: unzip
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -74,6 +80,15 @@ Summary:     Header files for SQLite development
 Summary(pl.UTF-8):     Pliki nagłówkowe SQLite
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+%if %{with unlock_notify}
+Provides:      %{name}-devel(unlock_notify)
+%endif
+%if %{with load_extension}
+Provides:      %{name}-devel(load_extension)
+%endif
+%if %{with icu}
+Provides:      %{name}-devel(icu)
+%endif
 
 %description devel
 SQLite is a C library that implements an SQL database engine. A large
@@ -111,6 +126,12 @@ Summary:   Static libraries for SQLite development
 Summary(pl.UTF-8):     Statyczne biblioteki SQLite
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
+%if %{with unclock_notify}
+Provides:      %{name}-static(unlock_notify)
+%endif
+%if %{with load_extension}
+Provides:      %{name}-static(load_extension)
+%endif
 
 %description static
 SQLite is a C library that implements an SQL database engine. A large
@@ -153,23 +174,68 @@ sqlite3 tcl extension.
 Rozszerzenie sqlite3 dla Tcl.
 
 %prep
-%setup -q -n sqlite-%{version}
+%setup -q -n sqlite-src-%{version_num}
 %patch0 -p1
-%patch1 -p1
 
-sed -i 's/mkdir doc/#mkdir doc/' Makefile*
+%{__sed} -i 's/mkdir doc/#mkdir doc/' Makefile.in
 
 %build
 %{__libtoolize}
 cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
-CFLAGS="%{rpmcflags} -DSQLITE_ENABLE_COLUMN_METADATA=1"
-export CFLAGS
+append-cppflags() {
+       CPPFLAGS="$CPPFLAGS $*"
+}
+append-libs() {
+       LIBS="$LIBS $*"
+}
+export CPPFLAGS="%{rpmcflags}"
+export LIBS
+%if %{with tcl}
+export TCLLIBDIR="%{tcl_sitearch}/sqlite3"
+%endif
+
+append-cppflags -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_SECURE_DELETE
+
+# Support column metadata functions.
+# http://sqlite.org/c3ref/column_database_name.html
+# http://sqlite.org/c3ref/table_column_metadata.html
+append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
+
+# Support Full-Text Search versions 3 and 4.
+# http://sqlite.org/fts3.html
+#append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
+append-cppflags -DSQLITE_ENABLE_FTS3
+
+# Support R*Trees.
+# http://sqlite.org/rtree.html
+append-cppflags -DSQLITE_ENABLE_RTREE
+
+# Support soundex() function.
+# http://sqlite.org/lang_corefunc.html#soundex
+#append-cppflags -DSQLITE_SOUNDEX
+
+%if %{with unlock_notify}
+# Support unlock notification.
+# http://sqlite.org/unlock_notify.html
+append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
+%endif
+
+%if %{with icu}
+append-cppflags -DSQLITE_ENABLE_ICU
+append-libs "-licui18n -licuuc"
+%endif
+
+%if %{with load_extension}
+append-libs "-ldl"
+%endif
+
 %configure \
-       %{?with_tcl:--with-tcl=%{_ulibdir}} \
-       %{!?with_tcl:--disable-tcl} \
+       %{!?with_tcl:--disable-tcl}%{?with_tcl:--with-tcl=%{_ulibdir}} \
+       %{__enable_disable load_extension load-extension} \
        --enable-threadsafe
+
 %{__make}
 
 %if %{with doc}
@@ -180,17 +246,16 @@ export CFLAGS
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
-
+install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}/man1}
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       TCLLIBDIR=%{_libdir}/tcl%{tclver}
+       DESTDIR=$RPM_BUILD_ROOT
 
-%if %{with tcl}
-sed -i -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_libdir}/tcl%{tclver}/sqlite3/pkgIndex.tcl
-%endif
+mv -f $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.so
+ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo lib*.so.*.*) \
+       $RPM_BUILD_ROOT%{_libdir}/libsqlite3.so
 
-install sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
+cp -p sqlite3.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -200,10 +265,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README
+%doc README.md
 %attr(755,root,root) %{_bindir}/sqlite3
-%attr(755,root,root) %{_libdir}/libsqlite3.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libsqlite3.so.0
+%attr(755,root,root) /%{_lib}/libsqlite3.so.*.*.*
+%attr(755,root,root) %ghost /%{_lib}/libsqlite3.so.0
 %{_mandir}/man1/sqlite3.1*
 
 %files devel
This page took 0.031429 seconds and 4 git commands to generate.