]> git.pld-linux.org Git - packages/spread-sheet-widget.git/blame - spread-sheet-widget.spec
- new
[packages/spread-sheet-widget.git] / spread-sheet-widget.spec
CommitLineData
0b13181f
AG
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
4#
5Summary: Library for Gtk+ which provides a widget for viewing and manipulating 2 dimensional tabular data
6Summary(pl.UTF-8): Biblioteka Gtk+ zapewniająca widget do przeglądania i manipulowania dwuwymiarowymi danymi tabelarycznymi
7Name: spread-sheet-widget
8Version: 0.3
9Release: 1
10License: GPL v3+
11Group: Libraries
12Source0: http://alpha.gnu.org/gnu/ssw/%{name}-%{version}.tar.gz
13# Source0-md5: 9bd94714a18229eb9e9a2b79dda30e1f
14Patch0: %{name}-am.patch
15URL: https://www.gnu.org/software/ssw/
16BuildRequires: autoconf
17BuildRequires: automake
18BuildRequires: glib2-devel >= 1:2.44
19BuildRequires: gtk+3-devel >= 3.18.0
20BuildRequires: intltool
21BuildRequires: libtool
22BuildRequires: texinfo
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26GNU Spread Sheet Widget is a library for Gtk+ which provides a widget
27for viewing and manipulating 2 dimensional tabular data in a manner
28similar to many popular spread sheet programs.
29
30The design follows the model-view-controller paradigm and is of
31complexity O(1) in both time and space. This means that it is
32efficient and fast even for very large data.
33
34Features commonly found in graphical user interfaces such as cut and
35paste, drag and drop and row/column labelling are also included.
36
37%description -l pl.UTF-8
38GNU Spread Sheet Widget to biblioteka Gtk+, która udostępnia widget do
39przeglądania i manipulowania dwuwymiarowymi danymi tabelarycznymi w
40sposób zbliżony do wielu popularnych programów do obsługi arkuszy
41kalkulacyjnych.
42
43Projekt jest zgodny z paradygmatem model-widok-kontroler i ma
44złożoność O (1) w czasie i przestrzeni. Oznacza to, że jest wydajny
45nawet dla bardzo dużych zestawów danych.
46
47Funkcje często spotykane w graficznych interfejsach użytkownika, takie
48jak wycinanie, wklejanie, przeciąganie i upuszczanie oraz
49etykietowanie wiersz / kolumna są również uwzględniane.
50
51%package devel
52Summary: Header files for %{name} library
53Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56
57%description devel
58Header files for %{name} library.
59
60%description devel -l pl.UTF-8
61Pliki nagłówkowe biblioteki %{name}.
62
63%package static
64Summary: Static %{name} library
65Summary(pl.UTF-8): Statyczna biblioteka %{name}
66Group: Development/Libraries
67Requires: %{name}-devel = %{version}-%{release}
68
69%description static
70Static %{name} library.
71
72%description static -l pl.UTF-8
73Statyczna biblioteka %{name}.
74
75%prep
76%setup -q
77%patch0 -p1
78
79%build
80%{__libtoolize}
81%{__aclocal}
82%{__autoconf}
83%{__autoheader}
84%{__automake}
85%configure \
86 %{!?with_static_libs:--disable-static}
87%{__make}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92%{__make} install \
93 DESTDIR=$RPM_BUILD_ROOT
94
95rm -f $RPM_BUILD_ROOT%{_infodir}/dir
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101%postun -p /sbin/ldconfig
102
103%post devel -p /sbin/postshell
104-/usr/sbin/fix-info-dir -c %{_infodir}
105
106%postun devel -p /sbin/postshell
107-/usr/sbin/fix-info-dir -c %{_infodir}
108
109%files
110%defattr(644,root,root,755)
111%doc AUTHORS ChangeLog NEWS README TODO
112%attr(755,root,root) %{_libdir}/libspread-sheet-widget.so.*.*.*
113%attr(755,root,root) %ghost %{_libdir}/libspread-sheet-widget.so.0
114
115%files devel
116%defattr(644,root,root,755)
117%attr(755,root,root) %{_libdir}/libspread-sheet-widget.so
118%{_libdir}/libspread-sheet-widget.la
119%{_includedir}/ssw-axis-model.h
120%{_includedir}/ssw-sheet-axis.h
121%{_includedir}/ssw-sheet.h
122%{_pkgconfigdir}/%{name}.pc
123%{_infodir}/%{name}.info*
124
125%if %{with static_libs}
126%files static
127%defattr(644,root,root,755)
128%{_libdir}/libspread-sheet-widget.a
129%endif
This page took 0.132707 seconds and 4 git commands to generate.