]> git.pld-linux.org Git - packages/spdylay.git/blame - spdylay.spec
- rebuild with libevent 2.1.11
[packages/spdylay.git] / spdylay.spec
CommitLineData
9bf22e59
JB
1#
2# Conditional build:
3%bcond_without tests # don't perform "make check"
4%bcond_without static_libs # don't build static library
5
6Summary: SPDY C library
7Summary(pl.UTF-8): Biblioteka C SPDY
8Name: spdylay
916d7449 9Version: 1.4.0
1684ce72 10Release: 3
9bf22e59
JB
11License: MIT
12Group: Libraries
4097aaf0
JB
13#Source0Download: https://github.com/tatsuhiro-t/spdylay/releases
14Source0: https://github.com/tatsuhiro-t/spdylay/releases/download/v%{version}/%{name}-%{version}.tar.xz
916d7449 15# Source0-md5: d1c976a8d2e222b00cee4b180be5e022
4097aaf0 16URL: http://tatsuhiro-t.github.io/spdylay/
9bf22e59
JB
17%{?with_tests:BuildRequires: CUnit >= 2.1}
18BuildRequires: libevent-devel >= 2.0.8
19BuildRequires: libstdc++-devel
20BuildRequires: libxml2-devel >= 1:2.7.7
21BuildRequires: openssl-devel >= 1.0.1
22BuildRequires: pkgconfig >= 1:0.20
23BuildRequires: tar >= 1:1.22
24BuildRequires: xz
25BuildRequires: zlib-devel >= 1.2.3
26Requires: libevent >= 2.0.8
27Requires: libxml2 >= 1:2.7.7
28Requires: openssl >= 1.0.1
29Requires: zlib >= 1.2.3
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33This is an experimental implementation of Google's SPDY protocol in C.
34This library provides SPDY version 2 and 3 framing layer
35implementation. It does not perform any I/O operations. When the
36library needs them, it calls the callback functions provided by the
37application. It also does not include any event polling mechanism, so
38the application can freely choose the way of handling events. This
39library code does not depend on any particular SSL library (except for
40example programs which depend on OpenSSL 1.0.1 or later).
41
42%description -l pl.UTF-8
43Ta biblioteka jest eksperymentalną implementacją protokołu SPDY
44Google'a w C. Udostępnia implementację warstwy ramek SPDY w wersji 2 i
453. Nie wykonuje żadnych operacji we/wy - w razie potrzeby odwołuje się
46do wywołań wstecznych dostarczonych przez aplikację. Nie zawiera także
47żadnego mechanizmu typu poll - aplikacja może dowolnie wybrać metodę
48obsługi zdarzeń. Biblioteka nie zależy od żadnej konkretnej biblioteki
49SSL (poza programami przykładowymi, które wymagają OpenSSL >= 1.0.1).
50
51%package devel
52Summary: Files needed for developing with libspdylay
53Summary(pl.UTF-8): Pliki niezbędne do tworzenia aplikacji z użyciem libspdylay
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56Requires: zlib-devel >= 1.2.3
57
58%description devel
59Files needed for building applications with libspdylay.
60
61%description devel -l pl.UTF-8
62Pliki niezbędne do tworzenia aplikacji z użyciem libspdylay.
63
64%package static
65Summary: Static libspdylay library
66Summary(pl.UTF-8): Statyczna biblioteka libspdylay
67Group: Development/Libraries
68Requires: %{name}-devel = %{version}-%{release}
69
70%description static
71Static libspdylay library.
72
73%description static -l pl.UTF-8
74Statyczna biblioteka libspdylay.
75
76%prep
77%setup -q
78
79%build
80%configure \
81 %{!?with_static_libs:--disable-static}
82
83%{__make}
84
85%if %{with tests}
86%{__make} check
87%endif
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
92%{__make} install \
93 DESTDIR=$RPM_BUILD_ROOT
94
95# obsoleted by pkg-config
96%{__rm} $RPM_BUILD_ROOT%{_libdir}/libspdylay.la
97# packaged as %doc
98%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/spdylay
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post -p /sbin/ldconfig
104%postun -p /sbin/ldconfig
105
106%files
107%defattr(644,root,root,755)
108%doc AUTHORS COPYING ChangeLog NEWS README.rst
109%attr(755,root,root) %{_bindir}/shrpx
110%attr(755,root,root) %{_bindir}/spdycat
111%attr(755,root,root) %{_bindir}/spdyd
112%attr(755,root,root) %{_libdir}/libspdylay.so.*.*.*
4097aaf0 113%attr(755,root,root) %ghost %{_libdir}/libspdylay.so.7
9bf22e59
JB
114
115%files devel
116%defattr(644,root,root,755)
117%attr(755,root,root) %{_libdir}/libspdylay.so
118%{_includedir}/spdylay
119%{_pkgconfigdir}/libspdylay.pc
120
121%if %{with static_libs}
122%files static
123%defattr(644,root,root,755)
124%{_libdir}/libspdylay.a
125%endif
This page took 1.648958 seconds and 4 git commands to generate.