]> git.pld-linux.org Git - packages/source-highlight.git/blob - source-highlight.spec
a37da111817b14165df09dfe8e9f02195a9ede20
[packages/source-highlight.git] / source-highlight.spec
1 Summary:        GNU Source Highlight
2 Summary(pl.UTF-8):      Podświetlanie składni z projektu GNU
3 Name:           source-highlight
4 Version:        3.1.9
5 Release:        1
6 License:        GPL v3+
7 Group:          Applications/Publishing
8 Source0:        https://ftp.gnu.org/gnu/src-highlite/%{name}-%{version}.tar.gz
9 # Source0-md5:  a51266164a537c97860d5d9664614dec
10 Patch0:         %{name}-info.patch
11 URL:            http://www.gnu.org/software/src-highlite/
12 BuildRequires:  bison
13 BuildRequires:  boost-devel >= 1.36.0
14 BuildRequires:  flex
15 BuildRequires:  help2man
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  texinfo
18 Requires:       %{name}-libs = %{version}-%{release}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This program, given a source file, produces a document with syntax
23 highlighting.
24
25 This package can handle many programming languages, e.g. C/C++, Flex,
26 Java, PHP, Perl, Prolog, Python as source languages; and some output
27 formats, e.g. HTML, XHTML, LaTeX.
28
29 %description -l pl.UTF-8
30 Ten program z pliku źródłowego tworzy dokument z podświetloną
31 składnią.
32
33 Pakiet potrafi obsłużyć wiele języków programowania, np. C/C++, Flex,
34 Java, PHP, Perl, Prolog, Python jako języki źródłowe; oraz kilka
35 formatów wyjściowych, np. HTML, XHTML, LaTeX.
36
37 %package libs
38 Summary:        Source highlight library
39 Summary(pl.UTF-8):      Biblioteka podświetlania składni
40 Group:          Libraries
41
42 %description libs
43 Source highlight library.
44
45 %description libs -l pl.UTF-8
46 Biblioteka podświetlania składni.
47
48 %package devel
49 Summary:        Header file for srchlite library
50 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki srchlite
51 Group:          Development/Libraries
52 Requires:       %{name}-libs = %{version}-%{release}
53 Requires:       boost-devel >= 1.36.0
54 Requires:       libstdc++-devel
55
56 %description devel
57 Header file for srchlite library.
58
59 %description devel -l pl.UTF-8
60 Plik nagłówkowy biblioteki srchlite.
61
62 %package static
63 Summary:        Static source-highlight library
64 Summary(pl.UTF-8):      Statyczna biblioteka source-highlight
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Statoic source highlight library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka podświetlania składni.
73
74 %package -n bash-completion-source-highlight
75 Summary:        bash-completion for source-higlight
76 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla pakietu source-highlight
77 Group:          Applications/Shells
78 Requires:       bash-completion
79
80 %description -n bash-completion-source-highlight
81 This package provides bash-completion for source-highlight.
82
83 %description -n bash-completion-source-highlight -l pl.UTF-8
84 Pakiet ten dostarcza bashowe uzupełnianie nazw dla pakiet
85 source-highlight.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90
91 %build
92 %configure \
93         --with-boost-libdir=%{_libdir}
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %{__rm} -rf docdir-%{name}-%{version}
104 %{__mv} -f $RPM_BUILD_ROOT%{_docdir}/%{name} docdir-%{name}-%{version}
105
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsource-highlight.la
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/postshell
112 -/usr/sbin/fix-info-dir -c %{_infodir}
113
114 %postun -p /sbin/postshell
115 -/usr/sbin/fix-info-dir -c %{_infodir}
116
117 %post   libs -p /sbin/ldconfig
118 %postun libs -p /sbin/ldconfig
119
120 %post   devel -p /sbin/postshell
121 -/usr/sbin/fix-info-dir -c %{_infodir}
122
123 %postun devel -p /sbin/postshell
124 -/usr/sbin/fix-info-dir -c %{_infodir}
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README THANKS TODO.txt doc/{*.css,*.html,*.java}
129 %doc docdir-%{name}-%{version}/*
130 %attr(755,root,root) %{_bindir}/check-regexp
131 %attr(755,root,root) %{_bindir}/cpp2html
132 %attr(755,root,root) %{_bindir}/java2html
133 %attr(755,root,root) %{_bindir}/source-highlight
134 %attr(755,root,root) %{_bindir}/source-highlight-esc.sh
135 %attr(755,root,root) %{_bindir}/source-highlight-settings
136 %attr(755,root,root) %{_bindir}/src-hilite-lesspipe.sh
137 %{_mandir}/man1/check-regexp.1*
138 %{_mandir}/man1/source-highlight.1*
139 %{_mandir}/man1/source-highlight-settings.1*
140 %{_datadir}/%{name}
141 %{_infodir}/source-highlight.info*
142
143 %files libs
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/libsource-highlight.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libsource-highlight.so.4
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/libsource-highlight.so
151 %{_includedir}/srchilite
152 %{_pkgconfigdir}/source-highlight.pc
153 %{_infodir}/source-highlight-lib.info*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libsource-highlight.a
158
159 %files -n bash-completion-source-highlight
160 %defattr(644,root,root,755)
161 %{_sysconfdir}/bash_completion.d/source-highlight
This page took 0.051603 seconds and 2 git commands to generate.