]> git.pld-linux.org Git - packages/snort.git/blobdiff - snort-libnet1.patch
- release 9 (by relup.sh)
[packages/snort.git] / snort-libnet1.patch
index 6a9a0f91738082ee9a6c347732c5802ff6deee13..63d64496dc0823b7089ad2a59f1ac1d1e3641b29 100644 (file)
@@ -1,76 +1,7 @@
-diff -Nur snort-2.0.0.org/configure.in snort-2.0.0/configure.in
---- snort-2.0.0.org/configure.in       2003-04-09 16:01:26.000000000 +0000
-+++ snort-2.0.0/configure.in   2003-07-03 22:28:27.000000000 +0000
-@@ -569,25 +569,25 @@
- AC_ARG_ENABLE(flexresp,
- [  --enable-flexresp       Flexible Responses on hostile connection attempts],
--[ CPPFLAGS="${CPPFLAGS} -DENABLE_RESPONSE `libnet-config --defines --cflags`" LDFLAGS="${LDFLAGS} `libnet-config --libs`"],)
-+[ CPPFLAGS="${CPPFLAGS} -DENABLE_RESPONSE `libnet1-config --defines --cflags`" LDFLAGS="${LDFLAGS} `libnet1-config --libs`"],)
-                 
- if test "$enable_flexresp" != "no" -a "$enable_flexresp" = "yes"; then
--  if test `libnet-config --cflags | wc -c` = "1"; then
-+  if test `libnet1-config --cflags | wc -c` = "1"; then
-     CFLAGS="${CFLAGS} -I/usr/local/include"
-     LIBNET_CONFIG_BROKEN_CFLAGS=yes
-   fi
--  if test `libnet-config --libs | wc -c` = "1"; then
--    AC_MSG_WARN(libnet-config --libs is broken on your system.  If you)
-+  if test `libnet1-config --libs | wc -c` = "1"; then
-+    AC_MSG_WARN(libnet1-config --libs is broken on your system.  If you)
-     AC_MSG_WARN(are using a precompiled package please notify the) 
-     AC_MSG_WARN(maintainer.)
-     LDFLAGS="${LDFLAGS} -L/usr/local/lib"
-   fi
-   LNET=""
--  AC_CHECK_HEADERS(libnet.h,, LNET="no")
-+  AC_CHECK_HEADERS(libnet1.h,, LNET="no")
-   if test "$LNET" = "no"; then
-     echo
-     echo "   ERROR!  Libnet header not found, go get it from"
-@@ -605,29 +605,29 @@
-       libnet_dir="/usr/include /usr/local/include"
-     fi
-   else
--    libnet_dir=`libnet-config --cflags | cut -dI -f2`
-+    libnet_dir=`libnet1-config --cflags | cut -dI -f2`
-   fi
-   LIBNET_INC_DIR=""
-   for i in $libnet_dir; do
--    if test -r $i/libnet.h; then
-+    if test -r $i/libnet1.h; then
-       LIBNET_INC_DIR=$i
-     fi
-   done
-   if test "$LIBNET_INC_DIR" != ""; then
--    if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet.h | grep -v 1.0.2a >/dev/null"; then
-+    if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet1.h | grep -v 1.0.2a >/dev/null"; then
-       AC_MSG_RESULT(no)
-       echo
-       echo "   ERROR!  Snort with --enable-flexresp will *only* work with"
-       echo "   libnet version 1.0.2a, go get it from"
-       echo "   http://www.packetfactory.net/projects/libnet/"
--      FAIL_MESSAGE("libnet 1.0.2a (libnet.h)", $LIBNET_INC_DIR)
-+      FAIL_MESSAGE("libnet 1.0.2a (libnet1.h)", $LIBNET_INC_DIR)
-     fi
-     AC_MSG_RESULT(yes)
-   else
-     AC_MSG_RESULT(no)
--    FAIL_MESSAGE("libnet 1.0.2a (libnet.h)", $libnet_dir)
-+    FAIL_MESSAGE("libnet 1.0.2a (libnet1.h)", $libnet_dir)
-   fi
-   LNET=""
-diff -Nur snort-2.0.0.org/src/detection-plugins/sp_react.c snort-2.0.0/src/detection-plugins/sp_react.c
---- snort-2.0.0.org/src/detection-plugins/sp_react.c   2003-04-03 21:10:52.000000000 +0000
-+++ snort-2.0.0/src/detection-plugins/sp_react.c       2003-07-03 22:31:13.000000000 +0000
-@@ -53,7 +53,7 @@
+diff -NurpP --minimal snort-2.6.1.3.a/src/detection-plugins/sp_react.c snort-2.6.1.3.b/src/detection-plugins/sp_react.c
+--- snort-2.6.1.3.a/src/detection-plugins/sp_react.c   2007-03-09 10:08:23.000000000 +0100
++++ snort-2.6.1.3.b/src/detection-plugins/sp_react.c   2007-03-09 10:40:03.000000000 +0100
+@@ -57,7 +57,7 @@
  #include <stdlib.h>
  #include <string.h>
  #include <ctype.h>
@@ -79,15 +10,189 @@ diff -Nur snort-2.0.0.org/src/detection-plugins/sp_react.c snort-2.0.0/src/detec
  
  #include "rules.h"
  #include "decode.h"
-diff -Nur snort-2.0.0.org/src/detection-plugins/sp_respond.c snort-2.0.0/src/detection-plugins/sp_respond.c
---- snort-2.0.0.org/src/detection-plugins/sp_respond.c 2003-04-03 21:10:52.000000000 +0000
-+++ snort-2.0.0/src/detection-plugins/sp_respond.c     2003-07-03 22:30:57.000000000 +0000
-@@ -30,7 +30,7 @@
+diff -NurpP --minimal snort-2.6.1.3.a/src/detection-plugins/sp_respond.c snort-2.6.1.3.b/src/detection-plugins/sp_respond.c
+--- snort-2.6.1.3.a/src/detection-plugins/sp_respond.c 2007-03-09 10:08:23.000000000 +0100
++++ snort-2.6.1.3.b/src/detection-plugins/sp_respond.c 2007-03-09 10:40:37.000000000 +0100
+@@ -34,7 +34,7 @@
  
  
- #ifdef ENABLE_RESPONSE
+ #if defined(ENABLE_RESPONSE) && !defined(ENABLE_RESPONSE2)
 -#include <libnet.h>
 +#include <libnet1.h>
  
  #include "decode.h"
  #include "rules.h"
+diff -NurpP --minimal snort-2.6.1.3.a/src/inline.c snort-2.6.1.3.b/src/inline.c
+--- snort-2.6.1.3.a/src/inline.c       2007-03-09 10:08:23.000000000 +0100
++++ snort-2.6.1.3.b/src/inline.c       2007-03-09 10:41:19.000000000 +0100
+@@ -20,7 +20,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <pcap.h>
+-#include <libnet.h>
++#include <libnet1.h>
+ #include "decode.h"
+ #include "inline.h"
+--- aaa/configure.in.orig      2008-07-18 20:42:29.000000000 +0000
++++ aaa/configure.in   2008-09-04 13:04:35.026969217 +0000
+@@ -1149,21 +1149,21 @@
+         if test -n "$with_libnet_includes" -a "$with_libnet_includes" != "no"; then
+             libnet_dir="${with_libnet_includes}"
+          else
+-            libnet_dir="/usr/include /usr/local/include /sw/include"
++            libnet_dir="/usr/include /usr/local/include /sw/include /usr/include/libnet1"
+         fi
+-        AC_MSG_CHECKING("for libnet.h version 1.0.x")
++        AC_MSG_CHECKING("for libnet1.h version 1.0.x")
+         for i in $libnet_dir; do
+-            if test -r "$i/libnet.h"; then
++            if test -r "$i/libnet1.h"; then
+                 LIBNET_INC_DIR="$i"
+             fi
+         done
+         if test "$LIBNET_INC_DIR" != ""; then
+-            if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet.h | grep -v 1.0 >/dev/null"; then
+-                FAIL_MESSAGE("libnet 1.0.x (libnet.h)", $LIBNET_INC_DIR)
++            if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet1.h | grep -v 1.0 >/dev/null"; then
++                FAIL_MESSAGE("libnet 1.0.x (libnet1.h)", $LIBNET_INC_DIR)
+             fi
+-            CFLAGS="${CFLAGS} `libnet-config --defines` `libnet-config --cflags`"
+-            LIBS="${LIBS} `libnet-config --libs`"
++            CFLAGS="${CFLAGS} `libnet1-config --defines` `libnet1-config --cflags`"
++            LIBS="${LIBS} `libnet1-config --libs`"
+             CPPFLAGS="${CPPFLAGS} -I${LIBNET_INC_DIR}"
+             AC_MSG_RESULT($i)
+         else
+@@ -1196,13 +1196,13 @@
+         exit
+     fi
+-    if test `libnet-config --cflags | wc -c` = "1"; then
++    if test `libnet1-config --cflags | wc -c` = "1"; then
+         CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/sw/include"
+         LIBNET_CONFIG_BROKEN_CFLAGS="yes"
+     fi
+-    if test `libnet-config --libs | wc -c` = "1"; then
+-        AC_MSG_WARN(libnet-config --libs is broken on your system.  If you)
++    if test `libnet1-config --libs | wc -c` = "1"; then
++        AC_MSG_WARN(libnet1-config --libs is broken on your system.  If you)
+         AC_MSG_WARN(are using a precompiled package please notify the) 
+         AC_MSG_WARN(maintainer.)
+         LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/sw/lib"
+@@ -1210,7 +1210,7 @@
+     fi
+     LNET=""
+-    AC_CHECK_HEADERS(libnet.h,, LNET="no")
++    AC_CHECK_HEADERS(libnet1.h,, LNET="no")
+     if test "x$LNET" = "xno"; then
+         echo
+         echo "   ERROR!  Libnet header not found, go get it from"
+@@ -1233,28 +1233,28 @@
+     LIBNET_INC_DIR=""
+     for i in $libnet_dir; do
+-        if test -r "$i/libnet.h"; then
++        if test -r "$i/libnet1.h"; then
+             LIBNET_INC_DIR="$i"
+         fi
+     done
+     if test "x$LIBNET_INC_DIR" != "x"; then
+-        if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet.h | grep -v 1.0.2a >/dev/null"; then
++        if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet1.h | grep -v 1.0.2a >/dev/null"; then
+             AC_MSG_RESULT(no)
+             echo
+             echo "   ERROR!  Snort with --enable-flexresp will *only* work with"
+             echo "   libnet version 1.0.2a, go get it from"
+             echo "   http://www.packetfactory.net/projects/libnet/"
+-            FAIL_MESSAGE("libnet 1.0.2a (libnet.h)", $LIBNET_INC_DIR)
++            FAIL_MESSAGE("libnet 1.0.2a (libnet1.h)", $LIBNET_INC_DIR)
+         fi
+         AC_MSG_RESULT(yes)
+     else
+         AC_MSG_RESULT(no)
+-        FAIL_MESSAGE("libnet 1.0.2a (libnet.h)", $libnet_dir)
++        FAIL_MESSAGE("libnet 1.0.2a (libnet1.h)", $libnet_dir)
+     fi
+     LNET=""
+-    AC_CHECK_LIB(net, libnet_build_ip,, LNET="no")
++    AC_CHECK_LIB(net1, libnet_build_ip,, LNET="no")
+     if test "x$LNET" = "xno"; then
+         echo
+         echo "   ERROR!  Libnet library not found, go get it from"
+@@ -1305,8 +1305,8 @@
+ [  --enable-react           Intercept and terminate offending HTTP accesses],
+        enable_react="$enableval", enable_react="no")
+ if test "x$enable_react" = "xyes"; then
+-    CPPFLAGS="${CPPFLAGS} -DENABLE_REACT `libnet-config --defines --cflags`"
+-    LDFLAGS="${LDFLAGS} `libnet-config --libs`"
++    CPPFLAGS="${CPPFLAGS} -DENABLE_REACT `libnet1-config --defines --cflags`"
++    LDFLAGS="${LDFLAGS} `libnet1-config --libs`"
+ fi
+ if test "x$enable_react" != "xno" -a "x$enable_react" = "xyes"; then
+@@ -1317,13 +1317,13 @@
+         exit
+     fi
+-    if test `libnet-config --cflags | wc -c` = "1"; then
++    if test `libnet1-config --cflags | wc -c` = "1"; then
+         CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/sw/include"
+         LIBNET_CONFIG_BROKEN_CFLAGS="yes"
+     fi
+-    if test `libnet-config --libs | wc -c` = "1"; then
+-        AC_MSG_WARN(libnet-config --libs is broken on your system.  If you)
++    if test `libnet1-config --libs | wc -c` = "1"; then
++        AC_MSG_WARN(libnet1-config --libs is broken on your system.  If you)
+         AC_MSG_WARN(are using a precompiled package please notify the)
+         AC_MSG_WARN(maintainer.)
+         LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/sw/lib"
+@@ -1331,7 +1331,7 @@
+     fi
+     LNET=""
+-    AC_CHECK_HEADERS(libnet.h,, LNET="no")
++    AC_CHECK_HEADERS(libnet1.h,, LNET="no")
+     if test "x$LNET" = "xno"; then
+         echo
+         echo "   ERROR!  Libnet header not found, go get it from"
+@@ -1354,28 +1354,28 @@
+     LIBNET_INC_DIR=""
+     for i in $libnet_dir; do
+-        if test -r "$i/libnet.h"; then
++        if test -r "$i/libnet1.h"; then
+             LIBNET_INC_DIR="$i"
+         fi
+     done
+     if test "x$LIBNET_INC_DIR" != "x"; then
+-        if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet.h | grep -v 1.0.2a >/dev/null"; then
++        if eval "grep LIBNET_VERSION $LIBNET_INC_DIR/libnet1.h | grep -v 1.0.2a >/dev/null"; then
+             AC_MSG_RESULT(no)
+             echo
+             echo "   ERROR!  Snort with --enable-react will *only* work with"
+             echo "   libnet version 1.0.2a, go get it from"
+             echo "   http://www.packetfactory.net/projects/libnet/"
+-            FAIL_MESSAGE("libnet 1.0.2a (libnet.h)", $LIBNET_INC_DIR)
++            FAIL_MESSAGE("libnet 1.0.2a (libnet1.h)", $LIBNET_INC_DIR)
+         fi
+         AC_MSG_RESULT(yes)
+     else
+         AC_MSG_RESULT(no)
+-        FAIL_MESSAGE("libnet 1.0.2a (libnet.h)", $libnet_dir)
++        FAIL_MESSAGE("libnet 1.0.2a (libnet1.h)", $libnet_dir)
+     fi
+     LNET=""
+-    AC_CHECK_LIB(net, libnet_build_ip,, LNET="no")
++    AC_CHECK_LIB(net1, libnet_build_ip,, LNET="no")
+     if test "x$LNET" = "xno"; then
+         echo
+         echo "   ERROR!  Libnet library not found, go get it from"
This page took 0.085948 seconds and 4 git commands to generate.