]> git.pld-linux.org Git - packages/serf.git/commitdiff
- updated to 1.3.1 (note: new soname; build system changed to scons) auto/th/serf-1.3.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 25 Aug 2013 09:44:30 +0000 (11:44 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 25 Aug 2013 09:44:30 +0000 (11:44 +0200)
- removed outdated sh,link patches; added scons patch instead

serf-link.patch [deleted file]
serf-scons.patch [new file with mode: 0644]
serf-sh.patch [deleted file]
serf.spec

diff --git a/serf-link.patch b/serf-link.patch
deleted file mode 100644 (file)
index 8ede4b2..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- serf-1.2.1/configure.in.orig       2013-06-06 15:24:17.713217048 +0200
-+++ serf-1.2.1/configure.in    2013-06-06 15:33:22.779872353 +0200
-@@ -182,10 +182,8 @@
-     APR_ADDTO(CPPFLAGS, "-I${openssl_prefix}/include")
-     if test -e "${openssl_prefix}/Makefile"; then
-       APR_ADDTO(LDFLAGS, "-L${openssl_prefix}")
--      APR_ADDTO(LDFLAGS, "-R${openssl_prefix}")
-     else
-       APR_ADDTO(LDFLAGS, "-L${openssl_prefix}/lib")
--      APR_ADDTO(LDFLAGS, "-R${openssl_prefix}/lib")
-     fi
-   fi
- ])
---- serf-1.2.1/configure.in~   2013-06-10 11:36:11.000000000 +0200
-+++ serf-1.2.1/configure.in    2013-06-10 11:39:28.923569641 +0200
-@@ -228,7 +228,7 @@
-       fi
-       APR_ADDTO(CFLAGS, "$GSSAPI_cflags")
-       APR_ADDTO(CFLAGS, [-DSERF_HAVE_GSSAPI])
--      APR_ADDTO(LDFLAGS, "$GSSAPI_libs")
-+      APR_ADDTO(LIBS, "$GSSAPI_libs")
-       AC_MSG_CHECKING([if gssapi works])
-       AC_LINK_IFELSE([AC_LANG_SOURCE([[
- #include <gssapi.h>
diff --git a/serf-scons.patch b/serf-scons.patch
new file mode 100644 (file)
index 0000000..7dc7c44
--- /dev/null
@@ -0,0 +1,40 @@
+--- serf-1.3.1/SConstruct.orig 2013-08-15 11:13:20.000000000 +0200
++++ serf-1.3.1/SConstruct      2013-08-25 09:57:51.577679354 +0200
+@@ -178,7 +178,6 @@
+ unknown = opts.UnknownVariables()
+ if unknown:
+   print 'Unknown variables:', ', '.join(unknown.keys())
+-  Exit(1)
+ apr = str(env['APR'])
+ apu = str(env['APU'])
+@@ -341,8 +341,8 @@
+   ### there is probably a better way to run/capture output.
+   ### env.ParseConfig() may be handy for getting this stuff into the build
+   if CALLOUT_OKAY:
+-    apr_libs = os.popen(env.subst('$APR --link-libtool --libs')).read().strip()
+-    apu_libs = os.popen(env.subst('$APU --link-libtool --libs')).read().strip()
++    apr_libs = os.popen(env.subst('$APR --link-ld --libs')).read().strip()
++    apu_libs = os.popen(env.subst('$APU --link-ld --libs')).read().strip()
+   else:
+     apr_libs = ''
+     apu_libs = ''
+@@ -374,6 +374,7 @@
+                          SUBST_DICT = {
+                            '@MAJOR@': str(MAJOR),
+                            '@PREFIX@': '$PREFIX',
++                           '@LIBDIR@': '$LIBDIR',
+                            '@INCLUDE_SUBDIR@': 'serf-%d' % (MAJOR,),
+                            '@VERSION@': '%d.%d.%d' % (MAJOR, MINOR, PATCH),
+                            '@LIBS@': '%s %s %s -lz' % (apu_libs, apr_libs,
+--- serf-1.3.1/build/serf.pc.in.orig   2011-08-06 09:52:19.000000000 +0200
++++ serf-1.3.1/build/serf.pc.in        2013-08-25 10:53:44.470871980 +0200
+@@ -1,7 +1,7 @@
+ SERF_MAJOR_VERSION=@MAJOR@
+ prefix=@PREFIX@
+ exec_prefix=${prefix}
+-libdir=${exec_prefix}/lib
++libdir=@LIBDIR@
+ includedir=${prefix}/include/@INCLUDE_SUBDIR@
+ Name: serf
diff --git a/serf-sh.patch b/serf-sh.patch
deleted file mode 100644 (file)
index f9435c8..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- serf-0.7.0/configure.in.orig       2009-07-28 00:20:24.000000000 +0200
-+++ serf-0.7.0/configure.in    2010-11-16 21:59:51.355099937 +0100
-@@ -78,7 +78,7 @@
- AC_SUBST(APR_VERSION)
- AC_SUBST(APR_CONFIG)
--APR_VERSION_MAJOR="`echo \"$APR_VERSION\" | sed 's,\..*,,'`"
-+APR_VERSION_MAJOR="$(echo "$APR_VERSION" | sed 's,\..*,,')"
- APR_VERSION_NUM="`echo \"$APR_VERSION\" | \
-                 sed -e 's/[[^0-9\.]].*$//' \
-                     -e 's/\.\([[0-9]]\)$/.0\1/' \
index 4e688f158f3e51c68ae85e230b740e630a7607d7..499d6bc23adb6cdfafba0b43c4c6c8d032cb040c 100644 (file)
--- a/serf.spec
+++ b/serf.spec
@@ -1,27 +1,25 @@
 #
 # Conditional build:
 %bcond_without kerberos5       # GSSAPI support
-%bcond_with    tests           # perform "make check" (uses localhost network, fails on apr side when IPV6 is enabled and localhost resolves only to IPV4 addresses)
+%bcond_with    tests           # perform "scons check" (uses localhost network, fails on apr side when IPV6 is enabled and localhost resolves only to IPV4 addresses)
 #
 Summary:       A high-performance asynchronous HTTP client library
 Summary(pl.UTF-8):     Wysokowydajna biblioteka asynchronicznego klienta HTTP
 Name:          serf
-Version:       1.2.1
-Release:       2
+Version:       1.3.1
+Release:       1
 License:       Apache v2.0
 Group:         Libraries
 #Source0Download: http://code.google.com/p/serf/downloads/list
 Source0:       http://serf.googlecode.com/files/%{name}-%{version}.tar.bz2
-# Source0-md5: 4f8e76c9c6567aee1d66aba49f76a58b
-Patch0:                %{name}-sh.patch
-Patch1:                %{name}-link.patch
+# Source0-md5: da5aca0cad19fd9c19129c3f8f7393dd
+Patch0:                %{name}-scons.patch
 URL:           http://code.google.com/p/serf/
 BuildRequires: apr-devel
 BuildRequires: apr-util-devel
-BuildRequires: autoconf >= 2.50
-BuildRequires: automake
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: scons >= 2.3.0
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -47,6 +45,7 @@ Requires:     %{name} = %{version}-%{release}
 Requires:      apr-devel
 Requires:      apr-util-devel
 %{?with_kerberos5:Requires:    heimdal-devel}
+Requires:      openssl-devel >= 0.9.7d
 
 %description devel
 C header files for the serf library.
@@ -69,27 +68,24 @@ Statyczne biblioteki serf.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
-%{__aclocal} -I build
-%{__autoconf}
-%configure \
-       --with-apr=%{_prefix} \
-       --with-apr-util=%{_prefix} \
-       %{?with_kerberos5:--with-gssapi=%{_prefix}} \
-       --with-openssl=%{_prefix}
-%{__make}
+%scons \
+       PREFIX=%{_prefix} \
+       LIBDIR=%{_libdir} \
+       GSSAPI=/usr
 
-%{?with_tests:%{__make} check}
+%if %{with tests}
+%scons check
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so*
+%scons install \
+       PREFIX=%{_prefix} \
+       LIBDIR=%{_libdir} \
+       --install-sandbox=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -101,13 +97,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc CHANGES NOTICE README
 %attr(755,root,root) %{_libdir}/libserf-1.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libserf-1.so.0
+%attr(755,root,root) %ghost %{_libdir}/libserf-1.so.3
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libserf-1.so
-%{_libdir}/libserf-1.la
-%{_includedir}/serf*.h
+%{_includedir}/serf-1
 %{_pkgconfigdir}/serf-1.pc
 
 %files static
This page took 0.117977 seconds and 4 git commands to generate.