]> git.pld-linux.org Git - packages/serf.git/commitdiff
patch from fedora to unbreak serf with openssl 3; rel 4 auto/th/serf-1.3.9-4
authorJan Palus <atler@pld-linux.org>
Wed, 13 Oct 2021 09:41:54 +0000 (11:41 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 13 Oct 2021 09:41:54 +0000 (11:41 +0200)
bio-ctrl.patch [new file with mode: 0644]
serf.spec

diff --git a/bio-ctrl.patch b/bio-ctrl.patch
new file mode 100644 (file)
index 0000000..b679edf
--- /dev/null
@@ -0,0 +1,21 @@
+diff --git a/buckets/ssl_buckets.c b/buckets/ssl_buckets.c
+index b01e5359db08..3c8b7e2a685f 100644
+--- a/buckets/ssl_buckets.c
++++ b/buckets/ssl_buckets.c
+@@ -407,7 +407,7 @@ static int bio_bucket_destroy(BIO *bio)
+ static long bio_bucket_ctrl(BIO *bio, int cmd, long num, void *ptr)
+ {
+-    long ret = 1;
++    long ret = 0;
+     switch (cmd) {
+     default:
+@@ -415,6 +415,7 @@ static long bio_bucket_ctrl(BIO *bio, int cmd, long num, void *ptr)
+         break;
+     case BIO_CTRL_FLUSH:
+         /* At this point we can't force a flush. */
++        ret = 1;
+         break;
+     case BIO_CTRL_PUSH:
+     case BIO_CTRL_POP:
index 8f78b9d80c504a4a86160b0e6c6f9bfb637eebcd..78908485c7a29208097430d1bf8b55b7a1bf30d4 100644 (file)
--- a/serf.spec
+++ b/serf.spec
@@ -7,13 +7,14 @@ Summary:      A high-performance asynchronous HTTP client library
 Summary(pl.UTF-8):     Wysokowydajna biblioteka asynchronicznego klienta HTTP
 Name:          serf
 Version:       1.3.9
-Release:       3
+Release:       4
 License:       Apache v2.0
 Group:         Libraries
 Source0:       https://www.apache.org/dist/serf/%{name}-%{version}.tar.bz2
 # Source0-md5: 370a6340ff20366ab088012cd13f2b57
 Patch0:                %{name}-scons.patch
 Patch1:                openssl3.patch
+Patch2:                bio-ctrl.patch
 URL:           https://serf.apache.org/
 BuildRequires: apr-devel
 BuildRequires: apr-util-devel
@@ -69,6 +70,7 @@ Statyczne biblioteki serf.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %scons \
This page took 0.195206 seconds and 4 git commands to generate.