]> git.pld-linux.org Git - packages/sendmail.git/commitdiff
- fix in %%files
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 26 Sep 2001 00:18:32 +0000 (00:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- one more fix in dtelnet patch, DESTDIR-related fix in makefile patch
- added STARTTLS support

Changed files:
    sendmail-dtelnet.patch -> 1.7
    sendmail-makefile.patch -> 1.2
    sendmail.spec -> 1.69

sendmail-dtelnet.patch
sendmail-makefile.patch
sendmail.spec

index 1cdb65a0fd0a8941adc7f69cabd179031cadd7ad..bb73d80972d128b99161bc4b988f00d4671cb6f9 100644 (file)
@@ -107,7 +107,7 @@ diff -Nur sendmail-8.12.0.orig/sendmail/srvrsmtp.c sendmail-8.12.0/sendmail/srvr
 -      else
 -              (void) sm_snprintf(cmdbuf, sizeof cmdbuf,
 -                       "%s-%%.*s ESMTP%%s", greetcode);
-+      sm_snprintf(cmdbuf, sizeof cmdbuf, "%s%c%%.*s ESMTP%%s", greetcode,
++      sm_snprintf(cmdbuf, sizeof cmdbuf, "%s%c%%.*s ESMTP%%s%s", greetcode,
 +              (p == NULL) ? ' ' : '-', DetectTelnet ? telnet_request : "");
        message(cmdbuf, (int) (id - inp), inp, id);
  
index ce4eac63a85e6b1ee132d34998f70ab021f30d1c..bb0bd8e0b83d6d0ab2a7f521bdcfdf2733009f46 100644 (file)
@@ -1,5 +1,48 @@
---- ./sendmail/Makefile.m4.org Thu Sep 20 01:30:44 2001
-+++ ./sendmail/Makefile.m4     Thu Sep 20 01:42:20 2001
+diff -Nur sendmail-8.12.0.orig/cf/cf/Makefile sendmail-8.12.0/cf/cf/Makefile
+--- sendmail-8.12.0.orig/cf/cf/Makefile        Mon Aug 20 17:16:48 2001
++++ sendmail-8.12.0/cf/cf/Makefile     Wed Sep 26 01:33:48 2001
+@@ -76,10 +76,10 @@
+ install-cf:  install-sendmail-cf install-submit-cf
+ install-sendmail-cf: $(CF).cf
+-      $(INSTALL) -c -o $(CFOWN) -g $(CFGRP) -m $(CFMODE) $(CF).cf ${DESTDIR}$(MAILDIR)/sendmail.cf
++      $(INSTALL) -c -m $(CFMODE) $(CF).cf ${DESTDIR}$(MAILDIR)/sendmail.cf
+ install-submit-cf: $(SUBMIT).cf
+-      $(INSTALL) -c -o $(CFOWN) -g $(CFGRP) -m $(CFMODE) $(SUBMIT).cf ${DESTDIR}$(MAILDIR)/submit.cf
++      $(INSTALL) -c -m $(CFMODE) $(SUBMIT).cf ${DESTDIR}$(MAILDIR)/submit.cf
+ depend:
+diff -Nur sendmail-8.12.0.orig/sendmail/Makefile.m4 sendmail-8.12.0/sendmail/Makefile.m4
+--- sendmail-8.12.0.orig/sendmail/Makefile.m4  Sat Jun 16 18:54:49 2001
++++ sendmail-8.12.0/sendmail/Makefile.m4       Wed Sep 26 01:35:09 2001
+@@ -11,7 +11,7 @@
+ dnl hack: /etc/mail is not defined as "location of .cf" in the build system
+ define(`bldTARGET_INST_DEP', ifdef(`confINST_DEP', `confINST_DEP',
+-`/etc/mail/submit.cf ${MSPQ}'))dnl
++`${DESTDIR}/etc/mail/submit.cf ${DESTDIR}${MSPQ}'))dnl
+ define(`bldTARGET_LINKS', ifdef(`confLINKS', `confLINKS',
+ `${DESTDIR}${UBINDIR}/newaliases ${DESTDIR}${UBINDIR}/mailq ${DESTDIR}${UBINDIR}/hoststat ${DESTDIR}${UBINDIR}/purgestat')
+ )dnl
+@@ -36,14 +36,14 @@
+ statistics:
+       ${CP} /dev/null statistics
+-/etc/mail/submit.cf:
++${DESTDIR}/etc/mail/submit.cf:
+       @echo "Please read INSTALL if anything fails while installing the binary."
+       @echo "/etc/mail/submit.cf will be installed now."
+       cd ${SRCDIR}/cf/cf && make install-submit-cf
+ MSPQ=ifdef(`confMSP_QUEUE_DIR', `confMSP_QUEUE_DIR', `/var/spool/clientmqueue')
+-${MSPQ}:
++${DESTDIR}${MSPQ}:
+       @echo "Please read INSTALL if anything fails while installing the binary."
+       @echo "You must have setup a new user ${MSPQOWN} and a new group ${GBINGRP}"
+       @echo "as explained in sendmail/SECURITY."
 @@ -61,7 +61,7 @@
  divert(bldTARGETS_SECTION)
  
        for i in confMTA_LINKS; do \
                rm -f $$i; \
                ln -s ${M`'BINDIR}/sm-mta $$i; \
---- ./cf/cf/Makefile.org       Thu Sep 20 01:04:53 2001
-+++ ./cf/cf/Makefile   Thu Sep 20 01:05:25 2001
-@@ -76,10 +76,10 @@
- install-cf:  install-sendmail-cf install-submit-cf
- install-sendmail-cf: $(CF).cf
--      $(INSTALL) -c -o $(CFOWN) -g $(CFGRP) -m $(CFMODE) $(CF).cf ${DESTDIR}$(MAILDIR)/sendmail.cf
-+      $(INSTALL) -c -m $(CFMODE) $(CF).cf ${DESTDIR}$(MAILDIR)/sendmail.cf
- install-submit-cf: $(SUBMIT).cf
--      $(INSTALL) -c -o $(CFOWN) -g $(CFGRP) -m $(CFMODE) $(SUBMIT).cf ${DESTDIR}$(MAILDIR)/submit.cf
-+      $(INSTALL) -c -m $(CFMODE) $(SUBMIT).cf ${DESTDIR}$(MAILDIR)/submit.cf
- depend:
index 5efb45338b6c0e34dc26253d4c923ced5760763a..dedecd19cd5cb7d00a9cc334c27ff0cb7e1108e1 100644 (file)
@@ -1,6 +1,7 @@
 #
 # Conditional build:
-# _without_ldap - without LDAP
+# _without_ldap                without LDAP support
+# _without_tls         without TLS (SSL) support
 #
 Summary:       A widely used Mail Transport Agent (MTA)
 Summary(de):   sendmail-Mail-Übertragungsagent
@@ -38,6 +39,7 @@ BuildRequires:        cyrus-sasl-devel
 BuildRequires: db3-devel
 BuildRequires: pam-devel
 %{!?_without_ldap:BuildRequires:       openldap-devel}
+%{!?_without_tls:BuildRequires:        openssl-devel}
 Requires:      m4
 Prereq:                /sbin/chkconfig
 Prereq:                /usr/sbin/groupadd
@@ -117,11 +119,15 @@ install %{SOURCE7} config.m4
 
 %build
 %if %{?debug:0}%{!?debug:1}
-echo "define(\`confLDOPTS\', \`-s\')" >> config.m4
+echo "define(\`confLDOPTS', \`-s')" >> config.m4
 %endif
 %if %{?_without_ldap:0}%{!?_without_ldap:1}
-echo "APPENDDEF(\`confMAPDEF\', \`-DLDAPMAP\')" >> config.m4
-echo "APPENDDEF(\`confLIBS\', \`-lldap -llber\')" >> config.m4
+echo "APPENDDEF(\`confMAPDEF', \`-DLDAPMAP')" >> config.m4
+echo "APPENDDEF(\`confLIBS', \`-lldap -llber')" >> config.m4
+%endif
+%if %{?_without_tls:0}%{!?_without_tls:1}
+echo "APPENDDEF(\`confENVDEF', \`-DSTARTTLS')" >> config.m4
+echo "APPENDDEF(\`confLIBS', \`-lssl -lcrypto')" >> config.m4
 %endif
 
 RPM_OPT_FLAGS="%{rpmcflags} -DUSE_VENDOR_CF_PATH=1 -DNETINET6"
@@ -215,7 +221,7 @@ mv -f smrsh/README README.smrsh
 mv -f cf/README README.cf
 mv -f doc/op/op.me .
 
-gzip -9nf FAQ KNOWNBUGS README* doc/op/op.me RELEASE_NOTES
+gzip -9nf FAQ KNOWNBUGS README* op.me RELEASE_NOTES
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.067151 seconds and 4 git commands to generate.