]> git.pld-linux.org Git - packages/seamonkey.git/blobdiff - seamonkey.spec
- fetch 2.0.10
[packages/seamonkey.git] / seamonkey.spec
index d468e19d84917a085db6715f09c5803f67038192..36cc2a4e67aa6a3e4e8b430bf8ddee0988cb98ed 100644 (file)
@@ -8,20 +8,20 @@
 %if %{without gnome}
 %undefine      with_gnomevfs
 %endif
-%define        enigmail_ver    0.95.6
+%define        enigmail_ver    1.1.2
 Summary:       SeaMonkey Community Edition - web browser
 Summary(es.UTF-8):     Navegador de Internet SeaMonkey Community Edition
 Summary(pl.UTF-8):     SeaMonkey Community Edition - przeglądarka WWW
 Summary(pt_BR.UTF-8):  Navegador SeaMonkey Community Edition
 Name:          seamonkey
-Version:       1.1.11
+Version:       2.0.10
 Release:       0.1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
-Source0:       ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/%{name}-%{version}.source.tar.bz2
-# Source0-md5: a1bde0923cb1eaef48e61c67676ad18f
+Source0:       ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/%{name}-%{version}.source.tar.bz2
+# Source0-md5: 08771818ede4a30c50500328b16c6f85
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: cfbe6ff77f80a349b396829757ad952a
+# Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
 Source2:       %{name}.desktop
 Source3:       %{name}-composer.desktop
 Source4:       %{name}-chat.desktop
@@ -206,7 +206,7 @@ Moduł Gnome-VFS dodający wsparcie dla URLi smb://.
 
 %prep
 %setup -qc
-cd mozilla
+cd comm-*
 tar -C mailnews/extensions -zxf %{SOURCE1}
 %patch0 -p1
 %patch1 -p1
@@ -260,7 +260,7 @@ ac_cv_visibility_pragma=no; export ac_cv_visibility_pragma
        --with-x
 
 %{__make} \
-       STRIP='printf "\033[1;31mWill not strip: %s\033[0;0m\n"'
+       STRIP=echo
 
 cd mailnews/extensions/enigmail
 ./makemake -r
@@ -333,33 +333,33 @@ if [ "$1" == "-remote" ]; then
 fi
 
 PING=`$SEAMONKEY -remote 'ping()' 2>&1 >/dev/null`
-       if [ -n "$PING" ]; then
-               if [ -f "`pwd`/$1" ]; then
+if [ -n "$PING" ]; then
+       if [ -f "`pwd`/$1" ]; then
                exec $SEAMONKEY "file://`pwd`/$1"
-               else
+       else
                exec $SEAMONKEY "$@"
-               fi
+       fi
 fi
 
-               if [ -z "$1" ]; then
+if [ -z "$1" ]; then
        exec $SEAMONKEY -remote 'xfeDoCommand (openBrowser)'
-               elif [ "$1" == "-mail" ]; then
+elif [ "$1" == "-mail" ]; then
        exec $SEAMONKEY -remote 'xfeDoCommand (openInbox)'
-               elif [ "$1" == "-compose" ]; then
+elif [ "$1" == "-compose" ]; then
        exec $SEAMONKEY -remote 'xfeDoCommand (composeMessage)'
 fi
 
 [[ $1 == -* ]] && exec $SEAMONKEY "$@"
 
-                               if [ -f "`pwd`/$1" ]; then
-                                       URL="file://`pwd`/$1"
-                               else
-                                       URL="$1"
-                               fi
+if [ -f "`pwd`/$1" ]; then
+       URL="file://`pwd`/$1"
+else
+       URL="$1"
+fi
 if grep -q -E 'browser.tabs.opentabfor.middleclick.*true' \
                ~/.mozilla/default/*/prefs.js; then
        exec $SEAMONKEY -remote "OpenUrl($URL,new-tab)"
-                               else
+else
        exec $SEAMONKEY -remote "OpenUrl($URL,new-window)"
 fi
 
@@ -389,11 +389,13 @@ EOF
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/%{name}-chrome+xpcom-generate
+if [ "$1" = 1 ]; then
+       %{_sbindir}/seamonkey-chrome+xpcom-generate
+fi
 %update_browser_plugins
 
 %postun
-%{_sbindir}/%{name}-chrome+xpcom-generate
+[ ! -x %{_sbindir}/seamonkey-chrome+xpcom-generate ] || %{_sbindir}/seamonkey-chrome+xpcom-generate
 if [ "$1" = 0 ]; then
        %update_browser_plugins
 fi
This page took 0.049872 seconds and 4 git commands to generate.