]> git.pld-linux.org Git - packages/seamonkey.git/blame - seamonkey.spec
- fixed install
[packages/seamonkey.git] / seamonkey.spec
CommitLineData
b19e17d8
JB
1#
2# Conditional build:
7c87af2b 3%bcond_without enigmail # don't build enigmail - GPG/PGP support
bd8dbb8a
JR
4%bcond_without gnomeui # disable gnomeui support
5%bcond_without gnome # disable gnomeui (alias)
7c87af2b
JR
6%bcond_without ldap # disable e-mail address lookups in LDAP directories
7%bcond_without lightning # disable Sunbird/Lightning calendar
bd8dbb8a
JR
8%bcond_with xulrunner # build with system xulrunner
9%bcond_with tests # enable tests (whatever they check)
10%bcond_without kerberos # disable krb5 support
7c87af2b 11
8c8a030f 12%if %{without gnome}
7c87af2b 13%undefine with_gnomeui
8c8a030f 14%endif
24441e9c 15
bd8dbb8a
JR
16%define enigmail_ver 1.4.1
17%define nspr_ver 4.9
18%define nss_ver 3.13.3
19%define xulrunner_ver 12.0
24441e9c
JR
20
21%if %{without xulrunner}
22# The actual sqlite version (see RHBZ#480989):
23%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24%endif
25
dc51aa63 26Summary: SeaMonkey Community Edition - web browser
fda067df
ER
27Summary(es.UTF-8): Navegador de Internet SeaMonkey Community Edition
28Summary(pl.UTF-8): SeaMonkey Community Edition - przeglądarka WWW
29Summary(pt_BR.UTF-8): Navegador SeaMonkey Community Edition
b19e17d8 30Name: seamonkey
bd8dbb8a 31Version: 2.9.1
2d1748a7 32Release: 0.1
e67de086 33License: MPL 1.1 or GPL v2+ or LGPL v2.1+
b19e17d8 34Group: X11/Applications/Networking
2d1748a7 35Source0: ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/%{name}-%{version}.source.tar.bz2
bd8dbb8a 36# Source0-md5: 8dd18d93a6570c3c9f3873bb177ccc6b
e14a25f7 37Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
bd8dbb8a 38# Source1-md5: 0eba75fbcf8f0bb32d538df102fbb8e9
5bead095 39Source2: %{name}.desktop
40Source3: %{name}-composer.desktop
41Source4: %{name}-chat.desktop
42Source5: %{name}-mail.desktop
43Source6: %{name}-venkman.desktop
bd8dbb8a 44Source7: %{name}.sh
8b22949b 45Patch0: %{name}-pld-homepage.patch
bd8dbb8a
JR
46Patch1: %{name}-agent.patch
47Patch2: %{name}-glueload-fix.patch
48Patch3: system-mozldap.patch
49Patch4: makefile.patch
50Patch5: system-cairo.patch
7bb99b6b 51URL: http://www.seamonkey-project.org/
bd8dbb8a 52BuildRequires: GConf2-devel >= 1.2.1
7c87af2b
JR
53BuildRequires: OpenGL-devel
54BuildRequires: alsa-lib-devel
b19e17d8 55BuildRequires: automake
7c87af2b
JR
56BuildRequires: bzip2-devel
57BuildRequires: cairo-devel >= 1.10.2-5
58BuildRequires: dbus-glib-devel >= 0.60
b19e17d8 59BuildRequires: freetype-devel >= 1:2.1.8
7c87af2b
JR
60BuildRequires: glib2-devel >= 1:2.18
61BuildRequires: gtk+2-devel >= 2:2.10
62%{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
63BuildRequires: hunspell-devel
98fe5fb0 64BuildRequires: libIDL-devel >= 0.8.0
7c87af2b
JR
65BuildRequires: libdnet-devel
66BuildRequires: libevent-devel >= 1.4.7
bd8dbb8a
JR
67# standalone libffi 3.0.9 or gcc's from 4.5(?)+
68BuildRequires: libffi-devel >= 6:3.0.9
69%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
70%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
71%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
7c87af2b 72BuildRequires: libiw-devel
b19e17d8 73BuildRequires: libjpeg-devel >= 6b
7c87af2b
JR
74BuildRequires: libnotify-devel >= 0.4
75BuildRequires: libpng(APNG)-devel >= 0.10
76BuildRequires: libpng-devel >= 1.4.1
b19e17d8 77BuildRequires: libstdc++-devel
7c87af2b
JR
78BuildRequires: libvpx-devel
79BuildRequires: nspr-devel >= 1:%{nspr_ver}
80BuildRequires: nss-devel >= 1:%{nss_ver}
81BuildRequires: pango-devel >= 1:1.14.0
bd8dbb8a 82BuildRequires: perl-base >= 1:5.6
7c87af2b 83BuildRequires: perl-modules >= 5.004
b19e17d8 84BuildRequires: pkgconfig
7c87af2b
JR
85BuildRequires: python >= 1:2.5
86BuildRequires: python-modules
c1527db1 87BuildRequires: rpm >= 4.4.9-56
7c87af2b 88BuildRequires: rpmbuild(macros) >= 1.601
b19e17d8 89BuildRequires: sed >= 4.0
bd8dbb8a 90BuildRequires: sqlite3-devel >= 3.7.10
7c87af2b
JR
91BuildRequires: startup-notification-devel >= 0.8
92BuildRequires: xorg-lib-libXScrnSaver-devel
f5fed05a 93BuildRequires: xorg-lib-libXext-devel
f5fed05a 94BuildRequires: xorg-lib-libXinerama-devel
f5fed05a 95BuildRequires: xorg-lib-libXt-devel
7c87af2b
JR
96%if %{with xulrunner}
97BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
98%endif
bd8dbb8a 99BuildRequires: yasm
7c87af2b 100BuildRequires: zip
510dc0c3 101BuildRequires: zlib-devel >= 1.2.3
7c87af2b
JR
102Requires(post): mktemp >= 1.5-18
103Requires: desktop-file-utils
104Requires: hicolor-icon-theme
105%if %{with xulrunner}
106%requires_eq_to xulrunner xulrunner-devel
107%else
6d3a5031 108Requires: browser-plugins >= 2.0
7c87af2b
JR
109Requires: cairo >= 1.10.2-5
110Requires: dbus-glib >= 0.60
111Requires: gtk+2 >= 2:2.18
112Requires: libpng >= 1.4.1
113Requires: libpng(APNG) >= 0.10
114Requires: myspell-common
115Requires: nspr >= 1:%{nspr_ver}
116Requires: nss >= 1:%{nss_ver}
117Requires: pango >= 1:1.14.0
118Requires: sqlite3 >= %{sqlite_build_version}
119Requires: startup-notification >= 0.8
120%endif
488e9642 121Provides: seamonkey-embedded = %{version}-%{release}
b19e17d8
JB
122Provides: wwwbrowser
123Obsoletes: light
f27b291c 124Obsoletes: mozilla
68683ec1 125Obsoletes: seamonkey-calendar
d6a799e8 126Obsoletes: seamonkey-libs
2607f7aa 127Obsoletes: seamonkey-mailnews
b19e17d8
JB
128BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
129
bd8dbb8a
JR
130%define topdir %{_builddir}/%{name}-%{version}
131%define objdir %{topdir}/obj-%{_target_cpu}
132
133%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
7c87af2b
JR
134
135# don't satisfy other packages
136%define _noautoprovfiles %{_libdir}/%{name}
92482a22 137# and as we don't provide them, don't require either
7c87af2b
JR
138%define _noautoreq libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
139%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
92482a22 140
b19e17d8 141%description
dc51aa63
ER
142SeaMonkey Community Edition is an open-source web browser, designed
143for standards compliance, performance and portability.
b19e17d8 144
97d18aeb 145%description -l es.UTF-8
dc51aa63 146SeaMonkey Community Edition es un navegador de Internet que se basa en
97d18aeb 147una versión inicial de Netscape Communicator.
b19e17d8 148
97d18aeb
JR
149%description -l pl.UTF-8
150SeaMonkey Community Edition jest potężną graficzną przeglądarką WWW,
151która jest następcą Mozilli, która następnie była następczynią
dc51aa63 152Netscape Communikatora.
b19e17d8 153
97d18aeb
JR
154%description -l pt_BR.UTF-8
155O SeaMonkey Community Edition é um web browser baseado numa versão
dc51aa63 156inicial do Netscape Communicator.
b19e17d8 157
97d18aeb
JR
158%description -l ru.UTF-8
159SeaMonkey Community Edition - полнофункциональный web-browser с
160открытыми исходными текстами, разработанный для максимального
161соотвествия стандартам, максмимальной переносимости и скорости работы
b19e17d8 162
2607f7aa
JR
163%package addon-lightning
164Summary: An integrated calendar for SeaMonkey
165Summary(pl.UTF-8): Zintegrowany kalendarz dla SeaMonkey
166License: MPL 1.1 or GPL v2+ or LGPL v2.1+
167Group: Applications/Networking
488e9642 168Requires: %{name} = %{version}-%{release}
3745e5ab 169
2607f7aa
JR
170%description addon-lightning
171Lightning is an calendar extension to Icedove email client.
b19e17d8 172
2607f7aa
JR
173%description addon-lightning -l pl.UTF-8
174Lightning to rozszerzenie do klienta poczty Icedove dodające
175funkcjonalność kalendarza.
b19e17d8 176
5bead095 177%package addon-enigmail
93b50f63
JB
178Summary: Enigmail %{enigmail_ver} - PGP/GPG support for SeaMonkey Community Edition
179Summary(pl.UTF-8): Enigmail %{enigmail_ver} - obsługa PGP/GPG dla SeaMonkey Community Edition
8c282ad7 180Group: X11/Applications/Networking
2607f7aa
JR
181Requires(post,postun): %{name} = %{version}-%{release}
182Requires: %{name} = %{version}-%{release}
5bead095 183Requires: gnupg >= 1.4.2.2
184
185%description addon-enigmail
794cd35c 186Enigmail is an extension to the mail client of SeaMonkey / Mozilla /
187Netscape and Mozilla Thunderbird which allows users to access the
188authentication and encryption features provided by GnuPG.
5bead095 189
97d18aeb 190%description addon-enigmail -l pl.UTF-8
794cd35c 191Enigmail jest rozszerzeniem dla klienta pocztowego SeaMonkey, Mozilla
97d18aeb
JR
192i Mozilla Thunderdbird pozwalającym użytkownikowi korzystać z
193funkcjonalności GnuPG.
5bead095 194
b19e17d8 195%package chat
dc51aa63 196Summary: SeaMonkey Community Edition Chat - integrated IRC client
fda067df 197Summary(pl.UTF-8): SeaMonkey Community Edition Chat - zintegrowany klient IRC-a
b19e17d8 198Group: X11/Applications/Networking
488e9642
JB
199Requires(post,postun): %{name} = %{version}-%{release}
200Requires: %{name} = %{version}-%{release}
f27b291c 201Obsoletes: mozilla-chat
b19e17d8
JB
202
203%description chat
dc51aa63
ER
204SeaMonkey Community Edition Chat - IRC client that is integrated with
205the SeaMonkey Community Edition web browser.
b19e17d8 206
97d18aeb 207%description chat -l pl.UTF-8
dc51aa63 208SeaMonkey Community Edition Chat - klient IRC-a zintegrowany z
97d18aeb 209przeglądarką SeaMonkey Community Edition.
b19e17d8
JB
210
211%package js-debugger
dc51aa63 212Summary: JavaScript debugger for use with SeaMonkey Community Edition
fda067df 213Summary(pl.UTF-8): Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition
b19e17d8 214Group: X11/Applications/Networking
488e9642
JB
215Requires(post,postun): %{name} = %{version}-%{release}
216Requires: %{name} = %{version}-%{release}
f27b291c 217Obsoletes: mozilla-js-debugger
b19e17d8
JB
218
219%description js-debugger
dc51aa63 220JavaScript debugger for use with SeaMonkey Community Edition.
b19e17d8 221
97d18aeb
JR
222%description js-debugger -l pl.UTF-8
223Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition.
b19e17d8
JB
224
225%package dom-inspector
dc51aa63 226Summary: A tool for inspecting the DOM of pages in SeaMonkey Community Edition
fda067df 227Summary(pl.UTF-8): Narzędzie do oglądania DOM stron w SeaMonkey Community Edition
b19e17d8 228Group: X11/Applications/Networking
488e9642
JB
229Requires(post,postun): %{name} = %{version}-%{release}
230Requires: %{name} = %{version}-%{release}
f27b291c 231Obsoletes: mozilla-dom-inspector
b19e17d8
JB
232
233%description dom-inspector
234This is a tool that allows you to inspect the DOM for web pages in
dc51aa63
ER
235SeaMonkey Community Edition. This is of great use to people who are
236doing SeaMonkey Community Edition chrome development or web page
237development.
b19e17d8 238
97d18aeb
JR
239%description dom-inspector -l pl.UTF-8
240To narzędzie pozwala na oglądanie DOM dla stron WWW w SeaMonkey
241Community Edition. Jest bardzo przydatne dla ludzi rozwijających
242chrome w SeaMonkey Community Edition lub tworzących strony WWW.
b19e17d8 243
b19e17d8 244%prep
dc51aa63 245%setup -qc
bd8dbb8a 246cd comm-release
5bead095 247tar -C mailnews/extensions -zxf %{SOURCE1}
bd8dbb8a
JR
248#patch0 -p1
249%patch1 -p1
250%patch2 -p1
251%patch3 -p1
252%patch4 -p1
2f09c133 253%patch5 -p1
bd8dbb8a
JR
254
255%build
256cd comm-release
257%if %{with xulrunner}
258if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
259 echo >&2
260 echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
261 echo >&2
262 exit 1
263fi
264%endif
265
266cp -f %{_datadir}/automake/config.* build/autoconf
267cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
268cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
269cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
270
271cat << EOF > .mozconfig
272mk_add_options MOZ_OBJDIR=%{objdir}
273
274export CFLAGS="%{rpmcflags}"
275export CXXFLAGS="%{rpmcflags}"
276
277%if %{with crashreporter}
278export MOZ_DEBUG_SYMBOLS=1
279%endif
280
281# Options for 'configure' (same as command-line options).
282ac_add_options --prefix=%{_prefix}
283ac_add_options --exec-prefix=%{_exec_prefix}
284ac_add_options --bindir=%{_bindir}
285ac_add_options --sbindir=%{_sbindir}
286ac_add_options --sysconfdir=%{_sysconfdir}
287ac_add_options --datadir=%{_datadir}
288ac_add_options --includedir=%{_includedir}
289ac_add_options --libdir=%{_libdir}
290ac_add_options --libexecdir=%{_libexecdir}
291ac_add_options --localstatedir=%{_localstatedir}
292ac_add_options --sharedstatedir=%{_sharedstatedir}
293ac_add_options --mandir=%{_mandir}
294ac_add_options --infodir=%{_infodir}
295ac_add_options --disable-elf-hack
296%if %{?debug:1}0
297ac_add_options --disable-optimize
298ac_add_options --enable-debug
299ac_add_options --enable-debug-modules
300ac_add_options --enable-debugger-info-modules
301ac_add_options --enable-crash-on-assert
c1527db1 302%else
bd8dbb8a
JR
303ac_add_options --disable-debug
304ac_add_options --disable-debug-modules
305ac_add_options --disable-logging
306ac_add_options --enable-optimize="%{rpmcflags} -Os"
c1527db1 307%endif
bd8dbb8a
JR
308ac_add_options --disable-strip
309ac_add_options --disable-strip-libs
310%if %{with tests}
311ac_add_options --enable-tests
312%else
313ac_add_options --disable-tests
314%endif
315ac_add_options --enable-gio
316%if %{with gnomeui}
317ac_add_options --enable-gnomeui
318%else
319ac_add_options --disable-gnomeui
320%endif
321ac_add_options --disable-gnomevfs
322%if %{with ldap}
323ac_add_options --enable-ldap
324ac_add_options --with-system-ldap
325%else
326ac_add_options --disable-ldap
327%endif
328%if %{with crashreporter}
329ac_add_options --enable-crashreporter
330%else
331ac_add_options --disable-crashreporter
332%endif
333ac_add_options --disable-xterm-updates
334ac_add_options --enable-postscript
335%if %{with lightning}
336ac_add_options --enable-calendar
337%else
338ac_add_options --disable-calendar
339%endif
340ac_add_options --disable-installer
341ac_add_options --disable-javaxpcom
342ac_add_options --disable-updater
343ac_add_options --disable-xprint
344ac_add_options --disable-permissions
345ac_add_options --disable-pref-extensions
346ac_add_options --enable-canvas
347ac_add_options --enable-crypto
348ac_add_options --enable-mathml
349ac_add_options --enable-libxul
350ac_add_options --enable-pango
351ac_add_options --enable-reorder
352ac_add_options --enable-startup-notification
353ac_add_options --enable-svg
354ac_add_options --enable-system-cairo
355ac_add_options --enable-system-hunspell
356ac_add_options --enable-system-sqlite
357ac_add_options --enable-application=suite
358ac_add_options --enable-default-toolkit=cairo-gtk2
359ac_add_options --enable-xinerama
360ac_add_options --with-distribution-id=org.pld-linux
bd8dbb8a 361ac_add_options --enable-shared-js
2607f7aa 362%if %{with xulrunner}
bd8dbb8a
JR
363ac_add_options --with-system-libxul
364ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
365%endif
366ac_add_options --with-pthreads
367ac_add_options --with-system-bz2
368ac_add_options --with-system-ffi
369ac_add_options --with-system-jpeg
370ac_add_options --with-system-libevent
371ac_add_options --with-system-libvpx
372ac_add_options --with-system-nspr
373ac_add_options --with-system-nss
374ac_add_options --with-system-png
375ac_add_options --with-system-zlib
376ac_add_options --enable-single-profile
377ac_add_options --disable-profilesharing
d7cc109a 378ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
bd8dbb8a 379EOF
b19e17d8 380
bd8dbb8a
JR
381%{__make} -j1 -f client.mk build \
382 STRIP="/bin/true" \
383 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
2607f7aa 384 installdir=%{_libdir}/%{name} \
bd8dbb8a
JR
385 CC="%{__cc}" \
386 CXX="%{__cxx}"
b19e17d8 387
bd8dbb8a
JR
388%if %{with crashreporter}
389# create debuginfo for crash-stats.mozilla.com
390%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
391%endif
392
393%if %{with enigmail}
5bead095 394cd mailnews/extensions/enigmail
bd8dbb8a
JR
395./makemake -r -o %{objdir}
396%{__make} -C %{objdir}/mailnews/extensions/enigmail \
397 STRIP="/bin/true" \
398 CC="%{__cc}" \
399 CXX="%{__cxx}"
400%endif
5bead095 401
b19e17d8
JB
402%install
403rm -rf $RPM_BUILD_ROOT
bd8dbb8a 404cd comm-release
b19e17d8 405install -d \
2607f7aa 406 $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
b19e17d8 407 $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
bd8dbb8a 408 $RPM_BUILD_ROOT%{_datadir}/%{name} \
d7cc109a 409 $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
b19e17d8 410
bd8dbb8a 411%browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
b19e17d8 412
d7cc109a 413cd %{objdir}
2607f7aa 414%{__make} -C suite/installer stage-package \
bd8dbb8a 415 DESTDIR=$RPM_BUILD_ROOT \
bd8dbb8a 416 installdir=%{_libdir}/%{name} \
2607f7aa
JR
417 PKG_SKIP_STRIP=1
418
419cp -a mozilla/dist/seamonkey/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
b19e17d8 420
bd8dbb8a
JR
421%if %{with xulrunner}
422# >= 5.0 seems to require this
423ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
424%endif
b19e17d8 425
d7cc109a
JR
426# Enable crash reporter for Thunderbird application
427%if %{with crashreporter}
428%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
429
430# Add debuginfo for crash-stats.mozilla.com
431install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
432cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
433%endif
434
435# copy manually lightning files, somewhy they are not installed by make
436cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
437 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
438 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
439
bd8dbb8a
JR
440# move arch independant ones to datadir
441mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
442mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
d7cc109a 443mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
2607f7aa 444mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
bd8dbb8a 445mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
2607f7aa
JR
446%if %{without xulrunner}
447mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
448mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
449%endif
b19e17d8 450
bd8dbb8a
JR
451ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
452ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
d7cc109a 453ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
2607f7aa 454ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
bd8dbb8a 455ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
2607f7aa
JR
456%if %{without xulrunner}
457ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
458ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
459%endif
460
461mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
462 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
bd8dbb8a 463
d7cc109a
JR
464# dir for arch independant extensions besides arch dependant extensions
465# see mozilla/xpcom/build/nsXULAppAPI.h
466# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
467install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
468
bd8dbb8a
JR
469%if %{without xulrunner}
470%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
471ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
2607f7aa
JR
472%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
473ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
bd8dbb8a 474%endif
b19e17d8 475
bd8dbb8a
JR
476sed 's,@LIBDIR@,%{_libdir},' %{SOURCE7} > $RPM_BUILD_ROOT%{_bindir}/seamonkey
477chmod a+rx $RPM_BUILD_ROOT%{_bindir}/seamonkey
b19e17d8 478
5bead095 479install %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} \
824eb755 480 $RPM_BUILD_ROOT%{_desktopdir}
b19e17d8 481
d7cc109a 482cp -p %{topdir}/comm-release/suite/branding/nightly/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
b19e17d8 483
2607f7aa 484# files created by seamonkey -register
d7cc109a
JR
485touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
486touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
b19e17d8 487
d7cc109a 488cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
b19e17d8
JB
489#!/bin/sh
490umask 022
d7cc109a
JR
491rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
492
493# it attempts to touch files in $HOME/.mozilla
494# beware if you run this with sudo!!!
495export HOME=$(mktemp -d)
496# also TMPDIR could be pointing to sudo user's homedir
497unset TMPDIR TMP || :
acf8815d 498
d7cc109a 499%{_libdir}/%{name}/seamonkey -register
acf8815d 500
d7cc109a 501rm -rf $HOME
b19e17d8 502EOF
d7cc109a 503chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
b19e17d8 504
d7cc109a
JR
505%if %{with enigmail}
506ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
507install -d $ext_dir/{chrome,components,defaults/preferences}
508cd mozilla/dist/bin
509#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
510#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
511cp -rfLp components/enig* $ext_dir/components
512cp -rfLp components/libenigmime.so $ext_dir/components
513cp -rfLp components/libipc.so $ext_dir/components
514cp -rfLp components/ipc.xpt $ext_dir/components
515cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
516cd -
517cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/install.rdf $ext_dir
518cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
519%endif
520
521# never package these. always remove
522# nss
523%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
524# nspr
525%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
526# mozldap
527%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
528# testpilot quiz
529%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
6d3a5031 530
b19e17d8
JB
531%clean
532rm -rf $RPM_BUILD_ROOT
533
6d3a5031 534%post
d7cc109a 535%{_libdir}/%{name}/register || :
6d3a5031 536%update_browser_plugins
d7cc109a 537%update_desktop_database
6d3a5031
ER
538
539%postun
6d3a5031
ER
540if [ "$1" = 0 ]; then
541 %update_browser_plugins
542fi
b19e17d8 543
b19e17d8
JB
544%files
545%defattr(644,root,root,755)
acf8815d 546%attr(755,root,root) %{_bindir}/seamonkey
b19e17d8 547
6d3a5031
ER
548# browser plugins v2
549%{_browserpluginsconfdir}/browsers.d/%{name}.*
550%config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
551
d7cc109a 552%dir %{_libdir}/%{name}
2607f7aa
JR
553%if %{without xulrunner}
554%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
d7cc109a 555%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
d7cc109a 556%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
2607f7aa
JR
557%attr(755,root,root) %{_libdir}/%{name}/libxul.so
558%endif
d7cc109a 559
2607f7aa
JR
560%{_libdir}/%{name}/blocklist.xml
561%attr(755,root,root) %{_libdir}/%{name}/register
d7cc109a 562
2607f7aa
JR
563%if %{with crashreporter}
564%{_libdir}/%{name}/crashreporter
565%{_libdir}/%{name}/crashreporter-override.ini
566%{_libdir}/%{name}/crashreporter.ini
567%{_libdir}/%{name}/Throbber-small.gif
568%endif
569
570# config?
571%{_libdir}/%{name}/application.ini
572%{_libdir}/%{name}/chrome.manifest
573
574%dir %{_libdir}/%{name}/components
575
576%{_libdir}/%{name}/components/FeedConverter.js
577%{_libdir}/%{name}/components/FeedWriter.js
578%{_libdir}/%{name}/components/Weave.js
579%{_libdir}/%{name}/components/WebContentConverter.js
580%{_libdir}/%{name}/components/browser.xpt
581%{_libdir}/%{name}/components/nsBrowserContentHandler.js
582%{_libdir}/%{name}/components/nsSessionStartup.js
583%{_libdir}/%{name}/components/nsSessionStore.js
584%{_libdir}/%{name}/components/nsSidebar.js
585
586%{_libdir}/%{name}/components/components.manifest
587%{_libdir}/%{name}/components/interfaces.manifest
588
589%if %{without xulrunner}
590%{_libdir}/%{name}/platform.ini
591%{_libdir}/%{name}/components/ConsoleAPI.js
592%{_libdir}/%{name}/components/FeedProcessor.js
593%{_libdir}/%{name}/components/GPSDGeolocationProvider.js
594%{_libdir}/%{name}/components/NetworkGeolocationProvider.js
595%{_libdir}/%{name}/components/PlacesCategoriesStarter.js
596%{_libdir}/%{name}/components/TelemetryPing.js
597%{_libdir}/%{name}/components/addonManager.js
598%{_libdir}/%{name}/components/amContentHandler.js
599%{_libdir}/%{name}/components/amWebInstallListener.js
600%{_libdir}/%{name}/components/contentAreaDropListener.js
601%{_libdir}/%{name}/components/contentSecurityPolicy.js
602%{_libdir}/%{name}/components/crypto-SDR.js
d7cc109a 603%{_libdir}/%{name}/components/jsconsole-clhandler.js
2607f7aa
JR
604%{_libdir}/%{name}/components/nsBadCertHandler.js
605%{_libdir}/%{name}/components/nsBlocklistService.js
606%{_libdir}/%{name}/components/nsContentDispatchChooser.js
607%{_libdir}/%{name}/components/nsContentPrefService.js
608%{_libdir}/%{name}/components/nsDefaultCLH.js
d7cc109a 609%{_libdir}/%{name}/components/nsFilePicker.js
2607f7aa
JR
610%{_libdir}/%{name}/components/nsFormAutoComplete.js
611%{_libdir}/%{name}/components/nsFormHistory.js
612%{_libdir}/%{name}/components/nsHandlerService.js
d7cc109a 613%{_libdir}/%{name}/components/nsHelperAppDlg.js
2607f7aa
JR
614%{_libdir}/%{name}/components/nsINIProcessor.js
615%{_libdir}/%{name}/components/nsInputListAutoComplete.js
616%{_libdir}/%{name}/components/nsLivemarkService.js
617%{_libdir}/%{name}/components/nsLoginInfo.js
618%{_libdir}/%{name}/components/nsLoginManager.js
619%{_libdir}/%{name}/components/nsLoginManagerPrompter.js
620%{_libdir}/%{name}/components/nsPlacesAutoComplete.js
621%{_libdir}/%{name}/components/nsPlacesExpiration.js
622%{_libdir}/%{name}/components/nsPrompter.js
d7cc109a 623%{_libdir}/%{name}/components/nsProxyAutoConfig.js
2607f7aa
JR
624%{_libdir}/%{name}/components/nsSearchService.js
625%{_libdir}/%{name}/components/nsSearchSuggestions.js
626%{_libdir}/%{name}/components/nsTaggingService.js
d7cc109a 627%{_libdir}/%{name}/components/nsURLFormatter.js
2607f7aa
JR
628%{_libdir}/%{name}/components/nsUpdateTimerManager.js
629%{_libdir}/%{name}/components/nsWebHandlerApp.js
630%{_libdir}/%{name}/components/storage-Legacy.js
631%{_libdir}/%{name}/components/storage-mozStorage.js
632%{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
633%endif
9015c9bf 634
2607f7aa
JR
635%{_libdir}/%{name}/components/nsAbout.js
636%{_libdir}/%{name}/components/nsAboutCertError.js
637%{_libdir}/%{name}/components/nsAboutData.js
638%{_libdir}/%{name}/components/nsAboutFeeds.js
639%{_libdir}/%{name}/components/nsAboutLife.js
640%{_libdir}/%{name}/components/nsAboutRights.js
641%{_libdir}/%{name}/components/nsAboutSessionRestore.js
642%{_libdir}/%{name}/components/nsAboutSyncTabs.js
643%{_libdir}/%{name}/components/nsComposerCmdLineHandler.js
644%{_libdir}/%{name}/components/nsSuiteDownloadManagerUI.js
645%{_libdir}/%{name}/components/nsSuiteGlue.js
646%{_libdir}/%{name}/components/nsTypeAheadFind.js
647%{_libdir}/%{name}/components/smileApplication.js
b19e17d8 648
2607f7aa
JR
649%if %{without xulrunner}
650%attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
651%endif
652
653%if %{without xulrunner}
654%attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
655%endif
656
657%attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
658
659%attr(755,root,root) %{_libdir}/%{name}/seamonkey
660%dir %{_libdir}/%{name}/plugins
661%if %{without xulrunner}
662%attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
663%attr(755,root,root) %{_libdir}/%{name}/seamonkey-bin
664%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
665%attr(755,root,root) %{_libdir}/%{name}/plugin-container
666%endif
667
668# symlinks
669%{_libdir}/%{name}/chrome
670%{_libdir}/%{name}/defaults
671%{_libdir}/%{name}/modules
672%{_libdir}/%{name}/searchplugins
673%if %{with xulrunner}
674%{_libdir}/%{name}/xulrunner
675%else
676%{_libdir}/%{name}/dictionaries
677%{_libdir}/%{name}/hyphenation
678%{_libdir}/%{name}/greprefs.js
679%{_libdir}/%{name}/res
680%endif
b19e17d8 681
2607f7aa
JR
682%dir %{_datadir}/%{name}
683%{_datadir}/%{name}/chrome
b19e17d8 684%{_datadir}/%{name}/defaults
2607f7aa 685%{_datadir}/%{name}/modules
b19e17d8 686%{_datadir}/%{name}/searchplugins
2607f7aa
JR
687%if %{without xulrunner}
688%{_datadir}/%{name}/greprefs.js
689%{_datadir}/%{name}/res
690%endif
b19e17d8 691
2607f7aa
JR
692%dir %{_datadir}/%{name}/extensions
693%dir %{_libdir}/%{name}/extensions
694# the signature of the default theme
695%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
696%{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
b19e17d8 697
2607f7aa
JR
698# files created by seamonkey -register
699%ghost %{_libdir}/%{name}/components/compreg.dat
700%ghost %{_libdir}/%{name}/components/xpti.dat
d7cc109a 701
2607f7aa
JR
702%{_libdir}/%{name}/components/glautocomp.js
703%{_libdir}/%{name}/components/jsmimeemitter.js
704%{_libdir}/%{name}/components/mail.xpt
d7cc109a 705%{_libdir}/%{name}/components/mdn-service.js
2607f7aa
JR
706%{_libdir}/%{name}/components/msgAsyncPrompter.js
707%{_libdir}/%{name}/components/newsblog.js
708%{_libdir}/%{name}/components/nsAbAutoCompleteMyDomain.js
709%{_libdir}/%{name}/components/nsAbAutoCompleteSearch.js
d7cc109a 710%{_libdir}/%{name}/components/nsAbLDAPAttributeMap.js
2607f7aa
JR
711%{_libdir}/%{name}/components/nsLDAPProtocolHandler.js
712%{_libdir}/%{name}/components/nsMailNewsCommandLineHandler.js
713%{_libdir}/%{name}/components/nsMsgTraitService.js
714%{_libdir}/%{name}/components/nsSMTPProtocolHandler.js
d7cc109a
JR
715%{_libdir}/%{name}/components/offlineStartup.js
716%{_libdir}/%{name}/components/smime-service.js
b19e17d8 717
2607f7aa
JR
718%{_libdir}/%{name}/isp
719%dir %{_datadir}/%{name}/isp
720%{_datadir}/%{name}/isp/Bogofilter.sfd
721%{_datadir}/%{name}/isp/DSPAM.sfd
722%{_datadir}/%{name}/isp/POPFile.sfd
723%{_datadir}/%{name}/isp/SpamAssassin.sfd
724%{_datadir}/%{name}/isp/SpamPal.sfd
725%{_datadir}/%{name}/isp/movemail.rdf
726%{_datadir}/%{name}/isp/rss.rdf
b19e17d8 727
2607f7aa
JR
728%{_pixmapsdir}/seamonkey.png
729%{_desktopdir}/%{name}.desktop
730%{_desktopdir}/%{name}-composer.desktop
824eb755 731%{_desktopdir}/%{name}-mail.desktop
b19e17d8 732
2607f7aa
JR
733%if %{with lightning}
734%files addon-lightning
735%defattr(644,root,root,755)
736%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
737%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
738%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
739%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
740%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
741%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
742%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
743%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
744%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
745%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
746%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
747%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
748%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
749%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
750%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
751%endif
752
753%if %{with enigmail}
5bead095 754%files addon-enigmail
755%defattr(644,root,root,755)
2607f7aa
JR
756%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
757%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
758%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
759%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
760%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
761%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
762%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
763%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
764%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
765%endif
5bead095 766
b19e17d8
JB
767%files chat
768%defattr(644,root,root,755)
2607f7aa 769%{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
824eb755 770%{_desktopdir}/%{name}-chat.desktop
b19e17d8
JB
771
772%files js-debugger
773%defattr(644,root,root,755)
2607f7aa 774%{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
824eb755 775%{_desktopdir}/%{name}-venkman.desktop
b19e17d8
JB
776
777%files dom-inspector
778%defattr(644,root,root,755)
2607f7aa 779%{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.203818 seconds and 4 git commands to generate.