]> git.pld-linux.org Git - packages/seafile-client.git/commitdiff
- up to 8.0.4 master auto/th/seafile-client-8.0.4-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 12 Oct 2021 21:51:12 +0000 (23:51 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 12 Oct 2021 21:51:12 +0000 (23:51 +0200)
seafile-client.spec
unknowwn-errors.patch [new file with mode: 0644]

index 87385668e42b13b44a818094c6c693f27d93f7fa..add32b43f141a4de0cbf608fe89cae82951ec553 100644 (file)
@@ -1,11 +1,12 @@
 Summary:       Seafile cloud storage desktop client
 Name:          seafile-client
-Version:       7.0.7
+Version:       8.0.4
 Release:       1
 License:       Apache v2.0
 Group:         Applications/Networking
 Source0:       https://github.com/haiwen/seafile-client/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: d518b25f48526667f078c08793d512fc
+# Source0-md5: f1962a9033be781bf68acccc43c895ea
+Patch0:                unknowwn-errors.patch
 URL:           https://www.seafile.com/
 BuildRequires: Qt5Core-devel
 BuildRequires: Qt5DBus-devel
@@ -43,9 +44,14 @@ team.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
-%cmake \
+mkdir -p build
+cd build
+%cmake ../ \
+       -DCMAKE_C_FLAGS="%{rpmcflags}" \
+       -DCMAKE_CXX_FLAGS="%{rpmcxxflags}" \
        -Dqmake_executable:FILEPATH=/usr/bin/qmake-qt5 \
        -DUSE_QT5=ON \
        -DCMAKE_BUILD_TYPE=Release .
@@ -54,7 +60,7 @@ team.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/seafile.desktop
diff --git a/unknowwn-errors.patch b/unknowwn-errors.patch
new file mode 100644 (file)
index 0000000..a4b3279
--- /dev/null
@@ -0,0 +1,34 @@
+--- seafile-client-8.0.4/src/utils/seafile-error.cpp~  2021-09-17 04:23:54.000000000 +0200
++++ seafile-client-8.0.4/src/utils/seafile-error.cpp   2021-10-12 23:38:32.287064065 +0200
+@@ -99,14 +99,6 @@
+         case SYNC_ERROR_ID_REMOVE_UNCOMMITTED_FOLDER:
+             error_str = QObject::tr("A folder that may contain not-yet-uploaded files is moved to seafile-recycle-bin folder.");
+             break;
+-#if !defined(Q_OS_WIN32)
+-        case SYNC_ERROR_ID_INVALID_PATH_ON_WINDOWS:
+-            error_str = QObject::tr("The file path contains symbols that are not supported by the Windows system");
+-            break;
+-#endif
+-        case SYNC_ERROR_ID_LIBRARY_TOO_LARGE:
+-            error_str = QObject::tr("Library is too large to sync.");
+-            break;
+         default:
+             qWarning("Unknown sync error");
+     }
+--- seafile-client-8.0.4/src/message-poller.cpp~       2021-09-17 04:23:54.000000000 +0200
++++ seafile-client-8.0.4/src/message-poller.cpp        2021-10-12 23:39:51.737017902 +0200
+@@ -176,14 +176,6 @@
+         case SYNC_ERROR_ID_REMOVE_UNCOMMITTED_FOLDER:
+             msg = tr("Folder %1 is moved to seafile-recycle-bin folder since it contains not-yet uploaded files.").arg(path);
+             break;
+-#if !defined(Q_OS_WIN32)
+-        case SYNC_ERROR_ID_INVALID_PATH_ON_WINDOWS:
+-            msg = tr("The file path %1 contains symbols that are not supported by the Windows system.").arg(path);
+-            break;
+-#endif
+-        case SYNC_ERROR_ID_LIBRARY_TOO_LARGE:
+-            msg = tr("Library is too large to sync.");
+-            break;
+         default:
+             qWarning("Unknown sync error id %d", err_id);
+             json_decref(object);
This page took 0.070486 seconds and 4 git commands to generate.