]> git.pld-linux.org Git - packages/scummvm.git/blobdiff - scummvm.spec
- allow cracked games to run
[packages/scummvm.git] / scummvm.spec
index 8223b7bf7a58e0305bd4fe1c59b41f2d54e02dd0..a6273f0f1506879cfff64390ec4117c296688b71 100644 (file)
@@ -1,71 +1,95 @@
-#
-# TODO:
-# - add desktop file and png icon. (when gui is ready)
-#
-%define                _snap           20021006
-%define                _toolsnap       20020919
+%define                version_tools   0.7.0
 Summary:       SCUMM graphic adventure game interpreter
 Summary(pl):   Interpreter przygodówek opartych na SCUMM
 Name:          scummvm
-Version:       0.2.0.%{_snap}
+Version:       0.7.1
 Release:       1
 License:       GPL
 Group:         X11/Applications/Games
-Source0:       %{name}-%{_snap}.tar.bz2
-#Source0:      http://telia.dl.sourceforge.net/sourceforge/scummvm/%{name}_%{version}-src.tgz
-Source1:       %{name}-tools-%{_toolsnap}.tar.bz2
-Patch0:                %{name}-lame.patch
-BuildRequires: mad-devel
+Source0:       http://dl.sourceforge.net/scummvm/%{name}-%{version}.tar.bz2
+# Source0-md5: a935499011c59441fcce8322ea1c4f1d
+Source1:       http://dl.sourceforge.net/scummvm/%{name}-tools-%{version_tools}.tar.bz2
+# Source1-md5: eeebbd4e309a8564dd911d5c26fed2f0
+Source2:       %{name}.desktop
+Source3:       %{name}.png
+Patch0:                %{name}-asm.patch
+URL:           http://scummvm.sourceforge.net/
 BuildRequires: SDL-devel >= 1.2.2
+BuildRequires: libmad-devel
+BuildRequires: libvorbis-devel
+BuildRequires: mpeg2dec-devel
+%ifarch %{ix86}
+BuildRequires: nasm
+%endif
+BuildRequires: sed >= 4.0
+BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-
 %description
-ScummVM is an implementation of the SCUMM (Script Creation Utility for
-Maniac Mansion) engine used in various Lucas Arts games such as Monkey
-Island and Day of the Tentacle. At this time ScummVM should be considered
-ALPHA software, as it's still under heavy development. Be aware that while
-many games will work with few major bugs, crashes can happen. Also note
-that saved games can, and probably will, be incompatible between releases.
+ScummVM is a collection of interpreters, capable of emulating several
+adventure game engines. ScummVM mainly supports games created using
+SCUMM (Script Creation Utility for Maniac Mansion), used in various
+LucasArts games such as Monkey Island, Day of the Tentacle, and
+others.
+
+ScummVM also contains interpreters for several non-SCUMM games.
+Currently these are Beneath a Steel Sky, Broken Sword 1 & 2, Flight of
+the Amazon Queen and Simon the Sorcerer 1 & 2.
 
-Also ScummVM is capable of playing several non-SCUMM games, at the moment
-this includes Simon The Sorcerer.
+At this time ScummVM should be considered beta software, and is still
+under heavy development. Be aware that whilst we attempt to make sure
+that many games can be completed with few major bugs, crashes can
+happen.
 
 %description -l pl
-ScummVM jest implementacj± silnika SCUMM (Narzêdzie tworz±ce skrypty dla
-Maniac Mansion) u¿ywanego w wielu grach Lucas Arts takich jak Monkey Island,
-czy Day of the Tentacle. ScummVM jest ca³y czas intensywnie rozwijany i
-powinien byæ traktowany jako program w stanie ALPHA. Wiele gier mo¿e siê
-wysypywaæ, lub dzia³aæ z b³êdami. Zapisane stany gry bêd± prawdopodobnie
-niekompatybilne pomiêdzy ró¿nymi wersjami ScummVM.
+ScummVM jest zbiorem interpreterów zdolnych do emulacji kilku silników
+gier przygodowych. ScummVM g³ównie wspiera gry stworzone z u¿yciem
+silnika SCUMM (Script Creation Utility for Maniac Mansion), u¿ywanego
+przez takie tytu³y stworzone przez Lucas Arts jak Monkey Island, Day
+of the Tentacle.
+
+ScummVM potrafi równie¿ interpretowaæ kilka gier nie opartych na
+SCUMM. W chwili obecnej s± to Beneath a Steel Sky, Broken Sword 1 i 2,
+Flight of the Amazon Queen oraz Simon the Sorcerer 1 i 2.
 
-ScummVM potrafi równie¿ obs³u¿yæ gry nie oparte na silniku SCUMM. W chwili
-obecnej jest to Simon The Sorcerer.
+ScummVM jest ca³y czas intensywnie rozwijany i powinien byæ traktowany
+jako program w stanie beta. Wiele gier powinno daæ siê skoñczyæ bez
+wiêkszych b³êdów, nale¿y byæ jednak ¶wiadomym, ¿e program mo¿e siê
+czasem wysypaæ.
 
 %package tools
-Summary:       SCUMM tools
-Summary(pl):   Narzêdzia zwi±zane ze SCUMM
+Summary:       ScummVM tools
+Summary(pl):   Narzêdzia zwi±zane ze ScummVM
 Group:         X11/Applications/Games
 
 %description tools
-SCUMM tools.
+Collection of various tools that may be useful to use in conjunction
+with ScummVM.
 
 %description tools -l pl
-Narzêdzia zwi±zane ze SCUMM.
+Zestaw narzêdzi mog±cych byæ u¿ytecznymi w po³±czeniu ze ScummVM.
 
 %prep
-%setup -q -a 1 -n %{name}
+%setup -q -a 1
 %patch0 -p1
 
+sed -i -e 's:(name "/lib" name ".so"):("%{_libdir}/lib" name ".so"):' base/plugins.cpp
+
 %build
+./configure \
+       --disable-debug \
+%ifnarch %{ix86}
+       --disable-nasm \
+%endif
+       --enable-kyra \
+       --enable-plugins
+
 %{__make} \
        CXX="%{__cxx}" \
-       CFLAGS="%{rpmcflags}" \
+       CXXFLAGS="%{rpmcflags} -DDYNAMIC_MODULES -fpic" \
        LDFLAGS="%{rpmldflags}"
 
-cd tools
+cd %{name}-tools-%{version_tools}
 %{__make} \
        CC="%{__cc}" \
        CFLAGS="%{rpmcflags}" \
@@ -73,26 +97,52 @@ cd tools
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man6}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man6,%{_pixmapsdir},%{_desktopdir},%{_libdir}}
 
 install scummvm $RPM_BUILD_ROOT%{_bindir}
 install scummvm.6 $RPM_BUILD_ROOT%{_mandir}/man6
 
-install tools/{descumm{3,5,6},rescumm} $RPM_BUILD_ROOT%{_bindir}
-install tools/extract $RPM_BUILD_ROOT%{_bindir}/extract-scummvm
+for i in kyra queen scumm sky sword{1,2} simon
+do
+       install $i/lib$i.so $RPM_BUILD_ROOT%{_libdir}
+done
+
+cd %{name}-tools-%{version_tools}
+install compress_san   $RPM_BUILD_ROOT%{_bindir}
+install convbdf                $RPM_BUILD_ROOT%{_bindir}
+install dekyra         $RPM_BUILD_ROOT%{_bindir}
+install descumm                $RPM_BUILD_ROOT%{_bindir}
+install desword2       $RPM_BUILD_ROOT%{_bindir}
+install extract                $RPM_BUILD_ROOT%{_bindir}/extract-scummvm
+install kyra_unpak     $RPM_BUILD_ROOT%{_bindir}
+install loom_tg16_extract      $RPM_BUILD_ROOT%{_bindir}
+install mm_nes_extract $RPM_BUILD_ROOT%{_bindir}
+install queenrebuild   $RPM_BUILD_ROOT%{_bindir}
+install rescumm                $RPM_BUILD_ROOT%{_bindir}
+install saga2mp3       $RPM_BUILD_ROOT%{_bindir}
+install simon1decr     $RPM_BUILD_ROOT%{_bindir}
+install simon2mp3      $RPM_BUILD_ROOT%{_bindir}
+install sword1mp3      $RPM_BUILD_ROOT%{_bindir}
+install sword2mp3      $RPM_BUILD_ROOT%{_bindir}
+cd -
+
+install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
+install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc NEWS README debian/README.Debian
+%doc NEWS README TODO
 %attr(755,root,root) %{_bindir}/scummvm
+%attr(755,root,root) %{_libdir}/*
 %{_mandir}/man6/*
+%{_pixmapsdir}/*
+%{_desktopdir}/*
 
 %files tools
 %defattr(644,root,root,755)
-%doc tools/readme.txt
-%attr(755,root,root) %{_bindir}/descumm*
-%attr(755,root,root) %{_bindir}/extract-scummvm
-%attr(755,root,root) %{_bindir}/rescumm
+%doc %{name}-tools-%{version_tools}/README
+%attr(755,root,root) %{_bindir}/*
+%exclude %{_bindir}/scummvm
This page took 0.093074 seconds and 4 git commands to generate.