]> git.pld-linux.org Git - packages/scummvm.git/blob - scummvm.spec
- don't use belnet.dl, it isn't browsable
[packages/scummvm.git] / scummvm.spec
1 %define         version_tools   0.7.0
2 Summary:        SCUMM graphic adventure game interpreter
3 Summary(pl):    Interpreter przygodówek opartych na SCUMM
4 Name:           scummvm
5 Version:        0.7.1
6 Release:        1
7 License:        GPL
8 Group:          X11/Applications/Games
9 Source0:        http://dl.sourceforge.net/scummvm/%{name}-%{version}.tar.bz2
10 # Source0-md5:  a935499011c59441fcce8322ea1c4f1d
11 Source1:        http://dl.sourceforge.net/scummvm/%{name}-tools-%{version_tools}.tar.bz2
12 # Source1-md5:  eeebbd4e309a8564dd911d5c26fed2f0
13 Source2:        %{name}.desktop
14 Source3:        %{name}.png
15 Patch0:         %{name}-asm.patch
16 URL:            http://scummvm.sourceforge.net/
17 BuildRequires:  SDL-devel >= 1.2.2
18 BuildRequires:  libmad-devel
19 BuildRequires:  libvorbis-devel
20 BuildRequires:  mpeg2dec-devel
21 %ifarch %{ix86}
22 BuildRequires:  nasm
23 %endif
24 BuildRequires:  zlib-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 ScummVM is a collection of interpreters, capable of emulating several
29 adventure game engines. ScummVM mainly supports games created using
30 SCUMM (Script Creation Utility for Maniac Mansion), used in various
31 LucasArts games such as Monkey Island, Day of the Tentacle, and
32 others.
33
34 ScummVM also contains interpreters for several non-SCUMM games.
35 Currently these are Beneath a Steel Sky, Broken Sword 1 & 2, Flight of
36 the Amazon Queen and Simon the Sorcerer 1 & 2.
37
38 At this time ScummVM should be considered beta software, and is still
39 under heavy development. Be aware that whilst we attempt to make sure
40 that many games can be completed with few major bugs, crashes can
41 happen.
42
43 %description -l pl
44 ScummVM jest zbiorem interpreterów zdolnych do emulacji kilku silników
45 gier przygodowych. ScummVM g³ównie wspiera gry stworzone z u¿yciem
46 silnika SCUMM (Script Creation Utility for Maniac Mansion), u¿ywanego
47 przez takie tytu³y stworzone przez Lucas Arts jak Monkey Island, Day
48 of the Tentacle.
49
50 ScummVM potrafi równie¿ interpretowaæ kilka gier nie opartych na
51 SCUMM. W chwili obecnej s± to Beneath a Steel Sky, Broken Sword 1 i 2,
52 Flight of the Amazon Queen oraz Simon the Sorcerer 1 i 2.
53
54 ScummVM jest ca³y czas intensywnie rozwijany i powinien byæ traktowany
55 jako program w stanie beta. Wiele gier powinno daæ siê skoñczyæ bez
56 wiêkszych b³êdów, nale¿y byæ jednak ¶wiadomym, ¿e program mo¿e siê
57 czasem wysypaæ.
58
59 %package tools
60 Summary:        ScummVM tools
61 Summary(pl):    Narzêdzia zwi±zane ze ScummVM
62 Group:          X11/Applications/Games
63
64 %description tools
65 Collection of various tools that may be useful to use in conjunction
66 with ScummVM.
67
68 %description tools -l pl
69 Zestaw narzêdzi mog±cych byæ u¿ytecznymi w po³±czeniu ze ScummVM.
70
71 %prep
72 %setup -q -a 1
73 %patch0 -p1
74
75 sed -i -e 's:(name "/lib" name ".so"):("%{_libdir}/lib" name ".so"):' base/plugins.cpp
76
77 %build
78 ./configure \
79         --disable-debug \
80 %ifnarch %{ix86}
81         --disable-nasm \
82 %endif
83         --enable-kyra \
84         --enable-plugins
85
86 %{__make} \
87         CXX="%{__cxx}" \
88         CXXFLAGS="%{rpmcflags} -DDYNAMIC_MODULES -fpic" \
89         LDFLAGS="%{rpmldflags}"
90
91 cd %{name}-tools-%{version_tools}
92 %{__make} \
93         CC="%{__cc}" \
94         CFLAGS="%{rpmcflags}" \
95         LDFLAGS="%{rpmldflags}"
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man6,%{_pixmapsdir},%{_desktopdir},%{_libdir}}
100
101 install scummvm $RPM_BUILD_ROOT%{_bindir}
102 install scummvm.6 $RPM_BUILD_ROOT%{_mandir}/man6
103
104 for i in kyra queen scumm sky sword{1,2} simon
105 do
106         install $i/lib$i.so $RPM_BUILD_ROOT%{_libdir}
107 done
108
109 cd %{name}-tools-%{version_tools}
110 install compress_san    $RPM_BUILD_ROOT%{_bindir}
111 install convbdf         $RPM_BUILD_ROOT%{_bindir}
112 install dekyra          $RPM_BUILD_ROOT%{_bindir}
113 install descumm         $RPM_BUILD_ROOT%{_bindir}
114 install desword2        $RPM_BUILD_ROOT%{_bindir}
115 install extract         $RPM_BUILD_ROOT%{_bindir}/extract-scummvm
116 install kyra_unpak      $RPM_BUILD_ROOT%{_bindir}
117 install loom_tg16_extract       $RPM_BUILD_ROOT%{_bindir}
118 install mm_nes_extract  $RPM_BUILD_ROOT%{_bindir}
119 install queenrebuild    $RPM_BUILD_ROOT%{_bindir}
120 install rescumm         $RPM_BUILD_ROOT%{_bindir}
121 install saga2mp3        $RPM_BUILD_ROOT%{_bindir}
122 install simon1decr      $RPM_BUILD_ROOT%{_bindir}
123 install simon2mp3       $RPM_BUILD_ROOT%{_bindir}
124 install sword1mp3       $RPM_BUILD_ROOT%{_bindir}
125 install sword2mp3       $RPM_BUILD_ROOT%{_bindir}
126 cd -
127
128 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
129 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %doc NEWS README TODO
137 %attr(755,root,root) %{_bindir}/scummvm
138 %attr(755,root,root) %{_libdir}/*
139 %{_mandir}/man6/*
140 %{_pixmapsdir}/*
141 %{_desktopdir}/*
142
143 %files tools
144 %defattr(644,root,root,755)
145 %doc %{name}-tools-%{version_tools}/README
146 %attr(755,root,root) %{_bindir}/*
147 %exclude %{_bindir}/scummvm
This page took 0.06756 seconds and 4 git commands to generate.