]> git.pld-linux.org Git - packages/scummvm.git/blob - scummvm.spec
- tabs in preamble
[packages/scummvm.git] / scummvm.spec
1 # TODO:
2 #  - include gui/themes/modern* and teach scummvm to search
3 #    for it in some system paths, not current dir
4 #
5 %define         version_tools   0.9.0
6 Summary:        SCUMM graphic adventure game interpreter
7 Summary(pl.UTF-8):      Interpreter przygodówek opartych na SCUMM
8 Name:           scummvm
9 Version:        0.9.1
10 Release:        1
11 License:        GPL
12 Group:          X11/Applications/Games
13 Source0:        http://dl.sourceforge.net/scummvm/%{name}-%{version}.tar.bz2
14 # Source0-md5:  30a82ad466bae223875e66ee14b94904
15 Source1:        http://dl.sourceforge.net/scummvm/%{name}-tools-%{version_tools}.tar.bz2
16 # Source1-md5:  c8164fa1cca90b1c3bff1c8949d875a3
17 Source2:        %{name}.desktop
18 Source3:        %{name}.png
19 URL:            http://scummvm.sourceforge.net/
20 BuildRequires:  SDL-devel >= 1.2.2
21 %ifarch %{ix86} %{x8664}
22 BuildRequires:  fluidsynth-devel
23 %endif
24 BuildRequires:  libmad-devel
25 BuildRequires:  libvorbis-devel
26 BuildRequires:  mpeg2dec-devel
27 %ifarch %{ix86}
28 BuildRequires:  nasm
29 %endif
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         specflags_sparc -fPIC
35
36 %description
37 ScummVM is a collection of interpreters, capable of emulating several
38 adventure game engines. ScummVM mainly supports games created using
39 SCUMM (Script Creation Utility for Maniac Mansion), used in various
40 LucasArts games such as Monkey Island, Day of the Tentacle, and
41 others.
42
43 ScummVM also contains interpreters for several non-SCUMM games.
44 Currently these are Beneath a Steel Sky, Broken Sword 1 & 2, Flight of
45 the Amazon Queen and Simon the Sorcerer 1 & 2.
46
47 At this time ScummVM should be considered beta software, and is still
48 under heavy development. Be aware that whilst we attempt to make sure
49 that many games can be completed with few major bugs, crashes can
50 happen.
51
52 %description -l pl.UTF-8
53 ScummVM jest zbiorem interpreterów zdolnych do emulacji kilku silników
54 gier przygodowych. ScummVM głównie wspiera gry stworzone z użyciem
55 silnika SCUMM (Script Creation Utility for Maniac Mansion), używanego
56 przez takie tytuły stworzone przez Lucas Arts jak Monkey Island, Day
57 of the Tentacle.
58
59 ScummVM potrafi również interpretować kilka gier nie opartych na
60 SCUMM. W chwili obecnej są to Beneath a Steel Sky, Broken Sword 1 i 2,
61 Flight of the Amazon Queen oraz Simon the Sorcerer 1 i 2.
62
63 ScummVM jest cały czas intensywnie rozwijany i powinien być traktowany
64 jako program w stanie beta. Wiele gier powinno dać się skończyć bez
65 większych błędów, należy być jednak świadomym, że program może się
66 czasem wysypać.
67
68 %package tools
69 Summary:        ScummVM tools
70 Summary(pl.UTF-8):      Narzędzia związane ze ScummVM
71 Group:          X11/Applications/Games
72
73 %description tools
74 Collection of various tools that may be useful to use in conjunction
75 with ScummVM.
76
77 %description tools -l pl.UTF-8
78 Zestaw narzędzi mogących być użytecznymi w połączeniu ze ScummVM.
79
80 %prep
81 %setup -q -a 1
82
83 sed -i -e 's:"plugins/":"%{_libdir}/scummvm/":' base/plugins.cpp
84
85 %build
86 ./configure \
87         --disable-debug \
88 %ifnarch %{ix86}
89         --disable-nasm \
90 %endif
91         --enable-lure \
92         --enable-cine \
93         --enable-plugins
94
95 %{__make} \
96         CXX="%{__cxx}" \
97         CXXFLAGS="%{rpmcflags} -DDYNAMIC_MODULES -fpic" \
98         LDFLAGS="%{rpmldflags}"
99
100 cd tools-%{version_tools}
101 %{__make} \
102         CC="%{__cc}" \
103         CFLAGS="%{rpmcflags}" \
104         LDFLAGS="%{rpmldflags}"
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man6,%{_pixmapsdir},%{_desktopdir},%{_libdir}/scummvm}
109
110 install scummvm $RPM_BUILD_ROOT%{_bindir}
111 #install scummvm.6 $RPM_BUILD_ROOT%{_mandir}/man6
112
113 install plugins/lib*.so $RPM_BUILD_ROOT%{_libdir}/scummvm
114
115 cd tools-%{version_tools}
116 install compress_kyra           $RPM_BUILD_ROOT%{_bindir}
117 install compress_queen          $RPM_BUILD_ROOT%{_bindir}
118 install compress_saga           $RPM_BUILD_ROOT%{_bindir}
119 install compress_scumm_bun      $RPM_BUILD_ROOT%{_bindir}
120 install compress_scumm_san      $RPM_BUILD_ROOT%{_bindir}
121 install compress_scumm_sou      $RPM_BUILD_ROOT%{_bindir}
122 install compress_simon          $RPM_BUILD_ROOT%{_bindir}
123 install compress_sword1         $RPM_BUILD_ROOT%{_bindir}
124 install compress_sword2         $RPM_BUILD_ROOT%{_bindir}
125 install dekyra                  $RPM_BUILD_ROOT%{_bindir}
126 install descumm                 $RPM_BUILD_ROOT%{_bindir}
127 install desword2                $RPM_BUILD_ROOT%{_bindir}
128 install encode_dxa              $RPM_BUILD_ROOT%{_bindir}
129 install extract_kyra            $RPM_BUILD_ROOT%{_bindir}
130 install extract_loom_tg16       $RPM_BUILD_ROOT%{_bindir}
131 install extract_mm_c64          $RPM_BUILD_ROOT%{_bindir}
132 install extract_mm_nes          $RPM_BUILD_ROOT%{_bindir}
133 install extract_scumm_mac       $RPM_BUILD_ROOT%{_bindir}
134 install extract_simon1_amiga    $RPM_BUILD_ROOT%{_bindir}
135 install extract_zak_c64         $RPM_BUILD_ROOT%{_bindir}
136 cd -
137
138 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
139 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS NEWS README TODO
147 %attr(755,root,root) %{_bindir}/scummvm
148 %{_libdir}/scummvm
149 #%{_mandir}/man6/*
150 %{_pixmapsdir}/*
151 %{_desktopdir}/*.desktop
152
153 %files tools
154 %defattr(644,root,root,755)
155 %doc tools-%{version_tools}/README
156 %attr(755,root,root) %{_bindir}/*
157 %exclude %{_bindir}/scummvm
This page took 0.090605 seconds and 4 git commands to generate.