]> git.pld-linux.org Git - packages/scribus.git/commitdiff
- fix building with poopler 21.03 auto/th/scribus-1.5.6.1-4
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 2 Apr 2021 20:47:47 +0000 (22:47 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 2 Apr 2021 20:47:47 +0000 (22:47 +0200)
- rel 4

poppler.patch [new file with mode: 0644]
scribus.spec

diff --git a/poppler.patch b/poppler.patch
new file mode 100644 (file)
index 0000000..e9913ac
--- /dev/null
@@ -0,0 +1,48 @@
+--- scribus-1.5.6.1/scribus/plugins/import/pdf/slaoutput.cpp~  2020-11-14 23:37:11.000000000 +0100
++++ scribus-1.5.6.1/scribus/plugins/import/pdf/slaoutput.cpp   2021-04-02 22:18:18.385332709 +0200
+@@ -2291,9 +2291,18 @@
+       return gTrue;\r
+ }\r
\r
+-GBool SlaOutputDev::tilingPatternFill(GfxState *state, Gfx * /*gfx*/, Catalog *cat, Object *str, POPPLER_CONST_070 double *pmat, int paintType, int tilingType, Dict *resDict, POPPLER_CONST_070 double *mat, POPPLER_CONST_070 double *bbox, int x0, int y0, int x1, int y1, double xStep, double yStep)\r
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(21, 3, 0)\r
++bool SlaOutputDev::tilingPatternFill(GfxState *state, Gfx * /*gfx*/, Catalog *cat, GfxTilingPattern *tPat, const double *mat, int x0, int y0, int x1, int y1, double xStep, double yStep)\r
++#else\r
++GBool SlaOutputDev::tilingPatternFill(GfxState *state, Gfx * /*gfx*/, Catalog *cat, Object *str, POPPLER_CONST_070 double *pmat, int /*paintType*/, int /*tilingType*/, Dict *resDict, POPPLER_CONST_070 double *mat, POPPLER_CONST_070 double *bbox, int x0, int y0, int x1, int y1, double xStep, double yStep)\r
++#endif\r
+ {\r
+ //    qDebug() << "SlaOutputDev::tilingPatternFill";\r
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(21, 3, 0)\r
++      const double *bbox = tPat->getBBox();\r
++      const double *pmat = tPat->getMatrix();\r
++      Dict *resDict = tPat->getResDict();\r
++#endif\r
+       PDFRectangle box;\r
+       Gfx *gfx;\r
+       QString id;\r
+@@ -2325,7 +2334,11 @@
+       // Unset the clip path as it is unrelated to the pattern's coordinate space.\r
+       QPainterPath savedClip = m_currentClipPath;\r
+       m_currentClipPath = QPainterPath();\r
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(21, 3, 0)\r
++        gfx->display(tPat->getContentStream());\r
++#else\r
+       gfx->display(str);\r
++#endif\r
+       m_currentClipPath = savedClip;\r
+       inPattern--;\r
+       gElements = m_groupStack.pop();\r
+--- scribus-1.5.6.1/scribus/plugins/import/pdf/slaoutput.h~    2020-11-14 23:37:11.000000000 +0100
++++ scribus-1.5.6.1/scribus/plugins/import/pdf/slaoutput.h     2021-04-02 22:15:19.594513556 +0200
+@@ -196,7 +196,11 @@
+       void stroke(GfxState *state) override;\r
+       void fill(GfxState *state) override;\r
+       void eoFill(GfxState *state) override;\r
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(21, 3, 0)\r
++      bool tilingPatternFill(GfxState *state, Gfx *gfx, Catalog *cat, GfxTilingPattern *tPat, const double *mat, int x0, int y0, int x1, int y1, double xStep, double yStep) override;\r
++#else\r
+       GBool tilingPatternFill(GfxState *state, Gfx *gfx, Catalog *cat, Object *str, POPPLER_CONST_070 double *pmat, int paintType, int tilingType, Dict *resDict, POPPLER_CONST_070 double *mat, POPPLER_CONST_070 double *bbox, int x0, int y0, int x1, int y1, double xStep, double yStep) override;\r
++#endif\r
+       GBool functionShadedFill(GfxState * /*state*/, GfxFunctionShading * /*shading*/) override { qDebug() << "Function Shaded Fill";  return gFalse; }\r
+       GBool axialShadedFill(GfxState *state, GfxAxialShading *shading, double tMin, double tMax) override;\r
+       GBool axialShadedSupportExtend(GfxState *state, GfxAxialShading *shading)  override { return (shading->getExtend0() == shading->getExtend1()); }\r
index e51595141ea6e5205db5617a3ca3906e57fc5aa0..7ca7ca925c2907a15f127b0a565cc0c4eee11ec0 100644 (file)
@@ -11,12 +11,13 @@ Summary:    Scribus - Open Source Desktop Publishing
 Summary(pl.UTF-8):     Scribus - DTP dla Wolnego Oprogramowania
 Name:          scribus
 Version:       1.5.6.1
-Release:       3
+Release:       4
 License:       GPL v2+
 Group:         X11/Applications/Publishing
 Source0:       http://downloads.sourceforge.net/scribus/%{name}-%{version}.tar.xz
 # Source0-md5: 12700cd8c6f08ef02f50495d2ef2d3ce
 Patch0:                %{name}-docs.patch
+Patch1:                poppler.patch
 URL:           https://www.scribus.net/
 BuildRequires: GraphicsMagick-devel
 BuildRequires: Qt5Core-devel >= %{qt_ver}
@@ -91,6 +92,8 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                specflags_ia32  -fomit-frame-pointer
 
+%define                _debugsource_packages   0
+
 %description
 Scribus is an open source desktop page layout program with the aim of
 producing commerical grade output in PDF and Postscript, primarily,
@@ -156,6 +159,7 @@ Domyślne szablony dokumentów dostarczane wraz ze Scribusem.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 mkdir -p build
This page took 0.124517 seconds and 4 git commands to generate.