]> git.pld-linux.org Git - packages/sblim-sfcb.git/commitdiff
- don't inline strncpy_kind
authorAdam Gołębiowski <adamg@pld-linux.org>
Sat, 29 Sep 2018 21:29:00 +0000 (23:29 +0200)
committerAdam Gołębiowski <adamg@pld-linux.org>
Sat, 29 Sep 2018 21:29:00 +0000 (23:29 +0200)
sblim-sfcb-dont-inline.patch [new file with mode: 0644]
sblim-sfcb.spec

diff --git a/sblim-sfcb-dont-inline.patch b/sblim-sfcb-dont-inline.patch
new file mode 100644 (file)
index 0000000..2988fb2
--- /dev/null
@@ -0,0 +1,11 @@
+--- sblim-sfcb-1.4.9/control.c~        2014-11-25 02:43:10.000000000 +0100
++++ sblim-sfcb-1.4.9/control.c 2018-09-29 23:23:00.359541768 +0200
+@@ -83,7 +83,7 @@
+  * Kindly null terminate, always, even if might overwrite
+  * the last char of the truncated string. 
+ */
+-inline char *strncpy_kind(char *to, char *from, size_t size) {
++char *strncpy_kind(char *to, char *from, size_t size) {
+   strncpy(to, from, size);
+   *(to + size - 1) = '\0';
+   return to;
index b0f8095125245d86aacc697e2c797bac4a1c1871..ff71481009a43f83de46ed1888a9fce7ddaad495 100644 (file)
@@ -10,6 +10,7 @@ Source0:      http://downloads.sourceforge.net/sblim/%{name}-%{version}.tar.bz2
 # Source0-md5: 28021cdabc73690a94f4f9d57254ce30
 Patch0:                %{name}-fix.patch
 Patch1:                am.patch
 # Source0-md5: 28021cdabc73690a94f4f9d57254ce30
 Patch0:                %{name}-fix.patch
 Patch1:                am.patch
+Patch2:                %{name}-dont-inline.patch
 URL:           http://sblim.sourceforge.net/
 BuildRequires: curl-devel >= 7.11.1
 BuildRequires: libstdc++-devel
 URL:           http://sblim.sourceforge.net/
 BuildRequires: curl-devel >= 7.11.1
 BuildRequires: libstdc++-devel
@@ -60,6 +61,7 @@ systemami.
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
 
 %build
 %{__libtoolize}
This page took 0.067554 seconds and 4 git commands to generate.