]> git.pld-linux.org Git - packages/sblim-sfcb.git/commitdiff
- new package
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 3 Jul 2012 15:36:42 +0000 (15:36 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix patch contains some fixes to jdbc provider code, but more work is needed;
  for now, disable jdbc

Changed files:
    sblim-sfcb-fix.patch -> 1.1
    sblim-sfcb.spec -> 1.1

sblim-sfcb-fix.patch [new file with mode: 0644]
sblim-sfcb.spec [new file with mode: 0644]

diff --git a/sblim-sfcb-fix.patch b/sblim-sfcb-fix.patch
new file mode 100644 (file)
index 0000000..1000ef0
--- /dev/null
@@ -0,0 +1,22 @@
+--- sblim-sfcb-1.3.15/sqlStatement.h.orig      2010-04-14 00:56:07.000000000 +0200
++++ sblim-sfcb-1.3.15/sqlStatement.h   2012-07-02 17:36:01.243897252 +0200
+@@ -344,7 +344,7 @@
+ UpdIns* newUpdIns(const char* tname, UtilList* colList,UtilList* assignmentList,UtilList* where);
+ Insert* newInsert(const char* tname);
+ ClassDef* newClassDef(int fieldCount, const char * className, UtilList * fieldNameList, int fNameLength, const char * superclass);
+-Call* newCall(char * tname, char * pname, UtilList * klist, UtilList * pList);
++Call* newCall(const char * tname, const char * pname, UtilList * klist, UtilList * pList);
+--- sblim-sfcb-1.3.15/sqlStatement.c.orig      2011-12-01 00:24:18.000000000 +0100
++++ sblim-sfcb-1.3.15/sqlStatement.c   2012-07-02 17:39:30.290555146 +0200
+@@ -1729,7 +1729,7 @@
+             sl = d.value.sint64;
+             break;
+        default:
+-          ul = 0; 
++          sl = 0; 
+           break;
+          }
+          sprintf(sp,"%lld", sl);
diff --git a/sblim-sfcb.spec b/sblim-sfcb.spec
new file mode 100644 (file)
index 0000000..c57fc11
--- /dev/null
@@ -0,0 +1,135 @@
+Summary:       Small Footprint CIM Broker
+Summary(pl.UTF-8):     Lekki broker CIM
+Name:          sblim-sfcb
+Version:       1.3.15
+Release:       1
+License:       Eclipse Public License v1.0
+Group:         Libraries
+Source0:       http://downloads.sourceforge.net/sblim/%{name}-%{version}.tar.bz2
+# Source0-md5: 117e50f989370376876163e621a59f73
+Patch0:                %{name}-fix.patch
+URL:           http://sblim.sourceforge.net/
+BuildRequires: curl-devel >= 7.11.1
+BuildRequires: libstdc++-devel
+BuildRequires: openslp-devel
+BuildRequires: openssl-devel >= 0.9.7
+BuildRequires: pam-devel
+Requires(post):        openssl-tools
+Suggests:      sblim-sfcb-schema
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+# undefined newList in libsfcUtil: circular dependencies with libsfcBrokerCore
+# undefined trimws in libsfcCimXmlCodec: symbols expected to be defined in binary
+%define                skip_post_check_so      libsfcUtil\.so.* libsfcCimXmlCodec\.so.*
+
+%description
+sfcb is a lightweight CIM daemon (aka CIMOM) that responds to CIM
+client requests for system management data and/or performs system
+management tasks. sfcb supports most of the standard CIM XML over
+HTTP/HTTPS protocol. It is highly modular, allowing functionality to
+be easily added, removed or customized for different management
+applications. sfcb is specifically targeted for small embedded system
+that do not have the available CPU, memory or disk resources to
+support a full-blown enterprise-level CIMOM. That said, sfcb runs very
+well on a regular Linux/Unix system and supports most of the functions
+required by CIM clients to manage such the system. 
+
+%description -l pl.UTF-8
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+%configure \
+       --enable-ipv6 \
+       --enable-pam \
+       --enable-slp \
+       --enable-ssl \
+       --enable-uds
+#      --enable-jdbc is broken (sfcSqlparse undefined)
+
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       initdir=/etc/rc.d/init.d
+
+# libraries with no headers installed
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/sfcb/libsfc{BrokerCore,CimXmlCodec,FileRepository,HttpAdapter,InternalProvider,Util}.so
+# the same or dlopened modules
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/sfcb/*.la
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+if [ ! -f %{_sysconfdir}/sfcb/server.pem -o ! -f %{_sysconfdir}/sfcb/client.pem ]; then
+       %{_datadir}/sfcb/genSslCert.sh %{_sysconfdir}/sfcb
+fi
+
+%files
+%defattr(644,root,root,755)
+%doc AUTHORS COPYING ChangeLog NEWS README
+%attr(754,root,root) /etc/rc.d/init.d/sfcb
+%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sfcb
+%dir %{_sysconfdir}/sfcb
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sfcb/sfcb.cfg
+%attr(755,root,root) %{_bindir}/sfcb*
+%attr(755,root,root) %{_bindir}/wbemcat
+%attr(755,root,root) %{_bindir}/xmltest
+%attr(755,root,root) %{_sbindir}/sfcbd
+%dir %{_libdir}/sfcb
+# libs
+%attr(755,root,root) %{_libdir}/sfcb/libsfcBrokerCore.so.*.*.*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcBrokerCore.so.0
+%attr(755,root,root) %{_libdir}/sfcb/libsfcCimXmlCodec.so.*.*.*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcCimXmlCodec.so.0
+%attr(755,root,root) %{_libdir}/sfcb/libsfcFileRepository.so.*.*.*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcFileRepository.so.0
+%attr(755,root,root) %{_libdir}/sfcb/libsfcHttpAdapter.so.*.*.*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcHttpAdapter.so.0
+%attr(755,root,root) %{_libdir}/sfcb/libsfcInternalProvider.so.*.*.*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcInternalProvider.so.0
+%attr(755,root,root) %{_libdir}/sfcb/libsfcUtil.so.*.*.*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcUtil.so.0
+# providers dlopened by libsfcBrokerCore
+%attr(755,root,root) %{_libdir}/sfcb/libsfcBasicAuthentication.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcBasicPAMAuthentication.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcCertificateAuthentication.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcClassProvider.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcClassProviderGz.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcClassProviderMem.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcClassProviderSf.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcCustomLib.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcElementCapabilitiesProvider.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcIndCIMXMLHandler.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcInteropProvider.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcInteropServerProvider.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcObjectImplSwapI32toP32.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcProfileProvider.so*
+%attr(755,root,root) %{_libdir}/sfcb/libsfcQualifierProvider.so*
+# dlopened by libcimcclient (sblib-sfcc)
+%attr(755,root,root) %{_libdir}/sfcb/libcimcClientSfcbLocal.so*
+%dir %{_datadir}/sfcb
+%attr(755,root,root) %{_datadir}/sfcb/genSslCert.sh
+%attr(755,root,root) %{_datadir}/sfcb/getSchema.sh
+%attr(755,root,root) %{_datadir}/sfcb/stageschema.sh
+%{_datadir}/sfcb/*.mof
+%{_datadir}/sfcb/default.reg
+%dir /var/lib/sfcb
+%dir /var/lib/sfcb/stage
+%config %verify(not md5 mtime size) /var/lib/sfcb/stage/default.reg
+%dir /var/lib/sfcb/stage/mofs
+%config %verify(not md5 mtime size) %dir /var/lib/sfcb/stage/mofs/indication.mof
+%dir /var/lib/sfcb/stage/mofs/root
+%dir /var/lib/sfcb/stage/mofs/root/interop
+%config %verify(not md5 mtime size) /var/lib/sfcb/stage/mofs/root/interop/*.mof
+%{_mandir}/man1/genSslCert.1*
+%{_mandir}/man1/getSchema.1*
+%{_mandir}/man1/sfcb*.1*
+%{_mandir}/man1/wbemcat.1*
+%{_mandir}/man1/xmltest.1*
This page took 0.063775 seconds and 4 git commands to generate.