]> git.pld-linux.org Git - packages/samba.git/commitdiff
- up to 4.8.3 auto/th/samba-4.8.3-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 4 Aug 2018 20:10:07 +0000 (22:10 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 4 Aug 2018 20:10:07 +0000 (22:10 +0200)
pcp.patch [new file with mode: 0644]
samba.spec

diff --git a/pcp.patch b/pcp.patch
new file mode 100644 (file)
index 0000000..6511fff
--- /dev/null
+++ b/pcp.patch
@@ -0,0 +1,117 @@
+commit 426e4a5a20cff73a80d80b46f15826deac3f934f
+Author: Amitay Isaacs <amitay@gmail.com>
+Date:   Thu Mar 1 12:32:26 2018 +1100
+
+    ctdb-pmda: Use modified API in pcp library 4.0
+    
+    Support backward compatibility by checking for __pmID_int type, which
+    was previously in <pcp/impl.h>.  In the new version, this type is not
+    defined anymore and there is no need to include <pcp/impl.h>.
+    
+    Signed-off-by: Amitay Isaacs <amitay@gmail.com>
+    Reviewed-by: Martin Schwenke <martin@meltin.net>
+    
+    Autobuild-User(master): Martin Schwenke <martins@samba.org>
+    Autobuild-Date(master): Fri Mar  2 00:38:52 CET 2018 on sn-devel-144
+
+diff --git a/ctdb/utils/pmda/pmda_ctdb.c b/ctdb/utils/pmda/pmda_ctdb.c
+index 41eaf93fb18..45ec5f19821 100644
+--- a/ctdb/utils/pmda/pmda_ctdb.c
++++ b/ctdb/utils/pmda/pmda_ctdb.c
+@@ -33,9 +33,17 @@
+ #include "client/client_sync.h"
+ #include <pcp/pmapi.h>
+-#include <pcp/impl.h>
+ #include <pcp/pmda.h>
++#ifdef HAVE___PMID_INT
++#include <pcp/impl.h>
++
++#define pmID_cluster(id)      id->cluster
++#define pmID_item(id)         id->item
++#define pmGetProgname()               pmProgname
++#define pmSetProgname(a)      __pmSetProgname(a)
++#endif
++
+ #include "domain.h"
+ /*
+@@ -386,7 +394,11 @@ static int
+ pmda_ctdb_fetch_cb(pmdaMetric *mdesc, unsigned int inst, pmAtomValue *atom)
+ {
+       int ret;
++#ifdef HAVE___PMID_INT
+       __pmID_int *id = (__pmID_int *)&(mdesc->m_desc.pmid);
++#else
++      pmID id = *(pmID *)&(mdesc->m_desc.pmid);
++#endif
+       if (inst != PM_IN_NULL) {
+               return PM_ERR_INST;
+@@ -399,27 +411,27 @@ pmda_ctdb_fetch_cb(pmdaMetric *mdesc, unsigned int inst, pmAtomValue *atom)
+       }
+-      switch (id->cluster) {
++      switch (pmID_cluster(id)) {
+       case 0:
+-              ret = fill_base(id->item, atom);
++              ret = fill_base(pmID_item(id), atom);
+               if (ret) {
+                       goto err_out;
+               }
+               break;
+       case 1:
+-              ret = fill_node(id->item, atom);
++              ret = fill_node(pmID_item(id), atom);
+               if (ret) {
+                       goto err_out;
+               }
+               break;
+       case 2:
+-              ret = fill_client(id->item, atom);
++              ret = fill_client(pmID_item(id), atom);
+               if (ret) {
+                       goto err_out;
+               }
+               break;
+       case 3:
+-              ret = fill_timeout(id->item, atom);
++              ret = fill_timeout(pmID_item(id), atom);
+               if (ret) {
+                       goto err_out;
+               }
+@@ -502,7 +514,7 @@ helpfile(void)
+ static void
+ usage(void)
+ {
+-      fprintf(stderr, "Usage: %s [options]\n\n", pmProgname);
++      fprintf(stderr, "Usage: %s [options]\n\n", pmGetProgname());
+       fputs("Options:\n"
+         "  -d domain        use domain (numeric) for metrics domain of PMDA\n"
+         "  -l logfile       write log into logfile rather than using default log name\n"
+@@ -524,9 +536,9 @@ main(int argc, char **argv)
+       char log_file[] = "pmda_ctdb.log";
+       pmdaInterface dispatch;
+-      __pmSetProgname(argv[0]);
++      pmSetProgname(argv[0]);
+-      pmdaDaemon(&dispatch, PMDA_INTERFACE_2, pmProgname, CTDB,
++      pmdaDaemon(&dispatch, PMDA_INTERFACE_2, argv[0], CTDB,
+                  log_file, helpfile());
+       if (pmdaGetOpt(argc, argv, "d:i:l:pu:?", &dispatch, &err) != EOF) {
+diff --git a/ctdb/wscript b/ctdb/wscript
+index f96d692cc16..d4170996aad 100644
+--- a/ctdb/wscript
++++ b/ctdb/wscript
+@@ -175,6 +175,7 @@ def configure(conf):
+         if not conf.CHECK_FUNCS_IN('pmdaDaemon', 'pcp_pmda'):
+             pmda_support = False
+         if pmda_support:
++            conf.CHECK_TYPE_IN('__pmID_int', 'pcp/pmapi.h pcp/impl.h')
+             have_pmda = True
+         else:
+             Logs.error("PMDA support not available")
index 424f1adb2ddc27448559be2edd845d021e048365..4bddf0247e1fb9a92e42fdf18359da5ea760f98c 100644 (file)
 Summary:       Samba Active Directory and SMB server
 Summary(pl.UTF-8):     Serwer Samba Active Directory i SMB
 Name:          samba
-Version:       4.8.2
+Version:       4.8.3
 Release:       1
 Epoch:         1
 License:       GPL v3
 Group:         Networking/Daemons
 Source0:       https://www.samba.org/ftp/samba/samba-%{version}.tar.gz
-# Source0-md5: 417c065455f8948d1de2be4edd074390
+# Source0-md5: 67f271ed6b793c2acfe014b5b8f0cca8
 Source1:       smb.init
 Source2:       samba.pamd
 Source4:       samba.sysconfig
@@ -53,7 +53,7 @@ Source10:     https://bitbucket.org/fumiyas/samba-virusfilter/downloads/samba-virusf
 Patch0:                system-heimdal.patch
 Patch1:                %{name}-c++-nofail.patch
 Patch2:                %{name}-lprng-no-dot-printers.patch
-
+Patch3:                pcp.patch
 Patch4:                unicodePwd-nthash-values-over-LDAP.patch
 Patch5:                %{name}-heimdal.patch
 Patch6:                server-role.patch
@@ -530,7 +530,7 @@ wyeksportowania do PMCD.
 %{?with_system_heimdal:%patch0 -p1}
 %patch1 -p1
 %patch2 -p1
-
+%patch3 -p1
 %patch4 -p1
 %{?with_system_heimdal:%patch5 -p1}
 %patch6 -p1
This page took 0.235675 seconds and 4 git commands to generate.