]> git.pld-linux.org Git - packages/rust.git/commitdiff
up to 1.64.0 auto/th/rust-1.64.0-1
authorJan Palus <atler@pld-linux.org>
Sun, 25 Sep 2022 16:56:14 +0000 (18:56 +0200)
committerJan Palus <atler@pld-linux.org>
Sun, 25 Sep 2022 16:56:14 +0000 (18:56 +0200)
- rust-analyzer is back (promoted to stable channel)

rust.spec

index 53249e9e1fd2ba7e6356e81a7ba9f8341f443f40..bd4965cd27e94d092fa303d3ee8155e3d65ea1a8 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -21,9 +21,9 @@
 # To bootstrap from scratch, set the channel and date from src/stage0.json
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
 # To bootstrap from scratch, set the channel and date from src/stage0.json
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
-%define                bootstrap_rust  1.62.0
+%define                bootstrap_rust  1.63.0
 %define                bootstrap_cargo %{bootstrap_rust}
 %define                bootstrap_cargo %{bootstrap_rust}
-%define                bootstrap_date  2022-06-30
+%define                bootstrap_date  2022-08-11
 
 %ifarch x32
 %define                with_cross      1
 
 %ifarch x32
 %define                with_cross      1
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     Język programowania Rust
 Name:          rust
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     Język programowania Rust
 Name:          rust
-Version:       1.63.0
+Version:       1.64.0
 Release:       1
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
 Release:       1
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
-# Source0-md5: 8aee73557c576c844c9636128766b1cc
+# Source0-md5: e77ac3a786d013604061b17f99dd9b27
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
-# Source1-md5: 55015a247c79c07e33010aa5f84ba379
+# Source1-md5: fccd4c3722193f8753d2918260f8c770
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
-# Source2-md5: da4968bc99f76ebe69bbb9f6479b7186
+# Source2-md5: 6802c415076b992b3122073e258aba80
 Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
 Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
-# Source3-md5: 03ba177dc69d8c8545ddd997d5aeb478
+# Source3-md5: a38786367b5950df6e0da112df405aef
 Source4:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
 Source4:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
-# Source4-md5: 15b2af8a9ab19cdef7dae36b1654ecb9
+# Source4-md5: 6bcdb6c0c6378ada390180dbc0530995
 Source5:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
 Source5:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
-# Source5-md5: e4abf4a8d96be76e0aadb2a7e2260e32
+# Source5-md5: 4877c64e55ae70eb4d0f93b262b37a1e
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
@@ -124,7 +124,6 @@ Requires:   %{name}-std%{?_isa} = %{version}-%{release}
 Requires:      %{name}-std(x86-64) = %{version}-%{release}
 Requires:      gcc-multilib-64
 %endif
 Requires:      %{name}-std(x86-64) = %{version}-%{release}
 Requires:      gcc-multilib-64
 %endif
-Obsoletes:     rust-analyzer < 1.53.0
 # Only x86_64 and i686 are Tier 1 platforms at this time.
 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
 # Only x86_64 and i686 are Tier 1 platforms at this time.
 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
@@ -224,6 +223,18 @@ Standard library for Rust.
 %description std -l pl.UTF-8
 Standardowa biblioteka Rusta.
 
 %description std -l pl.UTF-8
 Standardowa biblioteka Rusta.
 
+%package analyzer
+Summary:    Implementation of Language Server Protocol for Rust
+Summary(pl.UTF-8):    Implementacja Language Server Protocol dla Rusta
+Group:        Development/Tools
+Requires:    %{name} = %{version}-%{release}
+
+%description analyzer
+Implementation of Language Server Protocol for Rust.
+
+%description analyzer -l pl.UTF-8
+Implementacja Language Server Protocol dla Rusta.
+
 %package debugger-common
 Summary:       Common debugger pretty printers for Rust
 Summary(pl.UTF-8):     Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
 %package debugger-common
 Summary:       Common debugger pretty printers for Rust
 Summary(pl.UTF-8):     Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
@@ -522,6 +533,11 @@ EOF
 done
 )
 
 done
 )
 
+%files analyzer
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/rust-analyzer
+%attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
+
 %files debugger-common
 %defattr(644,root,root,755)
 %dir %{_datadir}/%{name}
 %files debugger-common
 %defattr(644,root,root,755)
 %dir %{_datadir}/%{name}
This page took 0.069264 seconds and 4 git commands to generate.