]> git.pld-linux.org Git - packages/rust.git/commitdiff
armv7h*l has its own target
authorJan Palus <atler@pld-linux.org>
Tue, 15 Jun 2021 17:59:07 +0000 (17:59 +0000)
committerJan Palus <atler@pld-linux.org>
Tue, 15 Jun 2021 17:59:07 +0000 (17:59 +0000)
rust.spec

index 30702e245c9d2bbb8eb50a5f7dded8f49e217dba..cdbfa871e187ab89b9958b1f46f77cbd49208254 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -51,6 +51,8 @@ Source3:      https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_ru
 # Source3-md5: 3ac79872671df7ea0215fd351f52ffcf
 Source4:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
 # Source4-md5: f624772d7c7ba2e83a51b4e9c1657f7b
+Source5:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
+# Source5-md5: 077d3f28a33af2cdb3897da9f8b81ca4
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
@@ -126,16 +128,22 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _lib                    lib64
 %define                _libdir                 %{_prefix}/lib64
 %else
-%ifarch armv6hl armv7hl armv7hnl
+%ifarch armv6hl
 %define                rust_triple             arm-unknown-linux-gnueabihf
 %define                rust_host_triple        %{rust_triple}
 %define                rust_bootstrap_triple   %{rust_triple}
 %else
+%ifarch armv7hl armv7hnl
+%define                rust_triple             armv7-unknown-linux-gnueabihf
+%define                rust_host_triple        %{rust_triple}
+%define                rust_bootstrap_triple   %{rust_triple}
+%else
 %define                rust_triple             %{_target_cpu}-unknown-linux-gnu
 %define                rust_host_triple        %{rust_triple}
 %define                rust_bootstrap_triple   %{rust_triple}
 %endif
 %endif
+%endif
 
 %if %{without bootstrap}
 %define                local_rust_root %{_prefix}
@@ -339,9 +347,12 @@ tar xf %{SOURCE2}
 %ifarch aarch64
 tar xf %{SOURCE3}
 %endif
-%ifarch armv6hl armv7hl armv7hnl
+%ifarch armv6hl
 tar xf %{SOURCE4}
 %endif
+%ifarch armv7hl armv7hnl
+tar xf %{SOURCE5}
+%endif
 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
 %{bootstrap_root}-root/install.sh \
        --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
This page took 0.227102 seconds and 4 git commands to generate.