]> git.pld-linux.org Git - packages/rust.git/blobdiff - rust.spec
up to 1.64.0
[packages/rust.git] / rust.spec
index 1bde5194b4d9874eac2a3af64d97440d0cf50591..bd4965cd27e94d092fa303d3ee8155e3d65ea1a8 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -21,9 +21,9 @@
 # To bootstrap from scratch, set the channel and date from src/stage0.json
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
-%define                bootstrap_rust  1.57.0
+%define                bootstrap_rust  1.63.0
 %define                bootstrap_cargo %{bootstrap_rust}
-%define                bootstrap_date  2021-12-02
+%define                bootstrap_date  2022-08-11
 
 %ifarch x32
 %define                with_cross      1
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     Język programowania Rust
 Name:          rust
-Version:       1.58.1
-Release:       2
+Version:       1.64.0
+Release:       1
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
-# Source0-md5: 835e82d659ea4fc19fd1f0888de01ad8
+# Source0-md5: e77ac3a786d013604061b17f99dd9b27
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
-# Source1-md5: 0f58dba84eba1a5ab8ec51f52d95f453
+# Source1-md5: fccd4c3722193f8753d2918260f8c770
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
-# Source2-md5: d75c7b995614c6ffa8df4409e64a13d6
+# Source2-md5: 6802c415076b992b3122073e258aba80
 Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
-# Source3-md5: 7ba95696643b96b765b7ef5179cba8a4
+# Source3-md5: a38786367b5950df6e0da112df405aef
 Source4:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
-# Source4-md5: 50ab0a0c6f4dc386e09616778e92a934
+# Source4-md5: 6bcdb6c0c6378ada390180dbc0530995
 Source5:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
-# Source5-md5: d79e80ff8677da71154b326f51ea39ee
+# Source5-md5: 4877c64e55ae70eb4d0f93b262b37a1e
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
@@ -65,7 +65,7 @@ BuildRequires:        rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.752
 %if %{without cross}
 BuildRequires: curl-devel
-BuildRequires: libgit2-devel >= 1.3.0
+BuildRequires: libgit2-devel >= 1.4.0
 BuildRequires: libstdc++-devel
 %if %{with system_llvm}
 BuildRequires: llvm >= 12.0
@@ -74,6 +74,7 @@ BuildRequires:        llvm-devel >= 12.0
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
 %endif
 %if %{without bootstrap}
@@ -88,18 +89,19 @@ BuildRequires:      glibc-devel(x86-x32)
 # building on x86_64 host with --target x32-pld-linux
 BuildRequires: curl-devel
 BuildRequires: gcc-multilib-x32
-BuildRequires: libgit2-devel >= 1.3.0
+BuildRequires: libgit2-devel >= 1.4.0
 BuildRequires: libstdc++-devel
 %{?with_system_llvm:BuildRequires:     llvm-devel >= 12.0}
 BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
 %else
 # building x86_64-hosted crosscompiler on x32 host
 BuildRequires: curl-devel(x86-64)
 BuildRequires: curl-devel(x86-x32)
 BuildRequires: gcc-multilib-64
-BuildRequires: libgit2-devel(x86-64) >= 1.3.0
-BuildRequires: libgit2-devel(x86-x32) >= 1.3.0
+BuildRequires: libgit2-devel(x86-64) >= 1.4.0
+BuildRequires: libgit2-devel(x86-x32) >= 1.4.0
 BuildRequires: libstdc++-multilib-64-devel
 %if %{with system_llvm}
 BuildRequires: llvm-devel(x86-64) >= 12.0
@@ -107,6 +109,8 @@ BuildRequires:      llvm-devel(x86-x32) >= 12.0
 %endif
 BuildRequires: openssl-devel(x86-64)
 BuildRequires: openssl-devel(x86-x32)
+BuildRequires: xz-devel(x86-64)
+BuildRequires: xz-devel(x86-x32)
 BuildRequires: zlib-devel(x86-64)
 BuildRequires: zlib-devel(x86-x32)
 %endif
@@ -118,8 +122,8 @@ Requires:   gcc
 Requires:      %{name}-std%{?_isa} = %{version}-%{release}
 %ifarch x32
 Requires:      %{name}-std(x86-64) = %{version}-%{release}
+Requires:      gcc-multilib-64
 %endif
-Obsoletes:     rust-analyzer < 1.53.0
 # Only x86_64 and i686 are Tier 1 platforms at this time.
 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
@@ -219,6 +223,18 @@ Standard library for Rust.
 %description std -l pl.UTF-8
 Standardowa biblioteka Rusta.
 
+%package analyzer
+Summary:    Implementation of Language Server Protocol for Rust
+Summary(pl.UTF-8):    Implementacja Language Server Protocol dla Rusta
+Group:        Development/Tools
+Requires:    %{name} = %{version}-%{release}
+
+%description analyzer
+Implementation of Language Server Protocol for Rust.
+
+%description analyzer -l pl.UTF-8
+Implementacja Language Server Protocol dla Rusta.
+
 %package debugger-common
 Summary:       Common debugger pretty printers for Rust
 Summary(pl.UTF-8):     Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
@@ -412,7 +428,8 @@ export AR="%{__ar}"
        --enable-vendor \
        --local-rust-root=%{local_rust_root} \
        --llvm-root=%{_prefix} \
-       --release-channel=%{channel}
+       --release-channel=%{channel} \
+       --set=llvm.static-libstdcpp=false
 
 export RUST_BACKTRACE=full
 %x_py dist --verbose
@@ -422,6 +439,9 @@ export RUST_BACKTRACE=full
 %install
 rm -rf $RPM_BUILD_ROOT
 
+export CC="%{__cc}"
+export CXX="%{__cxx}"
+export AR="%{__ar}"
 export DESTDIR=$RPM_BUILD_ROOT
 %x_py install
 
@@ -512,10 +532,11 @@ cat <<EOF
 EOF
 done
 )
-%dir %{rustlibdir}/%{rust_triple}/bin
-%ifnarch x32
-%attr(755,root,root) %{rustlibdir}/%{rust_triple}/bin/rust-llvm-dwp
-%endif
+
+%files analyzer
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/rust-analyzer
+%attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
 
 %files debugger-common
 %defattr(644,root,root,755)
This page took 0.285393 seconds and 4 git commands to generate.