]> git.pld-linux.org Git - packages/rust.git/blobdiff - rust.spec
- release 3 (by relup.sh)
[packages/rust.git] / rust.spec
index 31ce20d7e697f3e8d2960d677b6decc3f2c68ebe..b1f2e7d82747fdffe1807fba31e1fd12e9c7da35 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -7,6 +7,8 @@
 %bcond_with    bootstrap       # bootstrap using precompiled binaries
 %bcond_with    full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
 %bcond_without system_llvm     # system LLVM
+%bcond_without rustc           # rustc building
+%bcond_without cargo           # cargo building
 %bcond_with    tests           # build without tests
 
 # The channel can be stable, beta, or nightly
 # To bootstrap from scratch, set the channel and date from src/stage0.txt
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
-%define                bootstrap_rust  1.36.0
-%define                bootstrap_cargo 0.37.0
-%define                bootstrap_date  2019-07-04
+%define                bootstrap_rust  1.41.1
+%define                bootstrap_cargo 1.41.0
+%define                bootstrap_date  2020-02-27
 
+%ifarch x32
+%undefine      with_cargo
+%undefine      with_rustc
+%endif
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     Język programowania Rust
 Name:          rust
-Version:       1.37.0
-Release:       1
+Version:       1.42.0
+Release:       3
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
-Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
-# Source0-md5: e67432b37150f13e186ebfb67e5192fb
-Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.gz
-# Source1-md5: 487d17bbb86891f58160ccf6f0347b49
-Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.gz
-# Source2-md5: 5f969ed3c9ef2a7e2a8011be7eb796c3
-Patch0:                x32.patch
+Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
+# Source0-md5: 03a6111956f8d3bfdfc21aedce7f06bc
+Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
+# Source1-md5: 3336c39311a33005d51298c60b99f2c1
+Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
+# Source2-md5: be3f4d5143483c754a3c272eb213cd07
+Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-std-%{bootstrap_rust}-x86_64-unknown-linux-gnux32.tar.xz
+# Source3-md5: 38da0bf057e0801669f18f74555830bf
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
 BuildRequires: curl
 BuildRequires: libstdc++-devel
-%{?with_system_llvm:BuildRequires:     llvm-devel}
-BuildRequires: ncurses-devel
+%{?with_system_llvm:BuildRequires:     llvm-devel >= 7.0}
+BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: python >= 1:2.7
 BuildRequires: zlib-devel
 %if %{without bootstrap}
@@ -61,20 +68,23 @@ BuildRequires:      procps
 # https://github.com/rust-lang/rust/issues/11937
 Requires:      gcc
 # Only x86_64 and i686 are Tier 1 platforms at this time.
+# x32 is Tier 2, only rust-std is available (no rustc or cargo).
 # https://doc.rust-lang.org/stable/book/getting-started.html#tier-1
-ExclusiveArch: %{x8664} %{ix86}
+ExclusiveArch: %{x8664} %{ix86} x32
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %ifarch x32
-%define                rust_triple     x86_64-unknown-linux-gnux32
+%define                rust_triple             x86_64-unknown-linux-gnux32
+%define                rust_bootstrap_triple   x86_64-unknown-linux-gnu
 %else
-%define                rust_triple     %{_target_cpu}-unknown-linux-gnu
+%define                rust_triple             %{_target_cpu}-unknown-linux-gnu
+%define                rust_bootstrap_triple   %{_target_cpu}-unknown-linux-gnu
 %endif
 
 %if %{without bootstrap}
 %define                local_rust_root %{_prefix}
 %else
-%define                bootstrap_root  rust-%{bootstrap_rust}-%{rust_triple}
+%define                bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
 %define                local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
 %endif
 
@@ -205,9 +215,6 @@ Dopełnianie parametrów polecenia cargo w powłoce Zsh.
 
 %prep
 %setup -q -n %{rustc_package}
-%ifarch x32
-%patch0 -p1
-%endif
 
 %if %{with bootstrap}
 %ifarch %{x8664}
@@ -216,13 +223,26 @@ tar xf %{SOURCE1}
 %ifarch %{ix86}
 tar xf %{SOURCE2}
 %endif
+%ifarch x32
+tar xf %{SOURCE1}
+cd %{bootstrap_root}
+tar xf %{SOURCE3}
+%{__mv} rust-std-%{bootstrap_rust}-%{rust_triple} rust-std-%{rust_triple}
+cd ..
+%endif
 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
 %{bootstrap_root}-root/install.sh \
-       --components=cargo,rustc,rust-std-%{rust_triple} \
+       --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
        --prefix=%{local_rust_root} \
        --disable-ldconfig
 test -f %{local_rust_root}/bin/cargo
 test -f %{local_rust_root}/bin/rustc
+%ifarch x32
+%{bootstrap_root}-root/rust-std-%{rust_triple}/install.sh \
+       --components=rust-std-%{rust_triple} \
+       --prefix=%{local_rust_root} \
+       --disable-ldconfig
+%endif
 %endif
 
 # unbundle
@@ -337,24 +357,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/rustc
 %attr(755,root,root) %{_bindir}/rustdoc
 %attr(755,root,root) %{_bindir}/rustfmt
-%attr(755,root,root) %{_libdir}/libarena-*.so
-%attr(755,root,root) %{_libdir}/libfmt_macros-*.so
-%attr(755,root,root) %{_libdir}/libgraphviz-*.so
 %attr(755,root,root) %{_libdir}/librustc*-*.so
-%attr(755,root,root) %{_libdir}/libserialize-*.so
 %attr(755,root,root) %{_libdir}/libstd-*.so
-%attr(755,root,root) %{_libdir}/libsyntax-*.so
-%attr(755,root,root) %{_libdir}/libsyntax_ext-*.so
-%attr(755,root,root) %{_libdir}/libsyntax_pos-*.so
-%attr(755,root,root) %{_libdir}/libterm-*.so
 %attr(755,root,root) %{_libdir}/libtest-*.so
 %{_mandir}/man1/rustc.1*
 %{_mandir}/man1/rustdoc.1*
 %dir %{rustlibdir}
 %dir %{rustlibdir}/%{rust_triple}
 %{rustlibdir}/%{rust_triple}/analysis
-%dir %{rustlibdir}/%{rust_triple}/codegen-backends
-%attr(755,root,root) %{rustlibdir}/%{rust_triple}/codegen-backends/*.so
 %dir %{rustlibdir}/%{rust_triple}/lib
 %attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
 %{rustlibdir}/%{rust_triple}/lib/*.rlib
This page took 0.062232 seconds and 4 git commands to generate.