]> git.pld-linux.org Git - packages/rust.git/blobdiff - rust.spec
fractional release until mozilla catches up
[packages/rust.git] / rust.spec
index 60937c2646589a09dc23f5bc72d6f2d656730369..093075d8e9a3d23b3ad4d759c674cc5628102ecf 100644 (file)
--- a/rust.spec
+++ b/rust.spec
@@ -7,8 +7,6 @@
 %bcond_with    bootstrap       # bootstrap using precompiled binaries
 %bcond_with    full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
 %bcond_without system_llvm     # system LLVM
-%bcond_without rustc           # rustc building
-%bcond_without cargo           # cargo building
 %bcond_with    tests           # build without tests
 
 # The channel can be stable, beta, or nightly
 # To bootstrap from scratch, set the channel and date from src/stage0.txt
 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
 # or nightly wants some beta-YYYY-MM-DD
-%define                bootstrap_rust  1.43.1
-%define                bootstrap_cargo 1.43.1
-%define                bootstrap_date  2020-05-07
+%define                bootstrap_rust  1.46.0
+%define                bootstrap_cargo 1.46.0
+%define                bootstrap_date  2020-08-27
 
 %ifarch x32
-%undefine      with_cargo
-%undefine      with_rustc
+%define                with_cross      1
 %endif
 Summary:       The Rust Programming Language
 Summary(pl.UTF-8):     Język programowania Rust
 Name:          rust
-Version:       1.44.1
-Release:       1
+Version:       1.47.0
+Release:       0.1
 # Licenses: (rust itself) and (bundled libraries)
 License:       (Apache v2.0 or MIT) and (BSD and ISC and MIT)
 Group:         Development/Languages
 Source0:       https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
-# Source0-md5: 0cc3b079ddb1eb9a17f9e7e52efcebc5
+# Source0-md5: 6283a61cac54bb0a7d32bc447d07fadc
 Source1:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
-# Source1-md5: 62b0974a4bad5aeabd50c7a7fa74518c
+# Source1-md5: 45eaf35327db0bac923c65048637a2f5
 Source2:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
-# Source2-md5: 758d55172c8dddb1ec71913b5f532bb2
-Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-std-%{bootstrap_rust}-x86_64-unknown-linux-gnux32.tar.xz
-# Source3-md5: 4b07c6922a0965791cf8eb28fee9e89d
-Source4:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
-# Source4-md5: 3a9d54ab96f96664b2f6077cccb4e70b
+# Source2-md5: 6a2422d81e98df5b71a959c70aa4c81b
+Source3:       https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
+# Source3-md5: 144376df8b0ddfef57900b867746a9ab
 Patch0:                %{name}-x32.patch
 URL:           https://www.rust-lang.org/
 # for src/compiler-rt
 BuildRequires: cmake >= 3.4.3
 BuildRequires: curl
+# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
+BuildRequires: procps
+BuildRequires: python >= 1:2.7
+BuildRequires: rpmbuild(macros) >= 1.752
+%if %{without cross}
+BuildRequires: curl-devel
+BuildRequires: libgit2-devel
 BuildRequires: libstdc++-devel
-%{?with_system_llvm:BuildRequires:     llvm-devel >= 7.0}
+%{?with_system_llvm:BuildRequires:     llvm-devel >= 8.0}
 BuildRequires: openssl-devel >= 1.0.1
-BuildRequires: python >= 1:2.7
 BuildRequires: zlib-devel
+%endif
 %if %{without bootstrap}
 BuildRequires: %{name} >= %{bootstrap_rust}
 BuildRequires: cargo >= %{bootstrap_cargo}
 BuildConflicts:        %{name} > %{version}
 %endif
-# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
-BuildRequires: procps
+%ifarch x32
+BuildRequires: glibc-devel(x32)
+BuildRequires: glibc-devel(x86_64)
+%if "%{_host_cpu}" == "x86_64"
+# building on x86_64 host with --target x32-pld-linux
+BuildRequires: curl-devel
+BuildRequires: gcc-multilib-x32
+BuildRequires: libgit2-devel
+BuildRequires: libstdc++-devel
+%{?with_system_llvm:BuildRequires:     llvm-devel >= 8.0}
+BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: zlib-devel
+%else
+# building x86_64-hosted crosscompiler on x32 host
+BuildRequires: gcc-multilib-64
+BuildRequires: libstdc++-multilib-64-devel
+# how to specify?
+#BuildRequires:        curl-devel.x86_64
+#BuildRequires:        libgit2-devel.x86_64
+#BuildRequires:        llvm-devel.x86_64 >= 7.0
+#BuildRequires:        openssl-devel.x86_64
+#BuildRequires:        zlib-devel.x86_64
+%endif
+%endif
 # The C compiler is needed at runtime just for linking.  Someday rustc might
 # invoke the linker directly, and then we'll only need binutils.
 # https://github.com/rust-lang/rust/issues/11937
@@ -78,10 +102,12 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %ifarch x32
 %define                rust_triple             x86_64-unknown-linux-gnux32
+%define                rust_host_triple        x86_64-unknown-linux-gnu
 %define                rust_bootstrap_triple   x86_64-unknown-linux-gnu
 %else
 %define                rust_triple             %{_target_cpu}-unknown-linux-gnu
-%define                rust_bootstrap_triple   %{_target_cpu}-unknown-linux-gnu
+%define                rust_host_triple        %{rust_triple}
+%define                rust_bootstrap_triple   %{rust_triple}
 %endif
 
 %if %{without bootstrap}
@@ -125,11 +151,23 @@ Rust to systemowy język programowania działający bardzo szybko,
 zapobiegający naruszeniom ochrony pamięci i gwarantujący
 bezpieczną wielowątkowość.
 
+%package analyzer
+Summary:       Implementation of Language Server Protocol for Rust
+Summary(pl.UTF-8):     Implementacja Language Server Protocol dla Rusta
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+
+%description analyzer
+Implementation of Language Server Protocol for Rust.
+
+%description analyzer -l pl.UTF-8
+Implementacja Language Server Protocol dla Rusta.
+
 %package debugger-common
 Summary:       Common debugger pretty printers for Rust
 Summary(pl.UTF-8):     Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
 Group:         Development/Debuggers
-BuildArch:     noarch
+%{?noarchpackage}
 
 %description debugger-common
 This package includes the common functionality for rust-gdb and
@@ -144,7 +182,7 @@ Summary(pl.UTF-8):  Ładne wypisywanie struktur Rusta w GDB
 Group:         Development/Debuggers
 Requires:      %{name}-debugger-common = %{version}-%{release}
 Requires:      gdb
-BuildArch:     noarch
+%{?noarchpackage}
 
 %description gdb
 This package includes the rust-gdb script, which allows easier
@@ -160,7 +198,7 @@ Summary(pl.UTF-8):  Ładne wypisywanie struktur Rusta w LLDB
 Group:         Development/Debuggers
 Requires:      %{name}-debugger-common = %{version}-%{release}
 Requires:      lldb
-BuildArch:     noarch
+%{?noarchpackage}
 
 %description lldb
 This package includes the rust-lldb script, which allows easier
@@ -170,11 +208,23 @@ debugging of Rust programs.
 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
 odpluskwianie programów w języku Rust.
 
+%package rls
+Summary:       Rust Language Server for IDE integration
+Summary(pl.UTF-8):     Rust Language Server do integracji z IDE
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+
+%description rls
+Rust Language Server for IDE integration.
+
+%description rls -l pl.UTF-8
+Rust Language Server do integracji z IDE.
+
 %package doc
 Summary:       Documentation for Rust
 Summary(pl.UTF-8):     Dokumentacja do Rusta
 Group:         Documentation
-BuildArch:     noarch
+%{?noarchpackage}
 
 %description doc
 This package includes HTML documentation for the Rust programming
@@ -226,7 +276,8 @@ Dopełnianie parametrów polecenia cargo w powłoce Zsh.
 
 %prep
 %setup -q -n %{rustc_package}
-%patch0 -p1
+# irrelevant when not building rustc for x32
+#patch0 -p1
 
 %if %{with bootstrap}
 %ifarch %{x8664} x32
@@ -235,15 +286,8 @@ tar xf %{SOURCE1}
 %ifarch %{ix86}
 tar xf %{SOURCE2}
 %endif
-%ifarch x32
-tar xf %{SOURCE1}
-cd %{bootstrap_root}
-tar xf %{SOURCE3}
-%{__mv} rust-std-%{bootstrap_rust}-%{rust_triple} rust-std-%{rust_triple}
-cd ..
-%endif
 %ifarch aarch64
-tar xf %{SOURCE4}
+tar xf %{SOURCE3}
 %endif
 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
 %{bootstrap_root}-root/install.sh \
@@ -252,12 +296,6 @@ tar xf %{SOURCE4}
        --disable-ldconfig
 test -f %{local_rust_root}/bin/cargo
 test -f %{local_rust_root}/bin/rustc
-%ifarch x32
-%{bootstrap_root}-root/rust-std-%{rust_triple}/install.sh \
-       --components=rust-std-%{rust_triple} \
-       --prefix=%{local_rust_root} \
-       --disable-ldconfig
-%endif
 %endif
 
 # unbundle
@@ -266,8 +304,8 @@ test -f %{local_rust_root}/bin/rustc
 %{?with_system_llvm:%{__rm} -r src/llvm-project}
 
 # extract bundled licenses for packaging
-sed -e '/*\//q' vendor/backtrace-sys/src/libbacktrace/backtrace.h \
-       >vendor/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
+sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
+       >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
 
 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
@@ -280,10 +318,9 @@ find vendor -name .cargo-checksum.json \
        -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
 
 %build
-export PKG_CONFIG_ALLOW_CROSS=1
 %configure \
-       --build=%{rust_triple} \
-       --host=%{rust_triple} \
+       --build=%{rust_bootstrap_triple} \
+       --host=%{rust_host_triple} \
        --target=%{rust_triple} \
        --libdir=%{common_libdir} \
        --disable-codegen-tests \
@@ -368,14 +405,15 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md vendor/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
-%attr(755,root,root) %{_bindir}/rls
+%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
 %attr(755,root,root) %{_bindir}/rustc
 %attr(755,root,root) %{_bindir}/rustdoc
 %attr(755,root,root) %{_bindir}/rustfmt
+%attr(755,root,root) %{_libdir}/libchalk_derive-*.so
 %attr(755,root,root) %{_libdir}/librustc*-*.so
 %attr(755,root,root) %{_libdir}/libstd-*.so
 %attr(755,root,root) %{_libdir}/libtest-*.so
+%attr(755,root,root) %{_libdir}/libtracing_attributes-*.so
 %{_mandir}/man1/rustc.1*
 %{_mandir}/man1/rustdoc.1*
 %dir %{rustlibdir}
@@ -385,11 +423,25 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
 %{rustlibdir}/%{rust_triple}/lib/*.rlib
 
+# for cross-compiler (e.g. x86_64-hosted x32 rust)
+%if "%{rust_host_triple}" != "%{rust_triple}"
+%dir %{rustlibdir}/%{rust_host_triple}
+%{rustlibdir}/%{rust_host_triple}/analysis
+%dir %{rustlibdir}/%{rust_host_triple}/lib
+%attr(755,root,root) %{rustlibdir}/%{rust_host_triple}/lib/*.so
+%{rustlibdir}/%{rust_host_triple}/lib/*.rlib
+%endif
+
+%files analyzer
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/rust-analyzer
+
 %files debugger-common
 %defattr(644,root,root,755)
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/etc
-%{_datadir}/%{name}/etc/debugger_*.py*
+%{_datadir}/%{name}/etc/lldb_commands
+%{_datadir}/%{name}/etc/rust_types.py
 
 %files lldb
 %defattr(644,root,root,755)
@@ -402,6 +454,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/rust-gdbgui
 %{_datadir}/%{name}/etc/gdb_*.py*
 
+%files rls
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/rls
+
 %files doc
 %defattr(644,root,root,755)
 %dir %{_docdir}/%{name}
This page took 0.102868 seconds and 4 git commands to generate.