]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
db24ac28cf965cb01ccd82d4a9af89e7023fbead
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.json
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.61.0
25 %define         bootstrap_cargo %{bootstrap_rust}
26 %define         bootstrap_date  2022-05-19
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.62.1
40 Release:        1
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  ae8f03cc8f1cb6b1b0b026886a040796
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  6c2227cb2e8a2d86d93aeec4cd342bff
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  160592aa60ef07721dd78fc09c382c35
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  ea2b0213459466161d8eec4877825e75
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  397fb4e209cc1e53a4d8bf0587c29eed
54 Source5:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
55 # Source5-md5:  a11c7147725e51450d13ca6f29f5c944
56 URL:            https://www.rust-lang.org/
57 # for src/compiler-rt
58 BuildRequires:  cmake >= 3.4.3
59 BuildRequires:  curl
60 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
61 BuildRequires:  procps
62 BuildRequires:  python3
63 BuildRequires:  python3-modules
64 BuildRequires:  rpm-build >= 4.6
65 BuildRequires:  rpmbuild(macros) >= 1.752
66 %if %{without cross}
67 BuildRequires:  curl-devel
68 BuildRequires:  libgit2-devel >= 1.4.0
69 BuildRequires:  libstdc++-devel
70 %if %{with system_llvm}
71 BuildRequires:  llvm >= 12.0
72 BuildRequires:  llvm-devel >= 12.0
73 %endif
74 BuildRequires:  openssl-devel >= 1.0.1
75 BuildRequires:  tar >= 1:1.22
76 BuildRequires:  xz
77 BuildRequires:  xz-devel
78 BuildRequires:  zlib-devel
79 %endif
80 %if %{without bootstrap}
81 BuildRequires:  %{name} >= %{bootstrap_rust}
82 BuildRequires:  cargo >= %{bootstrap_cargo}
83 BuildConflicts: %{name} > %{version}
84 %endif
85 %ifarch x32
86 BuildRequires:  glibc-devel(x86-64)
87 BuildRequires:  glibc-devel(x86-x32)
88 %if "%{_host_cpu}" == "x86_64"
89 # building on x86_64 host with --target x32-pld-linux
90 BuildRequires:  curl-devel
91 BuildRequires:  gcc-multilib-x32
92 BuildRequires:  libgit2-devel >= 1.4.0
93 BuildRequires:  libstdc++-devel
94 %{?with_system_llvm:BuildRequires:      llvm-devel >= 12.0}
95 BuildRequires:  openssl-devel >= 1.0.1
96 BuildRequires:  xz-devel
97 BuildRequires:  zlib-devel
98 %else
99 # building x86_64-hosted crosscompiler on x32 host
100 BuildRequires:  curl-devel(x86-64)
101 BuildRequires:  curl-devel(x86-x32)
102 BuildRequires:  gcc-multilib-64
103 BuildRequires:  libgit2-devel(x86-64) >= 1.4.0
104 BuildRequires:  libgit2-devel(x86-x32) >= 1.4.0
105 BuildRequires:  libstdc++-multilib-64-devel
106 %if %{with system_llvm}
107 BuildRequires:  llvm-devel(x86-64) >= 12.0
108 BuildRequires:  llvm-devel(x86-x32) >= 12.0
109 %endif
110 BuildRequires:  openssl-devel(x86-64)
111 BuildRequires:  openssl-devel(x86-x32)
112 BuildRequires:  xz-devel(x86-64)
113 BuildRequires:  xz-devel(x86-x32)
114 BuildRequires:  zlib-devel(x86-64)
115 BuildRequires:  zlib-devel(x86-x32)
116 %endif
117 %endif
118 # The C compiler is needed at runtime just for linking.  Someday rustc might
119 # invoke the linker directly, and then we'll only need binutils.
120 # https://github.com/rust-lang/rust/issues/11937
121 Requires:       gcc
122 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
123 %ifarch x32
124 Requires:       %{name}-std(x86-64) = %{version}-%{release}
125 Requires:       gcc-multilib-64
126 %endif
127 Obsoletes:      rust-analyzer < 1.53.0
128 # Only x86_64 and i686 are Tier 1 platforms at this time.
129 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
130 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
131 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
132 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
133
134 %ifarch x32
135 %define         rust_triple             x86_64-unknown-linux-gnux32
136 %define         rust_host_triple        x86_64-unknown-linux-gnu
137 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
138 # libs in _libdir are x86_64 64bit
139 %define         _lib                    lib64
140 %define         _libdir                 %{_prefix}/lib64
141 %else
142 %ifarch armv6hl
143 %define         rust_triple             arm-unknown-linux-gnueabihf
144 %define         rust_host_triple        %{rust_triple}
145 %define         rust_bootstrap_triple   %{rust_triple}
146 %else
147 %ifarch armv7hl armv7hnl
148 %define         rust_triple             armv7-unknown-linux-gnueabihf
149 %define         rust_host_triple        %{rust_triple}
150 %define         rust_bootstrap_triple   %{rust_triple}
151 %define         rust_suppl_targets      thumbv7neon-unknown-linux-gnueabihf
152 %else
153 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
154 %define         rust_host_triple        %{rust_triple}
155 %define         rust_bootstrap_triple   %{rust_triple}
156 %endif
157 %endif
158 %endif
159
160 %define         rust_targets            %rust_triple %{?rust_suppl_targets}
161
162 %if %{without bootstrap}
163 %define         local_rust_root %{_prefix}
164 %else
165 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
166 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
167 %endif
168
169 # We're going to override --libdir when configuring to get rustlib into a
170 # common path, but we'll fix the shared libraries during install.
171 # Without this ugly hack, rust would not be able to build itself
172 # for non-bootstrap build, lib64 is just too complicated for it.
173 %define         common_libdir   %{_prefix}/lib
174 %define         rustlibdir      %{common_libdir}/rustlib
175
176 # once_call/once_callable non-function libstdc++ symbols
177 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
178
179 # ALL Rust libraries are private, because they don't keep an ABI.
180 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
181 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
182
183 %define         x_py { \
184         x_py() { \
185                 local cmd="$1"; \
186                 shift; \
187                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
188         }; x_py }
189
190
191 %description
192 Rust is a systems programming language that runs blazingly fast,
193 prevents segfaults, and guarantees thread safety.
194
195 This package includes the Rust compiler, standard library, and
196 documentation generator.
197
198 %description -l pl.UTF-8
199 Rust to systemowy język programowania działający bardzo szybko,
200 zapobiegający naruszeniom ochrony pamięci i gwarantujący
201 bezpieczną wielowątkowość.
202
203 %package analysis
204 Summary:        Metadata about the standard library
205 Summary(pl.UTF-8):      Metadane o standardowej bibliotece
206 Group:          Development/Tools
207 Requires:       %{name} = %{version}-%{release}
208
209 %description analysis
210 Metadata about the standard library.
211
212 %description analysis -l pl.UTF-8
213 Metadane o standardowej bibliotece.
214
215 %package std
216 Summary:        Standard library for Rust
217 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
218 Group:          Development/Tools
219 Requires:       %{name} = %{version}-%{release}
220
221 %description std
222 Standard library for Rust.
223
224 %description std -l pl.UTF-8
225 Standardowa biblioteka Rusta.
226
227 %package debugger-common
228 Summary:        Common debugger pretty printers for Rust
229 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
230 Group:          Development/Debuggers
231 BuildArch:      noarch
232
233 %description debugger-common
234 This package includes the common functionality for rust-gdb and
235 rust-lldb.
236
237 %description debugger-common -l pl.UTF-8
238 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
239
240 %package gdb
241 Summary:        GDB pretty printers for Rust
242 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
243 Group:          Development/Debuggers
244 Requires:       %{name}-debugger-common = %{version}-%{release}
245 Requires:       gdb
246 BuildArch:      noarch
247
248 %description gdb
249 This package includes the rust-gdb script, which allows easier
250 debugging of Rust programs.
251
252 %description gdb -l pl.UTF-8
253 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
254 odpluskwianie programów w języku Rust.
255
256 %package lldb
257 Summary:        LLDB pretty printers for Rust
258 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
259 Group:          Development/Debuggers
260 Requires:       %{name}-debugger-common = %{version}-%{release}
261 Requires:       lldb
262 BuildArch:      noarch
263
264 %description lldb
265 This package includes the rust-lldb script, which allows easier
266 debugging of Rust programs.
267
268 %description lldb -l pl.UTF-8
269 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
270 odpluskwianie programów w języku Rust.
271
272 %package rls
273 Summary:        Rust Language Server for IDE integration
274 Summary(pl.UTF-8):      Rust Language Server do integracji z IDE
275 Group:          Development/Tools
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       %{name}-analysis = %{version}-%{release}
278
279 %description rls
280 Rust Language Server for IDE integration.
281
282 %description rls -l pl.UTF-8
283 Rust Language Server do integracji z IDE.
284
285 %package doc
286 Summary:        Documentation for Rust
287 Summary(pl.UTF-8):      Dokumentacja do Rusta
288 Group:          Documentation
289 BuildArch:      noarch
290
291 %description doc
292 This package includes HTML documentation for the Rust programming
293 language and its standard library.
294
295 %description doc -l pl.UTF-8
296 Ten pakiet zawiera dokumentację w formacie HTML do języka
297 programowania Rust i jego biblioteki standardowej.
298
299 %package -n cargo
300 Summary:        Rust's package manager and build tool
301 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
302 Group:          Development/Tools
303 Requires:       %{name}%{?_isa}
304
305 %description -n cargo
306 Cargo is a tool that allows Rust projects to declare their various
307 dependencies and ensure that you'll always get a repeatable build.
308
309 %description -n cargo -l pl.UTF-8
310 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
311 zależności i zapewniające powtarzalność procesu budowania.
312
313 %package -n bash-completion-cargo
314 Summary:        Bash completion for cargo command
315 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
316 Group:          Applications/Shells
317 Requires:       %{name} = %{version}-%{release}
318 Requires:       bash-completion
319
320 %description -n bash-completion-cargo
321 Bash completion for cargo command.
322
323 %description -n bash-completion-cargo -l pl.UTF-8
324 Bashowe dopełnianie parametrów polecenia cargo.
325
326 %package -n zsh-completion-cargo
327 Summary:        Zsh completion for cargo command
328 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
329 Group:          Applications/Shells
330 Requires:       %{name} = %{version}-%{release}
331 Requires:       zsh
332
333 %description -n zsh-completion-cargo
334 Zsh completion for cargo command.
335
336 %description -n zsh-completion-cargo -l pl.UTF-8
337 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
338
339 %prep
340 %setup -q -n %{rustc_package}
341
342 %if %{with bootstrap}
343 %ifarch %{x8664} x32
344 tar xf %{SOURCE1}
345 %endif
346 %ifarch %{ix86}
347 tar xf %{SOURCE2}
348 %endif
349 %ifarch aarch64
350 tar xf %{SOURCE3}
351 %endif
352 %ifarch armv6hl
353 tar xf %{SOURCE4}
354 %endif
355 %ifarch armv7hl armv7hnl
356 tar xf %{SOURCE5}
357 %endif
358 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
359 %{bootstrap_root}-root/install.sh \
360         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
361         --prefix=%{local_rust_root} \
362         --disable-ldconfig
363 test -f %{local_rust_root}/bin/cargo
364 test -f %{local_rust_root}/bin/rustc
365 %endif
366
367 # unbundle
368 # We're disabling jemalloc, but rust-src still wants it.
369 #%{__rm} -r src/jemalloc
370 %if %{with system_llvm}
371 %{__rm} -r src/llvm-project
372 mkdir -p src/llvm-project/libunwind
373 %endif
374
375 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
376 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
377         src/etc/rust-gdb
378
379 # cargo has hardcoded libexec path - honour rpm _libexecdir
380 %if "%{_libexecdir}" != "%{_prefix}/libexec"
381 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
382 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
383         src/bootstrap/dist.rs \
384         src/tools/cargo/src/cargo/ops/registry/auth.rs
385 %{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
386 %endif
387
388 # The configure macro will modify some autoconf-related files, which upsets
389 # cargo when it tries to verify checksums in those files.  If we just truncate
390 # that file list, cargo won't have anything to complain about.
391 find vendor -name .cargo-checksum.json \
392         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
393
394 %build
395 export CC="%{__cc}"
396 export CXX="%{__cxx}"
397 export AR="%{__ar}"
398 %configure \
399         --build=%{rust_bootstrap_triple} \
400         --host=%{rust_host_triple} \
401         --target="%(echo %rust_targets | tr ' ' ,)" \
402         --libdir=%{common_libdir} \
403         --disable-codegen-tests \
404         --disable-debuginfo-lines \
405 %if %{with full_debuginfo}
406         --disable-debuginfo-only-std \
407         --enable-debuginfo \
408 %else
409         --enable-debuginfo-only-std \
410         --disable-debuginfo \
411 %endif
412         --disable-jemalloc \
413         --disable-option-checking \
414         --disable-rpath \
415         --enable-extended \
416         --enable-llvm-link-shared \
417         --enable-vendor \
418         --local-rust-root=%{local_rust_root} \
419         --llvm-root=%{_prefix} \
420         --release-channel=%{channel} \
421         --set=llvm.static-libstdcpp=false
422
423 export RUST_BACKTRACE=full
424 %x_py dist --verbose
425
426 %{?with_tests:%x_py test}
427
428 %install
429 rm -rf $RPM_BUILD_ROOT
430
431 export CC="%{__cc}"
432 export CXX="%{__cxx}"
433 export AR="%{__ar}"
434 export DESTDIR=$RPM_BUILD_ROOT
435 %x_py install
436
437 # Make sure the shared libraries are in the proper libdir
438 %if "%{_libdir}" != "%{common_libdir}"
439 mkdir -p %{buildroot}%{_libdir}
440 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
441         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
442 %endif
443
444 # The shared libraries should be executable for debuginfo extraction.
445 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
446
447 # The libdir libraries are identical to those under rustlib/.  It's easier on
448 # library loading if we keep them in libdir, but we do need them in rustlib/
449 # to support dynamic linking for compiler plugins, so we'll symlink.
450 for rust_target in %rust_targets; do
451         for l in libstd libtest ; do
452                 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
453                 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
454                 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
455                         ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
456                 fi
457         done
458 done
459
460 # Remove installer artifacts (manifests, uninstall scripts, etc.)
461 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
462
463 # FIXME: __os_install_post will strip the rlibs
464 # -- should we find a way to preserve debuginfo?
465
466 # Remove unwanted documentation files (we already package them)
467 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
468 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
469 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
470 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
471
472 # Sanitize the HTML documentation
473 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
474 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
475
476 # Move rust-gdb's python scripts so they're noarch
477 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
478 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
479
480 # We don't need stdlib source
481 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
482
483 # Create the path for crate-devel packages
484 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
485
486 %clean
487 rm -rf $RPM_BUILD_ROOT
488
489 %post   -p /sbin/ldconfig
490 %postun -p /sbin/ldconfig
491
492 %files
493 %defattr(644,root,root,755)
494 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
495 %attr(755,root,root) %{_bindir}/rust-demangler
496 %attr(755,root,root) %{_bindir}/rustc
497 %attr(755,root,root) %{_bindir}/rustdoc
498 %attr(755,root,root) %{_bindir}/rustfmt
499 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
500 %attr(755,root,root) %{_libdir}/libstd-*.so
501 %attr(755,root,root) %{_libdir}/libtest-*.so
502 %{_mandir}/man1/rustc.1*
503 %{_mandir}/man1/rustdoc.1*
504 %dir %{rustlibdir}
505
506 %files analysis
507 %defattr(644,root,root,755)
508 %(for rust_target in %rust_targets; do
509 echo "%{rustlibdir}/$rust_target/analysis"
510 done
511 )
512
513 %files std
514 %defattr(644,root,root,755)
515 %(for rust_target in %rust_targets; do
516 cat <<EOF
517 %dir %{rustlibdir}/$rust_target
518 %dir %{rustlibdir}/$rust_target/lib
519 %attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
520 %{rustlibdir}/$rust_target/lib/*.rlib
521 EOF
522 done
523 )
524
525 %files debugger-common
526 %defattr(644,root,root,755)
527 %dir %{_datadir}/%{name}
528 %dir %{_datadir}/%{name}/etc
529 %{_datadir}/%{name}/etc/lldb_commands
530 %{_datadir}/%{name}/etc/rust_types.py
531
532 %files lldb
533 %defattr(644,root,root,755)
534 %attr(755,root,root) %{_bindir}/rust-lldb
535 %{_datadir}/%{name}/etc/lldb_*.py*
536
537 %files gdb
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_bindir}/rust-gdb
540 %attr(755,root,root) %{_bindir}/rust-gdbgui
541 %{_datadir}/%{name}/etc/gdb_*.py*
542
543 %files rls
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_bindir}/rls
546
547 %files doc
548 %defattr(644,root,root,755)
549 %dir %{_docdir}/%{name}
550 %doc %{_docdir}/%{name}/html
551
552 %files -n cargo
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_bindir}/cargo
555 %attr(755,root,root) %{_bindir}/cargo-clippy
556 %attr(755,root,root) %{_bindir}/cargo-fmt
557 %attr(755,root,root) %{_bindir}/clippy-driver
558 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
559 %{_mandir}/man1/cargo*.1*
560 %dir %{_datadir}/cargo
561 %dir %{_datadir}/cargo/registry
562
563 %files -n bash-completion-cargo
564 %defattr(644,root,root,755)
565 %{_sysconfdir}/bash_completion.d/cargo
566
567 %files -n zsh-completion-cargo
568 %defattr(644,root,root,755)
569 %{zsh_compdir}/_cargo
This page took 0.062424 seconds and 2 git commands to generate.