]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
up to 1.64.0
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.json
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.63.0
25 %define         bootstrap_cargo %{bootstrap_rust}
26 %define         bootstrap_date  2022-08-11
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.64.0
40 Release:        1
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  e77ac3a786d013604061b17f99dd9b27
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  fccd4c3722193f8753d2918260f8c770
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  6802c415076b992b3122073e258aba80
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  a38786367b5950df6e0da112df405aef
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  6bcdb6c0c6378ada390180dbc0530995
54 Source5:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
55 # Source5-md5:  4877c64e55ae70eb4d0f93b262b37a1e
56 URL:            https://www.rust-lang.org/
57 # for src/compiler-rt
58 BuildRequires:  cmake >= 3.4.3
59 BuildRequires:  curl
60 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
61 BuildRequires:  procps
62 BuildRequires:  python3
63 BuildRequires:  python3-modules
64 BuildRequires:  rpm-build >= 4.6
65 BuildRequires:  rpmbuild(macros) >= 1.752
66 %if %{without cross}
67 BuildRequires:  curl-devel
68 BuildRequires:  libgit2-devel >= 1.4.0
69 BuildRequires:  libstdc++-devel
70 %if %{with system_llvm}
71 BuildRequires:  llvm >= 12.0
72 BuildRequires:  llvm-devel >= 12.0
73 %endif
74 BuildRequires:  openssl-devel >= 1.0.1
75 BuildRequires:  tar >= 1:1.22
76 BuildRequires:  xz
77 BuildRequires:  xz-devel
78 BuildRequires:  zlib-devel
79 %endif
80 %if %{without bootstrap}
81 BuildRequires:  %{name} >= %{bootstrap_rust}
82 BuildRequires:  cargo >= %{bootstrap_cargo}
83 BuildConflicts: %{name} > %{version}
84 %endif
85 %ifarch x32
86 BuildRequires:  glibc-devel(x86-64)
87 BuildRequires:  glibc-devel(x86-x32)
88 %if "%{_host_cpu}" == "x86_64"
89 # building on x86_64 host with --target x32-pld-linux
90 BuildRequires:  curl-devel
91 BuildRequires:  gcc-multilib-x32
92 BuildRequires:  libgit2-devel >= 1.4.0
93 BuildRequires:  libstdc++-devel
94 %{?with_system_llvm:BuildRequires:      llvm-devel >= 12.0}
95 BuildRequires:  openssl-devel >= 1.0.1
96 BuildRequires:  xz-devel
97 BuildRequires:  zlib-devel
98 %else
99 # building x86_64-hosted crosscompiler on x32 host
100 BuildRequires:  curl-devel(x86-64)
101 BuildRequires:  curl-devel(x86-x32)
102 BuildRequires:  gcc-multilib-64
103 BuildRequires:  libgit2-devel(x86-64) >= 1.4.0
104 BuildRequires:  libgit2-devel(x86-x32) >= 1.4.0
105 BuildRequires:  libstdc++-multilib-64-devel
106 %if %{with system_llvm}
107 BuildRequires:  llvm-devel(x86-64) >= 12.0
108 BuildRequires:  llvm-devel(x86-x32) >= 12.0
109 %endif
110 BuildRequires:  openssl-devel(x86-64)
111 BuildRequires:  openssl-devel(x86-x32)
112 BuildRequires:  xz-devel(x86-64)
113 BuildRequires:  xz-devel(x86-x32)
114 BuildRequires:  zlib-devel(x86-64)
115 BuildRequires:  zlib-devel(x86-x32)
116 %endif
117 %endif
118 # The C compiler is needed at runtime just for linking.  Someday rustc might
119 # invoke the linker directly, and then we'll only need binutils.
120 # https://github.com/rust-lang/rust/issues/11937
121 Requires:       gcc
122 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
123 %ifarch x32
124 Requires:       %{name}-std(x86-64) = %{version}-%{release}
125 Requires:       gcc-multilib-64
126 %endif
127 # Only x86_64 and i686 are Tier 1 platforms at this time.
128 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
129 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
130 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
131 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
132
133 %ifarch x32
134 %define         rust_triple             x86_64-unknown-linux-gnux32
135 %define         rust_host_triple        x86_64-unknown-linux-gnu
136 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
137 # libs in _libdir are x86_64 64bit
138 %define         _lib                    lib64
139 %define         _libdir                 %{_prefix}/lib64
140 %else
141 %ifarch armv6hl
142 %define         rust_triple             arm-unknown-linux-gnueabihf
143 %define         rust_host_triple        %{rust_triple}
144 %define         rust_bootstrap_triple   %{rust_triple}
145 %else
146 %ifarch armv7hl armv7hnl
147 %define         rust_triple             armv7-unknown-linux-gnueabihf
148 %define         rust_host_triple        %{rust_triple}
149 %define         rust_bootstrap_triple   %{rust_triple}
150 %define         rust_suppl_targets      thumbv7neon-unknown-linux-gnueabihf
151 %else
152 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
153 %define         rust_host_triple        %{rust_triple}
154 %define         rust_bootstrap_triple   %{rust_triple}
155 %endif
156 %endif
157 %endif
158
159 %define         rust_targets            %rust_triple %{?rust_suppl_targets}
160
161 %if %{without bootstrap}
162 %define         local_rust_root %{_prefix}
163 %else
164 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
165 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
166 %endif
167
168 # We're going to override --libdir when configuring to get rustlib into a
169 # common path, but we'll fix the shared libraries during install.
170 # Without this ugly hack, rust would not be able to build itself
171 # for non-bootstrap build, lib64 is just too complicated for it.
172 %define         common_libdir   %{_prefix}/lib
173 %define         rustlibdir      %{common_libdir}/rustlib
174
175 # once_call/once_callable non-function libstdc++ symbols
176 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
177
178 # ALL Rust libraries are private, because they don't keep an ABI.
179 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
180 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
181
182 %define         x_py { \
183         x_py() { \
184                 local cmd="$1"; \
185                 shift; \
186                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
187         }; x_py }
188
189
190 %description
191 Rust is a systems programming language that runs blazingly fast,
192 prevents segfaults, and guarantees thread safety.
193
194 This package includes the Rust compiler, standard library, and
195 documentation generator.
196
197 %description -l pl.UTF-8
198 Rust to systemowy język programowania działający bardzo szybko,
199 zapobiegający naruszeniom ochrony pamięci i gwarantujący
200 bezpieczną wielowątkowość.
201
202 %package analysis
203 Summary:        Metadata about the standard library
204 Summary(pl.UTF-8):      Metadane o standardowej bibliotece
205 Group:          Development/Tools
206 Requires:       %{name} = %{version}-%{release}
207
208 %description analysis
209 Metadata about the standard library.
210
211 %description analysis -l pl.UTF-8
212 Metadane o standardowej bibliotece.
213
214 %package std
215 Summary:        Standard library for Rust
216 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
217 Group:          Development/Tools
218 Requires:       %{name} = %{version}-%{release}
219
220 %description std
221 Standard library for Rust.
222
223 %description std -l pl.UTF-8
224 Standardowa biblioteka Rusta.
225
226 %package analyzer
227 Summary:    Implementation of Language Server Protocol for Rust
228 Summary(pl.UTF-8):    Implementacja Language Server Protocol dla Rusta
229 Group:        Development/Tools
230 Requires:    %{name} = %{version}-%{release}
231
232 %description analyzer
233 Implementation of Language Server Protocol for Rust.
234
235 %description analyzer -l pl.UTF-8
236 Implementacja Language Server Protocol dla Rusta.
237
238 %package debugger-common
239 Summary:        Common debugger pretty printers for Rust
240 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
241 Group:          Development/Debuggers
242 BuildArch:      noarch
243
244 %description debugger-common
245 This package includes the common functionality for rust-gdb and
246 rust-lldb.
247
248 %description debugger-common -l pl.UTF-8
249 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
250
251 %package gdb
252 Summary:        GDB pretty printers for Rust
253 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
254 Group:          Development/Debuggers
255 Requires:       %{name}-debugger-common = %{version}-%{release}
256 Requires:       gdb
257 BuildArch:      noarch
258
259 %description gdb
260 This package includes the rust-gdb script, which allows easier
261 debugging of Rust programs.
262
263 %description gdb -l pl.UTF-8
264 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
265 odpluskwianie programów w języku Rust.
266
267 %package lldb
268 Summary:        LLDB pretty printers for Rust
269 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
270 Group:          Development/Debuggers
271 Requires:       %{name}-debugger-common = %{version}-%{release}
272 Requires:       lldb
273 BuildArch:      noarch
274
275 %description lldb
276 This package includes the rust-lldb script, which allows easier
277 debugging of Rust programs.
278
279 %description lldb -l pl.UTF-8
280 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
281 odpluskwianie programów w języku Rust.
282
283 %package rls
284 Summary:        Rust Language Server for IDE integration
285 Summary(pl.UTF-8):      Rust Language Server do integracji z IDE
286 Group:          Development/Tools
287 Requires:       %{name} = %{version}-%{release}
288 Requires:       %{name}-analysis = %{version}-%{release}
289
290 %description rls
291 Rust Language Server for IDE integration.
292
293 %description rls -l pl.UTF-8
294 Rust Language Server do integracji z IDE.
295
296 %package doc
297 Summary:        Documentation for Rust
298 Summary(pl.UTF-8):      Dokumentacja do Rusta
299 Group:          Documentation
300 BuildArch:      noarch
301
302 %description doc
303 This package includes HTML documentation for the Rust programming
304 language and its standard library.
305
306 %description doc -l pl.UTF-8
307 Ten pakiet zawiera dokumentację w formacie HTML do języka
308 programowania Rust i jego biblioteki standardowej.
309
310 %package -n cargo
311 Summary:        Rust's package manager and build tool
312 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
313 Group:          Development/Tools
314 Requires:       %{name}%{?_isa}
315
316 %description -n cargo
317 Cargo is a tool that allows Rust projects to declare their various
318 dependencies and ensure that you'll always get a repeatable build.
319
320 %description -n cargo -l pl.UTF-8
321 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
322 zależności i zapewniające powtarzalność procesu budowania.
323
324 %package -n bash-completion-cargo
325 Summary:        Bash completion for cargo command
326 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
327 Group:          Applications/Shells
328 Requires:       %{name} = %{version}-%{release}
329 Requires:       bash-completion
330
331 %description -n bash-completion-cargo
332 Bash completion for cargo command.
333
334 %description -n bash-completion-cargo -l pl.UTF-8
335 Bashowe dopełnianie parametrów polecenia cargo.
336
337 %package -n zsh-completion-cargo
338 Summary:        Zsh completion for cargo command
339 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
340 Group:          Applications/Shells
341 Requires:       %{name} = %{version}-%{release}
342 Requires:       zsh
343
344 %description -n zsh-completion-cargo
345 Zsh completion for cargo command.
346
347 %description -n zsh-completion-cargo -l pl.UTF-8
348 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
349
350 %prep
351 %setup -q -n %{rustc_package}
352
353 %if %{with bootstrap}
354 %ifarch %{x8664} x32
355 tar xf %{SOURCE1}
356 %endif
357 %ifarch %{ix86}
358 tar xf %{SOURCE2}
359 %endif
360 %ifarch aarch64
361 tar xf %{SOURCE3}
362 %endif
363 %ifarch armv6hl
364 tar xf %{SOURCE4}
365 %endif
366 %ifarch armv7hl armv7hnl
367 tar xf %{SOURCE5}
368 %endif
369 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
370 %{bootstrap_root}-root/install.sh \
371         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
372         --prefix=%{local_rust_root} \
373         --disable-ldconfig
374 test -f %{local_rust_root}/bin/cargo
375 test -f %{local_rust_root}/bin/rustc
376 %endif
377
378 # unbundle
379 # We're disabling jemalloc, but rust-src still wants it.
380 #%{__rm} -r src/jemalloc
381 %if %{with system_llvm}
382 %{__rm} -r src/llvm-project
383 mkdir -p src/llvm-project/libunwind
384 %endif
385
386 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
387 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
388         src/etc/rust-gdb
389
390 # cargo has hardcoded libexec path - honour rpm _libexecdir
391 %if "%{_libexecdir}" != "%{_prefix}/libexec"
392 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
393 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
394         src/bootstrap/dist.rs \
395         src/tools/cargo/src/cargo/ops/registry/auth.rs
396 %{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
397 %endif
398
399 # The configure macro will modify some autoconf-related files, which upsets
400 # cargo when it tries to verify checksums in those files.  If we just truncate
401 # that file list, cargo won't have anything to complain about.
402 find vendor -name .cargo-checksum.json \
403         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
404
405 %build
406 export CC="%{__cc}"
407 export CXX="%{__cxx}"
408 export AR="%{__ar}"
409 %configure \
410         --build=%{rust_bootstrap_triple} \
411         --host=%{rust_host_triple} \
412         --target="%(echo %rust_targets | tr ' ' ,)" \
413         --libdir=%{common_libdir} \
414         --disable-codegen-tests \
415         --disable-debuginfo-lines \
416 %if %{with full_debuginfo}
417         --disable-debuginfo-only-std \
418         --enable-debuginfo \
419 %else
420         --enable-debuginfo-only-std \
421         --disable-debuginfo \
422 %endif
423         --disable-jemalloc \
424         --disable-option-checking \
425         --disable-rpath \
426         --enable-extended \
427         --enable-llvm-link-shared \
428         --enable-vendor \
429         --local-rust-root=%{local_rust_root} \
430         --llvm-root=%{_prefix} \
431         --release-channel=%{channel} \
432         --set=llvm.static-libstdcpp=false
433
434 export RUST_BACKTRACE=full
435 %x_py dist --verbose
436
437 %{?with_tests:%x_py test}
438
439 %install
440 rm -rf $RPM_BUILD_ROOT
441
442 export CC="%{__cc}"
443 export CXX="%{__cxx}"
444 export AR="%{__ar}"
445 export DESTDIR=$RPM_BUILD_ROOT
446 %x_py install
447
448 # Make sure the shared libraries are in the proper libdir
449 %if "%{_libdir}" != "%{common_libdir}"
450 mkdir -p %{buildroot}%{_libdir}
451 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
452         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
453 %endif
454
455 # The shared libraries should be executable for debuginfo extraction.
456 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
457
458 # The libdir libraries are identical to those under rustlib/.  It's easier on
459 # library loading if we keep them in libdir, but we do need them in rustlib/
460 # to support dynamic linking for compiler plugins, so we'll symlink.
461 for rust_target in %rust_targets; do
462         for l in libstd libtest ; do
463                 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
464                 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
465                 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
466                         ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
467                 fi
468         done
469 done
470
471 # Remove installer artifacts (manifests, uninstall scripts, etc.)
472 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
473
474 # FIXME: __os_install_post will strip the rlibs
475 # -- should we find a way to preserve debuginfo?
476
477 # Remove unwanted documentation files (we already package them)
478 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
479 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
480 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
481 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
482
483 # Sanitize the HTML documentation
484 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
485 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
486
487 # Move rust-gdb's python scripts so they're noarch
488 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
489 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
490
491 # We don't need stdlib source
492 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
493
494 # Create the path for crate-devel packages
495 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
496
497 %clean
498 rm -rf $RPM_BUILD_ROOT
499
500 %post   -p /sbin/ldconfig
501 %postun -p /sbin/ldconfig
502
503 %files
504 %defattr(644,root,root,755)
505 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
506 %attr(755,root,root) %{_bindir}/rust-demangler
507 %attr(755,root,root) %{_bindir}/rustc
508 %attr(755,root,root) %{_bindir}/rustdoc
509 %attr(755,root,root) %{_bindir}/rustfmt
510 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
511 %attr(755,root,root) %{_libdir}/libstd-*.so
512 %attr(755,root,root) %{_libdir}/libtest-*.so
513 %{_mandir}/man1/rustc.1*
514 %{_mandir}/man1/rustdoc.1*
515 %dir %{rustlibdir}
516
517 %files analysis
518 %defattr(644,root,root,755)
519 %(for rust_target in %rust_targets; do
520 echo "%{rustlibdir}/$rust_target/analysis"
521 done
522 )
523
524 %files std
525 %defattr(644,root,root,755)
526 %(for rust_target in %rust_targets; do
527 cat <<EOF
528 %dir %{rustlibdir}/$rust_target
529 %dir %{rustlibdir}/$rust_target/lib
530 %attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
531 %{rustlibdir}/$rust_target/lib/*.rlib
532 EOF
533 done
534 )
535
536 %files analyzer
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_bindir}/rust-analyzer
539 %attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
540
541 %files debugger-common
542 %defattr(644,root,root,755)
543 %dir %{_datadir}/%{name}
544 %dir %{_datadir}/%{name}/etc
545 %{_datadir}/%{name}/etc/lldb_commands
546 %{_datadir}/%{name}/etc/rust_types.py
547
548 %files lldb
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/rust-lldb
551 %{_datadir}/%{name}/etc/lldb_*.py*
552
553 %files gdb
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_bindir}/rust-gdb
556 %attr(755,root,root) %{_bindir}/rust-gdbgui
557 %{_datadir}/%{name}/etc/gdb_*.py*
558
559 %files rls
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_bindir}/rls
562
563 %files doc
564 %defattr(644,root,root,755)
565 %dir %{_docdir}/%{name}
566 %doc %{_docdir}/%{name}/html
567
568 %files -n cargo
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_bindir}/cargo
571 %attr(755,root,root) %{_bindir}/cargo-clippy
572 %attr(755,root,root) %{_bindir}/cargo-fmt
573 %attr(755,root,root) %{_bindir}/clippy-driver
574 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
575 %{_mandir}/man1/cargo*.1*
576 %dir %{_datadir}/cargo
577 %dir %{_datadir}/cargo/registry
578
579 %files -n bash-completion-cargo
580 %defattr(644,root,root,755)
581 %{_sysconfdir}/bash_completion.d/cargo
582
583 %files -n zsh-completion-cargo
584 %defattr(644,root,root,755)
585 %{zsh_compdir}/_cargo
This page took 0.084278 seconds and 3 git commands to generate.