]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
add support for building multiple targets
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.json
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.56.1
25 %define         bootstrap_cargo 1.56.1
26 %define         bootstrap_date  2021-11-01
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.57.0
40 Release:        1
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  0c7d63d9c456c4ec0f95bb6bb729c13e
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  9c12561dff9debea38e4b93f881ae2bb
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  947bd95b9c8a9943d43af1bbabf1a8e1
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  64d78bc0747c975fe0451e4fd5b8ac4b
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  a13652efd627b5e5f8bd278f378acea4
54 Source5:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
55 # Source5-md5:  3fb69008b1b0141d464a4a48317709b3
56 URL:            https://www.rust-lang.org/
57 # for src/compiler-rt
58 BuildRequires:  cmake >= 3.4.3
59 BuildRequires:  curl
60 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
61 BuildRequires:  procps
62 BuildRequires:  python3
63 BuildRequires:  python3-modules
64 BuildRequires:  rpm-build >= 4.6
65 BuildRequires:  rpmbuild(macros) >= 1.752
66 %if %{without cross}
67 BuildRequires:  curl-devel
68 BuildRequires:  libgit2-devel >= 1.3.0
69 BuildRequires:  libstdc++-devel
70 %if %{with system_llvm}
71 BuildRequires:  llvm >= 10.0
72 BuildRequires:  llvm-devel >= 10.0
73 %endif
74 BuildRequires:  openssl-devel >= 1.0.1
75 BuildRequires:  tar >= 1:1.22
76 BuildRequires:  xz
77 BuildRequires:  zlib-devel
78 %endif
79 %if %{without bootstrap}
80 BuildRequires:  %{name} >= %{bootstrap_rust}
81 BuildRequires:  cargo >= %{bootstrap_cargo}
82 BuildConflicts: %{name} > %{version}
83 %endif
84 %ifarch x32
85 BuildRequires:  glibc-devel(x86-64)
86 BuildRequires:  glibc-devel(x86-x32)
87 %if "%{_host_cpu}" == "x86_64"
88 # building on x86_64 host with --target x32-pld-linux
89 BuildRequires:  curl-devel
90 BuildRequires:  gcc-multilib-x32
91 BuildRequires:  libgit2-devel >= 1.3.0
92 BuildRequires:  libstdc++-devel
93 %{?with_system_llvm:BuildRequires:      llvm-devel >= 10.0}
94 BuildRequires:  openssl-devel >= 1.0.1
95 BuildRequires:  zlib-devel
96 %else
97 # building x86_64-hosted crosscompiler on x32 host
98 BuildRequires:  curl-devel(x86-64)
99 BuildRequires:  curl-devel(x86-x32)
100 BuildRequires:  gcc-multilib-64
101 BuildRequires:  libgit2-devel(x86-64) >= 1.3.0
102 BuildRequires:  libgit2-devel(x86-x32) >= 1.3.0
103 BuildRequires:  libstdc++-multilib-64-devel
104 %if %{with system_llvm}
105 BuildRequires:  llvm-devel(x86-64) >= 10.0
106 BuildRequires:  llvm-devel(x86-x32) >= 10.0
107 %endif
108 BuildRequires:  openssl-devel(x86-64)
109 BuildRequires:  openssl-devel(x86-x32)
110 BuildRequires:  zlib-devel(x86-64)
111 BuildRequires:  zlib-devel(x86-x32)
112 %endif
113 %endif
114 # The C compiler is needed at runtime just for linking.  Someday rustc might
115 # invoke the linker directly, and then we'll only need binutils.
116 # https://github.com/rust-lang/rust/issues/11937
117 Requires:       gcc
118 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
119 %ifarch x32
120 Requires:       %{name}-std(x86-64) = %{version}-%{release}
121 %endif
122 Obsoletes:      rust-analyzer < 1.53.0
123 # Only x86_64 and i686 are Tier 1 platforms at this time.
124 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
125 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
126 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
127 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
128
129 %ifarch x32
130 %define         rust_triple             x86_64-unknown-linux-gnux32
131 %define         rust_host_triple        x86_64-unknown-linux-gnu
132 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
133 # libs in _libdir are x86_64 64bit
134 %define         _lib                    lib64
135 %define         _libdir                 %{_prefix}/lib64
136 %else
137 %ifarch armv6hl
138 %define         rust_triple             arm-unknown-linux-gnueabihf
139 %define         rust_host_triple        %{rust_triple}
140 %define         rust_bootstrap_triple   %{rust_triple}
141 %else
142 %ifarch armv7hl armv7hnl
143 %define         rust_triple             armv7-unknown-linux-gnueabihf
144 %define         rust_host_triple        %{rust_triple}
145 %define         rust_bootstrap_triple   %{rust_triple}
146 %else
147 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
148 %define         rust_host_triple        %{rust_triple}
149 %define         rust_bootstrap_triple   %{rust_triple}
150 %endif
151 %endif
152 %endif
153
154 %define         rust_targets            %rust_triple %{?rust_suppl_targets}
155
156 %if %{without bootstrap}
157 %define         local_rust_root %{_prefix}
158 %else
159 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
160 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
161 %endif
162
163 # We're going to override --libdir when configuring to get rustlib into a
164 # common path, but we'll fix the shared libraries during install.
165 # Without this ugly hack, rust would not be able to build itself
166 # for non-bootstrap build, lib64 is just too complicated for it.
167 %define         common_libdir   %{_prefix}/lib
168 %define         rustlibdir      %{common_libdir}/rustlib
169
170 # once_call/once_callable non-function libstdc++ symbols
171 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
172
173 # ALL Rust libraries are private, because they don't keep an ABI.
174 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
175 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
176
177 %define         x_py { \
178         x_py() { \
179                 local cmd="$1"; \
180                 shift; \
181                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
182         }; x_py }
183
184
185 %description
186 Rust is a systems programming language that runs blazingly fast,
187 prevents segfaults, and guarantees thread safety.
188
189 This package includes the Rust compiler, standard library, and
190 documentation generator.
191
192 %description -l pl.UTF-8
193 Rust to systemowy język programowania działający bardzo szybko,
194 zapobiegający naruszeniom ochrony pamięci i gwarantujący
195 bezpieczną wielowątkowość.
196
197 %package analysis
198 Summary:        Metadata about the standard library
199 Summary(pl.UTF-8):      Metadane o standardowej bibliotece
200 Group:          Development/Tools
201 Requires:       %{name} = %{version}-%{release}
202
203 %description analysis
204 Metadata about the standard library.
205
206 %description analysis -l pl.UTF-8
207 Metadane o standardowej bibliotece.
208
209 %package std
210 Summary:        Standard library for Rust
211 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
212 Group:          Development/Tools
213 Requires:       %{name} = %{version}-%{release}
214
215 %description std
216 Standard library for Rust.
217
218 %description std -l pl.UTF-8
219 Standardowa biblioteka Rusta.
220
221 %package debugger-common
222 Summary:        Common debugger pretty printers for Rust
223 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
224 Group:          Development/Debuggers
225 BuildArch:      noarch
226
227 %description debugger-common
228 This package includes the common functionality for rust-gdb and
229 rust-lldb.
230
231 %description debugger-common -l pl.UTF-8
232 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
233
234 %package gdb
235 Summary:        GDB pretty printers for Rust
236 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
237 Group:          Development/Debuggers
238 Requires:       %{name}-debugger-common = %{version}-%{release}
239 Requires:       gdb
240 BuildArch:      noarch
241
242 %description gdb
243 This package includes the rust-gdb script, which allows easier
244 debugging of Rust programs.
245
246 %description gdb -l pl.UTF-8
247 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
248 odpluskwianie programów w języku Rust.
249
250 %package lldb
251 Summary:        LLDB pretty printers for Rust
252 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
253 Group:          Development/Debuggers
254 Requires:       %{name}-debugger-common = %{version}-%{release}
255 Requires:       lldb
256 BuildArch:      noarch
257
258 %description lldb
259 This package includes the rust-lldb script, which allows easier
260 debugging of Rust programs.
261
262 %description lldb -l pl.UTF-8
263 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
264 odpluskwianie programów w języku Rust.
265
266 %package rls
267 Summary:        Rust Language Server for IDE integration
268 Summary(pl.UTF-8):      Rust Language Server do integracji z IDE
269 Group:          Development/Tools
270 Requires:       %{name} = %{version}-%{release}
271 Requires:       %{name}-analysis = %{version}-%{release}
272
273 %description rls
274 Rust Language Server for IDE integration.
275
276 %description rls -l pl.UTF-8
277 Rust Language Server do integracji z IDE.
278
279 %package doc
280 Summary:        Documentation for Rust
281 Summary(pl.UTF-8):      Dokumentacja do Rusta
282 Group:          Documentation
283 BuildArch:      noarch
284
285 %description doc
286 This package includes HTML documentation for the Rust programming
287 language and its standard library.
288
289 %description doc -l pl.UTF-8
290 Ten pakiet zawiera dokumentację w formacie HTML do języka
291 programowania Rust i jego biblioteki standardowej.
292
293 %package -n cargo
294 Summary:        Rust's package manager and build tool
295 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
296 Group:          Development/Tools
297 Requires:       %{name}%{?_isa}
298
299 %description -n cargo
300 Cargo is a tool that allows Rust projects to declare their various
301 dependencies and ensure that you'll always get a repeatable build.
302
303 %description -n cargo -l pl.UTF-8
304 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
305 zależności i zapewniające powtarzalność procesu budowania.
306
307 %package -n bash-completion-cargo
308 Summary:        Bash completion for cargo command
309 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
310 Group:          Applications/Shells
311 Requires:       %{name} = %{version}-%{release}
312 Requires:       bash-completion
313
314 %description -n bash-completion-cargo
315 Bash completion for cargo command.
316
317 %description -n bash-completion-cargo -l pl.UTF-8
318 Bashowe dopełnianie parametrów polecenia cargo.
319
320 %package -n zsh-completion-cargo
321 Summary:        Zsh completion for cargo command
322 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
323 Group:          Applications/Shells
324 Requires:       %{name} = %{version}-%{release}
325 Requires:       zsh
326
327 %description -n zsh-completion-cargo
328 Zsh completion for cargo command.
329
330 %description -n zsh-completion-cargo -l pl.UTF-8
331 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
332
333 %prep
334 %setup -q -n %{rustc_package}
335
336 %if %{with bootstrap}
337 %ifarch %{x8664} x32
338 tar xf %{SOURCE1}
339 %endif
340 %ifarch %{ix86}
341 tar xf %{SOURCE2}
342 %endif
343 %ifarch aarch64
344 tar xf %{SOURCE3}
345 %endif
346 %ifarch armv6hl
347 tar xf %{SOURCE4}
348 %endif
349 %ifarch armv7hl armv7hnl
350 tar xf %{SOURCE5}
351 %endif
352 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
353 %{bootstrap_root}-root/install.sh \
354         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
355         --prefix=%{local_rust_root} \
356         --disable-ldconfig
357 test -f %{local_rust_root}/bin/cargo
358 test -f %{local_rust_root}/bin/rustc
359 %endif
360
361 # unbundle
362 # We're disabling jemalloc, but rust-src still wants it.
363 #%{__rm} -r src/jemalloc
364 %if %{with system_llvm}
365 %{__rm} -r src/llvm-project
366 mkdir -p src/llvm-project/libunwind
367 %endif
368
369 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
370 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
371         src/etc/rust-gdb
372
373 # cargo has hardcoded libexec path - honour rpm _libexecdir
374 %if "%{_libexecdir}" != "%{_prefix}/libexec"
375 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
376 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
377         src/bootstrap/dist.rs \
378         src/tools/cargo/src/cargo/ops/registry/auth.rs
379 %{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
380 %endif
381
382 # The configure macro will modify some autoconf-related files, which upsets
383 # cargo when it tries to verify checksums in those files.  If we just truncate
384 # that file list, cargo won't have anything to complain about.
385 find vendor -name .cargo-checksum.json \
386         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
387
388 %build
389 export CC="%{__cc}"
390 export CXX="%{__cxx}"
391 export AR="%{__ar}"
392 %configure \
393         --build=%{rust_bootstrap_triple} \
394         --host=%{rust_host_triple} \
395         --target="%(echo %rust_targets | tr ' ' ,)" \
396         --libdir=%{common_libdir} \
397         --disable-codegen-tests \
398         --disable-debuginfo-lines \
399 %if %{with full_debuginfo}
400         --disable-debuginfo-only-std \
401         --enable-debuginfo \
402 %else
403         --enable-debuginfo-only-std \
404         --disable-debuginfo \
405 %endif
406         --disable-jemalloc \
407         --disable-option-checking \
408         --disable-rpath \
409         --enable-extended \
410         --enable-llvm-link-shared \
411         --enable-vendor \
412         --local-rust-root=%{local_rust_root} \
413         --llvm-root=%{_prefix} \
414         --release-channel=%{channel}
415
416 export RUST_BACKTRACE=full
417 %x_py dist --verbose
418
419 %{?with_tests:%x_py test}
420
421 %install
422 rm -rf $RPM_BUILD_ROOT
423
424 export DESTDIR=$RPM_BUILD_ROOT
425 %x_py install
426
427 # Make sure the shared libraries are in the proper libdir
428 %if "%{_libdir}" != "%{common_libdir}"
429 mkdir -p %{buildroot}%{_libdir}
430 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
431         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
432 %endif
433
434 # The shared libraries should be executable for debuginfo extraction.
435 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
436
437 # The libdir libraries are identical to those under rustlib/.  It's easier on
438 # library loading if we keep them in libdir, but we do need them in rustlib/
439 # to support dynamic linking for compiler plugins, so we'll symlink.
440 for rust_target in %rust_targets; do
441         for l in libstd libtest ; do
442                 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
443                 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
444                 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
445                         ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
446                 fi
447         done
448 done
449
450 # Remove installer artifacts (manifests, uninstall scripts, etc.)
451 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
452
453 # FIXME: __os_install_post will strip the rlibs
454 # -- should we find a way to preserve debuginfo?
455
456 # Remove unwanted documentation files (we already package them)
457 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
458 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
459 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
460 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
461
462 # Sanitize the HTML documentation
463 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
464 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
465
466 # Move rust-gdb's python scripts so they're noarch
467 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
468 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
469
470 # We don't need stdlib source
471 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
472
473 # Create the path for crate-devel packages
474 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
475
476 %clean
477 rm -rf $RPM_BUILD_ROOT
478
479 %post   -p /sbin/ldconfig
480 %postun -p /sbin/ldconfig
481
482 %files
483 %defattr(644,root,root,755)
484 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
485 %attr(755,root,root) %{_bindir}/rust-demangler
486 %attr(755,root,root) %{_bindir}/rustc
487 %attr(755,root,root) %{_bindir}/rustdoc
488 %attr(755,root,root) %{_bindir}/rustfmt
489 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
490 %attr(755,root,root) %{_libdir}/libstd-*.so
491 %attr(755,root,root) %{_libdir}/libtest-*.so
492 %{_mandir}/man1/rustc.1*
493 %{_mandir}/man1/rustdoc.1*
494 %dir %{rustlibdir}
495
496 %files analysis
497 %defattr(644,root,root,755)
498 %(for rust_target in %rust_targets; do
499 echo "%{rustlibdir}/$rust_target/analysis"
500 done
501 )
502
503 %files std
504 %defattr(644,root,root,755)
505 %(for rust_target in %rust_targets; do
506 cat <<EOF
507 %dir %{rustlibdir}/$rust_target
508 %dir %{rustlibdir}/$rust_target/lib
509 %attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
510 %{rustlibdir}/$rust_target/lib/*.rlib
511 EOF
512 done
513 )
514 %dir %{rustlibdir}/%{rust_triple}/bin
515 %attr(755,root,root) %{rustlibdir}/%{rust_triple}/bin/rust-llvm-dwp
516
517 %files debugger-common
518 %defattr(644,root,root,755)
519 %dir %{_datadir}/%{name}
520 %dir %{_datadir}/%{name}/etc
521 %{_datadir}/%{name}/etc/lldb_commands
522 %{_datadir}/%{name}/etc/rust_types.py
523
524 %files lldb
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_bindir}/rust-lldb
527 %{_datadir}/%{name}/etc/lldb_*.py*
528
529 %files gdb
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_bindir}/rust-gdb
532 %attr(755,root,root) %{_bindir}/rust-gdbgui
533 %{_datadir}/%{name}/etc/gdb_*.py*
534
535 %files rls
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_bindir}/rls
538
539 %files doc
540 %defattr(644,root,root,755)
541 %dir %{_docdir}/%{name}
542 %doc %{_docdir}/%{name}/html
543
544 %files -n cargo
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_bindir}/cargo
547 %attr(755,root,root) %{_bindir}/cargo-clippy
548 %attr(755,root,root) %{_bindir}/cargo-fmt
549 %attr(755,root,root) %{_bindir}/clippy-driver
550 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
551 %{_mandir}/man1/cargo*.1*
552 %dir %{_datadir}/cargo
553 %dir %{_datadir}/cargo/registry
554
555 %files -n bash-completion-cargo
556 %defattr(644,root,root,755)
557 %{_sysconfdir}/bash_completion.d/cargo
558
559 %files -n zsh-completion-cargo
560 %defattr(644,root,root,755)
561 %{zsh_compdir}/_cargo
This page took 0.064265 seconds and 3 git commands to generate.