]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
no rust-llvm-dwp on x32; rel 2
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.json
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.57.0
25 %define         bootstrap_cargo %{bootstrap_rust}
26 %define         bootstrap_date  2021-12-02
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.58.1
40 Release:        2
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  835e82d659ea4fc19fd1f0888de01ad8
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  0f58dba84eba1a5ab8ec51f52d95f453
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  d75c7b995614c6ffa8df4409e64a13d6
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  7ba95696643b96b765b7ef5179cba8a4
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  50ab0a0c6f4dc386e09616778e92a934
54 Source5:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
55 # Source5-md5:  d79e80ff8677da71154b326f51ea39ee
56 URL:            https://www.rust-lang.org/
57 # for src/compiler-rt
58 BuildRequires:  cmake >= 3.4.3
59 BuildRequires:  curl
60 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
61 BuildRequires:  procps
62 BuildRequires:  python3
63 BuildRequires:  python3-modules
64 BuildRequires:  rpm-build >= 4.6
65 BuildRequires:  rpmbuild(macros) >= 1.752
66 %if %{without cross}
67 BuildRequires:  curl-devel
68 BuildRequires:  libgit2-devel >= 1.3.0
69 BuildRequires:  libstdc++-devel
70 %if %{with system_llvm}
71 BuildRequires:  llvm >= 12.0
72 BuildRequires:  llvm-devel >= 12.0
73 %endif
74 BuildRequires:  openssl-devel >= 1.0.1
75 BuildRequires:  tar >= 1:1.22
76 BuildRequires:  xz
77 BuildRequires:  zlib-devel
78 %endif
79 %if %{without bootstrap}
80 BuildRequires:  %{name} >= %{bootstrap_rust}
81 BuildRequires:  cargo >= %{bootstrap_cargo}
82 BuildConflicts: %{name} > %{version}
83 %endif
84 %ifarch x32
85 BuildRequires:  glibc-devel(x86-64)
86 BuildRequires:  glibc-devel(x86-x32)
87 %if "%{_host_cpu}" == "x86_64"
88 # building on x86_64 host with --target x32-pld-linux
89 BuildRequires:  curl-devel
90 BuildRequires:  gcc-multilib-x32
91 BuildRequires:  libgit2-devel >= 1.3.0
92 BuildRequires:  libstdc++-devel
93 %{?with_system_llvm:BuildRequires:      llvm-devel >= 12.0}
94 BuildRequires:  openssl-devel >= 1.0.1
95 BuildRequires:  zlib-devel
96 %else
97 # building x86_64-hosted crosscompiler on x32 host
98 BuildRequires:  curl-devel(x86-64)
99 BuildRequires:  curl-devel(x86-x32)
100 BuildRequires:  gcc-multilib-64
101 BuildRequires:  libgit2-devel(x86-64) >= 1.3.0
102 BuildRequires:  libgit2-devel(x86-x32) >= 1.3.0
103 BuildRequires:  libstdc++-multilib-64-devel
104 %if %{with system_llvm}
105 BuildRequires:  llvm-devel(x86-64) >= 12.0
106 BuildRequires:  llvm-devel(x86-x32) >= 12.0
107 %endif
108 BuildRequires:  openssl-devel(x86-64)
109 BuildRequires:  openssl-devel(x86-x32)
110 BuildRequires:  zlib-devel(x86-64)
111 BuildRequires:  zlib-devel(x86-x32)
112 %endif
113 %endif
114 # The C compiler is needed at runtime just for linking.  Someday rustc might
115 # invoke the linker directly, and then we'll only need binutils.
116 # https://github.com/rust-lang/rust/issues/11937
117 Requires:       gcc
118 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
119 %ifarch x32
120 Requires:       %{name}-std(x86-64) = %{version}-%{release}
121 %endif
122 Obsoletes:      rust-analyzer < 1.53.0
123 # Only x86_64 and i686 are Tier 1 platforms at this time.
124 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
125 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
126 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
127 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
128
129 %ifarch x32
130 %define         rust_triple             x86_64-unknown-linux-gnux32
131 %define         rust_host_triple        x86_64-unknown-linux-gnu
132 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
133 # libs in _libdir are x86_64 64bit
134 %define         _lib                    lib64
135 %define         _libdir                 %{_prefix}/lib64
136 %else
137 %ifarch armv6hl
138 %define         rust_triple             arm-unknown-linux-gnueabihf
139 %define         rust_host_triple        %{rust_triple}
140 %define         rust_bootstrap_triple   %{rust_triple}
141 %else
142 %ifarch armv7hl armv7hnl
143 %define         rust_triple             armv7-unknown-linux-gnueabihf
144 %define         rust_host_triple        %{rust_triple}
145 %define         rust_bootstrap_triple   %{rust_triple}
146 %define         rust_suppl_targets      thumbv7neon-unknown-linux-gnueabihf
147 %else
148 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
149 %define         rust_host_triple        %{rust_triple}
150 %define         rust_bootstrap_triple   %{rust_triple}
151 %endif
152 %endif
153 %endif
154
155 %define         rust_targets            %rust_triple %{?rust_suppl_targets}
156
157 %if %{without bootstrap}
158 %define         local_rust_root %{_prefix}
159 %else
160 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
161 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
162 %endif
163
164 # We're going to override --libdir when configuring to get rustlib into a
165 # common path, but we'll fix the shared libraries during install.
166 # Without this ugly hack, rust would not be able to build itself
167 # for non-bootstrap build, lib64 is just too complicated for it.
168 %define         common_libdir   %{_prefix}/lib
169 %define         rustlibdir      %{common_libdir}/rustlib
170
171 # once_call/once_callable non-function libstdc++ symbols
172 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
173
174 # ALL Rust libraries are private, because they don't keep an ABI.
175 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
176 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
177
178 %define         x_py { \
179         x_py() { \
180                 local cmd="$1"; \
181                 shift; \
182                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
183         }; x_py }
184
185
186 %description
187 Rust is a systems programming language that runs blazingly fast,
188 prevents segfaults, and guarantees thread safety.
189
190 This package includes the Rust compiler, standard library, and
191 documentation generator.
192
193 %description -l pl.UTF-8
194 Rust to systemowy język programowania działający bardzo szybko,
195 zapobiegający naruszeniom ochrony pamięci i gwarantujący
196 bezpieczną wielowątkowość.
197
198 %package analysis
199 Summary:        Metadata about the standard library
200 Summary(pl.UTF-8):      Metadane o standardowej bibliotece
201 Group:          Development/Tools
202 Requires:       %{name} = %{version}-%{release}
203
204 %description analysis
205 Metadata about the standard library.
206
207 %description analysis -l pl.UTF-8
208 Metadane o standardowej bibliotece.
209
210 %package std
211 Summary:        Standard library for Rust
212 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
213 Group:          Development/Tools
214 Requires:       %{name} = %{version}-%{release}
215
216 %description std
217 Standard library for Rust.
218
219 %description std -l pl.UTF-8
220 Standardowa biblioteka Rusta.
221
222 %package debugger-common
223 Summary:        Common debugger pretty printers for Rust
224 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
225 Group:          Development/Debuggers
226 BuildArch:      noarch
227
228 %description debugger-common
229 This package includes the common functionality for rust-gdb and
230 rust-lldb.
231
232 %description debugger-common -l pl.UTF-8
233 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
234
235 %package gdb
236 Summary:        GDB pretty printers for Rust
237 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
238 Group:          Development/Debuggers
239 Requires:       %{name}-debugger-common = %{version}-%{release}
240 Requires:       gdb
241 BuildArch:      noarch
242
243 %description gdb
244 This package includes the rust-gdb script, which allows easier
245 debugging of Rust programs.
246
247 %description gdb -l pl.UTF-8
248 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
249 odpluskwianie programów w języku Rust.
250
251 %package lldb
252 Summary:        LLDB pretty printers for Rust
253 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
254 Group:          Development/Debuggers
255 Requires:       %{name}-debugger-common = %{version}-%{release}
256 Requires:       lldb
257 BuildArch:      noarch
258
259 %description lldb
260 This package includes the rust-lldb script, which allows easier
261 debugging of Rust programs.
262
263 %description lldb -l pl.UTF-8
264 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
265 odpluskwianie programów w języku Rust.
266
267 %package rls
268 Summary:        Rust Language Server for IDE integration
269 Summary(pl.UTF-8):      Rust Language Server do integracji z IDE
270 Group:          Development/Tools
271 Requires:       %{name} = %{version}-%{release}
272 Requires:       %{name}-analysis = %{version}-%{release}
273
274 %description rls
275 Rust Language Server for IDE integration.
276
277 %description rls -l pl.UTF-8
278 Rust Language Server do integracji z IDE.
279
280 %package doc
281 Summary:        Documentation for Rust
282 Summary(pl.UTF-8):      Dokumentacja do Rusta
283 Group:          Documentation
284 BuildArch:      noarch
285
286 %description doc
287 This package includes HTML documentation for the Rust programming
288 language and its standard library.
289
290 %description doc -l pl.UTF-8
291 Ten pakiet zawiera dokumentację w formacie HTML do języka
292 programowania Rust i jego biblioteki standardowej.
293
294 %package -n cargo
295 Summary:        Rust's package manager and build tool
296 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
297 Group:          Development/Tools
298 Requires:       %{name}%{?_isa}
299
300 %description -n cargo
301 Cargo is a tool that allows Rust projects to declare their various
302 dependencies and ensure that you'll always get a repeatable build.
303
304 %description -n cargo -l pl.UTF-8
305 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
306 zależności i zapewniające powtarzalność procesu budowania.
307
308 %package -n bash-completion-cargo
309 Summary:        Bash completion for cargo command
310 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
311 Group:          Applications/Shells
312 Requires:       %{name} = %{version}-%{release}
313 Requires:       bash-completion
314
315 %description -n bash-completion-cargo
316 Bash completion for cargo command.
317
318 %description -n bash-completion-cargo -l pl.UTF-8
319 Bashowe dopełnianie parametrów polecenia cargo.
320
321 %package -n zsh-completion-cargo
322 Summary:        Zsh completion for cargo command
323 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
324 Group:          Applications/Shells
325 Requires:       %{name} = %{version}-%{release}
326 Requires:       zsh
327
328 %description -n zsh-completion-cargo
329 Zsh completion for cargo command.
330
331 %description -n zsh-completion-cargo -l pl.UTF-8
332 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
333
334 %prep
335 %setup -q -n %{rustc_package}
336
337 %if %{with bootstrap}
338 %ifarch %{x8664} x32
339 tar xf %{SOURCE1}
340 %endif
341 %ifarch %{ix86}
342 tar xf %{SOURCE2}
343 %endif
344 %ifarch aarch64
345 tar xf %{SOURCE3}
346 %endif
347 %ifarch armv6hl
348 tar xf %{SOURCE4}
349 %endif
350 %ifarch armv7hl armv7hnl
351 tar xf %{SOURCE5}
352 %endif
353 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
354 %{bootstrap_root}-root/install.sh \
355         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
356         --prefix=%{local_rust_root} \
357         --disable-ldconfig
358 test -f %{local_rust_root}/bin/cargo
359 test -f %{local_rust_root}/bin/rustc
360 %endif
361
362 # unbundle
363 # We're disabling jemalloc, but rust-src still wants it.
364 #%{__rm} -r src/jemalloc
365 %if %{with system_llvm}
366 %{__rm} -r src/llvm-project
367 mkdir -p src/llvm-project/libunwind
368 %endif
369
370 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
371 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
372         src/etc/rust-gdb
373
374 # cargo has hardcoded libexec path - honour rpm _libexecdir
375 %if "%{_libexecdir}" != "%{_prefix}/libexec"
376 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
377 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
378         src/bootstrap/dist.rs \
379         src/tools/cargo/src/cargo/ops/registry/auth.rs
380 %{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
381 %endif
382
383 # The configure macro will modify some autoconf-related files, which upsets
384 # cargo when it tries to verify checksums in those files.  If we just truncate
385 # that file list, cargo won't have anything to complain about.
386 find vendor -name .cargo-checksum.json \
387         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
388
389 %build
390 export CC="%{__cc}"
391 export CXX="%{__cxx}"
392 export AR="%{__ar}"
393 %configure \
394         --build=%{rust_bootstrap_triple} \
395         --host=%{rust_host_triple} \
396         --target="%(echo %rust_targets | tr ' ' ,)" \
397         --libdir=%{common_libdir} \
398         --disable-codegen-tests \
399         --disable-debuginfo-lines \
400 %if %{with full_debuginfo}
401         --disable-debuginfo-only-std \
402         --enable-debuginfo \
403 %else
404         --enable-debuginfo-only-std \
405         --disable-debuginfo \
406 %endif
407         --disable-jemalloc \
408         --disable-option-checking \
409         --disable-rpath \
410         --enable-extended \
411         --enable-llvm-link-shared \
412         --enable-vendor \
413         --local-rust-root=%{local_rust_root} \
414         --llvm-root=%{_prefix} \
415         --release-channel=%{channel}
416
417 export RUST_BACKTRACE=full
418 %x_py dist --verbose
419
420 %{?with_tests:%x_py test}
421
422 %install
423 rm -rf $RPM_BUILD_ROOT
424
425 export DESTDIR=$RPM_BUILD_ROOT
426 %x_py install
427
428 # Make sure the shared libraries are in the proper libdir
429 %if "%{_libdir}" != "%{common_libdir}"
430 mkdir -p %{buildroot}%{_libdir}
431 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
432         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
433 %endif
434
435 # The shared libraries should be executable for debuginfo extraction.
436 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
437
438 # The libdir libraries are identical to those under rustlib/.  It's easier on
439 # library loading if we keep them in libdir, but we do need them in rustlib/
440 # to support dynamic linking for compiler plugins, so we'll symlink.
441 for rust_target in %rust_targets; do
442         for l in libstd libtest ; do
443                 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
444                 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
445                 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
446                         ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
447                 fi
448         done
449 done
450
451 # Remove installer artifacts (manifests, uninstall scripts, etc.)
452 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
453
454 # FIXME: __os_install_post will strip the rlibs
455 # -- should we find a way to preserve debuginfo?
456
457 # Remove unwanted documentation files (we already package them)
458 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
459 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
460 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
461 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
462
463 # Sanitize the HTML documentation
464 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
465 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
466
467 # Move rust-gdb's python scripts so they're noarch
468 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
469 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
470
471 # We don't need stdlib source
472 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
473
474 # Create the path for crate-devel packages
475 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
476
477 %clean
478 rm -rf $RPM_BUILD_ROOT
479
480 %post   -p /sbin/ldconfig
481 %postun -p /sbin/ldconfig
482
483 %files
484 %defattr(644,root,root,755)
485 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
486 %attr(755,root,root) %{_bindir}/rust-demangler
487 %attr(755,root,root) %{_bindir}/rustc
488 %attr(755,root,root) %{_bindir}/rustdoc
489 %attr(755,root,root) %{_bindir}/rustfmt
490 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
491 %attr(755,root,root) %{_libdir}/libstd-*.so
492 %attr(755,root,root) %{_libdir}/libtest-*.so
493 %{_mandir}/man1/rustc.1*
494 %{_mandir}/man1/rustdoc.1*
495 %dir %{rustlibdir}
496
497 %files analysis
498 %defattr(644,root,root,755)
499 %(for rust_target in %rust_targets; do
500 echo "%{rustlibdir}/$rust_target/analysis"
501 done
502 )
503
504 %files std
505 %defattr(644,root,root,755)
506 %(for rust_target in %rust_targets; do
507 cat <<EOF
508 %dir %{rustlibdir}/$rust_target
509 %dir %{rustlibdir}/$rust_target/lib
510 %attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
511 %{rustlibdir}/$rust_target/lib/*.rlib
512 EOF
513 done
514 )
515 %dir %{rustlibdir}/%{rust_triple}/bin
516 %ifnarch x32
517 %attr(755,root,root) %{rustlibdir}/%{rust_triple}/bin/rust-llvm-dwp
518 %endif
519
520 %files debugger-common
521 %defattr(644,root,root,755)
522 %dir %{_datadir}/%{name}
523 %dir %{_datadir}/%{name}/etc
524 %{_datadir}/%{name}/etc/lldb_commands
525 %{_datadir}/%{name}/etc/rust_types.py
526
527 %files lldb
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_bindir}/rust-lldb
530 %{_datadir}/%{name}/etc/lldb_*.py*
531
532 %files gdb
533 %defattr(644,root,root,755)
534 %attr(755,root,root) %{_bindir}/rust-gdb
535 %attr(755,root,root) %{_bindir}/rust-gdbgui
536 %{_datadir}/%{name}/etc/gdb_*.py*
537
538 %files rls
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_bindir}/rls
541
542 %files doc
543 %defattr(644,root,root,755)
544 %dir %{_docdir}/%{name}
545 %doc %{_docdir}/%{name}/html
546
547 %files -n cargo
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_bindir}/cargo
550 %attr(755,root,root) %{_bindir}/cargo-clippy
551 %attr(755,root,root) %{_bindir}/cargo-fmt
552 %attr(755,root,root) %{_bindir}/clippy-driver
553 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
554 %{_mandir}/man1/cargo*.1*
555 %dir %{_datadir}/cargo
556 %dir %{_datadir}/cargo/registry
557
558 %files -n bash-completion-cargo
559 %defattr(644,root,root,755)
560 %{_sysconfdir}/bash_completion.d/cargo
561
562 %files -n zsh-completion-cargo
563 %defattr(644,root,root,755)
564 %{zsh_compdir}/_cargo
This page took 0.078108 seconds and 3 git commands to generate.