]> git.pld-linux.org Git - packages/rust.git/blame_incremental - rust.spec
adjusted and reenabled x32 patch
[packages/rust.git] / rust.spec
... / ...
CommitLineData
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
4# - package additional tools
5#
6# Conditional build:
7%bcond_with bootstrap # bootstrap using precompiled binaries
8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9%bcond_without system_llvm # system LLVM
10%bcond_with tests # build without tests
11
12# The channel can be stable, beta, or nightly
13%define channel stable
14
15%if "%{channel}" == "stable"
16%define rustc_package rustc-%{version}-src
17%else
18%define rustc_package rustc-%{channel}-src
19%endif
20
21# To bootstrap from scratch, set the channel and date from src/stage0.txt
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
24%define bootstrap_rust 1.46.0
25%define bootstrap_cargo 1.46.0
26%define bootstrap_date 2020-08-27
27
28%ifarch x32
29%define with_cross 1
30%endif
31Summary: The Rust Programming Language
32Summary(pl.UTF-8): Język programowania Rust
33Name: rust
34Version: 1.47.0
35Release: 0.1
36# Licenses: (rust itself) and (bundled libraries)
37License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
38Group: Development/Languages
39Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
40# Source0-md5: 6283a61cac54bb0a7d32bc447d07fadc
41Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
42# Source1-md5: 45eaf35327db0bac923c65048637a2f5
43Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
44# Source2-md5: 6a2422d81e98df5b71a959c70aa4c81b
45Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
46# Source3-md5: 144376df8b0ddfef57900b867746a9ab
47Patch0: %{name}-x32.patch
48URL: https://www.rust-lang.org/
49# for src/compiler-rt
50BuildRequires: cmake >= 3.4.3
51BuildRequires: curl
52# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
53BuildRequires: procps
54BuildRequires: python >= 1:2.7
55BuildRequires: rpmbuild(macros) >= 1.752
56%if %{without cross}
57BuildRequires: curl-devel
58BuildRequires: libgit2-devel
59BuildRequires: libstdc++-devel
60%{?with_system_llvm:BuildRequires: llvm-devel >= 8.0}
61BuildRequires: openssl-devel >= 1.0.1
62BuildRequires: zlib-devel
63%endif
64%if %{without bootstrap}
65BuildRequires: %{name} >= %{bootstrap_rust}
66BuildRequires: cargo >= %{bootstrap_cargo}
67BuildConflicts: %{name} > %{version}
68%endif
69%ifarch x32
70BuildRequires: glibc-devel(x32)
71BuildRequires: glibc-devel(x86_64)
72%if "%{_host_cpu}" == "x86_64"
73# building on x86_64 host with --target x32-pld-linux
74BuildRequires: curl-devel
75BuildRequires: gcc-multilib-x32
76BuildRequires: libgit2-devel
77BuildRequires: libstdc++-devel
78%{?with_system_llvm:BuildRequires: llvm-devel >= 8.0}
79BuildRequires: openssl-devel >= 1.0.1
80BuildRequires: zlib-devel
81%else
82# building x86_64-hosted crosscompiler on x32 host
83BuildRequires: gcc-multilib-64
84BuildRequires: libstdc++-multilib-64-devel
85# how to specify?
86#BuildRequires: curl-devel.x86_64
87#BuildRequires: libgit2-devel.x86_64
88#BuildRequires: llvm-devel.x86_64 >= 7.0
89#BuildRequires: openssl-devel.x86_64
90#BuildRequires: zlib-devel.x86_64
91%endif
92%endif
93# The C compiler is needed at runtime just for linking. Someday rustc might
94# invoke the linker directly, and then we'll only need binutils.
95# https://github.com/rust-lang/rust/issues/11937
96Requires: gcc
97# Only x86_64 and i686 are Tier 1 platforms at this time.
98# x32 is Tier 2, only rust-std is available (no rustc or cargo).
99# https://doc.rust-lang.org/nightly/rustc/platform-support.html
100ExclusiveArch: %{x8664} %{ix86} x32 aarch64
101BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103%ifarch x32
104%define rust_triple x86_64-unknown-linux-gnux32
105%define rust_host_triple x86_64-unknown-linux-gnu
106%define rust_bootstrap_triple x86_64-unknown-linux-gnu
107%else
108%define rust_triple %{_target_cpu}-unknown-linux-gnu
109%define rust_host_triple %{rust_triple}
110%define rust_bootstrap_triple %{rust_triple}
111%endif
112
113%if %{without bootstrap}
114%define local_rust_root %{_prefix}
115%else
116%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
117%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
118%endif
119
120# We're going to override --libdir when configuring to get rustlib into a
121# common path, but we'll fix the shared libraries during install.
122# Without this ugly hack, rust would not be able to build itself
123# for non-bootstrap build, lib64 is just too complicated for it.
124%define common_libdir %{_prefix}/lib
125%define rustlibdir %{common_libdir}/rustlib
126
127# once_call/once_callable non-function libstdc++ symbols
128%define skip_post_check_so 'librustc.*llvm.*\.so.*'
129
130# ALL Rust libraries are private, because they don't keep an ABI.
131%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
132%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
133
134%define x_py { \
135 x_py() { \
136 local cmd="$1"; \
137 shift; \
138 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
139 }; x_py }
140
141
142%description
143Rust is a systems programming language that runs blazingly fast,
144prevents segfaults, and guarantees thread safety.
145
146This package includes the Rust compiler, standard library, and
147documentation generator.
148
149%description -l pl.UTF-8
150Rust to systemowy język programowania działający bardzo szybko,
151zapobiegający naruszeniom ochrony pamięci i gwarantujący
152bezpieczną wielowątkowość.
153
154%package analyzer
155Summary: Implementation of Language Server Protocol for Rust
156Summary(pl.UTF-8): Implementacja Language Server Protocol dla Rusta
157Group: Development/Tools
158Requires: %{name} = %{version}-%{release}
159
160%description analyzer
161Implementation of Language Server Protocol for Rust.
162
163%description analyzer -l pl.UTF-8
164Implementacja Language Server Protocol dla Rusta.
165
166%package debugger-common
167Summary: Common debugger pretty printers for Rust
168Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
169Group: Development/Debuggers
170%{?noarchpackage}
171
172%description debugger-common
173This package includes the common functionality for rust-gdb and
174rust-lldb.
175
176%description debugger-common -l pl.UTF-8
177Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
178
179%package gdb
180Summary: GDB pretty printers for Rust
181Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
182Group: Development/Debuggers
183Requires: %{name}-debugger-common = %{version}-%{release}
184Requires: gdb
185%{?noarchpackage}
186
187%description gdb
188This package includes the rust-gdb script, which allows easier
189debugging of Rust programs.
190
191%description gdb -l pl.UTF-8
192Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
193odpluskwianie programów w języku Rust.
194
195%package lldb
196Summary: LLDB pretty printers for Rust
197Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
198Group: Development/Debuggers
199Requires: %{name}-debugger-common = %{version}-%{release}
200Requires: lldb
201%{?noarchpackage}
202
203%description lldb
204This package includes the rust-lldb script, which allows easier
205debugging of Rust programs.
206
207%description lldb -l pl.UTF-8
208Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
209odpluskwianie programów w języku Rust.
210
211%package rls
212Summary: Rust Language Server for IDE integration
213Summary(pl.UTF-8): Rust Language Server do integracji z IDE
214Group: Development/Tools
215Requires: %{name} = %{version}-%{release}
216
217%description rls
218Rust Language Server for IDE integration.
219
220%description rls -l pl.UTF-8
221Rust Language Server do integracji z IDE.
222
223%package doc
224Summary: Documentation for Rust
225Summary(pl.UTF-8): Dokumentacja do Rusta
226Group: Documentation
227%{?noarchpackage}
228
229%description doc
230This package includes HTML documentation for the Rust programming
231language and its standard library.
232
233%description doc -l pl.UTF-8
234Ten pakiet zawiera dokumentację w formacie HTML do języka
235programowania Rust i jego biblioteki standardowej.
236
237%package -n cargo
238Summary: Rust's package manager and build tool
239Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
240Group: Development/Tools
241Requires: %{name}
242
243%description -n cargo
244Cargo is a tool that allows Rust projects to declare their various
245dependencies and ensure that you'll always get a repeatable build.
246
247%description -n cargo -l pl.UTF-8
248Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
249zależności i zapewniające powtarzalność procesu budowania.
250
251%package -n bash-completion-cargo
252Summary: Bash completion for cargo command
253Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
254Group: Applications/Shells
255Requires: %{name} = %{version}-%{release}
256Requires: bash-completion
257
258%description -n bash-completion-cargo
259Bash completion for cargo command.
260
261%description -n bash-completion-cargo -l pl.UTF-8
262Bashowe dopełnianie parametrów polecenia cargo.
263
264%package -n zsh-completion-cargo
265Summary: Zsh completion for cargo command
266Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
267Group: Applications/Shells
268Requires: %{name} = %{version}-%{release}
269Requires: zsh
270
271%description -n zsh-completion-cargo
272Zsh completion for cargo command.
273
274%description -n zsh-completion-cargo -l pl.UTF-8
275Dopełnianie parametrów polecenia cargo w powłoce Zsh.
276
277%prep
278%setup -q -n %{rustc_package}
279# irrelevant when not building rustc for x32
280%patch0 -p1
281
282%if %{with bootstrap}
283%ifarch %{x8664} x32
284tar xf %{SOURCE1}
285%endif
286%ifarch %{ix86}
287tar xf %{SOURCE2}
288%endif
289%ifarch aarch64
290tar xf %{SOURCE3}
291%endif
292%{__mv} %{bootstrap_root} %{bootstrap_root}-root
293%{bootstrap_root}-root/install.sh \
294 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
295 --prefix=%{local_rust_root} \
296 --disable-ldconfig
297test -f %{local_rust_root}/bin/cargo
298test -f %{local_rust_root}/bin/rustc
299%endif
300
301# unbundle
302# We're disabling jemalloc, but rust-src still wants it.
303#%{__rm} -r src/jemalloc
304%{?with_system_llvm:%{__rm} -r src/llvm-project}
305
306# extract bundled licenses for packaging
307sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
308 >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
309
310# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
311sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
312 src/etc/rust-gdb
313
314# The configure macro will modify some autoconf-related files, which upsets
315# cargo when it tries to verify checksums in those files. If we just truncate
316# that file list, cargo won't have anything to complain about.
317find vendor -name .cargo-checksum.json \
318 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
319
320%build
321%configure \
322 --build=%{rust_bootstrap_triple} \
323 --host=%{rust_host_triple} \
324 --target=%{rust_triple} \
325 --libdir=%{common_libdir} \
326 --disable-codegen-tests \
327 --disable-debuginfo-lines \
328%if %{with full_debuginfo}
329 --disable-debuginfo-only-std \
330 --enable-debuginfo \
331%else
332 --enable-debuginfo-only-std \
333 --disable-debuginfo \
334%endif
335 --disable-jemalloc \
336 --disable-option-checking \
337 --disable-rpath \
338 --enable-extended \
339 --enable-llvm-link-shared \
340 --enable-vendor \
341 --local-rust-root=%{local_rust_root} \
342 --llvm-root=%{_prefix} \
343 --release-channel=%{channel}
344
345export RUST_BACKTRACE=full
346%x_py dist --verbose
347
348%{?with_tests:%x_py test}
349
350%install
351rm -rf $RPM_BUILD_ROOT
352
353export DESTDIR=$RPM_BUILD_ROOT
354%x_py install
355%x_py install src
356
357# Make sure the shared libraries are in the proper libdir
358%if "%{_libdir}" != "%{common_libdir}"
359mkdir -p %{buildroot}%{_libdir}
360find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
361 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
362%endif
363
364# The shared libraries should be executable for debuginfo extraction.
365find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
366
367# The libdir libraries are identical to those under rustlib/. It's easier on
368# library loading if we keep them in libdir, but we do need them in rustlib/
369# to support dynamic linking for compiler plugins, so we'll symlink.
370(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
371 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
372 -exec ln -v -f -s -t . '{}' '+')
373
374# Remove installer artifacts (manifests, uninstall scripts, etc.)
375find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
376
377# FIXME: __os_install_post will strip the rlibs
378# -- should we find a way to preserve debuginfo?
379
380# Remove unwanted documentation files (we already package them)
381%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
382%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
383%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
384%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
385
386# Sanitize the HTML documentation
387find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
388find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
389
390# Move rust-gdb's python scripts so they're noarch
391install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
392%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
393
394# We don't need stdlib source
395%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
396
397# Create the path for crate-devel packages
398install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
399
400%clean
401rm -rf $RPM_BUILD_ROOT
402
403%post -p /sbin/ldconfig
404%postun -p /sbin/ldconfig
405
406%files
407%defattr(644,root,root,755)
408%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
409%attr(755,root,root) %{_bindir}/rustc
410%attr(755,root,root) %{_bindir}/rustdoc
411%attr(755,root,root) %{_bindir}/rustfmt
412%attr(755,root,root) %{_libdir}/libchalk_derive-*.so
413%attr(755,root,root) %{_libdir}/librustc*-*.so
414%attr(755,root,root) %{_libdir}/libstd-*.so
415%attr(755,root,root) %{_libdir}/libtest-*.so
416%attr(755,root,root) %{_libdir}/libtracing_attributes-*.so
417%{_mandir}/man1/rustc.1*
418%{_mandir}/man1/rustdoc.1*
419%dir %{rustlibdir}
420%dir %{rustlibdir}/%{rust_triple}
421%{rustlibdir}/%{rust_triple}/analysis
422%dir %{rustlibdir}/%{rust_triple}/lib
423%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
424%{rustlibdir}/%{rust_triple}/lib/*.rlib
425
426# for cross-compiler (e.g. x86_64-hosted x32 rust)
427%if "%{rust_host_triple}" != "%{rust_triple}"
428%dir %{rustlibdir}/%{rust_host_triple}
429%{rustlibdir}/%{rust_host_triple}/analysis
430%dir %{rustlibdir}/%{rust_host_triple}/lib
431%attr(755,root,root) %{rustlibdir}/%{rust_host_triple}/lib/*.so
432%{rustlibdir}/%{rust_host_triple}/lib/*.rlib
433%endif
434
435%files analyzer
436%defattr(644,root,root,755)
437%attr(755,root,root) %{_bindir}/rust-analyzer
438
439%files debugger-common
440%defattr(644,root,root,755)
441%dir %{_datadir}/%{name}
442%dir %{_datadir}/%{name}/etc
443%{_datadir}/%{name}/etc/lldb_commands
444%{_datadir}/%{name}/etc/rust_types.py
445
446%files lldb
447%defattr(644,root,root,755)
448%attr(755,root,root) %{_bindir}/rust-lldb
449%{_datadir}/%{name}/etc/lldb_*.py*
450
451%files gdb
452%defattr(644,root,root,755)
453%attr(755,root,root) %{_bindir}/rust-gdb
454%attr(755,root,root) %{_bindir}/rust-gdbgui
455%{_datadir}/%{name}/etc/gdb_*.py*
456
457%files rls
458%defattr(644,root,root,755)
459%attr(755,root,root) %{_bindir}/rls
460
461%files doc
462%defattr(644,root,root,755)
463%dir %{_docdir}/%{name}
464%doc %{_docdir}/%{name}/html
465
466%files -n cargo
467%defattr(644,root,root,755)
468%attr(755,root,root) %{_bindir}/cargo
469%attr(755,root,root) %{_bindir}/cargo-clippy
470%attr(755,root,root) %{_bindir}/cargo-fmt
471%attr(755,root,root) %{_bindir}/clippy-driver
472%{_mandir}/man1/cargo*.1*
473%dir %{_datadir}/cargo
474%dir %{_datadir}/cargo/registry
475
476%files -n bash-completion-cargo
477%defattr(644,root,root,755)
478%{_sysconfdir}/bash_completion.d/cargo
479
480%files -n zsh-completion-cargo
481%defattr(644,root,root,755)
482%{zsh_compdir}/_cargo
This page took 0.15894 seconds and 4 git commands to generate.