]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
- relax internal deps
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
21# To bootstrap from scratch, set the channel and date from src/stage0.txt
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
8a54bb92
JP
24%define bootstrap_rust 1.51.0
25%define bootstrap_cargo 1.51.0
26%define bootstrap_date 2021-03-25
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
b263378f
JP
39Version: 1.52.1
40Release: 1
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
b263378f 45# Source0-md5: 2df4835e3a15cc6f7e06fa4a986285d2
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
8a54bb92 47# Source1-md5: 7640d6538716c6492e56f361e3af0631
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
8a54bb92 49# Source2-md5: 64f117dc1ae1543c8910eaa9a971ddd4
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
8a54bb92 51# Source3-md5: 3ac79872671df7ea0215fd351f52ffcf
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
8a54bb92 53# Source4-md5: f624772d7c7ba2e83a51b4e9c1657f7b
5aae056c 54Patch0: %{name}-x32.patch
e361528e 55URL: https://www.rust-lang.org/
e8f16183
JB
56# for src/compiler-rt
57BuildRequires: cmake >= 3.4.3
e361528e 58BuildRequires: curl
2eb30149
JB
59# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
60BuildRequires: procps
61BuildRequires: python >= 1:2.7
62BuildRequires: rpmbuild(macros) >= 1.752
63%if %{without cross}
8f176645 64BuildRequires: curl-devel
1f9b8560 65BuildRequires: libgit2-devel >= 1.1.0
d1b96fd8 66BuildRequires: libstdc++-devel
8a54bb92 67%{?with_system_llvm:BuildRequires: llvm-devel >= 9.0}
7da6653d 68BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
69BuildRequires: tar >= 1:1.22
70BuildRequires: xz
e361528e 71BuildRequires: zlib-devel
2eb30149 72%endif
e361528e 73%if %{without bootstrap}
d6d4cb2b 74BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 75BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 76BuildConflicts: %{name} > %{version}
e361528e 77%endif
2eb30149 78%ifarch x32
cd0c1484
JR
79BuildRequires: glibc-devel(x86-64)
80BuildRequires: glibc-devel(x86-x32)
2eb30149
JB
81%if "%{_host_cpu}" == "x86_64"
82# building on x86_64 host with --target x32-pld-linux
8f176645 83BuildRequires: curl-devel
2eb30149 84BuildRequires: gcc-multilib-x32
1f9b8560 85BuildRequires: libgit2-devel >= 1.1.0
2eb30149 86BuildRequires: libstdc++-devel
8a54bb92 87%{?with_system_llvm:BuildRequires: llvm-devel >= 9.0}
2eb30149
JB
88BuildRequires: openssl-devel >= 1.0.1
89BuildRequires: zlib-devel
90%else
91# building x86_64-hosted crosscompiler on x32 host
56b25e8b 92BuildRequires: curl-devel(x86-64)
cd0c1484 93BuildRequires: curl-devel(x86-x32)
2eb30149 94BuildRequires: gcc-multilib-64
1f9b8560 95BuildRequires: libgit2-devel(x86-64) >= 1.1.0
cd0c1484 96BuildRequires: libgit2-devel(x86-x32) >= 1.1.0
2eb30149 97BuildRequires: libstdc++-multilib-64-devel
cd0c1484
JR
98%if %{with system_llvm}
99BuildRequires: llvm-devel(x86-64) >= 9.0
100BuildRequires: llvm-devel(x86-x32) >= 9.0
101%endif
56b25e8b 102BuildRequires: openssl-devel(x86-64)
cd0c1484 103BuildRequires: openssl-devel(x86-x32)
56b25e8b 104BuildRequires: zlib-devel(x86-64)
cd0c1484 105BuildRequires: zlib-devel(x86-x32)
2eb30149
JB
106%endif
107%endif
e361528e
ER
108# The C compiler is needed at runtime just for linking. Someday rustc might
109# invoke the linker directly, and then we'll only need binutils.
110# https://github.com/rust-lang/rust/issues/11937
111Requires: gcc
cd0c1484
JR
112Requires: %{name}-std%{?_isa} = %{version}-%{release}
113%ifarch x32
114Requires: %{name}-std(x86-64) = %{version}-%{release}
115%endif
e361528e 116# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 117# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 118# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 119ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 120BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 121
e064fbd0 122%ifarch x32
badbe44d 123%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 124%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 125%define rust_bootstrap_triple x86_64-unknown-linux-gnu
e064fbd0 126%else
1fe729c8
JP
127%ifarch armv6hl armv7hl armv7hnl
128%define rust_triple arm-unknown-linux-gnueabihf
129%define rust_host_triple %{rust_triple}
130%define rust_bootstrap_triple %{rust_triple}
131%else
badbe44d 132%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
133%define rust_host_triple %{rust_triple}
134%define rust_bootstrap_triple %{rust_triple}
e064fbd0 135%endif
1fe729c8 136%endif
e361528e
ER
137
138%if %{without bootstrap}
8a073211 139%define local_rust_root %{_prefix}
e361528e 140%else
badbe44d 141%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 142%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
143%endif
144
18a1004b
JR
145# We're going to override --libdir when configuring to get rustlib into a
146# common path, but we'll fix the shared libraries during install.
5b9d67b0 147# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
148# for non-bootstrap build, lib64 is just too complicated for it.
149%define common_libdir %{_prefix}/lib
150%define rustlibdir %{common_libdir}/rustlib
151
19f98749 152# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 153%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 154
e361528e 155# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
156%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
157%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 158
37765656
JP
159%define x_py { \
160 x_py() { \
161 local cmd="$1"; \
162 shift; \
163 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
164 }; x_py }
165
166
e361528e
ER
167%description
168Rust is a systems programming language that runs blazingly fast,
169prevents segfaults, and guarantees thread safety.
170
171This package includes the Rust compiler, standard library, and
172documentation generator.
173
e8f16183
JB
174%description -l pl.UTF-8
175Rust to systemowy język programowania działający bardzo szybko,
176zapobiegający naruszeniom ochrony pamięci i gwarantujący
177bezpieczną wielowątkowość.
178
cd0c1484
JR
179%package analysis
180Summary: Metadata about the standard library
181Summary(pl.UTF-8): Metadane o standardowej bibliotece
182Group: Development/Tools
89a1e043 183Requires: %{name} = %{version}-%{release}
cd0c1484
JR
184
185%description analysis
186Metadata about the standard library.
187
188%description analysis -l pl.UTF-8
189Metadane o standardowej bibliotece.
190
191%package std
192Summary: Standard library for Rust
193Summary(pl.UTF-8): Standardowa biblioteka Rusta
194Group: Development/Tools
89a1e043 195Requires: %{name} = %{version}-%{release}
cd0c1484
JR
196
197%description std
198Standard library for Rust.
199
200%description std -l pl.UTF-8
201Standardowa biblioteka Rusta.
202
a7fda0f8
JP
203%package analyzer
204Summary: Implementation of Language Server Protocol for Rust
205Summary(pl.UTF-8): Implementacja Language Server Protocol dla Rusta
206Group: Development/Tools
89a1e043 207Requires: %{name} = %{version}-%{release}
a7fda0f8
JP
208
209%description analyzer
210Implementation of Language Server Protocol for Rust.
211
212%description analyzer -l pl.UTF-8
213Implementacja Language Server Protocol dla Rusta.
214
d1b96fd8
JR
215%package debugger-common
216Summary: Common debugger pretty printers for Rust
e8f16183 217Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 218Group: Development/Debuggers
e67020b3 219BuildArch: noarch
d1b96fd8
JR
220
221%description debugger-common
e8f16183
JB
222This package includes the common functionality for rust-gdb and
223rust-lldb.
224
225%description debugger-common -l pl.UTF-8
226Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 227
e361528e
ER
228%package gdb
229Summary: GDB pretty printers for Rust
e8f16183 230Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
231Group: Development/Debuggers
232Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 233Requires: gdb
e67020b3 234BuildArch: noarch
e361528e
ER
235
236%description gdb
237This package includes the rust-gdb script, which allows easier
238debugging of Rust programs.
239
e8f16183
JB
240%description gdb -l pl.UTF-8
241Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
242odpluskwianie programów w języku Rust.
243
d1b96fd8
JR
244%package lldb
245Summary: LLDB pretty printers for Rust
e8f16183 246Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
247Group: Development/Debuggers
248Requires: %{name}-debugger-common = %{version}-%{release}
249Requires: lldb
e67020b3 250BuildArch: noarch
d1b96fd8
JR
251
252%description lldb
253This package includes the rust-lldb script, which allows easier
254debugging of Rust programs.
255
e8f16183
JB
256%description lldb -l pl.UTF-8
257Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
258odpluskwianie programów w języku Rust.
259
a7fda0f8
JP
260%package rls
261Summary: Rust Language Server for IDE integration
262Summary(pl.UTF-8): Rust Language Server do integracji z IDE
263Group: Development/Tools
89a1e043
JR
264Requires: %{name} = %{version}-%{release}
265Requires: %{name}-analysis = %{version}-%{release}
a7fda0f8
JP
266
267%description rls
268Rust Language Server for IDE integration.
269
270%description rls -l pl.UTF-8
271Rust Language Server do integracji z IDE.
272
e361528e
ER
273%package doc
274Summary: Documentation for Rust
e8f16183 275Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 276Group: Documentation
e67020b3 277BuildArch: noarch
e361528e
ER
278
279%description doc
280This package includes HTML documentation for the Rust programming
281language and its standard library.
282
e8f16183
JB
283%description doc -l pl.UTF-8
284Ten pakiet zawiera dokumentację w formacie HTML do języka
285programowania Rust i jego biblioteki standardowej.
286
8a758d34
JP
287%package -n cargo
288Summary: Rust's package manager and build tool
289Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
290Group: Development/Tools
cd0c1484 291Requires: %{name}%{?_isa}
8a758d34
JP
292
293%description -n cargo
294Cargo is a tool that allows Rust projects to declare their various
295dependencies and ensure that you'll always get a repeatable build.
296
297%description -n cargo -l pl.UTF-8
298Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
299zależności i zapewniające powtarzalność procesu budowania.
300
6ed79af8
JB
301%package -n bash-completion-cargo
302Summary: Bash completion for cargo command
303Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
304Group: Applications/Shells
305Requires: %{name} = %{version}-%{release}
306Requires: bash-completion
307
308%description -n bash-completion-cargo
309Bash completion for cargo command.
310
311%description -n bash-completion-cargo -l pl.UTF-8
312Bashowe dopełnianie parametrów polecenia cargo.
313
8a758d34
JP
314%package -n zsh-completion-cargo
315Summary: Zsh completion for cargo command
316Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
317Group: Applications/Shells
318Requires: %{name} = %{version}-%{release}
6ed79af8 319Requires: zsh
8a758d34
JP
320
321%description -n zsh-completion-cargo
322Zsh completion for cargo command.
323
324%description -n zsh-completion-cargo -l pl.UTF-8
325Dopełnianie parametrów polecenia cargo w powłoce Zsh.
326
e361528e
ER
327%prep
328%setup -q -n %{rustc_package}
2eb30149 329# irrelevant when not building rustc for x32
8a54bb92 330#%%patch0 -p1
b5eceb5e 331
e361528e 332%if %{with bootstrap}
a1735efb 333%ifarch %{x8664} x32
e361528e
ER
334tar xf %{SOURCE1}
335%endif
336%ifarch %{ix86}
337tar xf %{SOURCE2}
338%endif
c160f211 339%ifarch aarch64
9eb0511e 340tar xf %{SOURCE3}
c160f211 341%endif
1fe729c8
JP
342%ifarch armv6hl armv7hl armv7hnl
343tar xf %{SOURCE4}
344%endif
d6d4cb2b
JR
345%{__mv} %{bootstrap_root} %{bootstrap_root}-root
346%{bootstrap_root}-root/install.sh \
badbe44d 347 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
348 --prefix=%{local_rust_root} \
349 --disable-ldconfig
350test -f %{local_rust_root}/bin/cargo
e361528e
ER
351test -f %{local_rust_root}/bin/rustc
352%endif
353
354# unbundle
d4b51567 355# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 356#%{__rm} -r src/jemalloc
9e7854c5
JP
357%if %{with system_llvm}
358%{__rm} -r src/llvm-project
359mkdir -p src/llvm-project/libunwind
360%endif
e361528e
ER
361
362# extract bundled licenses for packaging
5aae056c
JP
363sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
364 >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
e361528e
ER
365
366# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
367sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
368 src/etc/rust-gdb
369
5ee06aa0
JR
370# The configure macro will modify some autoconf-related files, which upsets
371# cargo when it tries to verify checksums in those files. If we just truncate
372# that file list, cargo won't have anything to complain about.
fe49e3fc 373find vendor -name .cargo-checksum.json \
5ee06aa0 374 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 375
e361528e
ER
376%build
377%configure \
2eb30149
JB
378 --build=%{rust_bootstrap_triple} \
379 --host=%{rust_host_triple} \
e8f16183 380 --target=%{rust_triple} \
18a1004b 381 --libdir=%{common_libdir} \
e8f16183 382 --disable-codegen-tests \
5ee06aa0 383 --disable-debuginfo-lines \
5b9d67b0 384%if %{with full_debuginfo}
5ee06aa0 385 --disable-debuginfo-only-std \
e361528e 386 --enable-debuginfo \
5b9d67b0
JB
387%else
388 --enable-debuginfo-only-std \
389 --disable-debuginfo \
390%endif
6ed79af8
JB
391 --disable-jemalloc \
392 --disable-option-checking \
393 --disable-rpath \
8a758d34 394 --enable-extended \
e8f16183 395 --enable-llvm-link-shared \
d6d4cb2b 396 --enable-vendor \
6ed79af8 397 --local-rust-root=%{local_rust_root} \
e8f16183 398 --llvm-root=%{_prefix} \
e361528e
ER
399 --release-channel=%{channel}
400
37765656
JP
401export RUST_BACKTRACE=full
402%x_py dist --verbose
e361528e 403
37765656 404%{?with_tests:%x_py test}
8a073211 405
e361528e
ER
406%install
407rm -rf $RPM_BUILD_ROOT
e361528e 408
37765656
JP
409export DESTDIR=$RPM_BUILD_ROOT
410%x_py install
e361528e 411
18a1004b
JR
412# Make sure the shared libraries are in the proper libdir
413%if "%{_libdir}" != "%{common_libdir}"
414mkdir -p %{buildroot}%{_libdir}
415find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
416 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
417%endif
418
d1b96fd8 419# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
420find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
421
d1b96fd8
JR
422# The libdir libraries are identical to those under rustlib/. It's easier on
423# library loading if we keep them in libdir, but we do need them in rustlib/
424# to support dynamic linking for compiler plugins, so we'll symlink.
18a1004b 425(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
d1b96fd8
JR
426 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
427 -exec ln -v -f -s -t . '{}' '+')
428
429# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 430find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
431
432# FIXME: __os_install_post will strip the rlibs
433# -- should we find a way to preserve debuginfo?
434
435# Remove unwanted documentation files (we already package them)
e8f16183
JB
436%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
437%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
438%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
439%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
440
441# Sanitize the HTML documentation
442find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
443find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
444
445# Move rust-gdb's python scripts so they're noarch
446install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 447%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 448
4f353dba
JR
449# We don't need stdlib source
450%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
451
1dd26160
JP
452# Create the path for crate-devel packages
453install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
454
e361528e
ER
455%clean
456rm -rf $RPM_BUILD_ROOT
457
458%post -p /sbin/ldconfig
459%postun -p /sbin/ldconfig
460
461%files
462%defattr(644,root,root,755)
5aae056c 463%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
ca8b753f 464%attr(755,root,root) %{_bindir}/miri
e361528e
ER
465%attr(755,root,root) %{_bindir}/rustc
466%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 467%attr(755,root,root) %{_bindir}/rustfmt
e8f16183 468%attr(755,root,root) %{_libdir}/librustc*-*.so
e8f16183 469%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 470%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
471%{_mandir}/man1/rustc.1*
472%{_mandir}/man1/rustdoc.1*
18a1004b 473%dir %{rustlibdir}
cd0c1484
JR
474
475%files analysis
476%defattr(644,root,root,755)
6ed79af8 477%{rustlibdir}/%{rust_triple}/analysis
cd0c1484
JR
478
479%files std
480%defattr(644,root,root,755)
481%dir %{rustlibdir}/%{rust_triple}
18a1004b
JR
482%dir %{rustlibdir}/%{rust_triple}/lib
483%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
484%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 485
a7fda0f8
JP
486%files analyzer
487%defattr(644,root,root,755)
488%attr(755,root,root) %{_bindir}/rust-analyzer
489
d1b96fd8
JR
490%files debugger-common
491%defattr(644,root,root,755)
492%dir %{_datadir}/%{name}
493%dir %{_datadir}/%{name}/etc
5aae056c
JP
494%{_datadir}/%{name}/etc/lldb_commands
495%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
496
497%files lldb
498%defattr(644,root,root,755)
499%attr(755,root,root) %{_bindir}/rust-lldb
500%{_datadir}/%{name}/etc/lldb_*.py*
501
e361528e
ER
502%files gdb
503%defattr(644,root,root,755)
504%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 505%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 506%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 507
a7fda0f8
JP
508%files rls
509%defattr(644,root,root,755)
510%attr(755,root,root) %{_bindir}/rls
511
e361528e
ER
512%files doc
513%defattr(644,root,root,755)
514%dir %{_docdir}/%{name}
d1b96fd8 515%doc %{_docdir}/%{name}/html
8a758d34
JP
516
517%files -n cargo
518%defattr(644,root,root,755)
519%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
520%attr(755,root,root) %{_bindir}/cargo-clippy
521%attr(755,root,root) %{_bindir}/cargo-fmt
ca8b753f 522%attr(755,root,root) %{_bindir}/cargo-miri
6ed79af8 523%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 524%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
525%{_mandir}/man1/cargo*.1*
526%dir %{_datadir}/cargo
527%dir %{_datadir}/cargo/registry
528
529%files -n bash-completion-cargo
530%defattr(644,root,root,755)
531%{_sysconfdir}/bash_completion.d/cargo
532
533%files -n zsh-completion-cargo
534%defattr(644,root,root,755)
535%{zsh_compdir}/_cargo
This page took 0.17229 seconds and 4 git commands to generate.