]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
BR: xz-devel
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
fc3be51a 21# To bootstrap from scratch, set the channel and date from src/stage0.json
e361528e
ER
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
98f7667c 24%define bootstrap_rust 1.61.0
aea1d260 25%define bootstrap_cargo %{bootstrap_rust}
98f7667c 26%define bootstrap_date 2022-05-19
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
c19e7faa
JP
31
32%if %{without full_debuginfo}
33%define _enable_debug_packages 0
34%endif
35
e361528e 36Summary: The Rust Programming Language
e8f16183 37Summary(pl.UTF-8): Język programowania Rust
e361528e 38Name: rust
98f7667c
JP
39Version: 1.62.0
40Release: 1
d1b96fd8 41# Licenses: (rust itself) and (bundled libraries)
e8f16183 42License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 43Group: Development/Languages
be28e1f1 44Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
98f7667c 45# Source0-md5: 3a4b30ad7dde630d4f69b8011bcf8c52
be28e1f1 46Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
98f7667c 47# Source1-md5: 6c2227cb2e8a2d86d93aeec4cd342bff
be28e1f1 48Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
98f7667c 49# Source2-md5: 160592aa60ef07721dd78fc09c382c35
9eb0511e 50Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
98f7667c 51# Source3-md5: ea2b0213459466161d8eec4877825e75
1fe729c8 52Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
98f7667c 53# Source4-md5: 397fb4e209cc1e53a4d8bf0587c29eed
ad044650 54Source5: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
98f7667c 55# Source5-md5: a11c7147725e51450d13ca6f29f5c944
e361528e 56URL: https://www.rust-lang.org/
e8f16183
JB
57# for src/compiler-rt
58BuildRequires: cmake >= 3.4.3
e361528e 59BuildRequires: curl
2eb30149
JB
60# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
61BuildRequires: procps
e65d284f
JP
62BuildRequires: python3
63BuildRequires: python3-modules
fc3be51a 64BuildRequires: rpm-build >= 4.6
2eb30149
JB
65BuildRequires: rpmbuild(macros) >= 1.752
66%if %{without cross}
8f176645 67BuildRequires: curl-devel
8745efaa 68BuildRequires: libgit2-devel >= 1.4.0
d1b96fd8 69BuildRequires: libstdc++-devel
2cec66d3 70%if %{with system_llvm}
aea1d260
JP
71BuildRequires: llvm >= 12.0
72BuildRequires: llvm-devel >= 12.0
2cec66d3 73%endif
7da6653d 74BuildRequires: openssl-devel >= 1.0.1
8a54bb92
JP
75BuildRequires: tar >= 1:1.22
76BuildRequires: xz
79a067de 77BuildRequires: xz-devel
e361528e 78BuildRequires: zlib-devel
2eb30149 79%endif
e361528e 80%if %{without bootstrap}
d6d4cb2b 81BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 82BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 83BuildConflicts: %{name} > %{version}
e361528e 84%endif
2eb30149 85%ifarch x32
cd0c1484
JR
86BuildRequires: glibc-devel(x86-64)
87BuildRequires: glibc-devel(x86-x32)
2eb30149
JB
88%if "%{_host_cpu}" == "x86_64"
89# building on x86_64 host with --target x32-pld-linux
8f176645 90BuildRequires: curl-devel
2eb30149 91BuildRequires: gcc-multilib-x32
8745efaa 92BuildRequires: libgit2-devel >= 1.4.0
2eb30149 93BuildRequires: libstdc++-devel
aea1d260 94%{?with_system_llvm:BuildRequires: llvm-devel >= 12.0}
2eb30149 95BuildRequires: openssl-devel >= 1.0.1
79a067de 96BuildRequires: xz-devel
2eb30149
JB
97BuildRequires: zlib-devel
98%else
99# building x86_64-hosted crosscompiler on x32 host
56b25e8b 100BuildRequires: curl-devel(x86-64)
cd0c1484 101BuildRequires: curl-devel(x86-x32)
2eb30149 102BuildRequires: gcc-multilib-64
8745efaa
JP
103BuildRequires: libgit2-devel(x86-64) >= 1.4.0
104BuildRequires: libgit2-devel(x86-x32) >= 1.4.0
2eb30149 105BuildRequires: libstdc++-multilib-64-devel
cd0c1484 106%if %{with system_llvm}
aea1d260
JP
107BuildRequires: llvm-devel(x86-64) >= 12.0
108BuildRequires: llvm-devel(x86-x32) >= 12.0
cd0c1484 109%endif
56b25e8b 110BuildRequires: openssl-devel(x86-64)
cd0c1484 111BuildRequires: openssl-devel(x86-x32)
79a067de
JP
112BuildRequires: xz-devel(x86-64)
113BuildRequires: xz-devel(x86-x32)
56b25e8b 114BuildRequires: zlib-devel(x86-64)
cd0c1484 115BuildRequires: zlib-devel(x86-x32)
2eb30149
JB
116%endif
117%endif
e361528e
ER
118# The C compiler is needed at runtime just for linking. Someday rustc might
119# invoke the linker directly, and then we'll only need binutils.
120# https://github.com/rust-lang/rust/issues/11937
121Requires: gcc
cd0c1484
JR
122Requires: %{name}-std%{?_isa} = %{version}-%{release}
123%ifarch x32
124Requires: %{name}-std(x86-64) = %{version}-%{release}
417178e1 125Requires: gcc-multilib-64
cd0c1484 126%endif
b8711561 127Obsoletes: rust-analyzer < 1.53.0
e361528e 128# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 129# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 130# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 131ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 132BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 133
e064fbd0 134%ifarch x32
badbe44d 135%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 136%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 137%define rust_bootstrap_triple x86_64-unknown-linux-gnu
a973dc7e
JR
138# libs in _libdir are x86_64 64bit
139%define _lib lib64
140%define _libdir %{_prefix}/lib64
e064fbd0 141%else
ad044650 142%ifarch armv6hl
1fe729c8
JP
143%define rust_triple arm-unknown-linux-gnueabihf
144%define rust_host_triple %{rust_triple}
145%define rust_bootstrap_triple %{rust_triple}
146%else
ad044650
JP
147%ifarch armv7hl armv7hnl
148%define rust_triple armv7-unknown-linux-gnueabihf
149%define rust_host_triple %{rust_triple}
150%define rust_bootstrap_triple %{rust_triple}
6c4856ce 151%define rust_suppl_targets thumbv7neon-unknown-linux-gnueabihf
ad044650 152%else
badbe44d 153%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
154%define rust_host_triple %{rust_triple}
155%define rust_bootstrap_triple %{rust_triple}
e064fbd0 156%endif
1fe729c8 157%endif
ad044650 158%endif
e361528e 159
62473c95
JP
160%define rust_targets %rust_triple %{?rust_suppl_targets}
161
e361528e 162%if %{without bootstrap}
8a073211 163%define local_rust_root %{_prefix}
e361528e 164%else
badbe44d 165%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 166%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
167%endif
168
18a1004b
JR
169# We're going to override --libdir when configuring to get rustlib into a
170# common path, but we'll fix the shared libraries during install.
5b9d67b0 171# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
172# for non-bootstrap build, lib64 is just too complicated for it.
173%define common_libdir %{_prefix}/lib
174%define rustlibdir %{common_libdir}/rustlib
175
19f98749 176# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 177%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 178
e361528e 179# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
180%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
181%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 182
37765656
JP
183%define x_py { \
184 x_py() { \
185 local cmd="$1"; \
186 shift; \
e65d284f 187 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
37765656
JP
188 }; x_py }
189
190
e361528e
ER
191%description
192Rust is a systems programming language that runs blazingly fast,
193prevents segfaults, and guarantees thread safety.
194
195This package includes the Rust compiler, standard library, and
196documentation generator.
197
e8f16183
JB
198%description -l pl.UTF-8
199Rust to systemowy język programowania działający bardzo szybko,
200zapobiegający naruszeniom ochrony pamięci i gwarantujący
201bezpieczną wielowątkowość.
202
cd0c1484
JR
203%package analysis
204Summary: Metadata about the standard library
205Summary(pl.UTF-8): Metadane o standardowej bibliotece
206Group: Development/Tools
89a1e043 207Requires: %{name} = %{version}-%{release}
cd0c1484
JR
208
209%description analysis
210Metadata about the standard library.
211
212%description analysis -l pl.UTF-8
213Metadane o standardowej bibliotece.
214
215%package std
216Summary: Standard library for Rust
217Summary(pl.UTF-8): Standardowa biblioteka Rusta
218Group: Development/Tools
89a1e043 219Requires: %{name} = %{version}-%{release}
cd0c1484
JR
220
221%description std
222Standard library for Rust.
223
224%description std -l pl.UTF-8
225Standardowa biblioteka Rusta.
226
d1b96fd8
JR
227%package debugger-common
228Summary: Common debugger pretty printers for Rust
e8f16183 229Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 230Group: Development/Debuggers
e67020b3 231BuildArch: noarch
d1b96fd8
JR
232
233%description debugger-common
e8f16183
JB
234This package includes the common functionality for rust-gdb and
235rust-lldb.
236
237%description debugger-common -l pl.UTF-8
238Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 239
e361528e
ER
240%package gdb
241Summary: GDB pretty printers for Rust
e8f16183 242Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
243Group: Development/Debuggers
244Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 245Requires: gdb
e67020b3 246BuildArch: noarch
e361528e
ER
247
248%description gdb
249This package includes the rust-gdb script, which allows easier
250debugging of Rust programs.
251
e8f16183
JB
252%description gdb -l pl.UTF-8
253Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
254odpluskwianie programów w języku Rust.
255
d1b96fd8
JR
256%package lldb
257Summary: LLDB pretty printers for Rust
e8f16183 258Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
259Group: Development/Debuggers
260Requires: %{name}-debugger-common = %{version}-%{release}
261Requires: lldb
e67020b3 262BuildArch: noarch
d1b96fd8
JR
263
264%description lldb
265This package includes the rust-lldb script, which allows easier
266debugging of Rust programs.
267
e8f16183
JB
268%description lldb -l pl.UTF-8
269Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
270odpluskwianie programów w języku Rust.
271
a7fda0f8
JP
272%package rls
273Summary: Rust Language Server for IDE integration
274Summary(pl.UTF-8): Rust Language Server do integracji z IDE
275Group: Development/Tools
89a1e043
JR
276Requires: %{name} = %{version}-%{release}
277Requires: %{name}-analysis = %{version}-%{release}
a7fda0f8
JP
278
279%description rls
280Rust Language Server for IDE integration.
281
282%description rls -l pl.UTF-8
283Rust Language Server do integracji z IDE.
284
e361528e
ER
285%package doc
286Summary: Documentation for Rust
e8f16183 287Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 288Group: Documentation
e67020b3 289BuildArch: noarch
e361528e
ER
290
291%description doc
292This package includes HTML documentation for the Rust programming
293language and its standard library.
294
e8f16183
JB
295%description doc -l pl.UTF-8
296Ten pakiet zawiera dokumentację w formacie HTML do języka
297programowania Rust i jego biblioteki standardowej.
298
8a758d34
JP
299%package -n cargo
300Summary: Rust's package manager and build tool
301Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
302Group: Development/Tools
cd0c1484 303Requires: %{name}%{?_isa}
8a758d34
JP
304
305%description -n cargo
306Cargo is a tool that allows Rust projects to declare their various
307dependencies and ensure that you'll always get a repeatable build.
308
309%description -n cargo -l pl.UTF-8
310Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
311zależności i zapewniające powtarzalność procesu budowania.
312
6ed79af8
JB
313%package -n bash-completion-cargo
314Summary: Bash completion for cargo command
315Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
316Group: Applications/Shells
317Requires: %{name} = %{version}-%{release}
318Requires: bash-completion
319
320%description -n bash-completion-cargo
321Bash completion for cargo command.
322
323%description -n bash-completion-cargo -l pl.UTF-8
324Bashowe dopełnianie parametrów polecenia cargo.
325
8a758d34
JP
326%package -n zsh-completion-cargo
327Summary: Zsh completion for cargo command
328Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
329Group: Applications/Shells
330Requires: %{name} = %{version}-%{release}
6ed79af8 331Requires: zsh
8a758d34
JP
332
333%description -n zsh-completion-cargo
334Zsh completion for cargo command.
335
336%description -n zsh-completion-cargo -l pl.UTF-8
337Dopełnianie parametrów polecenia cargo w powłoce Zsh.
338
e361528e
ER
339%prep
340%setup -q -n %{rustc_package}
b5eceb5e 341
e361528e 342%if %{with bootstrap}
a1735efb 343%ifarch %{x8664} x32
e361528e
ER
344tar xf %{SOURCE1}
345%endif
346%ifarch %{ix86}
347tar xf %{SOURCE2}
348%endif
c160f211 349%ifarch aarch64
9eb0511e 350tar xf %{SOURCE3}
c160f211 351%endif
ad044650 352%ifarch armv6hl
1fe729c8
JP
353tar xf %{SOURCE4}
354%endif
ad044650
JP
355%ifarch armv7hl armv7hnl
356tar xf %{SOURCE5}
357%endif
d6d4cb2b
JR
358%{__mv} %{bootstrap_root} %{bootstrap_root}-root
359%{bootstrap_root}-root/install.sh \
badbe44d 360 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
361 --prefix=%{local_rust_root} \
362 --disable-ldconfig
363test -f %{local_rust_root}/bin/cargo
e361528e
ER
364test -f %{local_rust_root}/bin/rustc
365%endif
366
367# unbundle
d4b51567 368# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 369#%{__rm} -r src/jemalloc
9e7854c5
JP
370%if %{with system_llvm}
371%{__rm} -r src/llvm-project
372mkdir -p src/llvm-project/libunwind
373%endif
e361528e 374
e361528e
ER
375# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
376sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
377 src/etc/rust-gdb
378
4b354bd7
JB
379# cargo has hardcoded libexec path - honour rpm _libexecdir
380%if "%{_libexecdir}" != "%{_prefix}/libexec"
381suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
382%{__sed} -i -e 's,"libexec","'${suffix}'",' \
383 src/bootstrap/dist.rs \
384 src/tools/cargo/src/cargo/ops/registry/auth.rs
385%{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
386%endif
387
5ee06aa0
JR
388# The configure macro will modify some autoconf-related files, which upsets
389# cargo when it tries to verify checksums in those files. If we just truncate
390# that file list, cargo won't have anything to complain about.
fe49e3fc 391find vendor -name .cargo-checksum.json \
5ee06aa0 392 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 393
e361528e 394%build
863a59ff
JP
395export CC="%{__cc}"
396export CXX="%{__cxx}"
397export AR="%{__ar}"
e361528e 398%configure \
2eb30149
JB
399 --build=%{rust_bootstrap_triple} \
400 --host=%{rust_host_triple} \
62473c95 401 --target="%(echo %rust_targets | tr ' ' ,)" \
18a1004b 402 --libdir=%{common_libdir} \
e8f16183 403 --disable-codegen-tests \
5ee06aa0 404 --disable-debuginfo-lines \
5b9d67b0 405%if %{with full_debuginfo}
5ee06aa0 406 --disable-debuginfo-only-std \
e361528e 407 --enable-debuginfo \
5b9d67b0
JB
408%else
409 --enable-debuginfo-only-std \
410 --disable-debuginfo \
411%endif
6ed79af8
JB
412 --disable-jemalloc \
413 --disable-option-checking \
414 --disable-rpath \
8a758d34 415 --enable-extended \
e8f16183 416 --enable-llvm-link-shared \
d6d4cb2b 417 --enable-vendor \
6ed79af8 418 --local-rust-root=%{local_rust_root} \
e8f16183 419 --llvm-root=%{_prefix} \
595dfba2
JP
420 --release-channel=%{channel} \
421 --set=llvm.static-libstdcpp=false
e361528e 422
37765656
JP
423export RUST_BACKTRACE=full
424%x_py dist --verbose
e361528e 425
37765656 426%{?with_tests:%x_py test}
8a073211 427
e361528e
ER
428%install
429rm -rf $RPM_BUILD_ROOT
e361528e 430
13ab0532
JP
431export CC="%{__cc}"
432export CXX="%{__cxx}"
433export AR="%{__ar}"
37765656
JP
434export DESTDIR=$RPM_BUILD_ROOT
435%x_py install
e361528e 436
18a1004b
JR
437# Make sure the shared libraries are in the proper libdir
438%if "%{_libdir}" != "%{common_libdir}"
439mkdir -p %{buildroot}%{_libdir}
440find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
441 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
442%endif
443
d1b96fd8 444# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
445find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
446
d1b96fd8
JR
447# The libdir libraries are identical to those under rustlib/. It's easier on
448# library loading if we keep them in libdir, but we do need them in rustlib/
449# to support dynamic linking for compiler plugins, so we'll symlink.
62473c95
JP
450for rust_target in %rust_targets; do
451 for l in libstd libtest ; do
452 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
453 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
454 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
455 ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
456 fi
457 done
a973dc7e 458done
d1b96fd8
JR
459
460# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 461find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
462
463# FIXME: __os_install_post will strip the rlibs
464# -- should we find a way to preserve debuginfo?
465
466# Remove unwanted documentation files (we already package them)
e8f16183
JB
467%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
468%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
469%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
470%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
471
472# Sanitize the HTML documentation
473find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
474find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
475
476# Move rust-gdb's python scripts so they're noarch
477install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 478%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 479
4f353dba
JR
480# We don't need stdlib source
481%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
482
1dd26160
JP
483# Create the path for crate-devel packages
484install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
485
e361528e
ER
486%clean
487rm -rf $RPM_BUILD_ROOT
488
489%post -p /sbin/ldconfig
490%postun -p /sbin/ldconfig
491
492%files
493%defattr(644,root,root,755)
16ea23d8 494%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
1736a047 495%attr(755,root,root) %{_bindir}/rust-demangler
e361528e
ER
496%attr(755,root,root) %{_bindir}/rustc
497%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 498%attr(755,root,root) %{_bindir}/rustfmt
a973dc7e 499%attr(755,root,root) %{_libdir}/librustc_driver-*.so
e8f16183 500%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 501%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
502%{_mandir}/man1/rustc.1*
503%{_mandir}/man1/rustdoc.1*
18a1004b 504%dir %{rustlibdir}
cd0c1484
JR
505
506%files analysis
507%defattr(644,root,root,755)
62473c95
JP
508%(for rust_target in %rust_targets; do
509echo "%{rustlibdir}/$rust_target/analysis"
510done
511)
cd0c1484
JR
512
513%files std
514%defattr(644,root,root,755)
62473c95
JP
515%(for rust_target in %rust_targets; do
516cat <<EOF
517%dir %{rustlibdir}/$rust_target
518%dir %{rustlibdir}/$rust_target/lib
519%attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
520%{rustlibdir}/$rust_target/lib/*.rlib
521EOF
522done
523)
e361528e 524
d1b96fd8
JR
525%files debugger-common
526%defattr(644,root,root,755)
527%dir %{_datadir}/%{name}
528%dir %{_datadir}/%{name}/etc
5aae056c
JP
529%{_datadir}/%{name}/etc/lldb_commands
530%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
531
532%files lldb
533%defattr(644,root,root,755)
534%attr(755,root,root) %{_bindir}/rust-lldb
535%{_datadir}/%{name}/etc/lldb_*.py*
536
e361528e
ER
537%files gdb
538%defattr(644,root,root,755)
539%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 540%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 541%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 542
a7fda0f8
JP
543%files rls
544%defattr(644,root,root,755)
545%attr(755,root,root) %{_bindir}/rls
546
e361528e
ER
547%files doc
548%defattr(644,root,root,755)
549%dir %{_docdir}/%{name}
d1b96fd8 550%doc %{_docdir}/%{name}/html
8a758d34
JP
551
552%files -n cargo
553%defattr(644,root,root,755)
554%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
555%attr(755,root,root) %{_bindir}/cargo-clippy
556%attr(755,root,root) %{_bindir}/cargo-fmt
557%attr(755,root,root) %{_bindir}/clippy-driver
8a54bb92 558%attr(755,root,root) %{_libexecdir}/cargo-credential-1password
8a758d34
JP
559%{_mandir}/man1/cargo*.1*
560%dir %{_datadir}/cargo
561%dir %{_datadir}/cargo/registry
562
563%files -n bash-completion-cargo
564%defattr(644,root,root,755)
565%{_sysconfdir}/bash_completion.d/cargo
566
567%files -n zsh-completion-cargo
568%defattr(644,root,root,755)
569%{zsh_compdir}/_cargo
This page took 0.280804 seconds and 4 git commands to generate.