]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
don't install src twice
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
cace5bf9 10%bcond_with tests # build without tests
e361528e 11
8a073211
JR
12# The channel can be stable, beta, or nightly
13%define channel stable
14
e361528e 15%if "%{channel}" == "stable"
8a073211 16%define rustc_package rustc-%{version}-src
e361528e 17%else
8a073211 18%define rustc_package rustc-%{channel}-src
e361528e
ER
19%endif
20
21# To bootstrap from scratch, set the channel and date from src/stage0.txt
22# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23# or nightly wants some beta-YYYY-MM-DD
9e7854c5
JP
24%define bootstrap_rust 1.47.0
25%define bootstrap_cargo 1.47.0
26%define bootstrap_date 2020-10-08
e361528e 27
badbe44d 28%ifarch x32
2eb30149 29%define with_cross 1
badbe44d 30%endif
e361528e 31Summary: The Rust Programming Language
e8f16183 32Summary(pl.UTF-8): Język programowania Rust
e361528e 33Name: rust
9e7854c5 34Version: 1.48.0
20b64456 35Release: 0.1
d1b96fd8 36# Licenses: (rust itself) and (bundled libraries)
e8f16183 37License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 38Group: Development/Languages
be28e1f1 39Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
9e7854c5 40# Source0-md5: 1d8996bba1abbd5b3b149ccc89589664
be28e1f1 41Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
9e7854c5 42# Source1-md5: 9365de1153dae7bf1f99224382f8d77c
be28e1f1 43Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
9e7854c5 44# Source2-md5: 9c351771a541e38416dd99ca85309059
9eb0511e 45Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
9e7854c5 46# Source3-md5: 1bb96238b441204e2b47561857ca9916
1fe729c8
JP
47Source4: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
48# Source4-md5: e178fcecb4bfdbacc967b76a5313c889
5aae056c 49Patch0: %{name}-x32.patch
e361528e 50URL: https://www.rust-lang.org/
e8f16183
JB
51# for src/compiler-rt
52BuildRequires: cmake >= 3.4.3
e361528e 53BuildRequires: curl
2eb30149
JB
54# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
55BuildRequires: procps
56BuildRequires: python >= 1:2.7
57BuildRequires: rpmbuild(macros) >= 1.752
58%if %{without cross}
8f176645
JB
59BuildRequires: curl-devel
60BuildRequires: libgit2-devel
d1b96fd8 61BuildRequires: libstdc++-devel
5aae056c 62%{?with_system_llvm:BuildRequires: llvm-devel >= 8.0}
7da6653d 63BuildRequires: openssl-devel >= 1.0.1
e361528e 64BuildRequires: zlib-devel
2eb30149 65%endif
e361528e 66%if %{without bootstrap}
d6d4cb2b 67BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 68BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 69BuildConflicts: %{name} > %{version}
e361528e 70%endif
2eb30149
JB
71%ifarch x32
72BuildRequires: glibc-devel(x32)
73BuildRequires: glibc-devel(x86_64)
74%if "%{_host_cpu}" == "x86_64"
75# building on x86_64 host with --target x32-pld-linux
8f176645 76BuildRequires: curl-devel
2eb30149 77BuildRequires: gcc-multilib-x32
8f176645 78BuildRequires: libgit2-devel
2eb30149 79BuildRequires: libstdc++-devel
5aae056c 80%{?with_system_llvm:BuildRequires: llvm-devel >= 8.0}
2eb30149
JB
81BuildRequires: openssl-devel >= 1.0.1
82BuildRequires: zlib-devel
83%else
84# building x86_64-hosted crosscompiler on x32 host
85BuildRequires: gcc-multilib-64
86BuildRequires: libstdc++-multilib-64-devel
3c25e53d
JR
87# how to specify? - rpm.org adds arch provides on packages (__isa), uncomment once we switch
88#BuildRequires: curl-devel(x86-64)
89#BuildRequires: libgit2-devel(x86-64)
90#BuildRequires: llvm-devel(x86-64)>= 7.0
91#BuildRequires: openssl-devel(x86-64)
92#BuildRequires: zlib-devel(x86-64)
2eb30149
JB
93%endif
94%endif
e361528e
ER
95# The C compiler is needed at runtime just for linking. Someday rustc might
96# invoke the linker directly, and then we'll only need binutils.
97# https://github.com/rust-lang/rust/issues/11937
98Requires: gcc
e361528e 99# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 100# x32 is Tier 2, only rust-std is available (no rustc or cargo).
4f433f76 101# https://doc.rust-lang.org/nightly/rustc/platform-support.html
1fe729c8 102ExclusiveArch: %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
6ed79af8 103BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 104
e064fbd0 105%ifarch x32
badbe44d 106%define rust_triple x86_64-unknown-linux-gnux32
2eb30149 107%define rust_host_triple x86_64-unknown-linux-gnu
badbe44d 108%define rust_bootstrap_triple x86_64-unknown-linux-gnu
e064fbd0 109%else
1fe729c8
JP
110%ifarch armv6hl armv7hl armv7hnl
111%define rust_triple arm-unknown-linux-gnueabihf
112%define rust_host_triple %{rust_triple}
113%define rust_bootstrap_triple %{rust_triple}
114%else
badbe44d 115%define rust_triple %{_target_cpu}-unknown-linux-gnu
2eb30149
JB
116%define rust_host_triple %{rust_triple}
117%define rust_bootstrap_triple %{rust_triple}
e064fbd0 118%endif
1fe729c8 119%endif
e361528e
ER
120
121%if %{without bootstrap}
8a073211 122%define local_rust_root %{_prefix}
e361528e 123%else
badbe44d 124%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 125%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
126%endif
127
18a1004b
JR
128# We're going to override --libdir when configuring to get rustlib into a
129# common path, but we'll fix the shared libraries during install.
5b9d67b0 130# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
131# for non-bootstrap build, lib64 is just too complicated for it.
132%define common_libdir %{_prefix}/lib
133%define rustlibdir %{common_libdir}/rustlib
134
19f98749 135# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 136%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 137
e361528e 138# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
139%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
140%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e 141
37765656
JP
142%define x_py { \
143 x_py() { \
144 local cmd="$1"; \
145 shift; \
146 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
147 }; x_py }
148
149
e361528e
ER
150%description
151Rust is a systems programming language that runs blazingly fast,
152prevents segfaults, and guarantees thread safety.
153
154This package includes the Rust compiler, standard library, and
155documentation generator.
156
e8f16183
JB
157%description -l pl.UTF-8
158Rust to systemowy język programowania działający bardzo szybko,
159zapobiegający naruszeniom ochrony pamięci i gwarantujący
160bezpieczną wielowątkowość.
161
a7fda0f8
JP
162%package analyzer
163Summary: Implementation of Language Server Protocol for Rust
164Summary(pl.UTF-8): Implementacja Language Server Protocol dla Rusta
165Group: Development/Tools
166Requires: %{name} = %{version}-%{release}
167
168%description analyzer
169Implementation of Language Server Protocol for Rust.
170
171%description analyzer -l pl.UTF-8
172Implementacja Language Server Protocol dla Rusta.
173
d1b96fd8
JR
174%package debugger-common
175Summary: Common debugger pretty printers for Rust
e8f16183 176Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8 177Group: Development/Debuggers
2eb30149 178%{?noarchpackage}
d1b96fd8
JR
179
180%description debugger-common
e8f16183
JB
181This package includes the common functionality for rust-gdb and
182rust-lldb.
183
184%description debugger-common -l pl.UTF-8
185Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 186
e361528e
ER
187%package gdb
188Summary: GDB pretty printers for Rust
e8f16183 189Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
190Group: Development/Debuggers
191Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 192Requires: gdb
2eb30149 193%{?noarchpackage}
e361528e
ER
194
195%description gdb
196This package includes the rust-gdb script, which allows easier
197debugging of Rust programs.
198
e8f16183
JB
199%description gdb -l pl.UTF-8
200Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
201odpluskwianie programów w języku Rust.
202
d1b96fd8
JR
203%package lldb
204Summary: LLDB pretty printers for Rust
e8f16183 205Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
206Group: Development/Debuggers
207Requires: %{name}-debugger-common = %{version}-%{release}
208Requires: lldb
2eb30149 209%{?noarchpackage}
d1b96fd8
JR
210
211%description lldb
212This package includes the rust-lldb script, which allows easier
213debugging of Rust programs.
214
e8f16183
JB
215%description lldb -l pl.UTF-8
216Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
217odpluskwianie programów w języku Rust.
218
a7fda0f8
JP
219%package rls
220Summary: Rust Language Server for IDE integration
221Summary(pl.UTF-8): Rust Language Server do integracji z IDE
222Group: Development/Tools
223Requires: %{name} = %{version}-%{release}
224
225%description rls
226Rust Language Server for IDE integration.
227
228%description rls -l pl.UTF-8
229Rust Language Server do integracji z IDE.
230
e361528e
ER
231%package doc
232Summary: Documentation for Rust
e8f16183 233Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8 234Group: Documentation
2eb30149 235%{?noarchpackage}
e361528e
ER
236
237%description doc
238This package includes HTML documentation for the Rust programming
239language and its standard library.
240
e8f16183
JB
241%description doc -l pl.UTF-8
242Ten pakiet zawiera dokumentację w formacie HTML do języka
243programowania Rust i jego biblioteki standardowej.
244
8a758d34
JP
245%package -n cargo
246Summary: Rust's package manager and build tool
247Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
248Group: Development/Tools
249Requires: %{name}
250
251%description -n cargo
252Cargo is a tool that allows Rust projects to declare their various
253dependencies and ensure that you'll always get a repeatable build.
254
255%description -n cargo -l pl.UTF-8
256Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
257zależności i zapewniające powtarzalność procesu budowania.
258
6ed79af8
JB
259%package -n bash-completion-cargo
260Summary: Bash completion for cargo command
261Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
262Group: Applications/Shells
263Requires: %{name} = %{version}-%{release}
264Requires: bash-completion
265
266%description -n bash-completion-cargo
267Bash completion for cargo command.
268
269%description -n bash-completion-cargo -l pl.UTF-8
270Bashowe dopełnianie parametrów polecenia cargo.
271
8a758d34
JP
272%package -n zsh-completion-cargo
273Summary: Zsh completion for cargo command
274Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
275Group: Applications/Shells
276Requires: %{name} = %{version}-%{release}
6ed79af8 277Requires: zsh
8a758d34
JP
278
279%description -n zsh-completion-cargo
280Zsh completion for cargo command.
281
282%description -n zsh-completion-cargo -l pl.UTF-8
283Dopełnianie parametrów polecenia cargo w powłoce Zsh.
284
e361528e
ER
285%prep
286%setup -q -n %{rustc_package}
2eb30149 287# irrelevant when not building rustc for x32
d794f84f 288%patch0 -p1
b5eceb5e 289
e361528e 290%if %{with bootstrap}
a1735efb 291%ifarch %{x8664} x32
e361528e
ER
292tar xf %{SOURCE1}
293%endif
294%ifarch %{ix86}
295tar xf %{SOURCE2}
296%endif
c160f211 297%ifarch aarch64
9eb0511e 298tar xf %{SOURCE3}
c160f211 299%endif
1fe729c8
JP
300%ifarch armv6hl armv7hl armv7hnl
301tar xf %{SOURCE4}
302%endif
d6d4cb2b
JR
303%{__mv} %{bootstrap_root} %{bootstrap_root}-root
304%{bootstrap_root}-root/install.sh \
badbe44d 305 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
306 --prefix=%{local_rust_root} \
307 --disable-ldconfig
308test -f %{local_rust_root}/bin/cargo
e361528e
ER
309test -f %{local_rust_root}/bin/rustc
310%endif
311
312# unbundle
d4b51567 313# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 314#%{__rm} -r src/jemalloc
9e7854c5
JP
315%if %{with system_llvm}
316%{__rm} -r src/llvm-project
317mkdir -p src/llvm-project/libunwind
318%endif
e361528e
ER
319
320# extract bundled licenses for packaging
5aae056c
JP
321sed -e '/*\//q' library/backtrace/crates/backtrace-sys/src/libbacktrace/backtrace.h \
322 >library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
e361528e
ER
323
324# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
325sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
326 src/etc/rust-gdb
327
5ee06aa0
JR
328# The configure macro will modify some autoconf-related files, which upsets
329# cargo when it tries to verify checksums in those files. If we just truncate
330# that file list, cargo won't have anything to complain about.
fe49e3fc 331find vendor -name .cargo-checksum.json \
5ee06aa0 332 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 333
e361528e
ER
334%build
335%configure \
2eb30149
JB
336 --build=%{rust_bootstrap_triple} \
337 --host=%{rust_host_triple} \
e8f16183 338 --target=%{rust_triple} \
18a1004b 339 --libdir=%{common_libdir} \
e8f16183 340 --disable-codegen-tests \
5ee06aa0 341 --disable-debuginfo-lines \
5b9d67b0 342%if %{with full_debuginfo}
5ee06aa0 343 --disable-debuginfo-only-std \
e361528e 344 --enable-debuginfo \
5b9d67b0
JB
345%else
346 --enable-debuginfo-only-std \
347 --disable-debuginfo \
348%endif
6ed79af8
JB
349 --disable-jemalloc \
350 --disable-option-checking \
351 --disable-rpath \
8a758d34 352 --enable-extended \
e8f16183 353 --enable-llvm-link-shared \
d6d4cb2b 354 --enable-vendor \
6ed79af8 355 --local-rust-root=%{local_rust_root} \
e8f16183 356 --llvm-root=%{_prefix} \
e361528e
ER
357 --release-channel=%{channel}
358
37765656
JP
359export RUST_BACKTRACE=full
360%x_py dist --verbose
e361528e 361
37765656 362%{?with_tests:%x_py test}
8a073211 363
e361528e
ER
364%install
365rm -rf $RPM_BUILD_ROOT
e361528e 366
37765656
JP
367export DESTDIR=$RPM_BUILD_ROOT
368%x_py install
e361528e 369
18a1004b
JR
370# Make sure the shared libraries are in the proper libdir
371%if "%{_libdir}" != "%{common_libdir}"
372mkdir -p %{buildroot}%{_libdir}
373find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
374 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
375%endif
376
d1b96fd8 377# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
378find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
379
d1b96fd8
JR
380# The libdir libraries are identical to those under rustlib/. It's easier on
381# library loading if we keep them in libdir, but we do need them in rustlib/
382# to support dynamic linking for compiler plugins, so we'll symlink.
18a1004b 383(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
d1b96fd8
JR
384 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
385 -exec ln -v -f -s -t . '{}' '+')
386
387# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 388find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
389
390# FIXME: __os_install_post will strip the rlibs
391# -- should we find a way to preserve debuginfo?
392
393# Remove unwanted documentation files (we already package them)
e8f16183
JB
394%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
395%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
396%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
397%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
398
399# Sanitize the HTML documentation
400find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
401find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
402
403# Move rust-gdb's python scripts so they're noarch
404install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 405%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 406
4f353dba
JR
407# We don't need stdlib source
408%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
409
1dd26160
JP
410# Create the path for crate-devel packages
411install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
412
e361528e
ER
413%clean
414rm -rf $RPM_BUILD_ROOT
415
416%post -p /sbin/ldconfig
417%postun -p /sbin/ldconfig
418
419%files
420%defattr(644,root,root,755)
5aae056c 421%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md library/backtrace/crates/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
e361528e
ER
422%attr(755,root,root) %{_bindir}/rustc
423%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 424%attr(755,root,root) %{_bindir}/rustfmt
5aae056c 425%attr(755,root,root) %{_libdir}/libchalk_derive-*.so
e8f16183 426%attr(755,root,root) %{_libdir}/librustc*-*.so
e8f16183 427%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 428%attr(755,root,root) %{_libdir}/libtest-*.so
5aae056c 429%attr(755,root,root) %{_libdir}/libtracing_attributes-*.so
e361528e
ER
430%{_mandir}/man1/rustc.1*
431%{_mandir}/man1/rustdoc.1*
18a1004b
JR
432%dir %{rustlibdir}
433%dir %{rustlibdir}/%{rust_triple}
6ed79af8 434%{rustlibdir}/%{rust_triple}/analysis
18a1004b
JR
435%dir %{rustlibdir}/%{rust_triple}/lib
436%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
437%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 438
2eb30149
JB
439# for cross-compiler (e.g. x86_64-hosted x32 rust)
440%if "%{rust_host_triple}" != "%{rust_triple}"
441%dir %{rustlibdir}/%{rust_host_triple}
442%{rustlibdir}/%{rust_host_triple}/analysis
443%dir %{rustlibdir}/%{rust_host_triple}/lib
444%attr(755,root,root) %{rustlibdir}/%{rust_host_triple}/lib/*.so
445%{rustlibdir}/%{rust_host_triple}/lib/*.rlib
446%endif
447
a7fda0f8
JP
448%files analyzer
449%defattr(644,root,root,755)
450%attr(755,root,root) %{_bindir}/rust-analyzer
451
d1b96fd8
JR
452%files debugger-common
453%defattr(644,root,root,755)
454%dir %{_datadir}/%{name}
455%dir %{_datadir}/%{name}/etc
5aae056c
JP
456%{_datadir}/%{name}/etc/lldb_commands
457%{_datadir}/%{name}/etc/rust_types.py
d1b96fd8
JR
458
459%files lldb
460%defattr(644,root,root,755)
461%attr(755,root,root) %{_bindir}/rust-lldb
462%{_datadir}/%{name}/etc/lldb_*.py*
463
e361528e
ER
464%files gdb
465%defattr(644,root,root,755)
466%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 467%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 468%{_datadir}/%{name}/etc/gdb_*.py*
e361528e 469
a7fda0f8
JP
470%files rls
471%defattr(644,root,root,755)
472%attr(755,root,root) %{_bindir}/rls
473
e361528e
ER
474%files doc
475%defattr(644,root,root,755)
476%dir %{_docdir}/%{name}
d1b96fd8 477%doc %{_docdir}/%{name}/html
8a758d34
JP
478
479%files -n cargo
480%defattr(644,root,root,755)
481%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
482%attr(755,root,root) %{_bindir}/cargo-clippy
483%attr(755,root,root) %{_bindir}/cargo-fmt
484%attr(755,root,root) %{_bindir}/clippy-driver
8a758d34
JP
485%{_mandir}/man1/cargo*.1*
486%dir %{_datadir}/cargo
487%dir %{_datadir}/cargo/registry
488
489%files -n bash-completion-cargo
490%defattr(644,root,root,755)
491%{_sysconfdir}/bash_completion.d/cargo
492
493%files -n zsh-completion-cargo
494%defattr(644,root,root,755)
495%{zsh_compdir}/_cargo
This page took 0.138449 seconds and 4 git commands to generate.