]> git.pld-linux.org Git - packages/rust.git/blame - rust.spec
- release 3 (by relup.sh)
[packages/rust.git] / rust.spec
CommitLineData
e361528e
ER
1# TODO
2# - consider a rust-std package containing .../rustlib/$target
3# This might allow multilib cross-compilation to work naturally.
8a758d34 4# - package additional tools
e361528e
ER
5#
6# Conditional build:
e8f16183 7%bcond_with bootstrap # bootstrap using precompiled binaries
398b58dd 8%bcond_with full_debuginfo # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
5b9d67b0 9%bcond_without system_llvm # system LLVM
badbe44d
JB
10%bcond_without rustc # rustc building
11%bcond_without cargo # cargo building
cace5bf9 12%bcond_with tests # build without tests
e361528e 13
8a073211
JR
14# The channel can be stable, beta, or nightly
15%define channel stable
16
e361528e 17%if "%{channel}" == "stable"
8a073211 18%define rustc_package rustc-%{version}-src
e361528e 19%else
8a073211 20%define rustc_package rustc-%{channel}-src
e361528e
ER
21%endif
22
23# To bootstrap from scratch, set the channel and date from src/stage0.txt
24# e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
25# or nightly wants some beta-YYYY-MM-DD
e901a823
JP
26%define bootstrap_rust 1.41.1
27%define bootstrap_cargo 1.41.0
28%define bootstrap_date 2020-02-27
e361528e 29
badbe44d
JB
30%ifarch x32
31%undefine with_cargo
32%undefine with_rustc
33%endif
e361528e 34Summary: The Rust Programming Language
e8f16183 35Summary(pl.UTF-8): Język programowania Rust
e361528e 36Name: rust
e901a823 37Version: 1.42.0
31742117 38Release: 3
d1b96fd8 39# Licenses: (rust itself) and (bundled libraries)
e8f16183 40License: (Apache v2.0 or MIT) and (BSD and ISC and MIT)
e361528e 41Group: Development/Languages
be28e1f1 42Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
e901a823 43# Source0-md5: 03a6111956f8d3bfdfc21aedce7f06bc
be28e1f1 44Source1: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
e901a823 45# Source1-md5: 3336c39311a33005d51298c60b99f2c1
be28e1f1 46Source2: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
e901a823 47# Source2-md5: be3f4d5143483c754a3c272eb213cd07
be28e1f1 48Source3: https://static.rust-lang.org/dist/%{bootstrap_date}/rust-std-%{bootstrap_rust}-x86_64-unknown-linux-gnux32.tar.xz
e901a823 49# Source3-md5: 38da0bf057e0801669f18f74555830bf
e361528e 50URL: https://www.rust-lang.org/
e8f16183
JB
51# for src/compiler-rt
52BuildRequires: cmake >= 3.4.3
e361528e 53BuildRequires: curl
d1b96fd8 54BuildRequires: libstdc++-devel
7da6653d
JB
55%{?with_system_llvm:BuildRequires: llvm-devel >= 7.0}
56BuildRequires: openssl-devel >= 1.0.1
e8f16183 57BuildRequires: python >= 1:2.7
e361528e
ER
58BuildRequires: zlib-devel
59%if %{without bootstrap}
d6d4cb2b 60BuildRequires: %{name} >= %{bootstrap_rust}
d1b96fd8 61BuildRequires: cargo >= %{bootstrap_cargo}
ff5a5e0b 62BuildConflicts: %{name} > %{version}
e361528e
ER
63%endif
64# make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
65BuildRequires: procps
e361528e
ER
66# The C compiler is needed at runtime just for linking. Someday rustc might
67# invoke the linker directly, and then we'll only need binutils.
68# https://github.com/rust-lang/rust/issues/11937
69Requires: gcc
e361528e 70# Only x86_64 and i686 are Tier 1 platforms at this time.
badbe44d 71# x32 is Tier 2, only rust-std is available (no rustc or cargo).
e361528e 72# https://doc.rust-lang.org/stable/book/getting-started.html#tier-1
badbe44d 73ExclusiveArch: %{x8664} %{ix86} x32
6ed79af8 74BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
e361528e 75
e064fbd0 76%ifarch x32
badbe44d
JB
77%define rust_triple x86_64-unknown-linux-gnux32
78%define rust_bootstrap_triple x86_64-unknown-linux-gnu
e064fbd0 79%else
badbe44d
JB
80%define rust_triple %{_target_cpu}-unknown-linux-gnu
81%define rust_bootstrap_triple %{_target_cpu}-unknown-linux-gnu
e064fbd0 82%endif
e361528e
ER
83
84%if %{without bootstrap}
8a073211 85%define local_rust_root %{_prefix}
e361528e 86%else
badbe44d 87%define bootstrap_root rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
8a073211 88%define local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
e361528e
ER
89%endif
90
18a1004b
JR
91# We're going to override --libdir when configuring to get rustlib into a
92# common path, but we'll fix the shared libraries during install.
5b9d67b0 93# Without this ugly hack, rust would not be able to build itself
18a1004b
JR
94# for non-bootstrap build, lib64 is just too complicated for it.
95%define common_libdir %{_prefix}/lib
96%define rustlibdir %{common_libdir}/rustlib
97
19f98749 98# once_call/once_callable non-function libstdc++ symbols
8f4c23f4 99%define skip_post_check_so 'librustc.*llvm.*\.so.*'
19f98749 100
e361528e 101# ALL Rust libraries are private, because they don't keep an ABI.
8a073211
JR
102%define _noautoreqfiles lib.*-[[:xdigit:]]{8}[.]so.*
103%define _noautoprovfiles lib.*-[[:xdigit:]]{8}[.]so.*
e361528e
ER
104
105%description
106Rust is a systems programming language that runs blazingly fast,
107prevents segfaults, and guarantees thread safety.
108
109This package includes the Rust compiler, standard library, and
110documentation generator.
111
e8f16183
JB
112%description -l pl.UTF-8
113Rust to systemowy język programowania działający bardzo szybko,
114zapobiegający naruszeniom ochrony pamięci i gwarantujący
115bezpieczną wielowątkowość.
116
d1b96fd8
JR
117%package debugger-common
118Summary: Common debugger pretty printers for Rust
e8f16183 119Summary(pl.UTF-8): Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
d1b96fd8
JR
120Group: Development/Debuggers
121BuildArch: noarch
122
123%description debugger-common
e8f16183
JB
124This package includes the common functionality for rust-gdb and
125rust-lldb.
126
127%description debugger-common -l pl.UTF-8
128Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
d1b96fd8 129
e361528e
ER
130%package gdb
131Summary: GDB pretty printers for Rust
e8f16183 132Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w GDB
d1b96fd8
JR
133Group: Development/Debuggers
134Requires: %{name}-debugger-common = %{version}-%{release}
e361528e 135Requires: gdb
e361528e 136BuildArch: noarch
e361528e
ER
137
138%description gdb
139This package includes the rust-gdb script, which allows easier
140debugging of Rust programs.
141
e8f16183
JB
142%description gdb -l pl.UTF-8
143Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
144odpluskwianie programów w języku Rust.
145
d1b96fd8
JR
146%package lldb
147Summary: LLDB pretty printers for Rust
e8f16183 148Summary(pl.UTF-8): Ładne wypisywanie struktur Rusta w LLDB
d1b96fd8
JR
149Group: Development/Debuggers
150Requires: %{name}-debugger-common = %{version}-%{release}
151Requires: lldb
d1b96fd8
JR
152BuildArch: noarch
153
154%description lldb
155This package includes the rust-lldb script, which allows easier
156debugging of Rust programs.
157
e8f16183
JB
158%description lldb -l pl.UTF-8
159Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
160odpluskwianie programów w języku Rust.
161
e361528e
ER
162%package doc
163Summary: Documentation for Rust
e8f16183 164Summary(pl.UTF-8): Dokumentacja do Rusta
d1b96fd8
JR
165Group: Documentation
166BuildArch: noarch
e361528e
ER
167
168%description doc
169This package includes HTML documentation for the Rust programming
170language and its standard library.
171
e8f16183
JB
172%description doc -l pl.UTF-8
173Ten pakiet zawiera dokumentację w formacie HTML do języka
174programowania Rust i jego biblioteki standardowej.
175
8a758d34
JP
176%package -n cargo
177Summary: Rust's package manager and build tool
178Summary(pl.UTF-8): Zarządca pakietów i narzędzie do budowania
179Group: Development/Tools
180Requires: %{name}
181
182%description -n cargo
183Cargo is a tool that allows Rust projects to declare their various
184dependencies and ensure that you'll always get a repeatable build.
185
186%description -n cargo -l pl.UTF-8
187Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
188zależności i zapewniające powtarzalność procesu budowania.
189
6ed79af8
JB
190%package -n bash-completion-cargo
191Summary: Bash completion for cargo command
192Summary(pl.UTF-8): Bashowe dopełnianie parametrów polecenia cargo
193Group: Applications/Shells
194Requires: %{name} = %{version}-%{release}
195Requires: bash-completion
196
197%description -n bash-completion-cargo
198Bash completion for cargo command.
199
200%description -n bash-completion-cargo -l pl.UTF-8
201Bashowe dopełnianie parametrów polecenia cargo.
202
8a758d34
JP
203%package -n zsh-completion-cargo
204Summary: Zsh completion for cargo command
205Summary(pl.UTF-8): Dopełnianie parametrów polecenia cargo w powłoce Zsh
206Group: Applications/Shells
207Requires: %{name} = %{version}-%{release}
6ed79af8 208Requires: zsh
8a758d34
JP
209
210%description -n zsh-completion-cargo
211Zsh completion for cargo command.
212
213%description -n zsh-completion-cargo -l pl.UTF-8
214Dopełnianie parametrów polecenia cargo w powłoce Zsh.
215
e361528e
ER
216%prep
217%setup -q -n %{rustc_package}
b5eceb5e 218
e361528e 219%if %{with bootstrap}
72bb5844 220%ifarch %{x8664}
e361528e
ER
221tar xf %{SOURCE1}
222%endif
223%ifarch %{ix86}
224tar xf %{SOURCE2}
225%endif
72bb5844
JR
226%ifarch x32
227tar xf %{SOURCE1}
228cd %{bootstrap_root}
229tar xf %{SOURCE3}
230%{__mv} rust-std-%{bootstrap_rust}-%{rust_triple} rust-std-%{rust_triple}
231cd ..
232%endif
d6d4cb2b
JR
233%{__mv} %{bootstrap_root} %{bootstrap_root}-root
234%{bootstrap_root}-root/install.sh \
badbe44d 235 --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
d6d4cb2b
JR
236 --prefix=%{local_rust_root} \
237 --disable-ldconfig
238test -f %{local_rust_root}/bin/cargo
e361528e 239test -f %{local_rust_root}/bin/rustc
72bb5844
JR
240%ifarch x32
241%{bootstrap_root}-root/rust-std-%{rust_triple}/install.sh \
242 --components=rust-std-%{rust_triple} \
243 --prefix=%{local_rust_root} \
244 --disable-ldconfig
245%endif
e361528e
ER
246%endif
247
248# unbundle
d4b51567 249# We're disabling jemalloc, but rust-src still wants it.
5b9d67b0 250#%{__rm} -r src/jemalloc
fe49e3fc 251%{?with_system_llvm:%{__rm} -r src/llvm-project}
e361528e
ER
252
253# extract bundled licenses for packaging
fe49e3fc
JP
254sed -e '/*\//q' vendor/backtrace-sys/src/libbacktrace/backtrace.h \
255 >vendor/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
e361528e
ER
256
257# rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
258sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
259 src/etc/rust-gdb
260
5ee06aa0
JR
261# The configure macro will modify some autoconf-related files, which upsets
262# cargo when it tries to verify checksums in those files. If we just truncate
263# that file list, cargo won't have anything to complain about.
fe49e3fc 264find vendor -name .cargo-checksum.json \
5ee06aa0 265 -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
e361528e 266
e361528e
ER
267%build
268%configure \
e8f16183
JB
269 --build=%{rust_triple} \
270 --host=%{rust_triple} \
271 --target=%{rust_triple} \
18a1004b 272 --libdir=%{common_libdir} \
e8f16183 273 --disable-codegen-tests \
5ee06aa0 274 --disable-debuginfo-lines \
5b9d67b0 275%if %{with full_debuginfo}
5ee06aa0 276 --disable-debuginfo-only-std \
e361528e 277 --enable-debuginfo \
5b9d67b0
JB
278%else
279 --enable-debuginfo-only-std \
280 --disable-debuginfo \
281%endif
6ed79af8
JB
282 --disable-jemalloc \
283 --disable-option-checking \
284 --disable-rpath \
8a758d34 285 --enable-extended \
e8f16183 286 --enable-llvm-link-shared \
d6d4cb2b 287 --enable-vendor \
6ed79af8 288 --local-rust-root=%{local_rust_root} \
e8f16183 289 --llvm-root=%{_prefix} \
e361528e
ER
290 --release-channel=%{channel}
291
5b9d67b0 292RUST_BACKTRACE=full \
6ed79af8 293./x.py dist --verbose
e361528e 294
8a073211
JR
295%{?with_tests:./x.py test}
296
e361528e
ER
297%install
298rm -rf $RPM_BUILD_ROOT
e361528e 299
4f353dba
JR
300DESTDIR=$RPM_BUILD_ROOT ./x.py install
301DESTDIR=$RPM_BUILD_ROOT ./x.py install src
e361528e 302
18a1004b
JR
303# Make sure the shared libraries are in the proper libdir
304%if "%{_libdir}" != "%{common_libdir}"
305mkdir -p %{buildroot}%{_libdir}
306find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
307 -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
308%endif
309
d1b96fd8 310# The shared libraries should be executable for debuginfo extraction.
e361528e
ER
311find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
312
d1b96fd8
JR
313# The libdir libraries are identical to those under rustlib/. It's easier on
314# library loading if we keep them in libdir, but we do need them in rustlib/
315# to support dynamic linking for compiler plugins, so we'll symlink.
18a1004b 316(cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
d1b96fd8
JR
317 find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
318 -exec ln -v -f -s -t . '{}' '+')
319
320# Remove installer artifacts (manifests, uninstall scripts, etc.)
18a1004b 321find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
e361528e
ER
322
323# FIXME: __os_install_post will strip the rlibs
324# -- should we find a way to preserve debuginfo?
325
326# Remove unwanted documentation files (we already package them)
e8f16183
JB
327%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
328%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
329%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
330%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
e361528e
ER
331
332# Sanitize the HTML documentation
333find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
334find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
335
336# Move rust-gdb's python scripts so they're noarch
337install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
e8f16183 338%{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
e361528e 339
4f353dba
JR
340# We don't need stdlib source
341%{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
342
1dd26160
JP
343# Create the path for crate-devel packages
344install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
345
e361528e
ER
346%clean
347rm -rf $RPM_BUILD_ROOT
348
349%post -p /sbin/ldconfig
350%postun -p /sbin/ldconfig
351
352%files
353%defattr(644,root,root,755)
fe49e3fc
JP
354%doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md vendor/backtrace-sys/src/libbacktrace/LICENSE-libbacktrace
355%attr(755,root,root) %{_bindir}/miri
6ed79af8 356%attr(755,root,root) %{_bindir}/rls
e361528e
ER
357%attr(755,root,root) %{_bindir}/rustc
358%attr(755,root,root) %{_bindir}/rustdoc
6ed79af8 359%attr(755,root,root) %{_bindir}/rustfmt
e8f16183 360%attr(755,root,root) %{_libdir}/librustc*-*.so
e8f16183 361%attr(755,root,root) %{_libdir}/libstd-*.so
e8f16183 362%attr(755,root,root) %{_libdir}/libtest-*.so
e361528e
ER
363%{_mandir}/man1/rustc.1*
364%{_mandir}/man1/rustdoc.1*
18a1004b
JR
365%dir %{rustlibdir}
366%dir %{rustlibdir}/%{rust_triple}
6ed79af8 367%{rustlibdir}/%{rust_triple}/analysis
18a1004b
JR
368%dir %{rustlibdir}/%{rust_triple}/lib
369%attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
370%{rustlibdir}/%{rust_triple}/lib/*.rlib
e361528e 371
d1b96fd8
JR
372%files debugger-common
373%defattr(644,root,root,755)
374%dir %{_datadir}/%{name}
375%dir %{_datadir}/%{name}/etc
376%{_datadir}/%{name}/etc/debugger_*.py*
377
378%files lldb
379%defattr(644,root,root,755)
380%attr(755,root,root) %{_bindir}/rust-lldb
381%{_datadir}/%{name}/etc/lldb_*.py*
382
e361528e
ER
383%files gdb
384%defattr(644,root,root,755)
385%attr(755,root,root) %{_bindir}/rust-gdb
fe49e3fc 386%attr(755,root,root) %{_bindir}/rust-gdbgui
d1b96fd8 387%{_datadir}/%{name}/etc/gdb_*.py*
e361528e
ER
388
389%files doc
390%defattr(644,root,root,755)
391%dir %{_docdir}/%{name}
d1b96fd8 392%doc %{_docdir}/%{name}/html
8a758d34
JP
393
394%files -n cargo
395%defattr(644,root,root,755)
396%attr(755,root,root) %{_bindir}/cargo
6ed79af8
JB
397%attr(755,root,root) %{_bindir}/cargo-clippy
398%attr(755,root,root) %{_bindir}/cargo-fmt
fe49e3fc 399%attr(755,root,root) %{_bindir}/cargo-miri
6ed79af8 400%attr(755,root,root) %{_bindir}/clippy-driver
8a758d34
JP
401%{_mandir}/man1/cargo*.1*
402%dir %{_datadir}/cargo
403%dir %{_datadir}/cargo/registry
404
405%files -n bash-completion-cargo
406%defattr(644,root,root,755)
407%{_sysconfdir}/bash_completion.d/cargo
408
409%files -n zsh-completion-cargo
410%defattr(644,root,root,755)
411%{zsh_compdir}/_cargo
This page took 0.128476 seconds and 4 git commands to generate.