]> git.pld-linux.org Git - packages/ruby.git/commitdiff
- added ffs patch: check for ffs() to define HAVE_FFS, which is checked in missing.h auto/th/ruby-1_9_2_0-1 auto/ti/ruby-1_9_2_0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 9 Oct 2010 17:21:56 +0000 (17:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  (without this, it defines ffs() without no-throw, thus conflicting with glibc when compiling in C++ mode)

Changed files:
    ruby-ffs.patch -> 1.1
    ruby.spec -> 1.220

ruby-ffs.patch [new file with mode: 0644]
ruby.spec

diff --git a/ruby-ffs.patch b/ruby-ffs.patch
new file mode 100644 (file)
index 0000000..d17309d
--- /dev/null
@@ -0,0 +1,11 @@
+--- ruby-1.9.2-p0/configure.in.orig    2010-10-09 14:30:10.239742720 +0200
++++ ruby-1.9.2-p0/configure.in 2010-10-09 14:35:19.007744396 +0200
+@@ -1163,7 +1163,7 @@
+ else
+   AC_LIBOBJ([signbit])
+ fi
+-AC_CHECK_FUNCS(fmod killpg wait4 waitpid fork spawnv syscall chroot getcwd eaccess\
++AC_CHECK_FUNCS(fmod killpg wait4 waitpid fork spawnv syscall chroot getcwd eaccess ffs\
+             truncate ftruncate chsize times utimes utimensat fcntl lockf lstat\
+             link symlink readlink readdir_r fsync fdatasync fchown\
+             setitimer setruid seteuid setreuid setresuid setproctitle socketpair\
index 5e4cfbc97d5654065777dd6d14e4637bf404be6e..6013e992d6dd66553aa0ddb18c8c1a88c67c38d4 100644 (file)
--- a/ruby.spec
+++ b/ruby.spec
@@ -31,6 +31,7 @@ Source4:      testrb.1
 Source5:       %{name}-mode-init.el
 Patch0:                %{name}-mkmf-shared.patch
 Patch1:                %{name}-lib64.patch
+Patch2:                %{name}-ffs.patch
 URL:           http://www.ruby-lang.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -207,6 +208,7 @@ Tryb Ruby i debugger dla Emacsa.
 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
This page took 0.052611 seconds and 4 git commands to generate.