]> git.pld-linux.org Git - packages/ruby.git/blobdiff - ruby.spec
cleanup unused patches; renum patches
[packages/ruby.git] / ruby.spec
index bc7d812815a487f0f75cbdf3b0ac994d292d9f36..dfa6dce8954a17e9425151ca3d574a29791c0996 100644 (file)
--- a/ruby.spec
+++ b/ruby.spec
@@ -3,23 +3,20 @@
 #      - replace ri with fastri
 #      - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
-# - fix requires/provides 'ruby(abi) = '
-# - nil this macro: %ruby_mod_ver_requires_eq "Requires: ruby-modules(ver) = "
-# - fix tk build
-# - %ruby_version is empty and rpm error then
-# - vendor packages get installed to /usr/share/ruby/vendor_ruby/PACKAGE, which
-#   will be installed fine on ruby < 2.0, but not usable as path not in include
-#   path, how to force vendor packages built with ruby 2.0 pull ruby 2.0?
+# - vendor *noarch* packages get installed to /usr/share/ruby/vendor_ruby/PACKAGE, which
+#   will be installed fine on ruby < 2.0, but not usable as dir not in included
+#   in load_path, how to force vendor packages built with ruby 2.0 pull ruby 2.0?
 #   for packages with gem deps it's simple: ruby-listen-2.7.1-0.2.noarch marks ruby-modules-2.0.0.451-0.17.x86_64 (cap /usr/share/gems/specifications)
+#   add that dir to legacy loadpath?
 #
 # Conditional build:
 %bcond_without doc             # skip (time-consuming) docs generating; intended for speed up test builds
-%bcond_without tk              # skip building package with Tk bindings
+%bcond_with    tk              # build Tk bindings (tcl8.6 is not supported)
 %bcond_without batteries       # Don't include rubygems, json, rake, minitest
 %bcond_without default_ruby    # use this Ruby as default system Ruby
 %bcond_with    bootstrap       # build bootstrap version
 
-%define                rel             0.21
+%define                rel             1
 %define                ruby_version    2.0
 %define                basever         2.0.0
 %define                patchlevel      481
@@ -67,20 +64,13 @@ Source6:    operating_system.rb
 Patch0:                %{oname}-lib64.patch
 Patch1:                %{oname}-ffs.patch
 Patch2:                fix-bison-invocation.patch
-# http://redmine.ruby-lang.org/issues/5231
-#Patch3:               disable-versioned-paths.patch
-# TODO: Should be submitted upstream?
-#Patch4:               arch-specific-dir.patch
-# http://redmine.ruby-lang.org/issues/5281
-#Patch5:               site-and-vendor-arch-flags.patch
-# Make mkmf verbose by default
-Patch6:                mkmf-verbose.patch
-Patch7:                strip-ccache.patch
-Patch8:                duplicated-paths.patch
-Patch9:                DESTDIR.patch
-Patch10:       empty-ruby-version.patch
-Patch11:       rubygems-2.0.0-binary-extensions.patch
-Patch12:       custom-rubygems-location.patch
+Patch3:                mkmf-verbose.patch
+Patch4:                strip-ccache.patch
+Patch5:                duplicated-paths.patch
+Patch6:                DESTDIR.patch
+Patch7:                empty-ruby-version.patch
+Patch8:                rubygems-2.0.0-binary-extensions.patch
+Patch9:                custom-rubygems-location.patch
 URL:           http://www.ruby-lang.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -433,16 +423,13 @@ Biblioteka JSON dla jÄ™zyka Ruby.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-#%patch3 -p1
-#%patch4 -p1
-#%patch5 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch10 -p1
-%patch11 -p1
-%patch12 -p1
 
 # must be regenerated with new bison
 %{__rm} parse.{c,h}
@@ -457,6 +444,9 @@ find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
        -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
        | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
 
+# no configure option to disable, so just rm
+%{!?with_tk:rm -rf ext/tk}
+
 %build
 rubygems_ver=$(awk '/VERSION =/ && $1 == "VERSION" {print $3}' lib/rubygems.rb | xargs)
 if [ $rubygems_ver != %{rubygems_ver} ]; then
This page took 0.06337 seconds and 4 git commands to generate.