]> git.pld-linux.org Git - packages/ruby.git/blobdiff - ruby.spec
up to 2.0.0p598
[packages/ruby.git] / ruby.spec
index 6d3e6d7f902889be35bf3ce5647e0af3a0d4dcae..9fcede6b5efb9234f960ffb6f81b44deeb8387e1 100644 (file)
--- a/ruby.spec
+++ b/ruby.spec
@@ -3,10 +3,11 @@
 #      - replace ri with fastri
 #      - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
-# - vendor packages get installed to /usr/share/ruby/vendor_ruby/PACKAGE, which
-#   will be installed fine on ruby < 2.0, but not usable as path not in include
-#   path, how to force vendor packages built with ruby 2.0 pull ruby 2.0?
+# - vendor *noarch* packages get installed to /usr/share/ruby/vendor_ruby/PACKAGE, which
+#   will be installed fine on ruby < 2.0, but not usable as dir not in included
+#   in load_path, how to force vendor packages built with ruby 2.0 pull ruby 2.0?
 #   for packages with gem deps it's simple: ruby-listen-2.7.1-0.2.noarch marks ruby-modules-2.0.0.451-0.17.x86_64 (cap /usr/share/gems/specifications)
+#   add that dir to legacy loadpath?
 #
 # Conditional build:
 %bcond_without doc             # skip (time-consuming) docs generating; intended for speed up test builds
 %bcond_without default_ruby    # use this Ruby as default system Ruby
 %bcond_with    bootstrap       # build bootstrap version
 
-%define                rel             0.21
+%define                rel             1
 %define                ruby_version    2.0
 %define                basever         2.0.0
-%define                patchlevel      481
+%define                patchlevel      598
 
 %define                ruby_suffix %{!?with_default_ruby:%{ruby_version}}
 %define                doc_version     2_0_0
@@ -47,8 +48,8 @@ Epoch:                1
 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
 License:       (Ruby or BSD) and Public Domain
 Group:         Development/Languages
-Source0:       ftp://ftp.ruby-lang.org/pub/ruby/2.0/%{oname}-%{basever}-p%{patchlevel}.tar.bz2
-# Source0-md5: ea406a8d415a1a5d8365596d4288f3da
+Source0:       https://ftp.ruby-lang.org/pub/ruby/2.0/%{oname}-%{basever}-p%{patchlevel}.tar.bz2
+# Source0-md5: a3f3908103a7d209d1d1cf4712e3953c
 Source1:       http://www.ruby-doc.org/download/%{oname}-doc-bundle.tar.gz
 # Source1-md5: ad1af0043be98ba1a4f6d0185df63876
 Source2:       http://www.ruby-doc.org/downloads/%{oname}_%{doc_version}_stdlib_rdocs.tgz
@@ -63,20 +64,14 @@ Source6:    operating_system.rb
 Patch0:                %{oname}-lib64.patch
 Patch1:                %{oname}-ffs.patch
 Patch2:                fix-bison-invocation.patch
-# http://redmine.ruby-lang.org/issues/5231
-#Patch3:               disable-versioned-paths.patch
-# TODO: Should be submitted upstream?
-#Patch4:               arch-specific-dir.patch
-# http://redmine.ruby-lang.org/issues/5281
-#Patch5:               site-and-vendor-arch-flags.patch
-# Make mkmf verbose by default
-Patch6:                mkmf-verbose.patch
-Patch7:                strip-ccache.patch
-Patch8:                duplicated-paths.patch
-Patch9:                DESTDIR.patch
-Patch10:       empty-ruby-version.patch
-Patch11:       rubygems-2.0.0-binary-extensions.patch
-Patch12:       custom-rubygems-location.patch
+Patch3:                mkmf-verbose.patch
+Patch4:                strip-ccache.patch
+Patch5:                duplicated-paths.patch
+Patch6:                DESTDIR.patch
+Patch7:                empty-ruby-version.patch
+Patch8:                rubygems-2.0.0-binary-extensions.patch
+Patch9:                custom-rubygems-location.patch
+Patch10:       %{oname}-posixsh.patch
 URL:           http://www.ruby-lang.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -103,7 +98,7 @@ Provides:    ruby(ver) = %{ruby_version}
 Obsoletes:     ruby-REXML <= 2.4.0-2
 Obsoletes:     ruby-doc < 1.8.4
 Obsoletes:     ruby-fastthread <= 0.6.3
-Conflicts:     rpm-build-macros < 1.694
+Conflicts:     rpm-build-macros < 1.695
 Conflicts:     ruby-activesupport < 2.3.11-2
 Conflicts:     ruby-activesupport2 < 2.3.11-2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -198,6 +193,7 @@ Obsoletes:  ruby-minitest <= 1.5.0
 %endif
 # FIXME later
 Provides:      ruby(abi) = %{ruby_version}
+%requires_eq_to        openssl openssl-devel
 
 %description modules
 Ruby standard modules and utilities:
@@ -322,6 +318,8 @@ Epoch:              0
 License:       GPL v2 and Ruby and MIT
 Group:         Development/Libraries
 Requires:      %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
+Requires:      %{name}-irb >= %{irb_ver}
+Requires:      %{name}-json >= %{json_ver}
 Obsoletes:     rdoc <= 0.9.0
 %if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
@@ -429,16 +427,14 @@ Biblioteka JSON dla jÄ™zyka Ruby.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-#%patch3 -p1
-#%patch4 -p1
-#%patch5 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch11 -p1
-%patch12 -p1
 
 # must be regenerated with new bison
 %{__rm} parse.{c,h}
@@ -453,6 +449,9 @@ find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
        -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
        | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
 
+# no configure option to disable, so just rm
+%{!?with_tk:rm -rf ext/tk}
+
 %build
 rubygems_ver=$(awk '/VERSION =/ && $1 == "VERSION" {print $3}' lib/rubygems.rb | xargs)
 if [ $rubygems_ver != %{rubygems_ver} ]; then
@@ -739,6 +738,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/rake%{ruby_suffix}
 %{_mandir}/man1/rake%{ruby_suffix}.1*
 %{ruby_libdir}/rake
+%{ruby_libdir}/rake.rb
 %dir %{gem_dir}/gems/rake-%{rake_ver}
 %{gem_dir}/gems/rake-%{rake_ver}/lib
 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
@@ -800,7 +800,12 @@ rm -rf $RPM_BUILD_ROOT
 %{ruby_libdir}/tmpdir.rb
 %{ruby_libdir}/tracer.rb
 %{ruby_libdir}/tsort.rb
-%{ruby_libdir}/[u-z]*.rb
+%{ruby_libdir}/un.rb
+%{ruby_libdir}/uri.rb
+%{ruby_libdir}/weakref.rb
+%{ruby_libdir}/webrick.rb
+%{ruby_libdir}/xmlrpc.rb
+%{ruby_libdir}/yaml.rb
 %if %{with batteries}
 %exclude %{ruby_libdir}/rubygems.rb
 %exclude %{ruby_libdir}/ubygems.rb
@@ -809,8 +814,37 @@ rm -rf $RPM_BUILD_ROOT
 %endif
 %exclude %{ruby_libdir}/irb.rb
 %exclude %{ruby_libdir}/mkmf.rb
-%attr(755,root,root) %{ruby_archdir}/[a-s]*.so
-%attr(755,root,root) %{ruby_archdir}/[u-z]*.so
+%exclude %{ruby_libdir}/rake.rb
+
+%{ruby_archdir}/rbconfig.rb
+%attr(755,root,root) %{ruby_archdir}/bigdecimal.so
+%attr(755,root,root) %{ruby_archdir}/continuation.so
+%attr(755,root,root) %{ruby_archdir}/coverage.so
+%attr(755,root,root) %{ruby_archdir}/curses.so
+%attr(755,root,root) %{ruby_archdir}/date_core.so
+%attr(755,root,root) %{ruby_archdir}/dbm.so
+%attr(755,root,root) %{ruby_archdir}/digest.so
+%attr(755,root,root) %{ruby_archdir}/dl.so
+%attr(755,root,root) %{ruby_archdir}/etc.so
+%attr(755,root,root) %{ruby_archdir}/fcntl.so
+%attr(755,root,root) %{ruby_archdir}/fiber.so
+%attr(755,root,root) %{ruby_archdir}/fiddle.so
+%attr(755,root,root) %{ruby_archdir}/gdbm.so
+%attr(755,root,root) %{ruby_archdir}/nkf.so
+%attr(755,root,root) %{ruby_archdir}/objspace.so
+%attr(755,root,root) %{ruby_archdir}/openssl.so
+%attr(755,root,root) %{ruby_archdir}/pathname.so
+%attr(755,root,root) %{ruby_archdir}/psych.so
+%attr(755,root,root) %{ruby_archdir}/pty.so
+%attr(755,root,root) %{ruby_archdir}/readline.so
+%attr(755,root,root) %{ruby_archdir}/ripper.so
+%attr(755,root,root) %{ruby_archdir}/sdbm.so
+%attr(755,root,root) %{ruby_archdir}/socket.so
+%attr(755,root,root) %{ruby_archdir}/stringio.so
+%attr(755,root,root) %{ruby_archdir}/strscan.so
+%attr(755,root,root) %{ruby_archdir}/syslog.so
+%attr(755,root,root) %{ruby_archdir}/zlib.so
+
 %dir %{ruby_archdir}/digest
 %attr(755,root,root) %{ruby_archdir}/digest/*.so
 %dir %{ruby_archdir}/dl
@@ -825,7 +859,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
 %dir %{ruby_archdir}/racc
 %attr(755,root,root) %{ruby_archdir}/racc/*.so
-%{ruby_archdir}/rbconfig.rb
 
 # bigdecimal
 %{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
This page took 0.075482 seconds and 4 git commands to generate.