]> git.pld-linux.org Git - packages/rtl8812au.git/commitdiff
- fix building with linux 4.7 auto/th/rtl8812au-4.3.2_11100.20140411-0.20140901.12
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 1 Aug 2016 19:52:44 +0000 (21:52 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 1 Aug 2016 19:52:44 +0000 (21:52 +0200)
- rel 12

linux-4.7.patch [new file with mode: 0644]
rtl8812au.spec [changed mode: 0644->0755]

diff --git a/linux-4.7.patch b/linux-4.7.patch
new file mode 100644 (file)
index 0000000..7cea561
--- /dev/null
@@ -0,0 +1,39 @@
+--- rtl8812au_linux-master/os_dep/linux/ioctl_cfg80211.c.orig  2016-08-01 21:49:34.559616222 +0200
++++ rtl8812au_linux-master/os_dep/linux/ioctl_cfg80211.c       2016-08-01 21:50:12.690473128 +0200
+@@ -25,6 +25,13 @@
+ #include <rtw_wifi_regd.h>
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4, 7, 0))
++#define ieee80211_band nl80211_band
++#define IEEE80211_BAND_2GHZ NL80211_BAND_2GHZ
++#define IEEE80211_BAND_5GHZ NL80211_BAND_5GHZ
++#define IEEE80211_NUM_BANDS NUM_NL80211_BANDS
++#endif
++
+ #define RTW_MAX_MGMT_TX_CNT (8)
+ #define RTW_SCAN_IE_LEN_MAX      2304
+--- rtl8812au_linux-master/os_dep/linux/wifi_regd.c.orig       2016-08-01 21:49:41.259767005 +0200
++++ rtl8812au_linux-master/os_dep/linux/wifi_regd.c    2016-08-01 21:50:02.516911448 +0200
+@@ -10,6 +10,13 @@
+ #include <rtw_wifi_regd.h>
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4, 7, 0))
++#define ieee80211_band nl80211_band
++#define IEEE80211_BAND_2GHZ NL80211_BAND_2GHZ
++#define IEEE80211_BAND_5GHZ NL80211_BAND_5GHZ
++#define IEEE80211_NUM_BANDS NUM_NL80211_BANDS
++#endif
++
+ static struct country_code_to_enum_rd allCountries[] = {
+       {COUNTRY_CODE_USER, "RD"},
+ };
+@@ -559,4 +566,4 @@
+       _rtw_reg_notifier_apply(wiphy, request, reg);
+ }
+-#endif //CONFIG_IOCTL_CFG80211
+\ No newline at end of file
++#endif //CONFIG_IOCTL_CFG80211
old mode 100644 (file)
new mode 100755 (executable)
index f881f12..96928cf
@@ -4,7 +4,7 @@
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
-%define                rel     11
+%define                rel     12
 %define                snap    20140901
 %define                pname   rtl8812au
 Summary:       Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
@@ -31,6 +31,7 @@ Patch8:               linux-4.1.patch
 Patch9:                linux-4.2.patch
 Patch10:       linux-4.3.patch
 Patch11:       linux-4.6.patch
+Patch12:       linux-4.7.patch
 BuildRequires: rpmbuild(macros) >= 1.701
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRoot:     %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
@@ -84,6 +85,7 @@ Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
 
 %build
 %{expand:%build_kernel_packages}
This page took 0.130133 seconds and 4 git commands to generate.