]> git.pld-linux.org Git - packages/rtl8812au.git/commitdiff
- fix building with kernel 4.11.9+ auto/th/rtl8812au-4.3.2_11100.20140411-0.20140901.15
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 15 Jul 2017 13:39:49 +0000 (22:39 +0900)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 15 Jul 2017 13:39:49 +0000 (22:39 +0900)
- rel 15

linux-4.11.9.patch [new file with mode: 0644]
rtl8812au.spec

diff --git a/linux-4.11.9.patch b/linux-4.11.9.patch
new file mode 100644 (file)
index 0000000..166138f
--- /dev/null
@@ -0,0 +1,27 @@
+--- rtl8812au_linux-master/os_dep/linux/ioctl_cfg80211.c~      2017-07-15 22:35:08.000000000 +0900
++++ rtl8812au_linux-master/os_dep/linux/ioctl_cfg80211.c       2017-07-15 22:35:33.436437371 +0900
+@@ -3792,7 +3792,12 @@
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(4,1,0))
+       mon_ndev->name_assign_type = name_assign_type;
+ #endif
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(4,11,9))
+       mon_ndev->destructor = rtw_ndev_destructor;
++#else
++      mon_ndev->needs_free_netdev = true;
++      mon_ndev->priv_destructor = rtw_ndev_destructor;
++#endif
+       
+ #if (LINUX_VERSION_CODE>=KERNEL_VERSION(2,6,29))
+       mon_ndev->netdev_ops = &rtw_cfg80211_monitor_if_ops;
+--- rtl8812au_linux-master/os_dep/linux/os_intfs.c~    2017-07-15 22:29:21.000000000 +0900
++++ rtl8812au_linux-master/os_dep/linux/os_intfs.c     2017-07-15 22:34:47.048201499 +0900
+@@ -2651,7 +2651,9 @@
+       if (ndev->ieee80211_ptr)
+               rtw_mfree((u8 *)ndev->ieee80211_ptr, sizeof(struct wireless_dev));
+ #endif
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(4,11,9))
+       free_netdev(ndev);
++#endif
+ }
+ #ifdef CONFIG_ARP_KEEP_ALIVE
index 420946e3b91311413f015b70be40e18996fd56ab..6e1fc279a0b88da11772082ef8955747d237595d 100644 (file)
@@ -4,7 +4,7 @@
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
-%define                rel     14
+%define                rel     15
 %define                snap    20140901
 %define                pname   rtl8812au
 Summary:       Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
@@ -34,6 +34,7 @@ Patch11:      linux-4.6.patch
 Patch12:       linux-4.7.patch
 Patch13:       linux-4.8.patch
 Patch14:       linux-4.11.patch
+Patch15:       linux-4.11.9.patch
 BuildRequires: rpmbuild(macros) >= 1.701
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRoot:     %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
@@ -90,6 +91,7 @@ Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
+%patch15 -p1
 
 %build
 %{expand:%build_kernel_packages}
This page took 0.07679 seconds and 4 git commands to generate.