]> git.pld-linux.org Git - packages/rtl8812au.git/blobdiff - rtl8812au.spec
- rel 16
[packages/rtl8812au.git] / rtl8812au.spec
index 7dde7e79db236d9d23efb9e3167b57f7991779e8..43cb3dfc96ef74a1ce31965a96c19a14396d27bd 100644 (file)
@@ -1,41 +1,45 @@
+# TODO: consider migrating to https://github.com/zebulon2/rtl8812au / https://aur.archlinux.org/packages/rtl8812au-v5-dkms-git/
+#
 # Conditional build:
-%bcond_without dist_kernel     # allow non-distribution kernel
 %bcond_with    verbose         # verbose build (V=1)
 
-%if "%{_alt_kernel}" != "%{nil}"
-%if 0%{?build_kernels:1}
-%{error:alt_kernel and build_kernels are mutually exclusive}
-exit 1
-%endif
-%global                _build_kernels          %{alt_kernel}
-%else
-%global                _build_kernels          %{?build_kernels:,%{?build_kernels}}
-%endif
-
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
-%define                kbrs    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo "BuildRequires:kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2" ; done)
-%define                kpkg    %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%kernel_pkg ; done)
-%define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
-
-%define                rel     1
-%define                snap    20140817
+%define                rel     16
+%define                snap    20140901
 %define                pname   rtl8812au
 Summary:       Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
 Name:          %{pname}%{_alt_kernel}
-Version:       4.2.2_7502.20130517
+Version:       4.3.2_11100.20140411
 Release:       0.%{snap}.%{rel}%{?_pld_builder:@%{_kernel_ver_str}}
 License:       GPL
 Group:         Base/Kernel
-URL:           http://www.realtek.com.tw/
-#Source0:      https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/v%{version}/%{name}-%{version}.tar.gz
-Source0:       https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
-# Source0-md5: 988810755bc6e687d358475861a2a6ca
-Patch0:                disable-CONFIG_IOCTL_CFG80211.patch
-Patch1:                usb-ids.patch
-BuildRequires: rpmbuild(macros) >= 1.678
-%{?with_dist_kernel:%{expand:%kbrs}}
+#Source0:      https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
+Source0:       https://github.com/austinmarton/rtl8812au_linux/archive/master/%{pname}-%{version}-%{snap}.tar.gz
+# Source0-md5: 693825ab344b68a1217f20ab8dd98b82
+# good luck finding this chip on Realtek website :/
+#URL:          http://www.realtek.com.tw/
+URL:           https://github.com/austinmarton/rtl8812au_linux
+Patch0:                linux-3.11.patch
+Patch1:                disable-debug.patch
+Patch2:                enable-cfg80211-support.patch
+Patch3:                update-cfg80211-support.patch
+Patch4:                warnings.patch
+Patch5:                gcc-4.9.patch
+Patch6:                linux-3.18.patch
+Patch7:                linux-4.0.patch
+Patch8:                linux-4.1.patch
+Patch9:                linux-4.2.patch
+Patch10:       linux-4.3.patch
+Patch11:       linux-4.6.patch
+Patch12:       linux-4.7.patch
+Patch13:       linux-4.8.patch
+Patch14:       linux-4.11.patch
+Patch15:       linux-4.11.9.patch
+Patch16:       linux-4.12.patch
+BuildRequires: rpmbuild(macros) >= 1.701
+%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRoot:     %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
 
 %description
@@ -47,10 +51,8 @@ Summary:     Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
 Release:       %{rel}@%{_kernel_ver_str}\
 Group:         Base/Kernel\
 Requires(post,postun): /sbin/depmod\
-%if %{with dist_kernel}\
 %requires_releq_kernel\
 Requires(postun):      %releq_kernel\
-%endif\
 \
 %description -n kernel%{_alt_kernel}-net-rtl8812au\
 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
@@ -67,21 +69,36 @@ Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
 %{nil}
 
 %define build_kernel_pkg()\
-%{__make} clean KVER=%{_kernel_ver}\
-%{__make} modules KVER=%{_kernel_ver}\
+%{__make} clean KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
+%{__make} modules KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
 %install_kernel_modules -D installed -m 8812au -d kernel/drivers/net/wireless\
 %{nil}
 
-%{expand:%kpkg}
+%{expand:%create_kernel_packages}
 
 %prep
 #%setup -q -n %{pname}-%{version}
-%setup -q -n rtl8812AU_8821AU_linux-master
+%setup -q -n rtl8812au_linux-master
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
+%patch13 -p1
+%patch14 -p1
+%patch15 -p1
+%patch16 -p1
 
 %build
-%{expand:%bkpkg}
+%{expand:%build_kernel_packages}
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.107144 seconds and 4 git commands to generate.