]> git.pld-linux.org Git - packages/rtl8812au.git/blob - rtl8812au.spec
bffa04767f989f61cfb0d90a95052afccabc1295
[packages/rtl8812au.git] / rtl8812au.spec
1 # Conditional build:
2 %bcond_with     verbose         # verbose build (V=1)
3
4 # nothing to be placed to debuginfo package
5 %define         _enable_debug_packages  0
6
7 %define         rel     15
8 %define         snap    20140901
9 %define         pname   rtl8812au
10 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
11 Name:           %{pname}%{_alt_kernel}
12 Version:        4.3.2_11100.20140411
13 Release:        0.%{snap}.%{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL
15 Group:          Base/Kernel
16 #Source0:       https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
17 Source0:        https://github.com/austinmarton/rtl8812au_linux/archive/master/%{pname}-%{version}-%{snap}.tar.gz
18 # Source0-md5:  693825ab344b68a1217f20ab8dd98b82
19 # good luck finding this chip on Realtek website :/
20 #URL:           http://www.realtek.com.tw/
21 URL:            https://github.com/austinmarton/rtl8812au_linux
22 Patch0:         linux-3.11.patch
23 Patch1:         disable-debug.patch
24 Patch2:         enable-cfg80211-support.patch
25 Patch3:         update-cfg80211-support.patch
26 Patch4:         warnings.patch
27 Patch5:         gcc-4.9.patch
28 Patch6:         linux-3.18.patch
29 Patch7:         linux-4.0.patch
30 Patch8:         linux-4.1.patch
31 Patch9:         linux-4.2.patch
32 Patch10:        linux-4.3.patch
33 Patch11:        linux-4.6.patch
34 Patch12:        linux-4.7.patch
35 Patch13:        linux-4.8.patch
36 Patch14:        linux-4.11.patch
37 Patch15:        linux-4.11.9.patch
38 Patch16:        linux-4.12.patch
39 BuildRequires:  rpmbuild(macros) >= 1.701
40 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
41 BuildRoot:      %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
42
43 %description
44 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter.
45
46 %define kernel_pkg()\
47 %package -n kernel%{_alt_kernel}-net-rtl8812au\
48 Summary:        Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
49 Release:        %{rel}@%{_kernel_ver_str}\
50 Group:          Base/Kernel\
51 Requires(post,postun):  /sbin/depmod\
52 %requires_releq_kernel\
53 Requires(postun):       %releq_kernel\
54 \
55 %description -n kernel%{_alt_kernel}-net-rtl8812au\
56 Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
57 \
58 %files -n kernel%{_alt_kernel}-net-rtl8812au\
59 %defattr(644,root,root,755)\
60 /lib/modules/%{_kernel_ver}/kernel/drivers/net/wireless/*.ko*\
61 \
62 %post   -n kernel%{_alt_kernel}-net-rtl8812au\
63 %depmod %{_kernel_ver}\
64 \
65 %postun -n kernel%{_alt_kernel}-net-rtl8812au\
66 %depmod %{_kernel_ver}\
67 %{nil}
68
69 %define build_kernel_pkg()\
70 %{__make} clean KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
71 %{__make} modules KVER=%{_kernel_ver} KSRC=%{_kernelsrcdir}\
72 %install_kernel_modules -D installed -m 8812au -d kernel/drivers/net/wireless\
73 %{nil}
74
75 %{expand:%create_kernel_packages}
76
77 %prep
78 #%setup -q -n %{pname}-%{version}
79 %setup -q -n rtl8812au_linux-master
80 %patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83 %patch3 -p1
84 %patch4 -p1
85 %patch5 -p1
86 %patch6 -p1
87 %patch7 -p1
88 %patch8 -p1
89 %patch9 -p1
90 %patch10 -p1
91 %patch11 -p1
92 %patch12 -p1
93 %patch13 -p1
94 %patch14 -p1
95 %patch15 -p1
96 %patch16 -p1
97
98 %build
99 %{expand:%build_kernel_packages}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT
104
105 cp -a installed/* $RPM_BUILD_ROOT
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
This page took 0.096033 seconds and 2 git commands to generate.