]> git.pld-linux.org Git - packages/rt.git/blobdiff - rt.spec
- up to 4.2.11
[packages/rt.git] / rt.spec
diff --git a/rt.spec b/rt.spec
index a0aaddb0fe347e440b56fd6823ac157c0ddae6fd..2ccc1d45b440621622af172a56fe0498a7fdb201 100644 (file)
--- a/rt.spec
+++ b/rt.spec
@@ -7,7 +7,7 @@
 #
 %define        perl_ver                                5.8.3
 %define        perl_apache_session_ver                 1.53
-%define        perl_cgi_ver                            3.38
+%define        perl_cgi_ver                            4.00
 %define        perl_class_returnvalue_ver              0.40
 %define        perl_css_squish_ver                     0.06
 %define        perl_dbd_mysql                          2.1018
@@ -31,6 +31,7 @@
 %define        perl_plack_ver                          1.0002
 %define        perl_starlet_ver                        0.20
 %define        perl_storable_ver                       2.08
+%define        perl_symbol_global_name_ver             0.05
 %define        perl_text_quoted_ver                    2.07
 %define        perl_text_wikiformat_ver                0.76
 %define        perl_tree_simple_ver                    1.18
 %define        perl_xml_rss_ver                        1.05
 #
 %bcond_with    testdeps        # used for checking dependencies
-%bcond_without apache          # no apache deps. TODO: make subpackage with apache config
 #
 %include       /usr/lib/rpm/macros.perl
 Summary:       Request Tracker
 Summary(pl.UTF-8):     Request Tracker - system do śledzenia zleceń
 Name:          rt
-Version:       4.2.0
-Release:       0.1
+Version:       4.2.11
+Release:       1
 License:       GPL v2
 Group:         Applications
 Source0:       http://download.bestpractical.com/pub/rt/release/%{name}-%{version}.tar.gz
-# Source0-md5: 98fcc484a37c62f0c202f3cc1fbefb89
+# Source0-md5: f0b02b2f97ff346ca2d57a17b136b9d0
 Source1:       %{name}-apache_dir.conf
 Source2:       %{name}-apache_vhost.conf
 Source3:       %{name}-apache.conf
 Source4:       %{name}.logrotate
+Source5:       lighttpd.conf
 Patch0:                %{name}-layout.patch
 Patch1:                %{name}-config.patch
 URL:           http://www.bestpractical.com/rt/
@@ -100,7 +101,10 @@ BuildRequires:     perl-GD >= %{perl_gd_ver}
 BuildRequires: perl-GD-Graph
 BuildRequires: perl-GD-TextUtil
 BuildRequires: perl-GnuPG-Interface
+BuildRequires: perl-GraphViz
+BuildRequires: perl-HTML-FormatExternal
 BuildRequires: perl-HTML-FormatText-WithLinks-AndTables
+BuildRequires: perl-HTML-Gumbo
 BuildRequires: perl-HTML-Mason >= %{perl_html_mason_ver}
 BuildRequires: perl-HTML-Mason-PSGIHandler
 BuildRequires: perl-HTML-Parser
@@ -113,11 +117,11 @@ BuildRequires:    perl-HTTP-Server-Simple-Mason >= %{perl_http_server_simple_mason_
 BuildRequires: perl-IPC-Run3
 BuildRequires: perl-JSON
 BuildRequires: perl-JavaScript-Minifier
+BuildRequires: perl-LWP-Protocol-https
 BuildRequires: perl-Locale-Maketext >= %{perl_locale_maketext_ver}
 BuildRequires: perl-Locale-Maketext-Fuzzy
 BuildRequires: perl-Locale-Maketext-Lexicon >= %{perl_locale_maketext_lexicon_ver}
 BuildRequires: perl-Log-Dispatch >= %{perl_log_dispatch_ver}
-BuildRequires: perl-LWP-Protocol-https
 BuildRequires: perl-MIME-Types
 BuildRequires: perl-MIME-tools >= %{perl_mime_tools_ver}
 BuildRequires: perl-MLDBM
@@ -137,7 +141,7 @@ BuildRequires:      perl-Role-Basic
 BuildRequires: perl-Starlet >= %{perl_starlet_ver}
 BuildRequires: perl-Storable >= %{perl_storable_ver}
 BuildRequires: perl-String-ShellQuote
-BuildRequires: perl-Symbol-Global-Name
+BuildRequires: perl-Symbol-Global-Name >= %{perl_symbol_global_name_ver}
 BuildRequires: perl-Term-ReadKey
 BuildRequires: perl-Test-Inline
 BuildRequires: perl-Text-Autoformat
@@ -158,11 +162,6 @@ BuildRequires:     perl-libnet
 %endif
 BuildRequires: perl-base >= %{perl_ver}
 BuildRequires: rpm-perlprov
-%if %{with apache}
-Requires:      apache-base >= 2.2.0
-Requires:      apache-mod_authz_host >= 2.2.0
-Requires:      apache-mod_perl >= 2.0
-%endif
 Requires:      fonts-TTF-Google-Droid
 Requires:      perl-Apache-DBI
 Requires:      perl-Apache-Session >= %{perl_apache_session_ver}
@@ -190,13 +189,16 @@ Requires: perl-Devel-GlobalDestruction
 Requires:      perl-Devel-StackTrace >= %{perl_devel_stacktrace_ver}
 Requires:      perl-Digest-MD5 >= %{perl_digest_md5_ver}
 Requires:      perl-Email-Address-List
-Requires:      perl-Encode >= 2.38
+Requires:      perl-Encode >= 1:2.64
 Requires:      perl-FCGI-ProcManager
 Requires:      perl-File-Which
 Requires:      perl-GD >= %{perl_gd_ver}
 Requires:      perl-GD-Graph
 Requires:      perl-GnuPG-Interface
+Requires:      perl-GraphViz
+Requires:      perl-HTML-FormatExternal
 Requires:      perl-HTML-FormatText-WithLinks-AndTables
+Requires:      perl-HTML-Gumbo
 Requires:      perl-HTML-Mason >= %{perl_html_mason_ver}
 Requires:      perl-HTML-Mason-PSGIHandler
 Requires:      perl-HTML-Quoted
@@ -207,11 +209,11 @@ Requires: perl-HTTP-Server-Simple-Mason >= %{perl_http_server_simple_mason_ver}
 Requires:      perl-IPC-Run3
 Requires:      perl-JSON
 Requires:      perl-JavaScript-Minifier
+Requires:      perl-LWP-Protocol-https
 Requires:      perl-Locale-Maketext >= %{perl_locale_maketext_ver}
 Requires:      perl-Locale-Maketext-Fuzzy
 Requires:      perl-Locale-Maketext-Lexicon >= %{perl_locale_maketext_lexicon_ver}
 Requires:      perl-Log-Dispatch >= %{perl_log_dispatch_ver}
-Requires:      perl-LWP-Protocol-https
 Requires:      perl-MIME-tools >= %{perl_mime_tools_ver}
 Requires:      perl-MailTools >= %{perl_mailtools_ver}
 Requires:      perl-Module-Versions-Report >= %{perl_module_versions_report_ver}
@@ -227,16 +229,16 @@ Requires: perl-Role-Basic
 Requires:      perl-Starlet >= %{perl_starlet_ver}
 Requires:      perl-Storable >= %{perl_storable_ver}
 Requires:      perl-String-ShellQuote
-Requires:      perl-Symbol-Global-Name
+Requires:      perl-Symbol-Global-Name >= %{perl_symbol_global_name_ver}
 Requires:      perl-Text-Password-Pronounceable
 Requires:      perl-Text-Quoted >= %{perl_text_quoted_ver}
 Requires:      perl-Text-WikiFormat >= %{perl_text_wikiformat_ver}
 Requires:      perl-Tree-Simple >= %{perl_tree_simple_ver}
+Requires:      perl-UNIVERSAL-require
 Requires:      perl-XML-RSS >= %{perl_xml_rss_ver}
 Requires:      perl-base >= %{perl_ver}
 Requires:      webapps
 Suggests:      perl-FCGI
-Conflicts:     apache-base < 2.4.0-1
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -281,6 +283,23 @@ Umożliwia on współdziałanie z serwerem RT po HTTP i oferuje interfejs
 do funkcjonalności RT bardziej dopasowany do automatyki i intergracji
 z innymi narzędziami.
 
+%package apache
+Summary:       Apache support files for RT
+Summary(pl.UTF-8):     Pliki wspomagające używanie RT z Apache
+Group:         Applications
+Requires:      %{name} = %{version}-%{release}
+Requires:      apache-base >= 2.2.0
+Requires:      apache-mod_authz_host >= 2.2.0
+Requires:      apache-mod_perl >= 2.0
+Requires:      webapps
+Conflicts:     apache-base < 2.4.0-1
+
+%description apache
+Apache support files for RT.
+
+%description apache -l pl.UTF-8
+Pliki wspomagające używanie RT z Apache.
+
 %prep
 %setup -q
 %patch0 -p0
@@ -290,6 +309,9 @@ mv aclocal.m4 acinclude.m4
 
 sed -i -e 's#libdir:.*#libdir: %{_libdir}#g' config.layout
 
+# prevent configure from using git
+sed -i -e 's#git describe --tags#false#g' configure.ac
+
 %build
 %{__aclocal}
 %{__autoconf}
@@ -320,6 +342,7 @@ install -d $RPM_BUILD_ROOT{/etc/{logrotate.d,cron.daily},%{_libdir}} \
 
 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 install %{SOURCE3} $RPM_BUILD_ROOT%{_webappsdir}/httpd.conf
+install %{SOURCE5} $RPM_BUILD_ROOT%{_webappsdir}/lighttpd.conf
 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
 ln -s %{_sbindir}/rt-clean-sessions $RPM_BUILD_ROOT/etc/cron.daily/rt-clean-sessions
@@ -334,18 +357,24 @@ rm -r $RPM_BUILD_ROOT%{_datadir}/fonts/TTF
 # *.in, tests
 find $RPM_BUILD_ROOT -type f -name \*.in -exec rm '{}' \;
 
-%triggerin -- apache-base
+%triggerin apache -- apache-base
 %webapp_register httpd %{_webapp}
 
-%triggerun -- apache-base
+%triggerun apache -- apache-base
 %webapp_unregister httpd %{_webapp}
 
+%triggerin -- lighttpd
+%webapp_register lighttpd %{_webapp}
+
+%triggerun -- lighttpd
+%webapp_unregister lighttpd %{_webapp}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README* docs etc/upgrade
+%doc README* docs
 
 %dir %{_sysconfdir}
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/[a-z]*
@@ -353,11 +382,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/RT_SiteConfig.pm
 # this is generic config that SHOULDN'T BE TOUCHED. Change settings in your local (site) config.
 %attr(640,root,http) %config %{_sysconfdir}/RT_Config.pm
+%attr(750,root,http) %dir %{_webappsdir}
+# web server configs with no separate deps (so no need for subpackage)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappsdir}/lighttpd.conf
 
-%if %{with apache}
-%dir %attr(750,root,http) %{_webappsdir}
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappsdir}/httpd.conf
-%endif
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
 %attr(755,root,root) /etc/cron.daily/rt-clean-sessions
 %attr(755,root,root) %{_bindir}/rt-*
@@ -368,9 +396,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/rt/po
 %{_datadir}/rt/static
 %{_libdir}/*
-%dir %attr(770,root,http) %{masonstatedir}
+%attr(770,root,http) %dir %{masonstatedir}
 %{_examplesdir}/%{name}-%{version}
 
 %files cli
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/rt
+
+%files apache
+%defattr(644,root,root,755)
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappsdir}/httpd.conf
This page took 0.109733 seconds and 4 git commands to generate.