]> git.pld-linux.org Git - packages/rt.git/blobdiff - rt.spec
- up to 4.0.17
[packages/rt.git] / rt.spec
diff --git a/rt.spec b/rt.spec
index 41b42928d0b649618b102cd90c2e47771ddceaf5..21d2490de24add30c045896a3df7cdc07d5b0df2 100644 (file)
--- a/rt.spec
+++ b/rt.spec
@@ -5,18 +5,18 @@
 #   apache[12]/standalone server...?)
 # - separate standalone server
 #
+%define        perl_ver                                5.8.3
 %define        perl_apache_session_ver                 1.53
 %define        perl_cgi_ver                            3.38
 %define        perl_class_returnvalue_ver              0.40
 %define        perl_css_squish_ver                     0.06
 %define        perl_dbd_mysql                          2.1018
 %define        perl_dbi_ver                            1.37
-%define        perl_dbix_searchbuilder_ver             1.54
+%define        perl_dbix_searchbuilder_ver             1.59
 %define        perl_devel_stacktrace_ver               1.19
 %define        perl_digest_md5_ver                     2.27
-%define        perl_file_spec_ver                      0.8
-%define        perl_html_mason_ver                     1.36
-%define        perl_html_rewriteattributes_ver         0.02
+%define        perl_html_mason_ver                     3:1.43
+%define        perl_html_rewriteattributes_ver         0.05
 %define        perl_html_scrubber_ver                  0.08
 %define        perl_http_server_simple_mason_ver       0.09
 %define        perl_http_server_simple_ver             0.34
 %define        perl_mailtools_ver                      1.57
 %define        perl_mime_tools_ver                     5.425
 %define        perl_module_versions_report_ver         1.05
+%define        perl_cgi_psgi                           0.12
 %define        perl_storable_ver                       2.08
 %define        perl_text_quoted_ver                    2.02
 %define        perl_text_wikiformat_ver                0.76
-%define        perl_tree_simple_ver                    1.04
+%define        perl_tree_simple_ver                    1.18
 %define        perl_text_template_ver                  1.45
 %define        perl_xml_rss_ver                        1.05
 #
+%bcond_with    testdeps        # used for checking dependencies
+%bcond_without apache          # no apache deps. TODO: make subpackage with apache config
+#
 %include       /usr/lib/rpm/macros.perl
 Summary:       Request Tracker
 Summary(pl.UTF-8):     Request Tracker - system do śledzenia zleceń
 Name:          rt
-Version:       3.8.5
+Version:       4.0.17
 Release:       1
 License:       GPL v2
 Group:         Applications
 Source0:       http://download.bestpractical.com/pub/rt/release/%{name}-%{version}.tar.gz
-# Source0-md5: 177addb62ec3c7ee7335b696dcb0b0a1
+# Source0-md5: aad39ab243853f991d8f78e85c1181f8
 Source1:       %{name}-apache_dir.conf
 Source2:       %{name}-apache_vhost.conf
 Source3:       %{name}-apache.conf
+Source4:       %{name}.logrotate
 Patch0:                %{name}-layout.patch
 Patch1:                %{name}-config.patch
 URL:           http://www.bestpractical.com/rt/
 BuildRequires: autoconf
 BuildRequires: automake
+%if %{with testdeps}
+BuildRequires: perl-Apache-DBI
 BuildRequires: perl-Apache-Session >= %{perl_apache_session_ver}
 BuildRequires: perl-CGI >= %{perl_cgi_ver}
+BuildRequires: perl-CGI-Emulate-PSGI
+BuildRequires: perl-CGI-PSGI >= %{perl_cgi_psgi}
 BuildRequires: perl-CGI-SpeedyCGI
 BuildRequires: perl-CSS-Squish >= %{perl_css_squish_ver}
 BuildRequires: perl-Cache-Cache
 BuildRequires: perl-Calendar-Simple
+BuildRequires: perl-Class-ISA
 BuildRequires: perl-Class-ReturnValue >= %{perl_class_returnvalue_ver}
+BuildRequires: perl-Convert-Color
 BuildRequires: perl-DBD-mysql >= %{perl_dbd_mysql}
 BuildRequires: perl-DBI >= %{perl_dbi_ver}
 BuildRequires: perl-DBIx-DataSource >= 0.02
 BuildRequires: perl-DBIx-SearchBuilder >= %{perl_dbix_searchbuilder_ver}
 BuildRequires: perl-Data-ICal
+BuildRequires: perl-Devel-GlobalDestruction
 BuildRequires: perl-Devel-StackTrace >= %{perl_devel_stacktrace_ver}
 BuildRequires: perl-Digest-MD5 >= %{perl_digest_md5_ver}
 BuildRequires: perl-Email-Address
 BuildRequires: perl-Exception-Class
 BuildRequires: perl-FCGI
+BuildRequires: perl-FCGI-ProcManager
 BuildRequires: perl-File-ShareDir
-BuildRequires: perl-File-Spec >= %{perl_file_spec_ver}
 BuildRequires: perl-File-Temp
 BuildRequires: perl-FreezeThaw
 BuildRequires: perl-GD
@@ -77,12 +89,17 @@ BuildRequires:      perl-GD-Graph
 BuildRequires: perl-GD-TextUtil
 BuildRequires: perl-GnuPG-Interface
 BuildRequires: perl-HTML-Mason >= %{perl_html_mason_ver}
+BuildRequires: perl-HTML-Mason-PSGIHandler
 BuildRequires: perl-HTML-Parser
+BuildRequires: perl-HTML-Quoted
 BuildRequires: perl-HTML-RewriteAttributes >= %{perl_html_rewriteattributes_ver}
 BuildRequires: perl-HTML-Scrubber >= %{perl_html_scrubber_ver}
 BuildRequires: perl-HTML-Tree
 BuildRequires: perl-HTTP-Server-Simple >= %{perl_http_server_simple_ver}
 BuildRequires: perl-HTTP-Server-Simple-Mason >= %{perl_http_server_simple_mason_ver}
+BuildRequires: perl-IPC-Run3
+BuildRequires: perl-JSON
+BuildRequires: perl-JavaScript-Minifier
 BuildRequires: perl-Locale-Maketext >= %{perl_locale_maketext_ver}
 BuildRequires: perl-Locale-Maketext-Fuzzy
 BuildRequires: perl-Locale-Maketext-Lexicon >= %{perl_locale_maketext_lexicon_ver}
@@ -92,14 +109,21 @@ BuildRequires:     perl-MIME-tools >= %{perl_mime_tools_ver}
 BuildRequires: perl-MLDBM
 BuildRequires: perl-MailTools >= %{perl_mailtools_ver}
 BuildRequires: perl-Module-Versions-Report >= %{perl_module_versions_report_ver}
+BuildRequires: perl-Net-CIDR
 BuildRequires: perl-Net-Server >= 0.34
+BuildRequires: perl-PSGI
 BuildRequires: perl-Params-Validate >= 0.02
 BuildRequires: perl-PerlIO-eol
+BuildRequires: perl-Plack
 BuildRequires: perl-Regexp-Common
+BuildRequires: perl-Regexp-Common-net-CIDR
+BuildRequires: perl-Regexp-IPv6
+BuildRequires: perl-Starlet
 BuildRequires: perl-Storable >= %{perl_storable_ver}
 BuildRequires: perl-Term-ReadKey
 BuildRequires: perl-Test-Inline
 BuildRequires: perl-Text-Autoformat
+BuildRequires: perl-Text-Password-Pronounceable
 BuildRequires: perl-Text-Quoted >= %{perl_text_quoted_ver}
 BuildRequires: perl-Text-Template >= %{perl_text_template_ver}
 BuildRequires: perl-Text-WikiFormat >= %{perl_text_wikiformat_ver}
@@ -112,31 +136,48 @@ BuildRequires:    perl-Tree-Simple >= %{perl_tree_simple_ver}
 BuildRequires: perl-UNIVERSAL-require
 BuildRequires: perl-WWW-Mechanize
 BuildRequires: perl-XML-RSS >= %{perl_xml_rss_ver}
-BuildRequires: perl-base >= 5.8.0
 BuildRequires: perl-libnet
+%endif
+BuildRequires: perl-base >= %{perl_ver}
+BuildRequires: rpm-perlprov
+%if %{with apache}
 Requires:      apache-base >= 2.2.0
 Requires:      apache-mod_authz_host >= 2.2.0
 Requires:      apache-mod_perl >= 2.0
+%endif
+Requires:      fonts-TTF-Google-Droid
 Requires:      perl-Apache-DBI
 Requires:      perl-Apache-Session >= %{perl_apache_session_ver}
 Requires:      perl-CGI >= %{perl_cgi_ver}
+Requires:      perl-CGI-Emulate-PSGI
+Requires:      perl-CGI-PSGI >= %{perl_cgi_psgi}
 Requires:      perl-CSS-Squish >= %{perl_css_squish_ver}
-Requires:      perl-CSS-Squish >= 0.06
+Requires:      perl-Cache-Cache
 Requires:      perl-Calendar-Simple
+Requires:      perl-Class-ISA
 Requires:      perl-Class-ReturnValue >= %{perl_class_returnvalue_ver}
+Requires:      perl-Convert-Color
 Requires:      perl-DBD-mysql >= %{perl_dbd_mysql}
 Requires:      perl-DBI >= %{perl_dbi_ver}
 Requires:      perl-DBIx-SearchBuilder >= %{perl_dbix_searchbuilder_ver}
 Requires:      perl-Data-ICal
+Requires:      perl-Devel-GlobalDestruction
 Requires:      perl-Devel-StackTrace >= %{perl_devel_stacktrace_ver}
 Requires:      perl-Digest-MD5 >= %{perl_digest_md5_ver}
-Requires:      perl-File-Spec >= %{perl_file_spec_ver}
+Requires:      perl-Encode >= 2.38
+Requires:      perl-FCGI-ProcManager
 Requires:      perl-GD-Graph
+Requires:      perl-GnuPG-Interface
 Requires:      perl-HTML-Mason >= %{perl_html_mason_ver}
+Requires:      perl-HTML-Mason-PSGIHandler
+Requires:      perl-HTML-Quoted
 Requires:      perl-HTML-RewriteAttributes >= %{perl_html_rewriteattributes_ver}
 Requires:      perl-HTML-Scrubber >= %{perl_html_scrubber_ver}
 Requires:      perl-HTTP-Server-Simple >= %{perl_http_server_simple_ver}
 Requires:      perl-HTTP-Server-Simple-Mason >= %{perl_http_server_simple_mason_ver}
+Requires:      perl-IPC-Run3
+Requires:      perl-JSON
+Requires:      perl-JavaScript-Minifier
 Requires:      perl-Locale-Maketext >= %{perl_locale_maketext_ver}
 Requires:      perl-Locale-Maketext-Fuzzy
 Requires:      perl-Locale-Maketext-Lexicon >= %{perl_locale_maketext_lexicon_ver}
@@ -144,18 +185,28 @@ Requires: perl-Log-Dispatch >= %{perl_log_dispatch_ver}
 Requires:      perl-MIME-tools >= %{perl_mime_tools_ver}
 Requires:      perl-MailTools >= %{perl_mailtools_ver}
 Requires:      perl-Module-Versions-Report >= %{perl_module_versions_report_ver}
+Requires:      perl-Moose
+Requires:      perl-Net-CIDR
+Requires:      perl-PSGI
 Requires:      perl-PerlIO-eol
+Requires:      perl-Plack
+Requires:      perl-Regexp-Common-net-CIDR
+Requires:      perl-Regexp-IPv6
+Requires:      perl-Starlet
 Requires:      perl-Storable >= %{perl_storable_ver}
+Requires:      perl-Text-Password-Pronounceable
 Requires:      perl-Text-Quoted >= %{perl_text_quoted_ver}
 Requires:      perl-Text-WikiFormat >= %{perl_text_wikiformat_ver}
 Requires:      perl-Tree-Simple >= %{perl_tree_simple_ver}
 Requires:      perl-XML-RSS >= %{perl_xml_rss_ver}
+Requires:      perl-base >= %{perl_ver}
 Requires:      webapps
 Suggests:      perl-FCGI
+Conflicts:     apache-base < 2.4.0-1
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq      'perl().*' 'perl(RT.*)' 'perl(Encode::compat)' 'perl(CGI::Fast)' 'perl(Exception::Class::Base)'
+%define                _noautoreq      'perl().*' 'perl(RT.*)' 'perl(Encode::compat)' 'perl(CGI::Fast)' 'perl(Exception::Class::Base)' 'perl(HTML::Mason::Request::PSGI)'
 # workarounds for bug in perl.req ("perl()") and ,,famous'' rpm's feature (RT::*)
 
 %define         _webapps        /etc/webapps
@@ -206,7 +257,7 @@ mv aclocal.m4 acinclude.m4
 sed -i -e 's#libdir:.*#libdir: %{_libdir}#g' config.layout
 
 %build
-%{__aclocal} -I m4
+%{__aclocal}
 %{__autoconf}
 USER=$(id -un) \
 %configure \
@@ -215,35 +266,44 @@ USER=$(id -un) \
        exp_htmldir=%{htmldir} \
        masonstatedir=%{masonstatedir} \
        masonsessiondir=%{masonstatedir} \
-       --with-speedycgi=%{_bindir}/speedycgi \
+       --with-apachectl=%{_sbindir}/apachectl \
        --with-my-user-group \
-       --with-db-type=mysql
+       --with-db-type=mysql \
+       --with-web-handler=fastcgi,modperl2
 
+%{?with_testdeps:%{__make} testdeps}
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir} \
+install -d $RPM_BUILD_ROOT{/etc/{logrotate.d,cron.daily},%{_libdir}} \
        $RPM_BUILD_ROOT%{masonstatedir} \
        $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
        $RPM_BUILD_ROOT%{_webappsdir}
 
-%{__make} install \
+# this is make install minus fixperms
+%{__make} config-install dirs files-install instruct \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 install %{SOURCE3} $RPM_BUILD_ROOT%{_webappsdir}/httpd.conf
+install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
+
+ln -s %{_sbindir}/rt-clean-sessions $RPM_BUILD_ROOT/etc/cron.daily/rt-clean-sessions
 
 # unneeded in installed copy
-rm -f $RPM_BUILD_ROOT%{_sbindir}/rt-test-dependencies
+rm $RPM_BUILD_ROOT%{_sbindir}/rt-test-dependencies
+
+# we use fonts-TTF-Google-Droid
+rm -r $RPM_BUILD_ROOT%{_datadir}/fonts/TTF
 
 # *.in, tests
 find $RPM_BUILD_ROOT -type f -name \*.in -exec rm '{}' \;
 
-%triggerin -- apache < 2.2.0, apache-base
+%triggerin -- apache-base
 %webapp_register httpd %{_webapp}
 
-%triggerun -- apache < 2.2.0, apache-base
+%triggerun -- apache-base
 %webapp_unregister httpd %{_webapp}
 
 %clean
@@ -251,18 +311,27 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README* UPGRADING docs
+%doc README* docs etc/upgrade
+
 %dir %{_sysconfdir}
-%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/[a-z]*
+# this is local config
+%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/RT_SiteConfig.pm
+# this is generic config that SHOULDN'T BE TOUCHED. Change settings in your local (site) config.
+%attr(640,root,http) %config %{_sysconfdir}/RT_Config.pm
+
+%if %{with apache}
 %dir %attr(750,root,http) %{_webappsdir}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappsdir}/httpd.conf
-%attr(755,root,root) %{_bindir}/mason_handler.*
+%endif
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
+%attr(755,root,root) /etc/cron.daily/rt-clean-sessions
 %attr(755,root,root) %{_bindir}/rt-*
-%attr(755,root,root) %{_bindir}/standalone_httpd
-%attr(755,root,root) %{_bindir}/webmux.pl
+%attr(755,root,root) %{_sbindir}/standalone_httpd
 %attr(755,root,root) %{_sbindir}/rt-*
-%dir %{_datadir}/rt3
-%{_datadir}/rt3/html
+%dir %{_datadir}/rt
+%{_datadir}/rt/html
+%{_datadir}/rt/po
 %{_libdir}/*
 %dir %attr(770,root,http) %{masonstatedir}
 %{_examplesdir}/%{name}-%{version}
This page took 0.05391 seconds and 4 git commands to generate.