]> git.pld-linux.org Git - packages/rsync.git/blobdiff - rsync.spec
up to 3.1.3; SECURITY; rsync-3.1.2-1-fadvise.patch disabled
[packages/rsync.git] / rsync.spec
index 03f0e0ea3732d86b742a5bafe766d4235158d218..72a0e813a0e8f7bde7eac68ec8408fcbdb055fd1 100644 (file)
@@ -1,6 +1,10 @@
+# TODO:
+#   3.1.3 rsyncd segfaults very early in server rsync:// mode (both inetd and standalone)
+#   rsync[27223]: segfault at 7468 ip 00007f4281c56e81 sp 00007ffc29186160 error 4 in libc-2.27.so[7f4281bd3000+1b4000]
 #
 # Conditional build:
 %bcond_with    rsh     # set remote shell command to rsh instead of ssh (old behaviour)
+%bcond_with    fadvise # apply fadvise patch
 %bcond_with    tests   # perform "make test"
 #
 %ifarch alpha
@@ -16,25 +20,26 @@ Summary(uk.UTF-8):  Програма для ефективного віддале
 Summary(zh_CN.UTF-8):  [通讯]传输工具
 Summary(zh_TW.UTF-8):  [喙啪]\e$(B6G?i火(c\e(B
 Name:          rsync
-Version:       3.0.9
-Release:       2
-License:       GPL
+Version:       3.1.3
+Release:       1
+Epoch:         1
+License:       GPL v3+
 Group:         Networking/Utilities
-Source0:       http://rsync.samba.org/ftp/rsync/%{name}-%{version}.tar.gz
-# Source0-md5: 5ee72266fe2c1822333c407e1761b92b
-Source1:       http://rsync.samba.org/ftp/rsync/rsync-patches-%{version}.tar.gz
-# Source1-md5: 992677c7f1ac2884d9469b3a0eff594a
+Source0:       https://rsync.samba.org/ftp/rsync/%{name}-%{version}.tar.gz
+# Source0-md5: 1581a588fde9d89f6bc6201e8129afaf
+Source1:       https://rsync.samba.org/ftp/rsync/rsync-patches-%{version}.tar.gz
+# Source1-md5: 753fc37ffc277571c69135e8bc5fae9d
 Source2:       %{name}.inet
 Source3:       %{name}.init
 Source4:       %{name}.sysconfig
 Source5:       %{name}d.logrotate
 Patch0:                %{name}-config.patch
-Patch1:                %{name}-dparam.patch
-URL:           http://rsync.samba.org/
+Patch1:                https://tobi.oetiker.ch/patches/rsync-3.1.2-1-fadvise.patch
+# Patch1-md5:  b055468e7cbc5d829aa943f07916d458
+URL:           https://rsync.samba.org/
 BuildRequires: acl-devel
-BuildRequires: autoconf >= 2.52
+BuildRequires: autoconf >= 2.59
 BuildRequires: automake
-BuildRequires: openssl-devel
 BuildRequires: popt-devel
 BuildRequires: rpmbuild(macros) >= 1.318
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -104,7 +109,7 @@ rsync - це швидша та гнучкіша альтернатива rcp, я
 Summary:       Files necessary to run rsync in daemon mode
 Summary(pl.UTF-8):     Pliki niezbędne do uruchomienia rsynca w trybie serwera
 Group:         Networking/Daemons
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      rc-inetd
 Provides:      rsyncd
 Obsoletes:     rsyncd
@@ -132,7 +137,7 @@ Summary:    Files necessary to run rsync in daemon mode
 Summary(pl.UTF-8):     Pliki niezbędne do uruchomienia rsynca w trybie serwera
 Group:         Networking/Daemons
 Requires(post,preun):  /sbin/chkconfig
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Provides:      rsyncd
 Obsoletes:     rsyncd
 Obsoletes:     rsyncd-inetd
@@ -157,12 +162,11 @@ techniczna nowego algorytmu została również dołączona do pakietu.
 %prep
 %setup -q -b1
 %patch0 -p1
-%patch1 -p1
+%{?with_fadvise:%patch1 -p1}
 
 # for compat with previous patched version
 patch -p1 -i patches/acls.diff || exit 1
 patch -p1 -i patches/xattrs.diff || exit 1
-patch -p1 < patches/openssl-support.diff || exit 1
 
 %build
 cp -f /usr/share/automake/config.sub .
@@ -173,7 +177,6 @@ cp -f /usr/share/automake/config.sub .
        %{?with_rsh:--with-rsh=rsh} \
        --enable-ipv6 \
        --enable-acl-support \
-       --enable-openssl \
        --enable-xattr-support \
        --disable-debug \
        --with-rsyncd-conf=%{_sysconfdir}/rsyncd.conf
@@ -245,10 +248,13 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README NEWS OLDNEWS TODO
-%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
-%attr(755,root,root) %{_bindir}/*
-%{_mandir}/man1/*
+%doc README NEWS OLDNEWS TODO support
+%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/CVSIGNORE
+%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/RSYNC_PASSWORD
+%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/RSYNC_PROXY
+%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/RSYNC_RSH
+%attr(755,root,root) %{_bindir}/rsync
+%{_mandir}/man1/rsync.1*
 
 %files -n rsyncd-inetd
 %defattr(644,root,root,755)
@@ -258,7 +264,7 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/rsyncd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/rsyncd
 %attr(640,root,root) %ghost /var/log/rsyncd.log
-%{_mandir}/man5/*
+%{_mandir}/man5/rsyncd.conf.5*
 
 %files -n rsyncd-standalone
 %defattr(644,root,root,755)
@@ -269,4 +275,4 @@ fi
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/rsyncd
 %attr(640,root,root) %ghost /var/log/rsyncd.log
 %attr(754,root,root) /etc/rc.d/init.d/rsyncd
-%{_mandir}/man5/*
+%{_mandir}/man5/rsyncd.conf.5*
This page took 0.072091 seconds and 4 git commands to generate.