]> git.pld-linux.org Git - packages/rsync.git/blobdiff - rsync.spec
- rel 6; actually apply the patch
[packages/rsync.git] / rsync.spec
index 7dd032b7762ad5e7d94135ac8a5622048854c1e2..6f71a643384d72cc23745571ca5958e6b47ceb67 100644 (file)
@@ -1,3 +1,6 @@
+# TODO:
+#   3.1.3 rsyncd segfaults very early in server rsync:// mode (both inetd and standalone)
+#   rsync[27223]: segfault at 7468 ip 00007f4281c56e81 sp 00007ffc29186160 error 4 in libc-2.27.so[7f4281bd3000+1b4000]
 #
 # Conditional build:
 %bcond_with    rsh     # set remote shell command to rsh instead of ssh (old behaviour)
@@ -16,29 +19,31 @@ Summary(uk.UTF-8):  Програма для ефективного віддале
 Summary(zh_CN.UTF-8):  [通讯]传输工具
 Summary(zh_TW.UTF-8):  [喙啪]\e$(B6G?i火(c\e(B
 Name:          rsync
-Version:       3.0.3
-Release:       2
-License:       GPL
+Version:       3.1.2
+Release:       6
+Epoch:         1
+License:       GPL v3+
 Group:         Networking/Utilities
 Source0:       http://rsync.samba.org/ftp/rsync/%{name}-%{version}.tar.gz
-# Source0-md5: 16d41aab9ece435198af222c5415a304
+# Source0-md5: 0f758d7e000c0f7f7d3792610fad70cb
 Source1:       http://rsync.samba.org/ftp/rsync/rsync-patches-%{version}.tar.gz
-# Source1-md5: ff814658791187a5f32c1a145714db43
+# Source1-md5: f412602a3cba0b872adfaed905a0aa28
 Source2:       %{name}.inet
 Source3:       %{name}.init
 Source4:       %{name}.sysconfig
 Source5:       %{name}d.logrotate
 Patch0:                %{name}-config.patch
-Patch1:                %{name}-dparam.patch
+Patch1:                https://tobi.oetiker.ch/patches/rsync-3.1.2-1-fadvise.patch
+# Patch1-md5:  b055468e7cbc5d829aa943f07916d458
 URL:           http://rsync.samba.org/
 BuildRequires: acl-devel
-BuildRequires: autoconf >= 2.52
+BuildRequires: autoconf >= 2.59
 BuildRequires: automake
-BuildRequires: openssl-devel
 BuildRequires: popt-devel
 BuildRequires: rpmbuild(macros) >= 1.318
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _duplicate_files_terminate_build        0
 %define                _sysconfdir     /etc/rsyncd
 
 %description
@@ -103,7 +108,7 @@ rsync - це швидша та гнучкіша альтернатива rcp, я
 Summary:       Files necessary to run rsync in daemon mode
 Summary(pl.UTF-8):     Pliki niezbędne do uruchomienia rsynca w trybie serwera
 Group:         Networking/Daemons
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      rc-inetd
 Provides:      rsyncd
 Obsoletes:     rsyncd
@@ -131,7 +136,7 @@ Summary:    Files necessary to run rsync in daemon mode
 Summary(pl.UTF-8):     Pliki niezbędne do uruchomienia rsynca w trybie serwera
 Group:         Networking/Daemons
 Requires(post,preun):  /sbin/chkconfig
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Provides:      rsyncd
 Obsoletes:     rsyncd
 Obsoletes:     rsyncd-inetd
@@ -167,6 +172,7 @@ cp -f /usr/share/automake/config.sub .
 %{__autoheader}
 %{__autoconf}
 %configure \
+       LIBS="-lcrypto" \
        %{?with_rsh:--with-rsh=rsh} \
        --enable-ipv6 \
        --enable-acl-support \
@@ -191,7 +197,7 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{sysconfig/rc-inetd,rc.d/init.d,l
 :> $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.secrets
 
 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.conf
-log file = /var/log/rsyncd.log
+#log file = /var/log/rsyncd.log
 EOF
 
 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/CVSIGNORE
@@ -241,28 +247,31 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README NEWS OLDNEWS TODO
-%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
-%attr(755,root,root) %{_bindir}/*
-%{_mandir}/man1/*
+%doc README NEWS OLDNEWS TODO support
+%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/CVSIGNORE
+%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/RSYNC_PASSWORD
+%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/RSYNC_PROXY
+%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/RSYNC_RSH
+%attr(755,root,root) %{_bindir}/rsync
+%{_mandir}/man1/rsync.1*
 
 %files -n rsyncd-inetd
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}
-%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.conf
-%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.secrets
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rsyncd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rsyncd.secrets
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/rsyncd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/rsyncd
 %attr(640,root,root) %ghost /var/log/rsyncd.log
-%{_mandir}/man5/*
+%{_mandir}/man5/rsyncd.conf.5*
 
 %files -n rsyncd-standalone
 %defattr(644,root,root,755)
 %dir %{_sysconfdir}
-%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.conf
-%attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.secrets
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rsyncd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rsyncd.secrets
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rsyncd
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/rsyncd
 %attr(640,root,root) %ghost /var/log/rsyncd.log
 %attr(754,root,root) /etc/rc.d/init.d/rsyncd
-%{_mandir}/man5/*
+%{_mandir}/man5/rsyncd.conf.5*
This page took 0.064151 seconds and 4 git commands to generate.