]> git.pld-linux.org Git - packages/rsync.git/blob - rsync.spec
- pre7
[packages/rsync.git] / rsync.spec
1 #
2 # Conditional build:
3 %bcond_with     rsh     # set remote shell command to rsh instead of ssh (old behaviour)
4 %bcond_with     tests   # perform "make test"
5 #
6 %ifarch alpha
7 %undefine       with_tests
8 %endif
9 Summary:        Program for efficient remote updates of files
10 Summary(es.UTF-8):      Programa para actualizar archivos remotos de forma eficiente
11 Summary(ko.UTF-8):      네트워크를 통한 파일동기화를 위한 프로그램
12 Summary(pl.UTF-8):      Program do wydajnego zdalnego uaktualniania plików
13 Summary(pt_BR.UTF-8):   Programa para atualizar arquivos remotos de forma eficiente
14 Summary(ru.UTF-8):      Программа для эффективного удаленного обновления файлов
15 Summary(uk.UTF-8):      Програма для ефективного віддаленого оновлення файлів
16 Summary(zh_CN.UTF-8):   [通讯]传输工具
17 Summary(zh_TW.UTF-8):   [喙啪]\e$(B6G?i火(c\e(B
18 Name:           rsync
19 Version:        3.0.0
20 # don't rel 1 until final release
21 Release:        0.1
22 License:        GPL
23 Group:          Networking/Utilities
24 Source0:        http://rsync.samba.org/ftp/rsync/%{name}-%{version}pre7.tar.gz
25 # Source0-md5:  601041c0243eea657af5191f249a5f91
26 Source1:        %{name}.inet
27 Source2:        %{name}.init
28 Source3:        %{name}.sysconfig
29 Source4:        %{name}d.logrotate
30 Patch0:         %{name}-config.patch
31 URL:            http://rsync.samba.org/
32 BuildRequires:  acl-devel
33 BuildRequires:  autoconf >= 2.52
34 BuildRequires:  automake
35 BuildRequires:  openssl-devel
36 BuildRequires:  popt-devel
37 BuildRequires:  rpmbuild(macros) >= 1.318
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _sysconfdir     /etc/rsyncd
41
42 %description
43 rsync is a replacement for rcp that has many more features.
44
45 rsync uses the "rsync algorithm" which provides a very fast method for
46 bringing remote files into sync. It does this by sending just the
47 differences in the files across the link, without requiring that both
48 sets of files are present at one of the ends of the link beforehand.
49
50 A technical report describing the rsync algorithm is included with
51 this package.
52
53 %description -l es.UTF-8
54 rsync es un substituto más rápido y flexible para rcp que permite la
55 sincronización de archivos o directorios, vía red, de forma rápida y
56 eficiente, entre diferentes máquinas transfiriendo solamente las
57 diferencias entre estos directorios de forma compactada. No necesita
58 que ninguna de las máquinas tengan una copia de lo que está en la
59 otra. Está disponible en este paquete, una relación técnica
60 describiendo el algoritmo usado por el rsync.
61
62 %description -l ko.UTF-8
63 Rsync는 원격 호스트 파일을 매우 빨리 동기화하는데 신뢰할만한
64 알고리즘을 사용한다. Rsync는 파일의 전체를 보내는 것 대신에 네트웍을
65 통해 파일의 다른 부분만을 전송하기 때문에 빠르다. Rsync는 강력한 미러
66 프로세스 혹은 rcp 커멘드를 통한 더 우수한 대체용으로써 사용된다. rsync
67 알고리즘을 묘사하는 기술적인 내용은 이 꾸러미에 포함되어 있다.
68
69 %description -l pl.UTF-8
70 Rsync jest zamiennikiem programu rcp z bardziej rozbudowaną składnią
71 poleceń. Program ten używa efektywnego algorytmu "rsync" w czasie
72 komunikacji i transportu plików do systemu zdalnego. Dokumentacja
73 techniczna nowego algorytmu została również dołączona do pakietu.
74
75 %description -l pt_BR.UTF-8
76 O rsync é um substituto mais rápido e flexível para o rcp permitindo
77 sincronização de arquivos ou diretórios via rede de forma rápida e
78 eficiente entre diferentes máquinas transferindo somente as diferenças
79 entre estes diretórios de forma compactada. Ele não precisa que
80 nenhuma das máquinas tenha uma cópia do que está na outra.
81
82 Um relatório técnico descrevendo o algoritmo usado pelo rsync está
83 disponível neste pacote.
84
85 %description -l ru.UTF-8
86 rsync - это более быстрая и гибкая альтернатива rcp, позволяющая
87 быструю и эффективную по отношению к ресурсам сети синхронизацию
88 файлов или каталогов на различных машинах путем передачи только
89 различий между ними в компрессированном виде. При этом совершенно не
90 обязательно, чтобы одна машина имела у себя копию того, что есть на
91 другой машине.
92
93 %description -l uk.UTF-8
94 rsync - це швидша та гнучкіша альтернатива rcp, яка забезпечує швидку
95 та ефективну по відношенню до ресурсів мережі синхронізацію файлів чи
96 каталогів на різних машинах шляхом передачі лише відмінностей між ними
97 в компресованому виді. При цьому зовсім не обов'язково, щоб одна
98 машина мала в себе копію того, що є на іншій машині.
99
100 %package -n rsyncd-inetd
101 Summary:        Files necessary to run rsync in daemon mode
102 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia rsynca w trybie serwera
103 Group:          Networking/Daemons
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       rc-inetd
106 Provides:       rsyncd
107 Obsoletes:      rsyncd
108 Obsoletes:      rsyncd-standalone
109
110 %description -n rsyncd-inetd
111 rsync is a replacement for rcp that has many more features.
112
113 rsync uses the "rsync algorithm" which provides a very fast method for
114 bringing remote files into sync. It does this by sending just the
115 differences in the files across the link, without requiring that both
116 sets of files are present at one of the ends of the link beforehand.
117
118 A technical report describing the rsync algorithm is included with
119 this package.
120
121 %description -n rsyncd-inetd -l pl.UTF-8
122 Rsync jest zamiennikiem programu rcp z bardziej rozbudowaną składnią
123 poleceń. Program ten używa efektywnego algorytmu "rsync" w czasie
124 komunikacji i transportu plików do systemu zdalnego. Dokumentacja
125 techniczna nowego algorytmu została również dołączona do pakietu.
126
127 %package -n rsyncd-standalone
128 Summary:        Files necessary to run rsync in daemon mode
129 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia rsynca w trybie serwera
130 Group:          Networking/Daemons
131 Requires(post,preun):   /sbin/chkconfig
132 Requires:       %{name} = %{version}-%{release}
133 Provides:       rsyncd
134 Obsoletes:      rsyncd
135 Obsoletes:      rsyncd-inetd
136
137 %description -n rsyncd-standalone
138 rsync is a replacement for rcp that has many more features.
139
140 rsync uses the "rsync algorithm" which provides a very fast method for
141 bringing remote files into sync. It does this by sending just the
142 differences in the files across the link, without requiring that both
143 sets of files are present at one of the ends of the link beforehand.
144
145 A technical report describing the rsync algorithm is included with
146 this package.
147
148 %description -n rsyncd-standalone -l pl.UTF-8
149 Rsync jest zamiennikiem programu rcp z bardziej rozbudowaną składnią
150 poleceń. Program ten używa efektywnego algorytmu "rsync" w czasie
151 komunikacji i transportu plików do systemu zdalnego. Dokumentacja
152 techniczna nowego algorytmu została również dołączona do pakietu.
153
154 %prep
155 %setup -q -n %{name}-%{version}pre7
156 %patch0 -p1
157
158 %build
159 cp -f /usr/share/automake/config.sub .
160 %{__autoheader}
161 %{__autoconf}
162 %configure \
163         %{?with_rsh:--with-rsh=rsh} \
164         --enable-ipv6 \
165         --enable-acl-support \
166         --enable-xattr-support \
167         --disable-debug \
168         --with-rsyncd-conf=%{_sysconfdir}/rsyncd.conf
169 %{__make} proto
170 %{__make}
171
172 %{?with_tests:%{__make} test}
173
174 %install
175 rm -rf $RPM_BUILD_ROOT
176 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{sysconfig/rc-inetd,rc.d/init.d,logrotate.d,env.d},/var/log}
177
178 %{__make} install \
179         prefix=$RPM_BUILD_ROOT%{_prefix} \
180         mandir=$RPM_BUILD_ROOT%{_mandir} \
181         bindir=$RPM_BUILD_ROOT%{_bindir}
182
183 :> $RPM_BUILD_ROOT/var/log/rsyncd.log
184 :> $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.secrets
185
186 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/rsyncd.conf
187 log file = /var/log/rsyncd.log
188 EOF
189
190 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/CVSIGNORE
191 #CVSIGNORE=
192 EOF
193 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/RSYNC_RSH
194 #RSYNC_RSH=
195 EOF
196 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/RSYNC_PROXY
197 #RSYNC_PROXY=
198 EOF
199 cat << 'EOF' > $RPM_BUILD_ROOT/etc/env.d/RSYNC_PASSWORD
200 #RSYNC_PASSWORD=
201 EOF
202
203 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/rsyncd
204 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rsyncd
205 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rsyncd
206 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/rsyncd
207
208 %clean
209 rm -rf $RPM_BUILD_ROOT
210
211 %post
212 %env_update
213
214 %postun
215 %env_update
216
217 %post -n rsyncd-inetd
218 %service -q rc-inetd reload
219
220 %postun -n rsyncd-inetd
221 if [ "$1" = "0" ]; then
222         %service -q rc-inetd reload
223 fi
224
225 %post -n rsyncd-standalone
226 /sbin/chkconfig --add rsyncd
227 %service rsyncd restart "rsync server"
228
229 %preun -n rsyncd-standalone
230 if [ "$1" = "0" ]; then
231         %service rsyncd stop
232         /sbin/chkconfig --del rsyncd
233 fi
234
235 %files
236 %defattr(644,root,root,755)
237 %doc README NEWS OLDNEWS TODO
238 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
239 %attr(755,root,root) %{_bindir}/*
240 %{_mandir}/man1/*
241
242 %files -n rsyncd-inetd
243 %defattr(644,root,root,755)
244 %dir %{_sysconfdir}
245 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.conf
246 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.secrets
247 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/rsyncd
248 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/rsyncd
249 %attr(640,root,root) %ghost /var/log/rsyncd.log
250 %{_mandir}/man5/*
251
252 %files -n rsyncd-standalone
253 %defattr(644,root,root,755)
254 %dir %{_sysconfdir}
255 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.conf
256 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/rsyncd.secrets
257 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rsyncd
258 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/rsyncd
259 %attr(640,root,root) %ghost /var/log/rsyncd.log
260 %attr(754,root,root) /etc/rc.d/init.d/rsyncd
261 %{_mandir}/man5/*
This page took 0.085988 seconds and 4 git commands to generate.