]> git.pld-linux.org Git - packages/rstudio.git/commitdiff
upstream patch to fix build with boost >= 1.75
authorJan Palus <atler@pld-linux.org>
Wed, 11 Aug 2021 07:34:08 +0000 (09:34 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 11 Aug 2021 08:07:54 +0000 (10:07 +0200)
boost1.75.patch [new file with mode: 0644]
rstudio.spec

diff --git a/boost1.75.patch b/boost1.75.patch
new file mode 100644 (file)
index 0000000..1f1dc3f
--- /dev/null
@@ -0,0 +1,79 @@
+From 0c6a7374b04827f5db97ed9b4f71c9ff14442c6c Mon Sep 17 00:00:00 2001
+From: Jan Marvin Garbuszus <jan.garbuszus@ruhr-uni-bochum.de>
+Date: Sun, 13 Dec 2020 15:09:23 +0100
+Subject: [PATCH] fix building with boost 1.75
+
+---
+ src/cpp/CMakeLists.txt              | 1 -
+ src/cpp/core/HtmlUtils.cpp          | 3 +++
+ src/cpp/core/file_lock/FileLock.cpp | 3 +++
+ src/cpp/r/session/RStdCallbacks.cpp | 2 ++
+ 4 files changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/src/cpp/CMakeLists.txt b/src/cpp/CMakeLists.txt
+index 18a951fb832..fb16f75b320 100644
+--- a/src/cpp/CMakeLists.txt
++++ b/src/cpp/CMakeLists.txt
+@@ -35,7 +35,6 @@ include("${CMAKE_CURRENT_SOURCE_DIR}/../../CMakeGlobals.txt")
+ # global directives
+ add_definitions(-DBOOST_ENABLE_ASSERT_HANDLER)
+-add_definitions(-DBOOST_BIND_GLOBAL_PLACEHOLDERS)
+ # test directory
+ set(TESTS_INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/tests/cpp" CACHE STRING "Test includes")
+diff --git a/src/cpp/core/HtmlUtils.cpp b/src/cpp/core/HtmlUtils.cpp
+index c0ffb19f427..ddd28a008ea 100644
+--- a/src/cpp/core/HtmlUtils.cpp
++++ b/src/cpp/core/HtmlUtils.cpp
+@@ -19,6 +19,7 @@
+ #include <boost/format.hpp>
+ #include <boost/foreach.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
++#include <boost/bind/bind.hpp>
+ #include <core/Base64.hpp>
+ #include <core/FileSerializer.hpp>
+@@ -26,6 +27,8 @@
+ #include <core/http/Util.hpp>
++using namespace boost::placeholders;
++
+ namespace rstudio {
+ namespace core {
+ namespace html_utils {
+diff --git a/src/cpp/core/file_lock/FileLock.cpp b/src/cpp/core/file_lock/FileLock.cpp
+index 4495ca02c89..11e444acbe0 100644
+--- a/src/cpp/core/file_lock/FileLock.cpp
++++ b/src/cpp/core/file_lock/FileLock.cpp
+@@ -27,7 +27,10 @@
+ #include <core/http/SocketUtils.hpp>
+ #include <boost/algorithm/string.hpp>
++#include <boost/bind/bind.hpp>
++using namespace boost::placeholders;
++
+ namespace rstudio {
+ namespace core {
+--- rstudio-1.1.143/src/cpp/r/session/RSession.cpp.orig        2017-04-12 00:42:14.000000000 +0200
++++ rstudio-1.1.143/src/cpp/r/session/RSession.cpp     2021-08-11 09:52:23.269455446 +0200
+@@ -18,6 +18,7 @@
+ #include <iostream>
++#include <boost/bind/bind.hpp>
+ #include <boost/regex.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
+ #include <boost/algorithm/string/replace.hpp>
+@@ -74,6 +74,8 @@
+ // constants for graphics scratch subdirectory
+ #define kGraphicsPath "graphics"
++using namespace boost::placeholders;
++
+ using namespace rstudio::core ;
+ namespace rstudio {
index cdce4cd2aef5578b534951e29afb1e982ea64102..1a0e07878182becb61a017ddb9ca1426342a035e 100644 (file)
@@ -27,6 +27,7 @@ Patch0:               %{name}-includes.patch
 Patch1:                %{name}-openssl.patch
 Patch2:                %{name}-boost.patch
 Patch3:                websocketpp-boost.patch
+Patch4:                boost1.75.patch
 URL:           http://rstudio.org/
 BuildRequires: Qt5Core-devel >= 5.4.0
 BuildRequires: Qt5DBus-devel >= 5.4.0
@@ -84,6 +85,7 @@ sieć przy użyciu serwera RStudio.
 cd src/cpp/ext
 %patch3 -p1
 cd ../../..
+%patch4 -p1
 
 mkdir -p dependencies/common/dictionaries
 unzip -qq %{SOURCE1} -d dependencies/common/dictionaries
This page took 0.153512 seconds and 4 git commands to generate.